Photon Voice: Package Functions

Photon Voice v2.55

Here is a list of all documented namespace members with links to the namespaces they belong to:
  • AudioSampleType : Photon.Voice
  • AudioSessionCategory : Photon.Voice.IOS
  • AudioSessionCategoryOption : Photon.Voice.IOS
  • AudioSessionMode : Photon.Voice.IOS
  • Codec : Photon.Voice
© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: Package Functions

  • AudioSampleType : Photon.Voice
  • AudioSessionCategory : Photon.Voice.IOS
  • AudioSessionCategoryOption : Photon.Voice.IOS
  • AudioSessionMode : Photon.Voice.IOS
  • Codec : Photon.Voice


Photon Voice: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12345]
▼N Photon |
▼N Voice |
►N FMOD |
C AudioInEnumerator |
C AudioInReader |
C AudioOut |
C AudioOutEvent |
►N Fusion |
C FusionVoiceClient |
C VoiceNetworkObject |
►N IOS |
C AudioInChangeNotifier |
C AudioInPusher |
C AudioInReader |
C AudioSessionParameters |
C AudioSessionParametersPresets |
►N MacOS |
C AudioInChangeNotifier |
C AudioInEnumerator | Enumerates microphones available on device
C AudioInPusher |
C AudioInReader |
►N PUN |
►N UtilityScripts |
C VoiceDebugScript | Utility script to be attached next to PhotonVoiceView & PhotonView on the player prefab to be network instantiated. Call voiceDebugScript.CantHearYou() on the networked object of the remote (or local) player if you can't hear the corresponding player
C PhotonVoiceView | Component that should be attached to a networked PUN prefab that has PhotonView. It will bind remote Recorder with local Speaker of the same networked prefab. This component makes automatic voice stream routing easy for players' characters/avatars
C PunVoiceClient | This class can be used to automatically sync client states between PUN and Voice. It also finds the Speaker component for a character's voice. For this to work attach a PhotonVoiceView next to the PhotonView of your player's prefab
►N Unity |
►N FMOD |
C FMODRecorderSetup |
C SpeakerFMOD |
►N UtilityScripts |
C ConnectAndJoin |
C MicAmplifier |
C MicAmplifierFloat |
C MicAmplifierShort |
C MicrophonePermission | Helper to request Microphone permission on Android or iOS
C PhotonVoiceLagSimulationGui |
C PhotonVoiceStatsGui | Basic GUI to show traffic and health statistics of the connection to Photon, toggled by shift+tab
C SaveIncomingStreamToFile |
C SaveOutgoingStreamToFile |
C TestTone |
C WaveWriter |
C AndroidAudioInAEC |
C AndroidAudioInParameters |
C AudioChangesHandler | This component is useful to handle audio device and config changes
C AudioClipWrapper |
C AudioInEnumerator |
C AudioOutCapture |
C Logger |
C MicWrapper |
C MicWrapperPusher |
C MicWrapperPusherOnAudioFilterRead |
C PhotonVoiceCreatedParams |
C Recorder | Component representing outgoing audio stream in scene
►C RecorderPreset |
C DSP |
C RemoteVoiceLink |
C Speaker |
C SpeakerAudioFilterRead |
C UnityAudioOut |
C UnityLogger |
C UnityMicrophone | A wrapper around UnityEngine.Microphone to be able to safely use Microphone and compile for WebGL
C UnityVoiceClient | Component that represents a Voice client and manages a simple Unity integration: a single Recorder and multiple remote speakers
C VideoInEnumerator |
C VoiceComponent |
C VoiceComponentImpl |
C VoiceConnection | Component that represents a Voice client
C VoiceLogger |
C WebRtcAudioDsp |
►N UWP |
C AudioInEnumerator |
C AudioInPusher |
C CaptureDevice |
C DeviceEnumerator |
C VideoInEnumerator |
►N Windows |
C AudioInEnumerator | Enumerates microphones available on device
C WindowsAudioInPusher |
C AudioDesc |
C AudioInChangeNotifierNotSupported |
►C AudioOutDelayControl |
C PlayDelayConfig |
C AudioOutDummy |
C AudioSyncBuffer |
►C AudioUtil | Collection of Audio Utility functions and classes
C GeneratorPusher | IAudioPusher that provides a constant tone signal
C GeneratorReader |
C ILevelMeter | Audio Level Metering interface
C IVoiceDetector | Voice Activity Detector interface
C LevelMeter | Audio Level Meter
C LevelMeterDummy | Dummy Audio Level Meter that doesn't actually do anything
C LevelMeterFloat | LevelMeter specialization for float audio
C LevelMeterShort | LevelMeter specialization for short audio
C Resampler | Sample-rate conversion Audio Processor
C TempoUp |
C ToneAudioPusher | IAudioPusher that provides a constant tone signal
C ToneAudioReader | IAudioReader that provides a constant tone signal
C VoiceDetector | Simple voice activity detector triggered by signal level
C VoiceDetectorCalibration | Calibration Utility for Voice Detector
C VoiceDetectorDummy | Dummy VoiceDetector that doesn't actually do anything
C VoiceDetectorFloat | VoiceDetector specialization for float audio
C VoiceDetectorShort | VoiceDetector specialization for float audio
C VoiceLevelDetectCalibrate | Utility Audio Processor Voice Detection Calibration
C WaveformAudioPusher | IAudioPusher that provides the given waveform
C WaveformAudioReader | IAudioReader that provides the given waveform
C BufferReaderPushAdapterAsyncPool | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync
C BufferReaderPushAdapterAsyncPoolFloatToShort | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting float samples to short
C BufferReaderPushAdapterAsyncPoolShortToFloat | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting short samples to float
C BufferReaderPushAdapterBase | Adapter base reading data from IDataReader<T>.Read and pushing it to LocalVoice
C DecoderConfigFrame | Stores the config frame and prevents other frames decoding until the decoder is ready
C DeviceEnumeratorBase |
C DeviceFeatures |
C DeviceInfo |
C FactoryPrimitiveArrayPool | PrimitiveArrayPool<T> as wrapped in object factory interface
C FactoryReusableArray | Array factory returnig the same array instance as long as it requested with the same array length. If length changes, new array instance created
C Flip |
C FrameBuffer |
C FrameOut |
C Framer | Utility class to re-frame packets
C FramerResampler |
C IAudioDesc | Audio Source interface
C IAudioInChangeNotifier |
C IAudioOut |
C IAudioPusher | Audio Pusher interface
C IAudioReader | Audio Reader interface
C IDataReader | Interface for pulling data, in case this is more appropriate than pushing it
C IDecoder | Generic decoder interface
C IDecoderDirect | Interface for an decoder which outputs data via explicit call
C IDeviceEnumerator |
C IEncoder | Generic encoder interface
C IEncoderDirect | Interface for an encoder which consumes input data via explicit call
C IEncoderDirectImage | Interface for an encoder which consumes images via explicit call
C ILocalVoiceAudio | Interface for an outgoing audio stream
C ILogger |
►C ImageBufferInfo |
C StrideSet |
►C ImageBufferNative |
C PlaneSet |
C ImageBufferNativeAlloc |
C ImageBufferNativeGCHandleBytes |
C ImageBufferNativeGCHandleSinglePlane |
C ImageBufferNativePool |
C IProcessor | Processor interface
C IResettable |
C IServiceable | Interface for classes that want their Service() function to be called regularly in the context of a LocalVoice
C IVoiceTransport |
C LoadBalancingTransport | Extends LoadBalancingClient with media streaming functionality
C LoadBalancingTransport2 | Variant of LoadBalancingTransport. Aims to be non-alloc at the cost of breaking compatibility with older clients
C LocalVoice | Represents outgoing data stream
C LocalVoiceAudio | Outgoing audio stream
C LocalVoiceAudioDummy | Dummy LocalVoiceAudio
C LocalVoiceAudioFloat | Specialization of LocalVoiceAudio<T> for float audio
C LocalVoiceAudioShort | Specialization of LocalVoiceAudio<T> for short audio
C LocalVoiceFramed | Typed re-framing LocalVoice
C MonoPInvokeCallbackAttribute |
C ObjectFactory | Uniform interface to ObjectPool<TType, TInfo> and single reusable object
C ObjectPool | Generic Pool to re-use objects of a certain type (TType) that optionally match a certain property or set of properties (TInfo)
►C OpusCodec |
C Decoder |
C Encoder |
C EncoderFloat |
C EncoderShort |
C Factory |
C Util |
C PhotonAppSettings | Collection of connection-relevant settings, used internally by PhotonNetwork.ConnectUsingSettings
C Platform |
C PrimitiveArrayPool | Pool of Arrays with components of type T, with ObjectPool info being the array's size
►C RawCodec |
C Decoder |
C Encoder |
C ShortToFloat |
C RemoteVoiceInfo | Information about a remote voice (incoming stream)
C RemoteVoiceOptions | Event Actions and other options for a remote voice (incoming stream)
C SendFrameParams |
C UnsupportedCodecException | Exception thrown if an unsupported codec is encountered
C UnsupportedPlatformException | Exception thrown if an unsupported platform is encountered
C UnsupportedSampleTypeException | Exception thrown if an unsupported audio sample type is encountered
►C VoiceClient | Voice client interact with other clients on network via IVoiceTransport
C CreateOptions |
C VoiceCreateOptions | Used to initialize optional properties of the LocalVoice instance at creation time
C VoiceEvent |
C VoiceFollowClient | This class can be used to automatically sync client states between Leader and Voice clients
C VoiceInfo | Describes stream properties
C WebRTCAudioLib |
C WebRTCAudioProcessor |


Photon Voice: Photon Namespace Reference

Namespaces
Photon Namespace Reference


Photon Voice: Photon.Voice Namespace Reference

  • Photon
  • Voice
Namespaces | Classes | Enumerations
Photon.Voice Namespace Reference

Classes

class | AudioDesc
class | AudioInChangeNotifierNotSupported
class | AudioInEnumeratorNotSupported
class | AudioOutDelayControl
class | AudioOutDummy
class | AudioSyncBuffer
class | AudioUtil
Collection of Audio Utility functions and classes. More...
class | BufferReaderPushAdapterAsyncPool
BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync. More...
class | BufferReaderPushAdapterAsyncPoolFloatToShort
BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting float samples to short. More...
class | BufferReaderPushAdapterAsyncPoolShortToFloat
BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting short samples to float. More...
class | BufferReaderPushAdapterBase
Adapter base reading data from IDataReader<T>.Read and pushing it to LocalVoice. More...
class | DecoderConfigFrame
Stores the config frame and prevents other frames decoding until the decoder is ready. More...
class | DeviceEnumeratorBase
class | DeviceEnumeratorNotSupported
class | DeviceEnumeratorSingleDevice
class | DeviceFeatures
struct | DeviceInfo
class | FactoryPrimitiveArrayPool
PrimitiveArrayPool<T> as wrapped in object factory interface. More...
class | FactoryReusableArray
Array factory returnig the same array instance as long as it requested with the same array length. If length changes, new array instance created. More...
struct | Flip
struct | FrameBuffer
class | FrameOut
class | Framer
Utility class to re-frame packets. More...
class | FramerResampler
interface | IAudioDesc
Audio Source interface. More...
interface | IAudioInChangeNotifier
interface | IAudioOut
interface | IAudioPusher
Audio Pusher interface. More...
interface | IAudioReader
Audio Reader interface. More...
interface | IDataReader
Interface for pulling data, in case this is more appropriate than pushing it. More...
interface | IDecoder
Generic decoder interface. More...
interface | IDecoderDirect
Interface for an decoder which outputs data via explicit call. More...
interface | IDeviceEnumerator
interface | IEncoder
Generic encoder interface. More...
interface | IEncoderDirect
Interface for an encoder which consumes input data via explicit call. More...
interface | IEncoderDirectImage
Interface for an encoder which consumes images via explicit call. More...
interface | ILocalVoiceAudio
Interface for an outgoing audio stream. More...
interface | ILogger
struct | ImageBufferInfo
class | ImageBufferNative
class | ImageBufferNativeAlloc
class | ImageBufferNativeGCHandleBytes
class | ImageBufferNativeGCHandleSinglePlane
class | ImageBufferNativePool
interface | IProcessor
Processor interface. More...
interface | IResettable
interface | IServiceable
Interface for classes that want their Service() function to be called regularly in the context of a LocalVoice. More...
interface | IVoiceTransport
class | LoadBalancingTransport
Extends LoadBalancingClient with media streaming functionality. More...
class | LoadBalancingTransport2
Variant of LoadBalancingTransport. Aims to be non-alloc at the cost of breaking compatibility with older clients. More...
class | LocalVoice
Represents outgoing data stream. More...
class | LocalVoiceAudio
Outgoing audio stream. More...
class | LocalVoiceAudioDummy
Dummy LocalVoiceAudio More...
class | LocalVoiceAudioFloat
Specialization of LocalVoiceAudio<T> for float audio More...
class | LocalVoiceAudioShort
Specialization of LocalVoiceAudio<T> for short audio More...
class | LocalVoiceFramed
Typed re-framing LocalVoice More...
class | MonoPInvokeCallbackAttribute
interface | ObjectFactory
Uniform interface to ObjectPool<TType, TInfo> and single reusable object. More...
class | ObjectPool
Generic Pool to re-use objects of a certain type (TType) that optionally match a certain property or set of properties (TInfo). More...
class | OpusCodec
class | PhotonAppSettings
Collection of connection-relevant settings, used internally by PhotonNetwork.ConnectUsingSettings. More...
class | PhotonTransportProtocol
class | Platform
class | PrimitiveArrayPool
Pool of Arrays with components of type T, with ObjectPool info being the array's size. More...
class | RawCodec
class | RemoteVoice
class | RemoteVoiceInfo
Information about a remote voice (incoming stream). More...
struct | RemoteVoiceOptions
Event Actions and other options for a remote voice (incoming stream). More...
struct | SendFrameParams
class | SpacingProfile
class | UnsupportedCodecException
Exception thrown if an unsupported codec is encountered. More...
class | UnsupportedPlatformException
Exception thrown if an unsupported platform is encountered. More...
class | UnsupportedSampleTypeException
Exception thrown if an unsupported audio sample type is encountered. More...
class | Util
class | VideoInEnumeratorNotSupported
class | VoiceClient
Voice client interact with other clients on network via IVoiceTransport. More...
struct | VoiceCreateOptions
Used to initialize optional properties of the LocalVoice instance at creation time. More...
class | VoiceEvent
class | VoiceFollowClient
This class can be used to automatically sync client states between Leader and Voice clients. More...
struct | VoiceInfo
Describes stream properties. More...
class | WebRTCAudioLib
class | WebRTCAudioProcessor

Enumerations

enum | CameraFacing
enum | AudioSampleType
The type of samples used for audio processing. More...
enum | LogLevel
enum | FrameFlags : byte
enum | Codec
Enum for Media Codecs supported by PhotonVoice. More...
enum | ImageFormat
enum | Rotation

Enumeration Type Documentation

◆ AudioSampleType

enum AudioSampleType
strong

The type of samples used for audio processing.

◆ Codec

enum Codec
strong

Enum for Media Codecs supported by PhotonVoice.

Transmitted in VoiceInfo. Do not change the values of this Enum!

Enumerator
AudioOpus

OPUS audio


Photon Voice: Photon.Voice.FMOD Namespace Reference

  • FMOD
Classes
Photon.Voice.FMOD Namespace Reference

Classes

class | AudioInEnumerator
class | AudioInReader
class | AudioOut
class | AudioOutEvent


Photon Voice: AudioInEnumerator Class Reference

  • FMOD
  • AudioInEnumerator
Public Member Functions | List of all members
AudioInEnumerator Class Reference

Inherits DeviceEnumeratorBase.

Public Member Functions

AudioInEnumerator (FMODLib.System coreSystem, ILogger logger)
override void | Refresh ()
override void | Dispose ()
- Public Member Functions inherited from DeviceEnumeratorBase
DeviceEnumeratorBase (ILogger logger)
IEnumerator< DeviceInfo > | GetEnumerator ()

Additional Inherited Members

- Public Attributes inherited from DeviceEnumeratorBase
virtual bool | IsSupported => true
- Protected Attributes inherited from DeviceEnumeratorBase
List< DeviceInfo > | devices = new List<DeviceInfo>()
ILogger | logger
- Properties inherited from DeviceEnumeratorBase
virtual string | Error [get, protected set]
Action | OnReady [protected get, set]
- Properties inherited from IDeviceEnumerator
bool | IsSupported [get]
Action | OnReady [set]
string | Error [get]


Photon Voice: Member List

  • FMOD
  • AudioInEnumerator
AudioInEnumerator Member List

This is the complete list of members for AudioInEnumerator, including all inherited members.

AudioInEnumerator(FMODLib.System coreSystem, ILogger logger) (defined in AudioInEnumerator) | AudioInEnumerator |
DeviceEnumeratorBase(ILogger logger) (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
devices (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Dispose() (defined in AudioInEnumerator) | AudioInEnumerator | virtual
Error (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
GetEnumerator() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
IsSupported (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
logger (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
OnReady (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
Refresh() (defined in AudioInEnumerator) | AudioInEnumerator | virtual


Photon Voice: AudioInReader< T > Class Template Reference

  • FMOD
  • AudioInReader
Public Member Functions | Public Attributes | Properties | List of all members
AudioInReader< T > Class Template Reference

Inherits IAudioReader< T >.

Public Member Functions

AudioInReader (FMODLib.System coreSystem, int device, int suggestedFrequency, ILogger logger)
void | Dispose ()
bool | Read (T[] readBuf)
Fill full given frame buffer with source uncompressed data or return false if not enough such data. More...

Public Attributes

bool isRecording

Properties

int? | SamplingRate [get]
int? | Channels [get]
string | Error [get]
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Member Function Documentation

◆ Read()

bool Read ( T[] buffer )

Fill full given frame buffer with source uncompressed data or return false if not enough such data.

Parameters
buffer Buffer to fill.
Returns
True if buffer was filled successfully, false otherwise.

Implements IDataReader< T >.


Photon Voice: Member List

  • FMOD
  • AudioInReader
AudioInReader< T > Member List

This is the complete list of members for AudioInReader< T >, including all inherited members.

AudioInReader(FMODLib.System coreSystem, int device, int suggestedFrequency, ILogger logger) (defined in AudioInReader< T >) | AudioInReader< T >
Channels (defined in AudioInReader< T >) | AudioInReader< T >
Dispose() (defined in AudioInReader< T >) | AudioInReader< T >
Error (defined in AudioInReader< T >) | AudioInReader< T >
isRecording (defined in AudioInReader< T >) | AudioInReader< T >
Read(T[] readBuf) | AudioInReader< T >
SamplingRate (defined in AudioInReader< T >) | AudioInReader< T >


Photon Voice: AudioOut< T > Class Template Reference

  • FMOD
  • AudioOut
Public Member Functions | Protected Attributes | Properties | List of all members
AudioOut< T > Class Template Reference

Inherits AudioOutDelayControl< T >.

Inherited by AudioOutEvent< T >.

Public Member Functions

AudioOut (FMODLib.System coreSystem, PlayDelayConfig playDelayConfig, ILogger logger, string logPrefix, bool debugInfo)
override void | OutCreate (int samplingRate, int channels, int bufferSamples)
override void | OutStart ()
override void | OutWrite (T[] frame, int offsetSamples)
override void | Stop ()

Protected Attributes

int | channels
int | frequency

Properties

FMODLib.Sound | Sound [get]
FMODLib.Channel | Channel [get]
override long | OutPos [get]
string | Error [get]


Photon Voice: Member List

  • FMOD
  • AudioOut
AudioOut< T > Member List

This is the complete list of members for AudioOut< T >, including all inherited members.

AudioOut(FMODLib.System coreSystem, PlayDelayConfig playDelayConfig, ILogger logger, string logPrefix, bool debugInfo) (defined in AudioOut< T >) | AudioOut< T > |
Channel (defined in AudioOut< T >) | AudioOut< T > |
channels (defined in AudioOut< T >) | AudioOut< T > | protected
Error (defined in AudioOut< T >) | AudioOut< T > |
frequency (defined in AudioOut< T >) | AudioOut< T > | protected
OutCreate(int samplingRate, int channels, int bufferSamples) (defined in AudioOut< T >) | AudioOut< T > |
OutPos (defined in AudioOut< T >) | AudioOut< T > |
OutStart() (defined in AudioOut< T >) | AudioOut< T > |
OutWrite(T[] frame, int offsetSamples) (defined in AudioOut< T >) | AudioOut< T > |
Sound (defined in AudioOut< T >) | AudioOut< T > |
Stop() (defined in AudioOut< T >) | AudioOut< T > |


Photon Voice: AudioOutEvent< T > Class Template Reference

  • FMOD
  • AudioOutEvent
Public Member Functions | Properties | List of all members
AudioOutEvent< T > Class Template Reference

Inherits AudioOut< T >.

Public Member Functions

AudioOutEvent (FMODLib.System coreSystem, FMODLib.Studio.EventInstance fmodEvent, PlayDelayConfig playDelayConfig, ILogger logger, string logPrefix, bool debugInfo)
override void | OutStart ()
override void | Stop ()
- Public Member Functions inherited from AudioOut< T >
AudioOut (FMODLib.System coreSystem, PlayDelayConfig playDelayConfig, ILogger logger, string logPrefix, bool debugInfo)
override void | OutCreate (int samplingRate, int channels, int bufferSamples)
override void | OutStart ()
override void | OutWrite (T[] frame, int offsetSamples)
override void | Stop ()

Properties

override long | OutPos [get]
- Properties inherited from AudioOut< T >
FMODLib.Sound | Sound [get]
FMODLib.Channel | Channel [get]
override long | OutPos [get]
string | Error [get]

Additional Inherited Members

- Protected Attributes inherited from AudioOut< T >
int | channels
int | frequency


Photon Voice: Member List

  • FMOD
  • AudioOutEvent
AudioOutEvent< T > Member List

This is the complete list of members for AudioOutEvent< T >, including all inherited members.

AudioOut(FMODLib.System coreSystem, PlayDelayConfig playDelayConfig, ILogger logger, string logPrefix, bool debugInfo) (defined in AudioOut< T >) | AudioOut< T > |
AudioOutEvent(FMODLib.System coreSystem, FMODLib.Studio.EventInstance fmodEvent, PlayDelayConfig playDelayConfig, ILogger logger, string logPrefix, bool debugInfo) (defined in AudioOutEvent< T >) | AudioOutEvent< T > |
Channel (defined in AudioOut< T >) | AudioOut< T > |
channels (defined in AudioOut< T >) | AudioOut< T > | protected
Error (defined in AudioOut< T >) | AudioOut< T > |
frequency (defined in AudioOut< T >) | AudioOut< T > | protected
OutCreate(int samplingRate, int channels, int bufferSamples) (defined in AudioOut< T >) | AudioOut< T > |
OutPos (defined in AudioOutEvent< T >) | AudioOutEvent< T > |
OutStart() (defined in AudioOutEvent< T >) | AudioOutEvent< T > |
OutWrite(T[] frame, int offsetSamples) (defined in AudioOut< T >) | AudioOut< T > |
Sound (defined in AudioOut< T >) | AudioOut< T > |
Stop() (defined in AudioOutEvent< T >) | AudioOutEvent< T > |


Photon Voice: Photon.Voice.Fusion Namespace Reference

  • Fusion
Classes | Typedefs
Photon.Voice.Fusion Namespace Reference

Classes

class | FusionVoiceClient
class | VoiceNetworkObject

Typedefs

using PhotonAppSettings = global::Fusion.Photon.Realtime.PhotonAppSettings


Photon Voice: FusionVoiceClient Class Reference

  • Fusion
  • FusionVoiceClient
Public Attributes | Protected Member Functions | Protected Attributes | List of all members
FusionVoiceClient Class Reference

Inherits VoiceFollowClient, and INetworkRunnerCallbacks.

Public Attributes

bool | UseFusionAppSettings = true
Whether or not to use the Voice AppId and all the other AppSettings from Fusion's RealtimeAppSettings ScriptableObject singleton in the Voice client/app. More...
bool | UseFusionAuthValues = true
Whether or not to use the same AuthenticationValues used in Fusion client/app in Voice client/app as well. This means that the same UserID will be used in both clients. If custom authentication is used and setup in Fusion AppId from dashboard, the same configuration should be done for the Voice AppId. More...
- Public Attributes inherited from VoiceFollowClient
bool | AutoConnectAndJoin = true
Auto connect voice client and join a voice room when Leader client is joined to a Leader room More...
- Public Attributes inherited from VoiceConnection
virtual bool | AlwaysUsePrimaryRecorder => false
AppSettings | Settings
Settings to be used by this Voice Client More...
Voice.ILogger | Logger => voiceComponentImpl.Logger
VoiceLogger | VoiceLogger => voiceComponentImpl.VoiceLogger
bool | UsePrimaryRecorder => this.usePrimaryRecorder
Use VoiceConnection.PrimaryRecorder directly. More...

Protected Member Functions

override void | Start ()
override void | Awake ()
override void | OnDestroy ()
override Speaker | InstantiateSpeakerForRemoteVoice (int playerId, byte voiceId, object userData)
override string | GetVoiceRoomName ()
override bool | ConnectVoice ()
- Protected Member Functions inherited from VoiceFollowClient
override void | OnDestroy ()
override void | OnOperationResponseReceived (OperationResponse operationResponse)
void | LeaderStateChanged (ClientState toState)
override void | OnVoiceStateChanged (ClientState fromState, ClientState toState)
virtual bool | JoinVoiceRoom (string voiceRoomName)
- Protected Member Functions inherited from VoiceConnection
override void | Awake ()
virtual void | Update ()
virtual void | FixedUpdate ()
void | CalcStatistics ()

Protected Attributes

override bool | LeaderInRoom => this.networkRunner.SessionInfo.IsValid
override bool | LeaderOfflineMode => networkRunner.GameMode == GameMode.Single

Additional Inherited Members

- Public Member Functions inherited from VoiceFollowClient
bool | ConnectAndJoinRoom ()
Connect voice client to Photon servers and join a Voice room More...
void | Disconnect ()
Disconnect voice client from all Photon servers More...
- Public Member Functions inherited from VoiceConnection
virtual bool | ConnectUsingSettings (AppSettings overwriteSettings=null)
Connect to Photon server using Settings More...
bool | AddSpeaker (Speaker speaker, object userData)
Tries to link local Speaker with remote voice stream using UserData. Useful if Speaker created after stream is started. More...
Speaker | InstantiateSpeakerPrefab (GameObject parent, bool destroyOnRemove)
Instantiates SpeakerPrefab, optionally attaches it to the provided parent. More...
bool | AddRecorder (Recorder rec)
void | RemoveRecorder (Recorder rec)
- Static Public Attributes inherited from VoiceConnection
const int | ChannelAudio = 1
Recommended Photon Transport channel for audio. Chosen not to interfere with video and default channel. More...
const int | ChannelVideo = 2
Recommended Photon Transport channel for video. Chosen not to interfere with audio and default channel. More...
- Properties inherited from VoiceFollowClient
abstract bool | LeaderInRoom [get]
abstract bool | LeaderOfflineMode [get]
- Properties inherited from VoiceConnection
new LoadBalancingTransport | Client [get]
VoiceClient | VoiceClient [get]
Returns underlying Photon Voice client. More...
ClientState | ClientState [get]
Returns Photon Voice client state. More...
float | FramesReceivedPerSecond [get]
Number of frames received per second. More...
float | FramesLostPerSecond [get]
Number of frames lost per second. More...
float | FramesLostPercent [get]
Percentage of lost frames. More...
GameObject | SpeakerPrefab [get, set]
Prefab that contains Speaker component to be instantiated when receiving a new remote audio source info More...
Recorder | PrimaryRecorder [get, set]
Primary Recorder to be used by VoiceConnection implementations directly or via integration objects. More...
string | BestRegionSummaryInPreferences [get, set]
Used to store and access the "Best Region Summary" in the Player Preferences. More...
- Events inherited from VoiceConnection
Action< Speaker > | SpeakerLinked
Fires when a speaker has been linked to a remote audio stream More...
Action< RemoteVoiceLink > | RemoteVoiceAdded
Fires when a remote voice stream is added More...

Member Data Documentation

◆ UseFusionAppSettings

bool UseFusionAppSettings = true

Whether or not to use the Voice AppId and all the other AppSettings from Fusion's RealtimeAppSettings ScriptableObject singleton in the Voice client/app.

◆ UseFusionAuthValues

bool UseFusionAuthValues = true

Whether or not to use the same AuthenticationValues used in Fusion client/app in Voice client/app as well. This means that the same UserID will be used in both clients. If custom authentication is used and setup in Fusion AppId from dashboard, the same configuration should be done for the Voice AppId.


Photon Voice: Member List

  • Fusion
  • FusionVoiceClient
FusionVoiceClient Member List

This is the complete list of members for FusionVoiceClient, including all inherited members.

AddRecorder(Recorder rec) (defined in VoiceConnection) | VoiceConnection |
AddSpeaker(Speaker speaker, object userData) | VoiceConnection |
AlwaysUsePrimaryRecorder (defined in VoiceConnection) | VoiceConnection |
AutoConnectAndJoin | VoiceFollowClient |
Awake() (defined in FusionVoiceClient) | FusionVoiceClient | protected
BestRegionSummaryInPreferences | VoiceConnection |
CalcStatistics() (defined in VoiceConnection) | VoiceConnection | protected
ChannelAudio | VoiceConnection | static
ChannelVideo | VoiceConnection | static
Client (defined in VoiceConnection) | VoiceConnection |
ClientState | VoiceConnection |
ConnectAndJoinRoom() | VoiceFollowClient |
ConnectUsingSettings(AppSettings overwriteSettings=null) | VoiceConnection | virtual
ConnectVoice() (defined in FusionVoiceClient) | FusionVoiceClient | protectedvirtual
Disconnect() | VoiceFollowClient |
FixedUpdate() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
FramesLostPercent | VoiceConnection |
FramesLostPerSecond | VoiceConnection |
FramesReceivedPerSecond | VoiceConnection |
GetVoiceRoomName() (defined in FusionVoiceClient) | FusionVoiceClient | protectedvirtual
InstantiateSpeakerForRemoteVoice(int playerId, byte voiceId, object userData) (defined in FusionVoiceClient) | FusionVoiceClient | protectedvirtual
InstantiateSpeakerPrefab(GameObject parent, bool destroyOnRemove) | VoiceConnection |
JoinVoiceRoom(string voiceRoomName) (defined in VoiceFollowClient) | VoiceFollowClient | protectedvirtual
LeaderInRoom (defined in FusionVoiceClient) | FusionVoiceClient | protected
LeaderOfflineMode (defined in FusionVoiceClient) | FusionVoiceClient | protected
LeaderStateChanged(ClientState toState) (defined in VoiceFollowClient) | VoiceFollowClient | protected
Logger (defined in VoiceConnection) | VoiceConnection |
OnDestroy() (defined in FusionVoiceClient) | FusionVoiceClient | protectedvirtual
OnOperationResponseReceived(OperationResponse operationResponse) (defined in VoiceFollowClient) | VoiceFollowClient | protectedvirtual
OnVoiceStateChanged(ClientState fromState, ClientState toState) (defined in VoiceFollowClient) | VoiceFollowClient | protectedvirtual
PrimaryRecorder | VoiceConnection |
RemoteVoiceAdded | VoiceConnection |
RemoveRecorder(Recorder rec) (defined in VoiceConnection) | VoiceConnection |
Settings | VoiceConnection |
SpeakerLinked | VoiceConnection |
SpeakerPrefab | VoiceConnection |
Start() (defined in FusionVoiceClient) | FusionVoiceClient | protectedvirtual
Update() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
UseFusionAppSettings | FusionVoiceClient |
UseFusionAuthValues | FusionVoiceClient |
UsePrimaryRecorder | VoiceConnection |
VoiceClient | VoiceConnection |
VoiceLogger (defined in VoiceConnection) | VoiceConnection |


Photon Voice: VoiceNetworkObject Class Reference

  • Fusion
  • VoiceNetworkObject
Public Member Functions | Public Attributes | Protected Attributes | Properties | List of all members
VoiceNetworkObject Class Reference

Inherits NetworkBehaviour.

Public Member Functions

override void | Spawned ()
override void | Despawned (NetworkRunner runner, bool hasState)

Public Attributes

VoiceLogger | VoiceLogger => voiceComponentImpl.VoiceLogger
bool | IsSpeaking => this.SpeakerInUse != null && this.SpeakerInUse.IsPlaying
If true, this VoiceNetworkObject has a Speaker that is currently playing received audio frames from remote audio source More...
bool | IsRecording => this.RecorderInUse != null && this.RecorderInUse.IsCurrentlyTransmitting
If true, this VoiceNetworkObject has a Recorder that is currently transmitting audio stream from local audio source More...
bool | IsLocal => Runner.Topology == SimulationConfig.Topologies.Shared ? this.Object.HasStateAuthority : this.Object.HasInputAuthority

Protected Attributes

Voice.ILogger Logger => voiceComponentImpl.Logger

Properties

Recorder | RecorderInUse [get]
The Recorder component currently used by this VoiceNetworkObject More...
Speaker | SpeakerInUse [get]
The Speaker component currently used by this VoiceNetworkObject More...

Member Data Documentation

◆ IsRecording

bool IsRecording => this.RecorderInUse != null && this.RecorderInUse.IsCurrentlyTransmitting

If true, this VoiceNetworkObject has a Recorder that is currently transmitting audio stream from local audio source

◆ IsSpeaking

bool IsSpeaking => this.SpeakerInUse != null && this.SpeakerInUse.IsPlaying

If true, this VoiceNetworkObject has a Speaker that is currently playing received audio frames from remote audio source

Property Documentation

◆ RecorderInUse

Recorder RecorderInUse
get

The Recorder component currently used by this VoiceNetworkObject

◆ SpeakerInUse

Speaker SpeakerInUse
get

The Speaker component currently used by this VoiceNetworkObject


Photon Voice: Member List

  • Fusion
  • VoiceNetworkObject
VoiceNetworkObject Member List

This is the complete list of members for VoiceNetworkObject, including all inherited members.

Despawned(NetworkRunner runner, bool hasState) (defined in VoiceNetworkObject) | VoiceNetworkObject |
IsLocal (defined in VoiceNetworkObject) | VoiceNetworkObject |
IsRecording | VoiceNetworkObject |
IsSpeaking | VoiceNetworkObject |
Logger (defined in VoiceNetworkObject) | VoiceNetworkObject | protected
RecorderInUse | VoiceNetworkObject |
Spawned() (defined in VoiceNetworkObject) | VoiceNetworkObject |
SpeakerInUse | VoiceNetworkObject |
VoiceLogger (defined in VoiceNetworkObject) | VoiceNetworkObject |


Photon Voice: Photon.Voice.IOS Namespace Reference

  • IOS
Classes | Enumerations
Photon.Voice.IOS Namespace Reference

Classes

class | AudioInChangeNotifier
class | AudioInPusher
class | AudioInReader
struct | AudioSessionParameters
class | AudioSessionParametersPresets

Enumerations

enum | AudioSessionCategory
enum | AudioSessionMode
enum | AudioSessionCategoryOption

Enumeration Type Documentation

◆ AudioSessionCategory

enum AudioSessionCategory
strong
Enumerator
Ambient

Use this category for background sounds such as rain, car engine noise, etc. Mixes with other music.

API_AVAILABLE(ios(3.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);

SoloAmbient

Use this category for background sounds. Other music will stop playing.

API_AVAILABLE(ios(3.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);

Playback

Use this category for music tracks.

API_AVAILABLE(ios(3.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);

Record

Use this category when recording audio.

API_AVAILABLE(ios(3.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);

PlayAndRecord

Use this category when recording and playing back audio.

API_AVAILABLE(ios(3.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);

AudioProcessing

Use this category when using a hardware codec or signal processor while not playing or recording audio.

API_DEPRECATED("No longer supported", ios(3.0, 10.0)) API_UNAVAILABLE(watchos, tvos) API_UNAVAILABLE(macos);

MultiRoute

Use this category to customize the usage of available audio accessories and built-in audio hardware. For example, this category provides an application with the ability to use an available USB output and headphone output simultaneously for separate, distinct streams of audio data. Use of this category by an application requires a more detailed knowledge of, and interaction with, the capabilities of the available audio routes. May be used for input, output, or both. Note that not all output types and output combinations are eligible for multi-route. Input is limited to the last-in input port. Eligible inputs consist of the following: AVAudioSessionPortUSBAudio, AVAudioSessionPortHeadsetMic, and AVAudioSessionPortBuiltInMic. Eligible outputs consist of the following: AVAudioSessionPortUSBAudio, AVAudioSessionPortLineOut, AVAudioSessionPortHeadphones, AVAudioSessionPortHDMI, and AVAudioSessionPortBuiltInSpeaker. Note that AVAudioSessionPortBuiltInSpeaker is only allowed to be used when there are no other eligible outputs connected.

API_AVAILABLE(ios(6.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);

◆ AudioSessionCategoryOption

enum AudioSessionCategoryOption
strong
Enumerator
MixWithOthers

This allows an application to set whether or not other active audio apps will be interrupted or mixed with when your app's audio session goes active. The typical cases are: (1) AVAudioSessionCategoryPlayAndRecord or AVAudioSessionCategoryMultiRoute this will default to false, but can be set to true. This would allow other applications to play in the background while an app had both audio input and output enabled (2) AVAudioSessionCategoryPlayback this will default to false, but can be set to true. This would allow other applications to play in the background, but an app will still be able to play regardless of the setting of the ringer switch (3) Other categories this defaults to false and cannot be changed (that is, the mix with others setting of these categories cannot be overridden. An application must be prepared for setting this property to fail as behaviour may change in future releases. If an application changes their category, they should reassert the option (it is not sticky across category changes). MixWithOthers is only valid with AVAudioSessionCategoryPlayAndRecord, AVAudioSessionCategoryPlayback, and AVAudioSessionCategoryMultiRoute

DuckOthers

This allows an application to set whether or not other active audio apps will be ducked when when your app's audio session goes active. An example of this is the Nike app, which provides periodic updates to its user (it reduces the volume of any music currently being played while it provides its status). This defaults to off. Note that the other audio will be ducked for as long as the current session is active. You will need to deactivate your audio session when you want full volume playback of the other audio. If your category is AVAudioSessionCategoryPlayback, AVAudioSessionCategoryPlayAndRecord, or AVAudioSessionCategoryMultiRoute, by default the audio session will be non-mixable and non-ducking. Setting this option will also make your category mixable with others (AVAudioSessionCategoryOptionMixWithOthers will be set). DuckOthers is only valid with AVAudioSessionCategoryAmbient, AVAudioSessionCategoryPlayAndRecord, AVAudioSessionCategoryPlayback, and AVAudioSessionCategoryMultiRoute

AllowBluetooth

This allows an application to change the default behaviour of some audio session categories with regards to showing bluetooth Hands-Free Profile (HFP) devices as available routes. The current category behavior is: (1) AVAudioSessionCategoryPlayAndRecord this will default to false, but can be set to true. This will allow a paired bluetooth HFP device to show up as an available route for input, while playing through the category-appropriate output (2) AVAudioSessionCategoryRecord this will default to false, but can be set to true. This will allow a paired bluetooth HFP device to show up as an available route for input (3) Other categories this defaults to false and cannot be changed (that is, enabling bluetooth for input in these categories is not allowed) An application must be prepared for setting this option to fail as behaviour may change in future releases. If an application changes their category or mode, they should reassert the override (it is not sticky across category and mode changes). AllowBluetooth is only valid with AVAudioSessionCategoryRecord and AVAudioSessionCategoryPlayAndRecord

DefaultToSpeaker

This allows an application to change the default behaviour of some audio session categories with regards to the audio route. The current category behavior is: (1) AVAudioSessionCategoryPlayAndRecord category this will default to false, but can be set to true. this will route to Speaker (instead of Receiver) when no other audio route is connected. (2) Other categories this defaults to false and cannot be changed (that is, the default to speaker setting of these categories cannot be overridden An application must be prepared for setting this property to fail as behaviour may change in future releases. If an application changes their category, they should reassert the override (it is not sticky across category and mode changes). DefaultToSpeaker is only valid with AVAudioSessionCategoryPlayAndRecord

◆ AudioSessionMode

enum AudioSessionMode
strong
Enumerator
Default | Modes modify the audio category in order to introduce behavior that is tailored to the specific use of audio within an application. Available in iOS 5.0 and greater. The default mode API_AVAILABLE(ios(5.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);
VoiceChat | Only valid with AVAudioSessionCategoryPlayAndRecord. Appropriate for Voice over IP (VoIP) applications. Reduces the number of allowable audio routes to be only those that are appropriate for VoIP applications and may engage appropriate system-supplied signal processing. Has the side effect of setting AVAudioSessionCategoryOptionAllowBluetooth API_AVAILABLE(ios(5.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);
VideoRecording | Only valid with AVAudioSessionCategoryPlayAndRecord or AVAudioSessionCategoryRecord. Modifies the audio routing options and may engage appropriate system-supplied signal processing. API_AVAILABLE(ios(5.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);
Measurement | Appropriate for applications that wish to minimize the effect of system-supplied signal processing for input and/or output audio signals. API_AVAILABLE(ios(5.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);
MoviePlayback | Engages appropriate output signal processing for movie playback scenarios. Currently only applied during playback over built-in speaker. API_AVAILABLE(ios(6.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);
VideoChat | Only valid with kAudioSessionCategory_PlayAndRecord. Reduces the number of allowable audio routes to be only those that are appropriate for video chat applications. May engage appropriate system-supplied signal processing. Has the side effect of setting AVAudioSessionCategoryOptionAllowBluetooth and AVAudioSessionCategoryOptionDefaultToSpeaker. API_AVAILABLE(ios(7.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);


Photon Voice: AudioInChangeNotifier Class Reference

  • IOS
  • AudioInChangeNotifier
Public Member Functions | Public Attributes | Properties | List of all members
AudioInChangeNotifier Class Reference

Inherits IAudioInChangeNotifier.

Public Member Functions

AudioInChangeNotifier (Action callback, ILogger logger)
void Dispose ()
Disposes enumerator. Call it to free native resources. More...

Public Attributes

bool IsSupported => true

Properties

string | Error [get]
If not null, the enumerator is in invalid state. More...
- Properties inherited from IAudioInChangeNotifier
bool | IsSupported [get]
string | Error [get]

Member Function Documentation

◆ Dispose()

void Dispose ( )

Disposes enumerator. Call it to free native resources.

Property Documentation

◆ Error

string Error
get

If not null, the enumerator is in invalid state.


Photon Voice: Member List

  • IOS
  • AudioInChangeNotifier
AudioInChangeNotifier Member List

This is the complete list of members for AudioInChangeNotifier, including all inherited members.

AudioInChangeNotifier(Action callback, ILogger logger) (defined in AudioInChangeNotifier) | AudioInChangeNotifier
Dispose() | AudioInChangeNotifier
Error | AudioInChangeNotifier
IsSupported (defined in AudioInChangeNotifier) | AudioInChangeNotifier


Photon Voice: AudioInPusher Class Reference

  • IOS
  • AudioInPusher
Public Member Functions | Properties | List of all members
AudioInPusher Class Reference

Inherits IAudioPusher< float >, and IResettable.

Public Member Functions

AudioInPusher (AudioSessionParameters sessParam, ILogger logger)
void | SetCallback (Action< float[]> callback, ObjectFactory< float[], int > bufferFactory)
void | Reset ()
void | Dispose ()
- Public Member Functions inherited from IAudioPusher< float >
void | SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data. More...

Properties

int | Channels [get]
int | SamplingRate [get]
string | Error [get]


Photon Voice: Member List

  • IOS
  • AudioInPusher
AudioInPusher Member List

This is the complete list of members for AudioInPusher, including all inherited members.

AudioInPusher(AudioSessionParameters sessParam, ILogger logger) (defined in AudioInPusher) | AudioInPusher
Channels (defined in AudioInPusher) | AudioInPusher
Dispose() (defined in AudioInPusher) | AudioInPusher
Error (defined in AudioInPusher) | AudioInPusher
Reset() (defined in AudioInPusher) | AudioInPusher
SamplingRate (defined in AudioInPusher) | AudioInPusher
SetCallback(Action< float[]> callback, ObjectFactory< float[], int > bufferFactory) (defined in AudioInPusher) | AudioInPusher
IAudioPusher< float >.SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | IAudioPusher< float >


Photon Voice: AudioInReader Class Reference

  • IOS
  • AudioInReader
Public Member Functions | Properties | List of all members
AudioInReader Class Reference

Inherits IAudioReader< float >, and IResettable.

Public Member Functions

AudioInReader (AudioSessionParameters sessParam, ILogger logger)
void | Reset ()
void | Dispose ()
bool | Read (float[] buf)

Properties

int | Channels [get]
int | SamplingRate [get]
string | Error [get]


Photon Voice: Member List

  • IOS
  • AudioInReader
AudioInReader Member List

This is the complete list of members for AudioInReader, including all inherited members.

AudioInReader(AudioSessionParameters sessParam, ILogger logger) (defined in AudioInReader) | AudioInReader
Channels (defined in AudioInReader) | AudioInReader
Dispose() (defined in AudioInReader) | AudioInReader
Error (defined in AudioInReader) | AudioInReader
Read(float[] buf) (defined in AudioInReader) | AudioInReader
Reset() (defined in AudioInReader) | AudioInReader
SamplingRate (defined in AudioInReader) | AudioInReader


Photon Voice: AudioSessionParameters Struct Reference

  • IOS
  • AudioSessionParameters
Public Member Functions | Public Attributes | List of all members
AudioSessionParameters Struct Reference

Public Member Functions

int | CategoryOptionsToInt ()
override string | ToString ()

Public Attributes

AudioSessionCategory | Category
AudioSessionMode | Mode
AudioSessionCategoryOption[] | CategoryOptions


Photon Voice: Member List

  • IOS
  • AudioSessionParameters
AudioSessionParameters Member List

This is the complete list of members for AudioSessionParameters, including all inherited members.

Category (defined in AudioSessionParameters) | AudioSessionParameters
CategoryOptions (defined in AudioSessionParameters) | AudioSessionParameters
CategoryOptionsToInt() (defined in AudioSessionParameters) | AudioSessionParameters
Mode (defined in AudioSessionParameters) | AudioSessionParameters
ToString() (defined in AudioSessionParameters) | AudioSessionParameters


Photon Voice: AudioSessionParametersPresets Class Reference

  • IOS
  • AudioSessionParametersPresets
Static Public Attributes | List of all members
AudioSessionParametersPresets Class Reference

Static Public Attributes

static AudioSessionParameters | Game
static AudioSessionParameters | VoIP

Member Data Documentation

◆ Game

AudioSessionParameters Game
static
Initial value:
= new AudioSessionParameters()
{
Category = AudioSessionCategory.PlayAndRecord,
Mode = AudioSessionMode.VoiceChat,
CategoryOptions = new AudioSessionCategoryOption[] { AudioSessionCategoryOption.DefaultToSpeaker, AudioSessionCategoryOption.AllowBluetooth }
}

◆ VoIP

AudioSessionParameters VoIP
static
Initial value:
= new AudioSessionParameters()
{
Category = AudioSessionCategory.PlayAndRecord,
Mode = AudioSessionMode.VoiceChat,
CategoryOptions = new AudioSessionCategoryOption[] { AudioSessionCategoryOption.AllowBluetooth }
}
Photon.Voice.IOS.AudioSessionCategoryOption
AudioSessionCategoryOption
Definition: iOSAudioSession.cs:129
Photon.Voice.IOS.AudioSessionCategory
AudioSessionCategory
Definition: iOSAudioSession.cs:3
Photon.Voice.IOS.AudioSessionMode
AudioSessionMode
Definition: iOSAudioSession.cs:50


Photon Voice: Member List

  • IOS
  • AudioSessionParametersPresets
AudioSessionParametersPresets Member List

This is the complete list of members for AudioSessionParametersPresets, including all inherited members.

Game (defined in AudioSessionParametersPresets) | AudioSessionParametersPresets | static
VoIP (defined in AudioSessionParametersPresets) | AudioSessionParametersPresets | static


Photon Voice: Photon.Voice.MacOS Namespace Reference

  • MacOS
Classes
Photon.Voice.MacOS Namespace Reference

Classes

class | AudioInChangeNotifier
class | AudioInEnumerator
Enumerates microphones available on device. More...
class | AudioInPusher
class | AudioInReader


Photon Voice: AudioInChangeNotifier Class Reference

  • MacOS
  • AudioInChangeNotifier
Public Member Functions | Public Attributes | Properties | List of all members
AudioInChangeNotifier Class Reference

Inherits IAudioInChangeNotifier.

Public Member Functions

AudioInChangeNotifier (Action callback, ILogger logger)
void Dispose ()
Disposes enumerator. Call it to free native resources. More...

Public Attributes

bool IsSupported => true

Properties

string | Error [get]
If not null, the enumerator is in invalid state. More...
- Properties inherited from IAudioInChangeNotifier
bool | IsSupported [get]
string | Error [get]

Member Function Documentation

◆ Dispose()

void Dispose ( )

Disposes enumerator. Call it to free native resources.

Property Documentation

◆ Error

string Error
get

If not null, the enumerator is in invalid state.


Photon Voice: Member List

  • MacOS
  • AudioInChangeNotifier
AudioInChangeNotifier Member List

This is the complete list of members for AudioInChangeNotifier, including all inherited members.

AudioInChangeNotifier(Action callback, ILogger logger) (defined in AudioInChangeNotifier) | AudioInChangeNotifier
Dispose() | AudioInChangeNotifier
Error | AudioInChangeNotifier
IsSupported (defined in AudioInChangeNotifier) | AudioInChangeNotifier


Photon Voice: AudioInEnumerator Class Reference

  • MacOS
  • AudioInEnumerator
Public Member Functions | List of all members
AudioInEnumerator Class Reference

Enumerates microphones available on device. More...

Inherits DeviceEnumeratorBase.

Public Member Functions

AudioInEnumerator (ILogger logger)
override void | Refresh ()
Refreshes the microphones list. More...
override void | Dispose ()
Disposes enumerator. Call it to free native resources. More...
- Public Member Functions inherited from DeviceEnumeratorBase
DeviceEnumeratorBase (ILogger logger)
IEnumerator< DeviceInfo > | GetEnumerator ()

Additional Inherited Members

- Public Attributes inherited from DeviceEnumeratorBase
virtual bool | IsSupported => true
- Protected Attributes inherited from DeviceEnumeratorBase
List< DeviceInfo > | devices = new List<DeviceInfo>()
ILogger | logger
- Properties inherited from DeviceEnumeratorBase
virtual string | Error [get, protected set]
Action | OnReady [protected get, set]
- Properties inherited from IDeviceEnumerator
bool | IsSupported [get]
Action | OnReady [set]
string | Error [get]

Detailed Description

Enumerates microphones available on device.

Member Function Documentation

◆ Dispose()

override void Dispose ( )
virtual

Disposes enumerator. Call it to free native resources.

Implements DeviceEnumeratorBase.

◆ Refresh()

override void Refresh ( )
virtual

Refreshes the microphones list.

Implements DeviceEnumeratorBase.


Photon Voice: Member List

  • MacOS
  • AudioInEnumerator
AudioInEnumerator Member List

This is the complete list of members for AudioInEnumerator, including all inherited members.

AudioInEnumerator(ILogger logger) (defined in AudioInEnumerator) | AudioInEnumerator |
DeviceEnumeratorBase(ILogger logger) (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
devices (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Dispose() | AudioInEnumerator | virtual
Error (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
GetEnumerator() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
IsSupported (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
logger (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
OnReady (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
Refresh() | AudioInEnumerator | virtual


Photon Voice: AudioInPusher Class Reference

  • MacOS
  • AudioInPusher
Public Member Functions | Properties | List of all members
AudioInPusher Class Reference

Inherits IAudioPusher< float >.

Public Member Functions

AudioInPusher (int deviceID, ILogger logger)
void | SetCallback (Action< float[]> callback, ObjectFactory< float[], int > bufferFactory)
void | Dispose ()
- Public Member Functions inherited from IAudioPusher< float >
void | SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data. More...

Properties

int | Channels [get]
int | SamplingRate [get]
string | Error [get]


Photon Voice: Member List

  • MacOS
  • AudioInPusher
AudioInPusher Member List

This is the complete list of members for AudioInPusher, including all inherited members.

AudioInPusher(int deviceID, ILogger logger) (defined in AudioInPusher) | AudioInPusher
Channels (defined in AudioInPusher) | AudioInPusher
Dispose() (defined in AudioInPusher) | AudioInPusher
Error (defined in AudioInPusher) | AudioInPusher
SamplingRate (defined in AudioInPusher) | AudioInPusher
SetCallback(Action< float[]> callback, ObjectFactory< float[], int > bufferFactory) (defined in AudioInPusher) | AudioInPusher
IAudioPusher< float >.SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | IAudioPusher< float >


Photon Voice: AudioInReader Class Reference

  • MacOS
  • AudioInReader
Public Member Functions | Properties | List of all members
AudioInReader Class Reference

Inherits IAudioReader< float >.

Public Member Functions

AudioInReader (int deviceID, ILogger logger)
void | Dispose ()
bool | Read (float[] buf)

Properties

int | Channels [get]
int | SamplingRate [get]
string | Error [get]


Photon Voice: Member List

  • MacOS
  • AudioInReader
AudioInReader Member List

This is the complete list of members for AudioInReader, including all inherited members.

AudioInReader(int deviceID, ILogger logger) (defined in AudioInReader) | AudioInReader
Channels (defined in AudioInReader) | AudioInReader
Dispose() (defined in AudioInReader) | AudioInReader
Error (defined in AudioInReader) | AudioInReader
Read(float[] buf) (defined in AudioInReader) | AudioInReader
SamplingRate (defined in AudioInReader) | AudioInReader


Photon Voice: Photon.Voice.PUN Namespace Reference

  • PUN
Namespaces | Classes
Photon.Voice.PUN Namespace Reference

Classes

class | PhotonVoiceView
Component that should be attached to a networked PUN prefab that has PhotonView. It will bind remote Recorder with local Speaker of the same networked prefab. This component makes automatic voice stream routing easy for players' characters/avatars. More...
class | PunVoiceClient
This class can be used to automatically sync client states between PUN and Voice. It also finds the Speaker component for a character's voice. For this to work attach a PhotonVoiceView next to the PhotonView of your player's prefab. More...


Photon Voice: Photon.Voice.PUN.UtilityScripts Namespace Reference

  • PUN
  • UtilityScripts
Classes
Photon.Voice.PUN.UtilityScripts Namespace Reference

Classes

class VoiceDebugScript
Utility script to be attached next to PhotonVoiceView & PhotonView on the player prefab to be network instantiated. Call voiceDebugScript.CantHearYou() on the networked object of the remote (or local) player if you can't hear the corresponding player. More...


Photon Voice: VoiceDebugScript Class Reference

  • PUN
  • UtilityScripts
  • VoiceDebugScript
Public Member Functions | Public Attributes | List of all members
VoiceDebugScript Class Reference

Utility script to be attached next to PhotonVoiceView & PhotonView on the player prefab to be network instantiated. Call voiceDebugScript.CantHearYou() on the networked object of the remote (or local) player if you can't hear the corresponding player. More...

Inherits MonoBehaviourPun.

Public Member Functions

void CantHearYou ()

Public Attributes

bool | ForceRecordingAndTransmission
Make sure recorder.TransmitEnabled and recorder.RecordingEnabled are true. More...
AudioClip | TestAudioClip
Audio file to be broadcast when TestUsingAudioClip is enabled. More...
bool | TestUsingAudioClip
Broadcast Audio file to make sure transmission over network works if microphone (audio input device/hardware) is not reliable. Requires setting AudioClip in TestAudioClip. More...
bool | DisableVad
Disable recorder.VoiceDetection for easier testing. More...
bool | IncreaseLogLevels
Set main voice component's log level to ALL (max). More...
bool | LocalDebug
Debug DebugEcho mode (Can't Hear My Self?!). More...

Detailed Description

Utility script to be attached next to PhotonVoiceView & PhotonView on the player prefab to be network instantiated. Call voiceDebugScript.CantHearYou() on the networked object of the remote (or local) player if you can't hear the corresponding player.

Member Data Documentation

◆ DisableVad

bool DisableVad

Disable recorder.VoiceDetection for easier testing.

◆ ForceRecordingAndTransmission

bool ForceRecordingAndTransmission

Make sure recorder.TransmitEnabled and recorder.RecordingEnabled are true.

◆ IncreaseLogLevels

bool IncreaseLogLevels

Set main voice component's log level to ALL (max).

◆ LocalDebug

bool LocalDebug

Debug DebugEcho mode (Can't Hear My Self?!).

◆ TestAudioClip

AudioClip TestAudioClip

Audio file to be broadcast when TestUsingAudioClip is enabled.

◆ TestUsingAudioClip

bool TestUsingAudioClip

Broadcast Audio file to make sure transmission over network works if microphone (audio input device/hardware) is not reliable. Requires setting AudioClip in TestAudioClip.


Photon Voice: Member List

  • PUN
  • UtilityScripts
  • VoiceDebugScript
VoiceDebugScript Member List

This is the complete list of members for VoiceDebugScript, including all inherited members.

CantHearYou() (defined in VoiceDebugScript) | VoiceDebugScript
DisableVad | VoiceDebugScript
ForceRecordingAndTransmission | VoiceDebugScript
IncreaseLogLevels | VoiceDebugScript
LocalDebug | VoiceDebugScript
TestAudioClip | VoiceDebugScript
TestUsingAudioClip | VoiceDebugScript


Photon Voice: PhotonVoiceView Class Reference

  • PUN
  • PhotonVoiceView
Protected Member Functions | Properties | List of all members
PhotonVoiceView Class Reference

Component that should be attached to a networked PUN prefab that has PhotonView. It will bind remote Recorder with local Speaker of the same networked prefab. This component makes automatic voice stream routing easy for players' characters/avatars. More...

Inherits VoiceComponent.

Protected Member Functions

override void Awake ()

Properties

Recorder | RecorderInUse [get]
The Recorder component currently used by this PhotonVoiceView More...
Speaker | SpeakerInUse [get]
The Speaker component currently used by this PhotonVoiceView More...
bool | IsSpeaking [get]
If true, this PhotonVoiceView has a Speaker that is currently playing received audio frames from remote audio source More...
bool | IsRecording [get]
If true, this PhotonVoiceView has a Recorder that is currently transmitting audio stream from local audio source More...
- Properties inherited from VoiceComponent
string | Name [set]

Additional Inherited Members

- Public Attributes inherited from VoiceComponent
VoiceLogger | VoiceLogger => impl.VoiceLogger
- Protected Attributes inherited from VoiceComponent
Voice.ILogger | Logger => impl.Logger

Detailed Description

Component that should be attached to a networked PUN prefab that has PhotonView. It will bind remote Recorder with local Speaker of the same networked prefab. This component makes automatic voice stream routing easy for players' characters/avatars.

Property Documentation

◆ IsRecording

bool IsRecording
get

If true, this PhotonVoiceView has a Recorder that is currently transmitting audio stream from local audio source

◆ IsSpeaking

bool IsSpeaking
get

If true, this PhotonVoiceView has a Speaker that is currently playing received audio frames from remote audio source

◆ RecorderInUse

Recorder RecorderInUse
get

The Recorder component currently used by this PhotonVoiceView

◆ SpeakerInUse

Speaker SpeakerInUse
get

The Speaker component currently used by this PhotonVoiceView


Photon Voice: Member List

  • PUN
  • PhotonVoiceView
PhotonVoiceView Member List

This is the complete list of members for PhotonVoiceView, including all inherited members.

Awake() (defined in PhotonVoiceView) | PhotonVoiceView | protectedvirtual
IsRecording | PhotonVoiceView |
IsSpeaking | PhotonVoiceView |
Logger (defined in VoiceComponent) | VoiceComponent | protected
Name (defined in VoiceComponent) | VoiceComponent |
RecorderInUse | PhotonVoiceView |
SpeakerInUse | PhotonVoiceView |
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: PunVoiceClient Class Reference

  • PUN
  • PunVoiceClient
Static Public Attributes | Protected Member Functions | Protected Attributes | Properties | List of all members
PunVoiceClient Class Reference

This class can be used to automatically sync client states between PUN and Voice. It also finds the Speaker component for a character's voice. For this to work attach a PhotonVoiceView next to the PhotonView of your player's prefab. More...

Inherits VoiceFollowClient.

Static Public Attributes

const string | VoiceRoomNameSuffix = "_voice_"
Suffix for voice room names appended to Leader room names. More...
- Static Public Attributes inherited from VoiceConnection
const int | ChannelAudio = 1
Recommended Photon Transport channel for audio. Chosen not to interfere with video and default channel. More...
const int | ChannelVideo = 2
Recommended Photon Transport channel for video. Chosen not to interfere with audio and default channel. More...

Protected Member Functions

override void | Start ()
override void | OnDestroy ()
override Speaker | InstantiateSpeakerForRemoteVoice (int playerId, byte voiceId, object userData)
override string | GetVoiceRoomName ()
override bool | ConnectVoice ()
- Protected Member Functions inherited from VoiceFollowClient
override void | OnDestroy ()
override void | OnOperationResponseReceived (OperationResponse operationResponse)
void | LeaderStateChanged (ClientState toState)
override void | OnVoiceStateChanged (ClientState fromState, ClientState toState)
virtual bool | JoinVoiceRoom (string voiceRoomName)
- Protected Member Functions inherited from VoiceConnection
override void | Awake ()
virtual void | Update ()
virtual void | FixedUpdate ()
void | CalcStatistics ()

Protected Attributes

override bool | LeaderInRoom => PhotonNetwork.InRoom
override bool | LeaderOfflineMode => PhotonNetwork.OfflineMode

Properties

static PunVoiceClient | Instance [get]
Singleton instance for PunVoiceClient More...
bool | UsePunAppSettings [get, set]
Whether or not to use the Voice AppId and all the other AppSettings from PUN's PhotonServerSettings ScriptableObject singleton in the Voice client/app. More...
bool | UsePunAuthValues [get, set]
Whether or not to use the same PhotonNetwork.AuthValues in PunVoiceClient.Instance.Client.AuthValues. This means that the same UserID will be used in both clients. If custom authentication is used and setup in PUN app, the same configuration should be done for the Voice app. More...
- Properties inherited from VoiceFollowClient
abstract bool | LeaderInRoom [get]
abstract bool | LeaderOfflineMode [get]
- Properties inherited from VoiceConnection
new LoadBalancingTransport | Client [get]
VoiceClient | VoiceClient [get]
Returns underlying Photon Voice client. More...
ClientState | ClientState [get]
Returns Photon Voice client state. More...
float | FramesReceivedPerSecond [get]
Number of frames received per second. More...
float | FramesLostPerSecond [get]
Number of frames lost per second. More...
float | FramesLostPercent [get]
Percentage of lost frames. More...
GameObject | SpeakerPrefab [get, set]
Prefab that contains Speaker component to be instantiated when receiving a new remote audio source info More...
Recorder | PrimaryRecorder [get, set]
Primary Recorder to be used by VoiceConnection implementations directly or via integration objects. More...
string | BestRegionSummaryInPreferences [get, set]
Used to store and access the "Best Region Summary" in the Player Preferences. More...

Additional Inherited Members

- Public Member Functions inherited from VoiceFollowClient
bool | ConnectAndJoinRoom ()
Connect voice client to Photon servers and join a Voice room More...
void | Disconnect ()
Disconnect voice client from all Photon servers More...
- Public Member Functions inherited from VoiceConnection
virtual bool | ConnectUsingSettings (AppSettings overwriteSettings=null)
Connect to Photon server using Settings More...
bool | AddSpeaker (Speaker speaker, object userData)
Tries to link local Speaker with remote voice stream using UserData. Useful if Speaker created after stream is started. More...
Speaker | InstantiateSpeakerPrefab (GameObject parent, bool destroyOnRemove)
Instantiates SpeakerPrefab, optionally attaches it to the provided parent. More...
bool | AddRecorder (Recorder rec)
void | RemoveRecorder (Recorder rec)
- Public Attributes inherited from VoiceFollowClient
bool | AutoConnectAndJoin = true
Auto connect voice client and join a voice room when Leader client is joined to a Leader room More...
- Public Attributes inherited from VoiceConnection
virtual bool | AlwaysUsePrimaryRecorder => false
AppSettings | Settings
Settings to be used by this Voice Client More...
Voice.ILogger | Logger => voiceComponentImpl.Logger
VoiceLogger | VoiceLogger => voiceComponentImpl.VoiceLogger
bool | UsePrimaryRecorder => this.usePrimaryRecorder
Use VoiceConnection.PrimaryRecorder directly. More...
- Events inherited from VoiceConnection
Action< Speaker > | SpeakerLinked
Fires when a speaker has been linked to a remote audio stream More...
Action< RemoteVoiceLink > | RemoteVoiceAdded
Fires when a remote voice stream is added More...

Detailed Description

This class can be used to automatically sync client states between PUN and Voice. It also finds the Speaker component for a character's voice. For this to work attach a PhotonVoiceView next to the PhotonView of your player's prefab.

Member Data Documentation

◆ VoiceRoomNameSuffix

const string VoiceRoomNameSuffix = "_voice_"
static

Suffix for voice room names appended to Leader room names.

Property Documentation

◆ Instance

PunVoiceClient Instance
staticget

Singleton instance for PunVoiceClient

◆ UsePunAppSettings

bool UsePunAppSettings
getset

Whether or not to use the Voice AppId and all the other AppSettings from PUN's PhotonServerSettings ScriptableObject singleton in the Voice client/app.

◆ UsePunAuthValues

bool UsePunAuthValues
getset

Whether or not to use the same PhotonNetwork.AuthValues in PunVoiceClient.Instance.Client.AuthValues. This means that the same UserID will be used in both clients. If custom authentication is used and setup in PUN app, the same configuration should be done for the Voice app.


Photon Voice: Member List

  • PUN
  • PunVoiceClient
PunVoiceClient Member List

This is the complete list of members for PunVoiceClient, including all inherited members.

AddRecorder(Recorder rec) (defined in VoiceConnection) | VoiceConnection |
AddSpeaker(Speaker speaker, object userData) | VoiceConnection |
AlwaysUsePrimaryRecorder (defined in VoiceConnection) | VoiceConnection |
AutoConnectAndJoin | VoiceFollowClient |
Awake() (defined in VoiceConnection) | VoiceConnection | protected
BestRegionSummaryInPreferences | VoiceConnection |
CalcStatistics() (defined in VoiceConnection) | VoiceConnection | protected
ChannelAudio | VoiceConnection | static
ChannelVideo | VoiceConnection | static
Client (defined in VoiceConnection) | VoiceConnection |
ClientState | VoiceConnection |
ConnectAndJoinRoom() | VoiceFollowClient |
ConnectUsingSettings(AppSettings overwriteSettings=null) | VoiceConnection | virtual
ConnectVoice() (defined in PunVoiceClient) | PunVoiceClient | protectedvirtual
Disconnect() | VoiceFollowClient |
FixedUpdate() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
FramesLostPercent | VoiceConnection |
FramesLostPerSecond | VoiceConnection |
FramesReceivedPerSecond | VoiceConnection |
GetVoiceRoomName() (defined in PunVoiceClient) | PunVoiceClient | protectedvirtual
Instance | PunVoiceClient | static
InstantiateSpeakerForRemoteVoice(int playerId, byte voiceId, object userData) (defined in PunVoiceClient) | PunVoiceClient | protectedvirtual
InstantiateSpeakerPrefab(GameObject parent, bool destroyOnRemove) | VoiceConnection |
JoinVoiceRoom(string voiceRoomName) (defined in VoiceFollowClient) | VoiceFollowClient | protectedvirtual
LeaderInRoom (defined in PunVoiceClient) | PunVoiceClient | protected
LeaderOfflineMode (defined in PunVoiceClient) | PunVoiceClient | protected
LeaderStateChanged(ClientState toState) (defined in VoiceFollowClient) | VoiceFollowClient | protected
Logger (defined in VoiceConnection) | VoiceConnection |
OnDestroy() (defined in PunVoiceClient) | PunVoiceClient | protectedvirtual
OnOperationResponseReceived(OperationResponse operationResponse) (defined in VoiceFollowClient) | VoiceFollowClient | protectedvirtual
OnVoiceStateChanged(ClientState fromState, ClientState toState) (defined in VoiceFollowClient) | VoiceFollowClient | protectedvirtual
PrimaryRecorder | VoiceConnection |
RemoteVoiceAdded | VoiceConnection |
RemoveRecorder(Recorder rec) (defined in VoiceConnection) | VoiceConnection |
Settings | VoiceConnection |
SpeakerLinked | VoiceConnection |
SpeakerPrefab | VoiceConnection |
Start() (defined in PunVoiceClient) | PunVoiceClient | protectedvirtual
Update() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
UsePrimaryRecorder | VoiceConnection |
UsePunAppSettings | PunVoiceClient |
UsePunAuthValues | PunVoiceClient |
VoiceClient | VoiceConnection |
VoiceLogger (defined in VoiceConnection) | VoiceConnection |
VoiceRoomNameSuffix | PunVoiceClient | static


Photon Voice: Photon.Voice.Unity Namespace Reference

  • Unity
Namespaces | Classes
Photon.Voice.Unity Namespace Reference

Classes

class | AndroidAudioInAEC
struct | AndroidAudioInParameters
class | AudioChangesHandler
This component is useful to handle audio device and config changes. More...
class | AudioClipWrapper
class | AudioInEnumerator
class | AudioOutCapture
class | Logger
class | MicWrapper
class | MicWrapperPusher
class | MicWrapperPusherOnAudioFilterRead
class | PhotonVoiceCreatedParams
class | Recorder
Component representing outgoing audio stream in scene. More...
class | RecorderPreset
class | RemoteVoiceLink
class | Speaker
class | SpeakerAudioFilterRead
class | UnityAudioOut
class | UnityLogger
class | UnityMicrophone
A wrapper around UnityEngine.Microphone to be able to safely use Microphone and compile for WebGL. More...
class | UnityVoiceClient
Component that represents a Voice client and manages a simple Unity integration: a single Recorder and multiple remote speakers. More...
class | VideoInEnumerator
class | VoiceComponent
class | VoiceComponentImpl
class | VoiceConnection
Component that represents a Voice client. More...
class | VoiceLogger
class | WebRtcAudioDsp


Photon Voice: Photon.Voice.Unity.FMOD Namespace Reference

  • Unity
  • FMOD
Classes
Photon.Voice.Unity.FMOD Namespace Reference

Classes

class | FMODRecorderSetup
class | SpeakerFMOD


Photon Voice: FMODRecorderSetup Class Reference

  • Unity
  • FMOD
  • FMODRecorderSetup
Protected Member Functions | List of all members
FMODRecorderSetup Class Reference

Inherits VoiceComponent.

Protected Member Functions

override void Awake ()

Additional Inherited Members

- Public Attributes inherited from VoiceComponent
VoiceLogger | VoiceLogger => impl.VoiceLogger
- Protected Attributes inherited from VoiceComponent
Voice.ILogger | Logger => impl.Logger
- Properties inherited from VoiceComponent
string | Name [set]


Photon Voice: Member List

  • Unity
  • FMOD
  • FMODRecorderSetup
FMODRecorderSetup Member List

This is the complete list of members for FMODRecorderSetup, including all inherited members.

Awake() (defined in FMODRecorderSetup) | FMODRecorderSetup | protectedvirtual
Logger (defined in VoiceComponent) | VoiceComponent | protected
Name (defined in VoiceComponent) | VoiceComponent |
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: SpeakerFMOD Class Reference

  • Unity
  • FMOD
  • SpeakerFMOD
Protected Member Functions | List of all members
SpeakerFMOD Class Reference

Inherits Speaker.

Protected Member Functions

override IAudioOut< float > | CreateAudioOut ()
- Protected Member Functions inherited from Speaker
override void | Awake ()
virtual void | OnDestroy ()
void | Update ()

Additional Inherited Members

- Public Member Functions inherited from Speaker
void | RestartPlayback ()
Restarts the audio playback of the linked incoming remote audio stream via AudioSource component. More...
- Public Attributes inherited from VoiceComponent
VoiceLogger | VoiceLogger => impl.VoiceLogger
- Protected Attributes inherited from Speaker
IAudioOut< float > | audioOutput
AudioOutDelayControl.PlayDelayConfig | playDelayConfig = AudioOutDelayControl.PlayDelayConfig.Default
bool | restartOnDeviceChange = true
- Protected Attributes inherited from VoiceComponent
Voice.ILogger | Logger => impl.Logger
- Properties inherited from Speaker
bool | IsPlaying [get]
Is the speaker playing right now. More...
int? | Lag [get]
The current difference between positions in the buffer of (jittery) stream writer and (clock-driven) audio output reader in ms. More...
Action< Speaker > | OnRemoteVoiceRemoveAction [get, set]
Register a method to be called when remote voice removed. More...
RemoteVoiceLink | RemoteVoice [get]
bool | IsLinked [get]
Whether or not this Speaker has been linked to a remote voice stream. More...
AudioOutDelayControl.PlayDelayConfig | PlayDelayConfig [get, set]
Gets or sets jitter buffer config. More...
int | PlayDelay [get, set]
Gets or sets jitter buffer size in ms. More...
bool | RestartOnDeviceChange [get, set]
- Properties inherited from VoiceComponent
string | Name [set]


Photon Voice: Member List

  • Unity
  • FMOD
  • SpeakerFMOD
SpeakerFMOD Member List

This is the complete list of members for SpeakerFMOD, including all inherited members.

audioOutput (defined in Speaker) | Speaker | protected
Awake() (defined in Speaker) | Speaker | protectedvirtual
CreateAudioOut() (defined in SpeakerFMOD) | SpeakerFMOD | protectedvirtual
IsLinked | Speaker |
IsPlaying | Speaker |
Lag | Speaker |
Logger (defined in VoiceComponent) | VoiceComponent | protected
Name (defined in VoiceComponent) | VoiceComponent |
OnDestroy() (defined in Speaker) | Speaker | protectedvirtual
OnRemoteVoiceRemoveAction | Speaker |
PlayDelay | Speaker |
playDelayConfig (defined in Speaker) | Speaker | protected
PlayDelayConfig | Speaker |
RemoteVoice (defined in Speaker) | Speaker |
RestartOnDeviceChange (defined in Speaker) | Speaker |
restartOnDeviceChange (defined in Speaker) | Speaker | protected
RestartPlayback() | Speaker |
Update() (defined in Speaker) | Speaker | protected
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: Photon.Voice.Unity.UtilityScripts Namespace Reference

  • Unity
  • UtilityScripts
Classes
Photon.Voice.Unity.UtilityScripts Namespace Reference

Classes

class | ConnectAndJoin
class | MicAmplifier
class | MicAmplifierFloat
class | MicAmplifierShort
class | MicrophonePermission
Helper to request Microphone permission on Android or iOS. More...
class | PhotonVoiceLagSimulationGui
class | PhotonVoiceStatsGui
Basic GUI to show traffic and health statistics of the connection to Photon, toggled by shift+tab. More...
class | SaveIncomingStreamToFile
class | SaveOutgoingStreamToFile
class | TestTone
class | WaveWriter


Photon Voice: ConnectAndJoin Class Reference

  • Unity
  • UtilityScripts
  • ConnectAndJoin
Public Member Functions | Public Attributes | Properties | List of all members
ConnectAndJoin Class Reference

Inherits MonoBehaviour, IConnectionCallbacks, and IMatchmakingCallbacks.

Public Member Functions

void | ConnectNow ()
void | OnCreatedRoom ()
void | OnCreateRoomFailed (short returnCode, string message)
void | OnFriendListUpdate (List< FriendInfo > friendList)
void | OnJoinedRoom ()
void | OnJoinRandomFailed (short returnCode, string message)
void | OnJoinRoomFailed (short returnCode, string message)
void | OnLeftRoom ()
void | OnConnected ()
void | OnConnectedToMaster ()
void | OnDisconnected (DisconnectCause cause)
void | OnRegionListReceived (RegionHandler regionHandler)
void | OnCustomAuthenticationResponse (Dictionary< string, object > data)
void | OnCustomAuthenticationFailed (string debugMessage)

Public Attributes

bool | RandomRoom = true
string | RoomName

Properties

bool IsConnected [get]


Photon Voice: Member List

  • Unity
  • UtilityScripts
  • ConnectAndJoin
ConnectAndJoin Member List

This is the complete list of members for ConnectAndJoin, including all inherited members.

ConnectNow() (defined in ConnectAndJoin) | ConnectAndJoin
IsConnected (defined in ConnectAndJoin) | ConnectAndJoin
OnConnected() (defined in ConnectAndJoin) | ConnectAndJoin
OnConnectedToMaster() (defined in ConnectAndJoin) | ConnectAndJoin
OnCreatedRoom() (defined in ConnectAndJoin) | ConnectAndJoin
OnCreateRoomFailed(short returnCode, string message) (defined in ConnectAndJoin) | ConnectAndJoin
OnCustomAuthenticationFailed(string debugMessage) (defined in ConnectAndJoin) | ConnectAndJoin
OnCustomAuthenticationResponse(Dictionary< string, object > data) (defined in ConnectAndJoin) | ConnectAndJoin
OnDisconnected(DisconnectCause cause) (defined in ConnectAndJoin) | ConnectAndJoin
OnFriendListUpdate(List< FriendInfo > friendList) (defined in ConnectAndJoin) | ConnectAndJoin
OnJoinedRoom() (defined in ConnectAndJoin) | ConnectAndJoin
OnJoinRandomFailed(short returnCode, string message) (defined in ConnectAndJoin) | ConnectAndJoin
OnJoinRoomFailed(short returnCode, string message) (defined in ConnectAndJoin) | ConnectAndJoin
OnLeftRoom() (defined in ConnectAndJoin) | ConnectAndJoin
OnRegionListReceived(RegionHandler regionHandler) (defined in ConnectAndJoin) | ConnectAndJoin
RandomRoom (defined in ConnectAndJoin) | ConnectAndJoin
RoomName (defined in ConnectAndJoin) | ConnectAndJoin


Photon Voice: MicAmplifier Class Reference

  • Unity
  • UtilityScripts
  • MicAmplifier
Properties | List of all members
MicAmplifier Class Reference

Inherits VoiceComponent.

Properties

float | AmplificationFactor [get, set]
- Properties inherited from VoiceComponent
string | Name [set]

Additional Inherited Members

- Public Attributes inherited from VoiceComponent
VoiceLogger | VoiceLogger => impl.VoiceLogger
- Protected Member Functions inherited from VoiceComponent
virtual void | Awake ()
- Protected Attributes inherited from VoiceComponent
Voice.ILogger | Logger => impl.Logger


Photon Voice: Member List

  • Unity
  • UtilityScripts
  • MicAmplifier
MicAmplifier Member List

This is the complete list of members for MicAmplifier, including all inherited members.

AmplificationFactor (defined in MicAmplifier) | MicAmplifier |
Awake() (defined in VoiceComponent) | VoiceComponent | protectedvirtual
Logger (defined in VoiceComponent) | VoiceComponent | protected
Name (defined in VoiceComponent) | VoiceComponent |
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: MicAmplifierFloat Class Reference

  • Unity
  • UtilityScripts
  • MicAmplifierFloat
Public Member Functions | Properties | List of all members
MicAmplifierFloat Class Reference

Inherits IProcessor< float >.

Public Member Functions

MicAmplifierFloat (float amplificationFactor)
float[] | Process (float[] buf)
void | Dispose ()
- Public Member Functions inherited from IProcessor< float >
T[] | Process (T[] buf)
Process a frame of data. More...

Properties

float | AmplificationFactor [get, set]
bool | Disabled [get, set]


Photon Voice: Member List

  • Unity
  • UtilityScripts
  • MicAmplifierFloat
MicAmplifierFloat Member List

This is the complete list of members for MicAmplifierFloat, including all inherited members.

AmplificationFactor (defined in MicAmplifierFloat) | MicAmplifierFloat
Disabled (defined in MicAmplifierFloat) | MicAmplifierFloat
Dispose() (defined in MicAmplifierFloat) | MicAmplifierFloat
MicAmplifierFloat(float amplificationFactor) (defined in MicAmplifierFloat) | MicAmplifierFloat
Process(float[] buf) (defined in MicAmplifierFloat) | MicAmplifierFloat
IProcessor< float >.Process(T[] buf) | IProcessor< float >


Photon Voice: MicAmplifierShort Class Reference

  • Unity
  • UtilityScripts
  • MicAmplifierShort
Public Member Functions | Properties | List of all members
MicAmplifierShort Class Reference

Inherits IProcessor< short >.

Public Member Functions

MicAmplifierShort (float amplificationFactor)
short[] | Process (short[] buf)
void | Dispose ()
- Public Member Functions inherited from IProcessor< short >
T[] | Process (T[] buf)
Process a frame of data. More...

Properties

float | AmplificationFactor [get, set]
bool | Disabled [get, set]


Photon Voice: Member List

  • Unity
  • UtilityScripts
  • MicAmplifierShort
MicAmplifierShort Member List

This is the complete list of members for MicAmplifierShort, including all inherited members.

AmplificationFactor (defined in MicAmplifierShort) | MicAmplifierShort
Disabled (defined in MicAmplifierShort) | MicAmplifierShort
Dispose() (defined in MicAmplifierShort) | MicAmplifierShort
MicAmplifierShort(float amplificationFactor) (defined in MicAmplifierShort) | MicAmplifierShort
Process(short[] buf) (defined in MicAmplifierShort) | MicAmplifierShort
IProcessor< short >.Process(T[] buf) | IProcessor< short >


Photon Voice: MicrophonePermission Class Reference

  • Unity
  • UtilityScripts
  • MicrophonePermission
Public Member Functions | Protected Member Functions | Properties | Events | List of all members
MicrophonePermission Class Reference

Helper to request Microphone permission on Android or iOS. More...

Inherits VoiceComponent.

Public Member Functions

void InitVoice ()

Protected Member Functions

override void Awake ()

Properties

bool? | HasPermission [get]
- Properties inherited from VoiceComponent
string | Name [set]

Events

static Action< bool > MicrophonePermissionCallback

Additional Inherited Members

- Public Attributes inherited from VoiceComponent
VoiceLogger | VoiceLogger => impl.VoiceLogger
- Protected Attributes inherited from VoiceComponent
Voice.ILogger | Logger => impl.Logger

Detailed Description

Helper to request Microphone permission on Android or iOS.


Photon Voice: Member List

  • Unity
  • UtilityScripts
  • MicrophonePermission
MicrophonePermission Member List

This is the complete list of members for MicrophonePermission, including all inherited members.

Awake() (defined in MicrophonePermission) | MicrophonePermission | protectedvirtual
HasPermission (defined in MicrophonePermission) | MicrophonePermission |
InitVoice() (defined in MicrophonePermission) | MicrophonePermission |
Logger (defined in VoiceComponent) | VoiceComponent | protected
MicrophonePermissionCallback (defined in MicrophonePermission) | MicrophonePermission | static
Name (defined in VoiceComponent) | VoiceComponent |
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: PhotonVoiceLagSimulationGui Class Reference

  • Unity
  • UtilityScripts
  • PhotonVoiceLagSimulationGui
Public Member Functions | List of all members
PhotonVoiceLagSimulationGui Class Reference

Inherits MonoBehaviour.

Public Member Functions

void Start ()


Photon Voice: Member List

  • Unity
  • UtilityScripts
  • PhotonVoiceLagSimulationGui
PhotonVoiceLagSimulationGui Member List

This is the complete list of members for PhotonVoiceLagSimulationGui, including all inherited members.

Start() (defined in PhotonVoiceLagSimulationGui) PhotonVoiceLagSimulationGui


Photon Voice: PhotonVoiceStatsGui Class Reference

  • Unity
  • UtilityScripts
  • PhotonVoiceStatsGui
List of all members
PhotonVoiceStatsGui Class Reference

Basic GUI to show traffic and health statistics of the connection to Photon, toggled by shift+tab. More...

Inherits MonoBehaviour.

Detailed Description

Basic GUI to show traffic and health statistics of the connection to Photon, toggled by shift+tab.

The shown health values can help identify problems with connection losses or performance. Example: If the time delta between two consecutive SendOutgoingCommands calls is a second or more, chances rise for a disconnect being caused by this (because acknowledgments to the server need to be sent in due time).


Photon Voice: Member List

  • Unity
  • UtilityScripts
  • PhotonVoiceStatsGui
PhotonVoiceStatsGui Member List

This is the complete list of members for PhotonVoiceStatsGui, including all inherited members.


Photon Voice: SaveIncomingStreamToFile Class Reference

  • Unity
  • UtilityScripts
  • SaveIncomingStreamToFile
Protected Member Functions | List of all members
SaveIncomingStreamToFile Class Reference

Inherits VoiceComponent.

Protected Member Functions

override void Awake ()

Additional Inherited Members

- Public Attributes inherited from VoiceComponent
VoiceLogger | VoiceLogger => impl.VoiceLogger
- Protected Attributes inherited from VoiceComponent
Voice.ILogger | Logger => impl.Logger
- Properties inherited from VoiceComponent
string | Name [set]


Photon Voice: Member List

  • Unity
  • UtilityScripts
  • SaveIncomingStreamToFile
SaveIncomingStreamToFile Member List

This is the complete list of members for SaveIncomingStreamToFile, including all inherited members.

Awake() (defined in SaveIncomingStreamToFile) | SaveIncomingStreamToFile | protectedvirtual
Logger (defined in VoiceComponent) | VoiceComponent | protected
Name (defined in VoiceComponent) | VoiceComponent |
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: SaveOutgoingStreamToFile Class Reference

  • Unity
  • UtilityScripts
  • SaveOutgoingStreamToFile
Classes | List of all members
SaveOutgoingStreamToFile Class Reference

Inherits VoiceComponent.

Additional Inherited Members

- Public Attributes inherited from VoiceComponent
VoiceLogger | VoiceLogger => impl.VoiceLogger
- Protected Member Functions inherited from VoiceComponent
virtual void | Awake ()
- Protected Attributes inherited from VoiceComponent
Voice.ILogger | Logger => impl.Logger
- Properties inherited from VoiceComponent
string | Name [set]


Photon Voice: Member List

  • Unity
  • UtilityScripts
  • SaveOutgoingStreamToFile
SaveOutgoingStreamToFile Member List

This is the complete list of members for SaveOutgoingStreamToFile, including all inherited members.

Awake() (defined in VoiceComponent) | VoiceComponent | protectedvirtual
Logger (defined in VoiceComponent) | VoiceComponent | protected
Name (defined in VoiceComponent) | VoiceComponent |
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: TestTone Class Reference

  • Unity
  • UtilityScripts
  • TestTone
List of all members
TestTone Class Reference

Inherits MonoBehaviour.


Photon Voice: Member List

  • Unity
  • UtilityScripts
  • TestTone
TestTone Member List

This is the complete list of members for TestTone, including all inherited members.


Photon Voice: WaveWriter Class Reference

  • Unity
  • UtilityScripts
  • WaveWriter
Public Member Functions | Protected Member Functions | List of all members
WaveWriter Class Reference

Inherits IDisposable.

Public Member Functions

WaveWriter (string fileName, int sampleRate, int bits, int channels)
WaveWriter (Stream stream, int sampleRate, int bitsPerSample, int channels)
void | Dispose ()
void | WriteSample (float sample)
void | WriteSamples (float[] samples, int offset, int count)
void | Write (byte[] buffer, int offset, int count)
void | Write (byte value)
void | Write (short value)
void | Write (int value)
void | Write (float value)

Protected Member Functions

virtual void Dispose (bool disposing)


Photon Voice: Member List

  • Unity
  • UtilityScripts
  • WaveWriter
WaveWriter Member List

This is the complete list of members for WaveWriter, including all inherited members.

Dispose() (defined in WaveWriter) | WaveWriter |
Dispose(bool disposing) (defined in WaveWriter) | WaveWriter | protectedvirtual
WaveWriter(string fileName, int sampleRate, int bits, int channels) (defined in WaveWriter) | WaveWriter |
WaveWriter(Stream stream, int sampleRate, int bitsPerSample, int channels) (defined in WaveWriter) | WaveWriter |
Write(byte[] buffer, int offset, int count) (defined in WaveWriter) | WaveWriter |
Write(byte value) (defined in WaveWriter) | WaveWriter |
Write(short value) (defined in WaveWriter) | WaveWriter |
Write(int value) (defined in WaveWriter) | WaveWriter |
Write(float value) (defined in WaveWriter) | WaveWriter |
WriteSample(float sample) (defined in WaveWriter) | WaveWriter |
WriteSamples(float[] samples, int offset, int count) (defined in WaveWriter) | WaveWriter |


Photon Voice: AndroidAudioInAEC Class Reference

  • Unity
  • AndroidAudioInAEC
Classes | Public Member Functions | Properties | List of all members
AndroidAudioInAEC Class Reference

Inherits IAudioPusher< short >, and IResettable.

Public Member Functions

AndroidAudioInAEC (Voice.ILogger logger, bool enableAEC=false, bool enableAGC=false, bool enableNS=false)
void | SetCallback (Action< short[]> callback, ObjectFactory< short[], int > bufferFactory)
void | Reset ()
void | Dispose ()
- Public Member Functions inherited from IAudioPusher< short >
void | SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data. More...

Properties

int | Channels [get]
int | SamplingRate [get]
string | Error [get]


Photon Voice: Member List

  • Unity
  • AndroidAudioInAEC
AndroidAudioInAEC Member List

This is the complete list of members for AndroidAudioInAEC, including all inherited members.

AndroidAudioInAEC(Voice.ILogger logger, bool enableAEC=false, bool enableAGC=false, bool enableNS=false) (defined in AndroidAudioInAEC) | AndroidAudioInAEC
Channels (defined in AndroidAudioInAEC) | AndroidAudioInAEC
Dispose() (defined in AndroidAudioInAEC) | AndroidAudioInAEC
Error (defined in AndroidAudioInAEC) | AndroidAudioInAEC
Reset() (defined in AndroidAudioInAEC) | AndroidAudioInAEC
SamplingRate (defined in AndroidAudioInAEC) | AndroidAudioInAEC
SetCallback(Action< short[]> callback, ObjectFactory< short[], int > bufferFactory) (defined in AndroidAudioInAEC) | AndroidAudioInAEC
IAudioPusher< short >.SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | IAudioPusher< short >


Photon Voice: AndroidAudioInParameters Struct Reference

  • Unity
  • AndroidAudioInParameters
Public Attributes | Static Public Attributes | List of all members
AndroidAudioInParameters Struct Reference

Public Attributes

bool | EnableAEC
bool | EnableAGC
bool | EnableNS

Static Public Attributes

static AndroidAudioInParameters Default = new AndroidAudioInParameters() { EnableAEC = true, EnableAGC = true, EnableNS = true }


Photon Voice: Member List

  • Unity
  • AndroidAudioInParameters
AndroidAudioInParameters Member List

This is the complete list of members for AndroidAudioInParameters, including all inherited members.

Default (defined in AndroidAudioInParameters) | AndroidAudioInParameters | static
EnableAEC (defined in AndroidAudioInParameters) | AndroidAudioInParameters |
EnableAGC (defined in AndroidAudioInParameters) | AndroidAudioInParameters |
EnableNS (defined in AndroidAudioInParameters) | AndroidAudioInParameters |


Photon Voice: AudioChangesHandler Class Reference

  • Unity
  • AudioChangesHandler
Public Attributes | Protected Member Functions | List of all members
AudioChangesHandler Class Reference

This component is useful to handle audio device and config changes. More...

Inherits VoiceComponent.

Public Attributes

bool | HandleDeviceChange = true
Try to react to device change notification when Recorder is started. More...
bool | HandleDeviceChangeIOS
iOS: Try to react to device change notification when Recorder is started. More...
bool | HandleDeviceChangeAndroid
Android: Try to react to device change notification when Recorder is started. More...
- Public Attributes inherited from VoiceComponent
VoiceLogger | VoiceLogger => impl.VoiceLogger

Protected Member Functions

override void Awake ()

Additional Inherited Members

- Protected Attributes inherited from VoiceComponent
Voice.ILogger | Logger => impl.Logger
- Properties inherited from VoiceComponent
string | Name [set]

Detailed Description

This component is useful to handle audio device and config changes.

Member Data Documentation

◆ HandleDeviceChange

bool HandleDeviceChange = true

Try to react to device change notification when Recorder is started.

◆ HandleDeviceChangeAndroid

bool HandleDeviceChangeAndroid

Android: Try to react to device change notification when Recorder is started.

◆ HandleDeviceChangeIOS

bool HandleDeviceChangeIOS

iOS: Try to react to device change notification when Recorder is started.


Photon Voice: Member List

  • Unity
  • AudioChangesHandler
AudioChangesHandler Member List

This is the complete list of members for AudioChangesHandler, including all inherited members.

Awake() (defined in AudioChangesHandler) | AudioChangesHandler | protectedvirtual
HandleDeviceChange | AudioChangesHandler |
HandleDeviceChangeAndroid | AudioChangesHandler |
HandleDeviceChangeIOS | AudioChangesHandler |
Logger (defined in VoiceComponent) | VoiceComponent | protected
Name (defined in VoiceComponent) | VoiceComponent |
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: AudioClipWrapper Class Reference

  • Unity
  • AudioClipWrapper
Public Member Functions | Properties | List of all members
AudioClipWrapper Class Reference

Inherits IAudioReader< float >.

Public Member Functions

AudioClipWrapper (AudioClip audioClip)
bool | Read (float[] buffer)
void | Dispose ()

Properties

bool | Loop [get, set]
int | SamplingRate [get]
int | Channels [get]
string | Error [get]


Photon Voice: Member List

  • Unity
  • AudioClipWrapper
AudioClipWrapper Member List

This is the complete list of members for AudioClipWrapper, including all inherited members.

AudioClipWrapper(AudioClip audioClip) (defined in AudioClipWrapper) | AudioClipWrapper
Channels (defined in AudioClipWrapper) | AudioClipWrapper
Dispose() (defined in AudioClipWrapper) | AudioClipWrapper
Error (defined in AudioClipWrapper) | AudioClipWrapper
Loop (defined in AudioClipWrapper) | AudioClipWrapper
Read(float[] buffer) (defined in AudioClipWrapper) | AudioClipWrapper
SamplingRate (defined in AudioClipWrapper) | AudioClipWrapper


Photon Voice: AudioInEnumerator Class Reference

  • Unity
  • AudioInEnumerator
Public Member Functions | Public Attributes | Properties | List of all members
AudioInEnumerator Class Reference

Inherits DeviceEnumeratorBase.

Public Member Functions

AudioInEnumerator (ILogger logger)
override void | Refresh ()
override void | Dispose ()
- Public Member Functions inherited from DeviceEnumeratorBase
DeviceEnumeratorBase (ILogger logger)
IEnumerator< DeviceInfo > | GetEnumerator ()

Public Attributes

override bool | IsSupported => false
- Public Attributes inherited from DeviceEnumeratorBase
virtual bool | IsSupported => true

Properties

override string | Error [get]
- Properties inherited from DeviceEnumeratorBase
virtual string | Error [get, protected set]
Action | OnReady [protected get, set]
- Properties inherited from IDeviceEnumerator
bool | IsSupported [get]
Action | OnReady [set]
string | Error [get]

Additional Inherited Members

- Protected Attributes inherited from DeviceEnumeratorBase
List< DeviceInfo > | devices = new List<DeviceInfo>()
ILogger | logger


Photon Voice: Member List

  • Unity
  • AudioInEnumerator
AudioInEnumerator Member List

This is the complete list of members for AudioInEnumerator, including all inherited members.

AudioInEnumerator(ILogger logger) (defined in AudioInEnumerator) | AudioInEnumerator |
DeviceEnumeratorBase(ILogger logger) (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
devices (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Dispose() (defined in AudioInEnumerator) | AudioInEnumerator | virtual
Error (defined in AudioInEnumerator) | AudioInEnumerator |
GetEnumerator() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
IsSupported (defined in AudioInEnumerator) | AudioInEnumerator |
logger (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
OnReady (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
Refresh() (defined in AudioInEnumerator) | AudioInEnumerator | virtual


Photon Voice: AudioOutCapture Class Reference

  • Unity
  • AudioOutCapture
Events | List of all members
AudioOutCapture Class Reference

Inherits MonoBehaviour.

Events

Action< float[], int > OnAudioFrame


Photon Voice: Member List

  • Unity
  • AudioOutCapture
AudioOutCapture Member List

This is the complete list of members for AudioOutCapture, including all inherited members.

OnAudioFrame (defined in AudioOutCapture) AudioOutCapture


Photon Voice: Logger Class Reference

  • Unity
  • Logger
Public Member Functions | Properties | List of all members
Logger Class Reference

Inherits ILogger.

Public Member Functions

Logger (LogLevel level=LogLevel.Debug)
void Log (LogLevel level, string fmt, params object[] args)

Properties

LogLevel | Level [get, set]
- Properties inherited from ILogger
LogLevel | Level [get]


Photon Voice: Member List

  • Unity
  • Logger
Logger Member List

This is the complete list of members for Logger, including all inherited members.

Level (defined in Logger) | Logger
Log(LogLevel level, string fmt, params object[] args) (defined in Logger) | Logger
Logger(LogLevel level=LogLevel.Debug) (defined in Logger) | Logger


Photon Voice: MicWrapper Class Reference

  • Unity
  • MicWrapper
Public Member Functions | Properties | List of all members
MicWrapper Class Reference

Inherits IAudioReader< float >.

Public Member Functions

MicWrapper (string device, int suggestedFrequency, ILogger logger)
void | Dispose ()
bool | Read (float[] buffer)

Properties

int? | SamplingRate [get]
int? | Channels [get]
string | Error [get]


Photon Voice: Member List

  • Unity
  • MicWrapper
MicWrapper Member List

This is the complete list of members for MicWrapper, including all inherited members.

Channels (defined in MicWrapper) | MicWrapper
Dispose() (defined in MicWrapper) | MicWrapper
Error (defined in MicWrapper) | MicWrapper
MicWrapper(string device, int suggestedFrequency, ILogger logger) (defined in MicWrapper) | MicWrapper
Read(float[] buffer) (defined in MicWrapper) | MicWrapper
SamplingRate (defined in MicWrapper) | MicWrapper


Photon Voice: MicWrapperPusher Class Reference

  • Unity
  • MicWrapperPusher
Public Member Functions | Properties | List of all members
MicWrapperPusher Class Reference

Inherits IAudioPusher< float >.

Public Member Functions

MicWrapperPusher (GameObject parent, string device, int suggestedFrequency, ILogger logger)
void | SetCallback (Action< float[]> callback, ObjectFactory< float[], int > bufferFactory)
void | Dispose ()
- Public Member Functions inherited from IAudioPusher< float >
void | SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data. More...

Properties

int? | SamplingRate [get]
int? | Channels [get]
string | Error [get]


Photon Voice: Member List

  • Unity
  • MicWrapperPusher
MicWrapperPusher Member List

This is the complete list of members for MicWrapperPusher, including all inherited members.

Channels (defined in MicWrapperPusher) | MicWrapperPusher
Dispose() (defined in MicWrapperPusher) | MicWrapperPusher
Error (defined in MicWrapperPusher) | MicWrapperPusher
MicWrapperPusher(GameObject parent, string device, int suggestedFrequency, ILogger logger) (defined in MicWrapperPusher) | MicWrapperPusher
SamplingRate (defined in MicWrapperPusher) | MicWrapperPusher
SetCallback(Action< float[]> callback, ObjectFactory< float[], int > bufferFactory) (defined in MicWrapperPusher) | MicWrapperPusher
IAudioPusher< float >.SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | IAudioPusher< float >


Photon Voice: MicWrapperPusherOnAudioFilterRead Class Reference

  • Unity
  • MicWrapperPusherOnAudioFilterRead
Events | List of all members
MicWrapperPusherOnAudioFilterRead Class Reference

Inherits MonoBehaviour.

Events

Action< float[], int > OnAudioFrame


Photon Voice: Member List

  • Unity
  • MicWrapperPusherOnAudioFilterRead
MicWrapperPusherOnAudioFilterRead Member List

This is the complete list of members for MicWrapperPusherOnAudioFilterRead, including all inherited members.

OnAudioFrame (defined in MicWrapperPusherOnAudioFilterRead) MicWrapperPusherOnAudioFilterRead


Photon Voice: PhotonVoiceCreatedParams Class Reference

  • Unity
  • PhotonVoiceCreatedParams
Properties | List of all members
PhotonVoiceCreatedParams Class Reference

Properties

Voice.LocalVoice | Voice [get, set]
Voice.IAudioDesc | AudioDesc [get, set]


Photon Voice: Member List

  • Unity
  • PhotonVoiceCreatedParams
PhotonVoiceCreatedParams Member List

This is the complete list of members for PhotonVoiceCreatedParams, including all inherited members.

AudioDesc (defined in PhotonVoiceCreatedParams) | PhotonVoiceCreatedParams
Voice (defined in PhotonVoiceCreatedParams) | PhotonVoiceCreatedParams


Photon Voice: Recorder Class Reference

  • Unity
  • Recorder
Public Types | Public Member Functions | Static Public Attributes | Protected Member Functions | Properties | List of all members
Recorder Class Reference

Component representing outgoing audio stream in scene. More...

Inherits VoiceComponent.

Public Types

enum | InputSourceType
enum | MicType

Public Member Functions

bool | RestartRecording ()
Restarts recording if Recorder.RecordingEnabled is true More...
void | VoiceDetectorCalibrate (int durationMs, Action< float > detectionEndedCallback=null)
Trigger voice detector calibration process. While calibrating, keep silence. Voice detector sets threshold basing on measured background noise level. More...
bool | SetIosAudioSessionParameters (IOS.AudioSessionParameters asp)
Sets the AudioSessionParameters for iOS audio initialization when Photon MicrophoneType is used. More...
bool | SetIosAudioSessionParameters (IOS.AudioSessionCategory category, IOS.AudioSessionMode mode, IOS.AudioSessionCategoryOption[] options)
Sets the AudioSessionParameters for iOS audio initialization when Photon MicrophoneType is used. More...
bool | SetAndroidNativeMicrophoneSettings (bool aec=false, bool agc=false, bool ns=false)
Sets the native Android audio input settings when the Photon microphone type is used. More...
bool | ResetLocalAudio ()
Resets audio session and parameters locally to fix broken recording due to system configuration modifications or audio interruptions or audio routing changes. More...

Static Public Attributes

const int | MIN_OPUS_BITRATE = 6000
const int | MAX_OPUS_BITRATE = 510000

Protected Member Functions

virtual void | SendPhotonVoiceCreatedMessage ()
void | Update ()
- Protected Member Functions inherited from VoiceComponent
virtual void | Awake ()

Properties

bool | TransmitEnabled [get, set]
If true, audio transmission is enabled. More...
bool | Encrypt [get, set]
If true, voice stream is sent encrypted. More...
bool | DebugEchoMode [get, set]
If true, outgoing stream routed back to client via server same way as for remote client's streams. More...
bool | ReliableMode [get, set]
If true, stream data sent in reliable mode. More...
bool | VoiceDetection [get, set]
If true, voice detection enabled. More...
float | VoiceDetectionThreshold [get, set]
Voice detection threshold (0..1, where 1 is full amplitude). More...
int | VoiceDetectionDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. Default is 500ms More...
object | UserData [get, set]
Custom user object to be sent in the voice stream info event. More...
Func< IAudioDesc > | InputFactory [get, set]
Set the method returning new Voice.IAudioDesc instance to be assigned to a new voice created with Source set to Factory More...
AudioUtil.IVoiceDetector? | VoiceDetector [get]
Returns voice activity detector for recorder's audio stream. More...
byte | InterestGroup [get, set]
Target interest group that will receive transmitted audio. More...
int[] | TargetPlayers [get, set]
Target players which will receive transmitted audio. More...
bool | IsCurrentlyTransmitting [get]
Returns true if audio stream broadcasts. More...
AudioUtil.ILevelMeter? | LevelMeter [get]
Level meter utility. More...
bool | VoiceDetectorCalibrating [get]
If true, voice detector calibration is in progress. More...
ILocalVoiceAudio | voiceAudio [get]
InputSourceType | SourceType [get, set]
Audio data source. More...
MicType | MicrophoneType [get, set]
Which microphone API to use when the Source is set to Microphone. More...
AudioClip | AudioClip [get, set]
Source audio clip. More...
bool | LoopAudioClip [get, set]
Loop playback for audio clip sources. More...
SamplingRate | SamplingRate [get, set]
Outgoing audio stream sampling rate. More...
OpusCodec.FrameDuration | FrameDuration [get, set]
Outgoing audio stream encoder delay. More...
int | Bitrate [get, set]
Outgoing audio stream bitrate. More...
bool | RecordingEnabled [get, set]
Gets or sets whether this Recorder is recording audio to be transmitted. More...
bool | StopRecordingWhenPaused [get, set]
If true, stop recording when paused resume/restart when un-paused. More...
bool | UseOnAudioFilterRead [get, set]
If true, recording will make use of Unity's OnAudioFitlerRead callback from a muted local AudioSource. More...
bool | UseMicrophoneTypeFallback [get, set]
If true, if recording fails to start with Unity microphone type, Photon microphone type is used -if available- as a fallback and vice versa. More...
bool | RecordWhenJoined [get, set]
If true, recording starts when joining the room and stops when leaving the room. More...
DeviceInfo | MicrophoneDevice [get, set]
bool | AndroidMicrophoneAGC [get]
bool | AndroidMicrophoneAEC [get]
bool | AndroidMicrophoneNS [get]
- Properties inherited from VoiceComponent
string | Name [set]

Additional Inherited Members

- Public Attributes inherited from VoiceComponent
VoiceLogger | VoiceLogger => impl.VoiceLogger
- Protected Attributes inherited from VoiceComponent
Voice.ILogger | Logger => impl.Logger

Detailed Description

Component representing outgoing audio stream in scene.

Member Function Documentation

◆ ResetLocalAudio()

bool ResetLocalAudio ( )

Resets audio session and parameters locally to fix broken recording due to system configuration modifications or audio interruptions or audio routing changes.

Returns
If reset is done.

◆ RestartRecording()

bool RestartRecording ( )

Restarts recording if Recorder.RecordingEnabled is true

◆ SetAndroidNativeMicrophoneSettings()

bool SetAndroidNativeMicrophoneSettings | ( | bool | aec = false,
 |  | bool | agc = false,
 |  | bool | ns = false
 | ) |  |

Sets the native Android audio input settings when the Photon microphone type is used.

Parameters
aec | Acoustic Echo Cancellation
agc | Automatic Gain Control
ns | Noise Suppression
Returns
If a change has been made.

◆ SetIosAudioSessionParameters() [1/2]

bool SetIosAudioSessionParameters | ( | IOS.AudioSessionCategory | category,
 |  | IOS.AudioSessionMode | mode,
 |  | IOS.AudioSessionCategoryOption[] | options
 | ) |  |

Sets the AudioSessionParameters for iOS audio initialization when Photon MicrophoneType is used.

Parameters
category | Audio session category to be used.
mode | Audio session mode to be used.
options | Audio session category options to be used
Returns
If a change has been made.

◆ SetIosAudioSessionParameters() [2/2]

bool SetIosAudioSessionParameters ( IOS.AudioSessionParameters asp )

Sets the AudioSessionParameters for iOS audio initialization when Photon MicrophoneType is used.

Parameters
asp You can use custom value or one from presets, IOS.AudioSessionParametersPresets
Returns
If a change has been made.

◆ VoiceDetectorCalibrate()

void VoiceDetectorCalibrate | ( | int | durationMs,
 |  | Action< float > | detectionEndedCallback = null
 | ) |  |

Trigger voice detector calibration process. While calibrating, keep silence. Voice detector sets threshold basing on measured background noise level.

Parameters
durationMs | Duration of calibration in milliseconds.
detectionEndedCallback | Callback when VAD calibration ends.

Property Documentation

◆ AudioClip

AudioClip AudioClip
getset

Source audio clip.

◆ Bitrate

int Bitrate
getset

Outgoing audio stream bitrate.

◆ DebugEchoMode

bool DebugEchoMode
getset

If true, outgoing stream routed back to client via server same way as for remote client's streams.

Initialized with serialized field and can be updated by Editor at runtime.

◆ Encrypt

bool Encrypt
getset

If true, voice stream is sent encrypted.

Initialized with serialized field and can be updated by Editor at runtime.

◆ FrameDuration

OpusCodec.FrameDuration FrameDuration
getset

Outgoing audio stream encoder delay.

◆ InputFactory

Func<IAudioDesc> InputFactory
getset

Set the method returning new Voice.IAudioDesc instance to be assigned to a new voice created with Source set to Factory

◆ InterestGroup

byte InterestGroup
getset

Target interest group that will receive transmitted audio.

If InterestGroup != 0, recorder's audio data is sent only to clients listening to this group. Initialized with serialized field and can be updated by Editor at runtime.

◆ IsCurrentlyTransmitting

bool IsCurrentlyTransmitting
get

Returns true if audio stream broadcasts.

◆ LevelMeter

AudioUtil.ILevelMeter? LevelMeter
get

Level meter utility.

◆ LoopAudioClip

bool LoopAudioClip
getset

Loop playback for audio clip sources.

◆ MicrophoneType

MicType MicrophoneType
getset

Which microphone API to use when the Source is set to Microphone.

◆ RecordingEnabled

bool RecordingEnabled
getset

Gets or sets whether this Recorder is recording audio to be transmitted.

◆ RecordWhenJoined

bool RecordWhenJoined
getset

If true, recording starts when joining the room and stops when leaving the room.

◆ ReliableMode

bool ReliableMode
getset

If true, stream data sent in reliable mode.

Initialized with serialized field and can be updated by Editor at runtime.

◆ SamplingRate

SamplingRate SamplingRate
getset

Outgoing audio stream sampling rate.

◆ SourceType

InputSourceType SourceType
getset

Audio data source.

◆ StopRecordingWhenPaused

bool StopRecordingWhenPaused
getset

If true, stop recording when paused resume/restart when un-paused.

◆ TargetPlayers

int [] TargetPlayers
getset

Target players which will receive transmitted audio.

Initialized with serialized field and can be updated by Editor at runtime

◆ TransmitEnabled

bool TransmitEnabled
getset

If true, audio transmission is enabled.

◆ UseMicrophoneTypeFallback

bool UseMicrophoneTypeFallback
getset

If true, if recording fails to start with Unity microphone type, Photon microphone type is used -if available- as a fallback and vice versa.

◆ UseOnAudioFilterRead

bool UseOnAudioFilterRead
getset

If true, recording will make use of Unity's OnAudioFitlerRead callback from a muted local AudioSource.

If enabled, 3D sounds and voice positioning can be lost.

◆ UserData

object UserData
getset

Custom user object to be sent in the voice stream info event.

◆ VoiceDetection

bool VoiceDetection
getset

If true, voice detection enabled.

◆ VoiceDetectionDelayMs

int VoiceDetectionDelayMs
getset

Keep detected state during this time after signal level dropped below threshold. Default is 500ms

◆ VoiceDetectionThreshold

float VoiceDetectionThreshold
getset

Voice detection threshold (0..1, where 1 is full amplitude).

◆ VoiceDetector

AudioUtil.IVoiceDetector? VoiceDetector
get

Returns voice activity detector for recorder's audio stream.

◆ VoiceDetectorCalibrating

bool VoiceDetectorCalibrating
get

If true, voice detector calibration is in progress.


Photon Voice: Member List

  • Unity
  • Recorder
Recorder Member List

This is the complete list of members for Recorder, including all inherited members.

AndroidMicrophoneAEC (defined in Recorder) | Recorder |
AndroidMicrophoneAGC (defined in Recorder) | Recorder |
AndroidMicrophoneNS (defined in Recorder) | Recorder |
AudioClip | Recorder |
Awake() (defined in VoiceComponent) | VoiceComponent | protectedvirtual
Bitrate | Recorder |
DebugEchoMode | Recorder |
Encrypt | Recorder |
FrameDuration | Recorder |
InputFactory | Recorder |
InputSourceType enum name (defined in Recorder) | Recorder |
InterestGroup | Recorder |
IsCurrentlyTransmitting | Recorder |
LevelMeter | Recorder |
Logger (defined in VoiceComponent) | VoiceComponent | protected
LoopAudioClip | Recorder |
MAX_OPUS_BITRATE (defined in Recorder) | Recorder | static
MicrophoneDevice (defined in Recorder) | Recorder |
MicrophoneType | Recorder |
MicType enum name (defined in Recorder) | Recorder |
MIN_OPUS_BITRATE (defined in Recorder) | Recorder | static
Name (defined in VoiceComponent) | VoiceComponent |
RecordingEnabled | Recorder |
RecordWhenJoined | Recorder |
ReliableMode | Recorder |
ResetLocalAudio() | Recorder |
RestartRecording() | Recorder |
SamplingRate | Recorder |
SendPhotonVoiceCreatedMessage() (defined in Recorder) | Recorder | protectedvirtual
SetAndroidNativeMicrophoneSettings(bool aec=false, bool agc=false, bool ns=false) | Recorder |
SetIosAudioSessionParameters(IOS.AudioSessionParameters asp) | Recorder |
SetIosAudioSessionParameters(IOS.AudioSessionCategory category, IOS.AudioSessionMode mode, IOS.AudioSessionCategoryOption[] options) | Recorder |
SourceType | Recorder |
StopRecordingWhenPaused | Recorder |
TargetPlayers | Recorder |
TransmitEnabled | Recorder |
Update() (defined in Recorder) | Recorder | protected
UseMicrophoneTypeFallback | Recorder |
UseOnAudioFilterRead | Recorder |
UserData | Recorder |
voiceAudio (defined in Recorder) | Recorder | protected
VoiceDetection | Recorder |
VoiceDetectionDelayMs | Recorder |
VoiceDetectionThreshold | Recorder |
VoiceDetector | Recorder |
VoiceDetectorCalibrate(int durationMs, Action< float > detectionEndedCallback=null) | Recorder |
VoiceDetectorCalibrating | Recorder |
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: RecorderPreset Class Reference

  • Unity
  • RecorderPreset
Classes | Public Attributes | Protected Member Functions | List of all members
RecorderPreset Class Reference

Inherits VoiceComponent.

Classes

struct DSP

Public Attributes

RuntimePlatform | Platform
MicType | MicrophoneType
bool | DSPEnabled
DSP | DSPSettings
- Public Attributes inherited from VoiceComponent
VoiceLogger | VoiceLogger => impl.VoiceLogger

Protected Member Functions

override void Awake ()

Additional Inherited Members

- Protected Attributes inherited from VoiceComponent
Voice.ILogger | Logger => impl.Logger
- Properties inherited from VoiceComponent
string | Name [set]


Photon Voice: Member List

  • Unity
  • RecorderPreset
RecorderPreset Member List

This is the complete list of members for RecorderPreset, including all inherited members.

Awake() (defined in RecorderPreset) | RecorderPreset | protectedvirtual
DSPEnabled (defined in RecorderPreset) | RecorderPreset |
DSPSettings (defined in RecorderPreset) | RecorderPreset |
Logger (defined in VoiceComponent) | VoiceComponent | protected
MicrophoneType (defined in RecorderPreset) | RecorderPreset |
Name (defined in VoiceComponent) | VoiceComponent |
Platform (defined in RecorderPreset) | RecorderPreset |
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: RecorderPreset.DSP Struct Reference

  • Unity
  • RecorderPreset
  • DSP
Public Attributes | List of all members
RecorderPreset.DSP Struct Reference

Public Attributes

bool | AEC
bool | VAD


Photon Voice: Member List

  • Unity
  • RecorderPreset
  • DSP
RecorderPreset.DSP Member List

This is the complete list of members for RecorderPreset.DSP, including all inherited members.

AEC (defined in RecorderPreset.DSP) | RecorderPreset.DSP
VAD (defined in RecorderPreset.DSP) | RecorderPreset.DSP


Photon Voice: RemoteVoiceLink Class Reference

  • Unity
  • RemoteVoiceLink
Public Member Functions | Public Attributes | Events | List of all members
RemoteVoiceLink Class Reference

Public Member Functions

RemoteVoiceLink (VoiceInfo info, int playerId, byte voiceId, int channelId, ref RemoteVoiceOptions options)
override string ToString ()

Public Attributes

readonly VoiceInfo | VoiceInfo
readonly int | PlayerId
readonly byte | VoiceId
readonly int | ChannelId

Events

Action< FrameOut< float > > | FloatFrameDecoded
Action | RemoteVoiceRemoved


Photon Voice: Member List

  • Unity
  • RemoteVoiceLink
RemoteVoiceLink Member List

This is the complete list of members for RemoteVoiceLink, including all inherited members.

ChannelId (defined in RemoteVoiceLink) | RemoteVoiceLink
FloatFrameDecoded (defined in RemoteVoiceLink) | RemoteVoiceLink
PlayerId (defined in RemoteVoiceLink) | RemoteVoiceLink
RemoteVoiceLink(VoiceInfo info, int playerId, byte voiceId, int channelId, ref RemoteVoiceOptions options) (defined in RemoteVoiceLink) | RemoteVoiceLink
RemoteVoiceRemoved (defined in RemoteVoiceLink) | RemoteVoiceLink
ToString() (defined in RemoteVoiceLink) | RemoteVoiceLink
VoiceId (defined in RemoteVoiceLink) | RemoteVoiceLink
VoiceInfo (defined in RemoteVoiceLink) | RemoteVoiceLink


Photon Voice: Speaker Class Reference

  • Unity
  • Speaker
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
Speaker Class Reference

Inherits VoiceComponent.

Inherited by SpeakerFMOD, and SpeakerAudioFilterRead.

Public Member Functions

void RestartPlayback ()
Restarts the audio playback of the linked incoming remote audio stream via AudioSource component. More...

Protected Member Functions

override void | Awake ()
virtual IAudioOut< float > | CreateAudioOut ()
virtual void | OnDestroy ()
void | Update ()

Protected Attributes

IAudioOut< float > | audioOutput
AudioOutDelayControl.PlayDelayConfig | playDelayConfig = AudioOutDelayControl.PlayDelayConfig.Default
bool | restartOnDeviceChange = true
- Protected Attributes inherited from VoiceComponent
Voice.ILogger | Logger => impl.Logger

Properties

bool | IsPlaying [get]
Is the speaker playing right now. More...
int? | Lag [get]
The current difference between positions in the buffer of (jittery) stream writer and (clock-driven) audio output reader in ms. More...
Action< Speaker > | OnRemoteVoiceRemoveAction [get, set]
Register a method to be called when remote voice removed. More...
RemoteVoiceLink | RemoteVoice [get]
bool | IsLinked [get]
Whether or not this Speaker has been linked to a remote voice stream. More...
AudioOutDelayControl.PlayDelayConfig | PlayDelayConfig [get, set]
Gets or sets jitter buffer config. More...
int | PlayDelay [get, set]
Gets or sets jitter buffer size in ms. More...
bool | RestartOnDeviceChange [get, set]
- Properties inherited from VoiceComponent
string | Name [set]

Additional Inherited Members

- Public Attributes inherited from VoiceComponent
VoiceLogger VoiceLogger => impl.VoiceLogger

Member Function Documentation

◆ RestartPlayback()

void RestartPlayback ( )

Restarts the audio playback of the linked incoming remote audio stream via AudioSource component.

Returns
True if playback is successfully restarted.

Property Documentation

◆ IsLinked

bool IsLinked
get

Whether or not this Speaker has been linked to a remote voice stream.

◆ IsPlaying

bool IsPlaying
get

Is the speaker playing right now.

◆ Lag

int? Lag
get

The current difference between positions in the buffer of (jittery) stream writer and (clock-driven) audio output reader in ms.

◆ OnRemoteVoiceRemoveAction

Action<Speaker> OnRemoteVoiceRemoveAction
getset

Register a method to be called when remote voice removed.

◆ PlayDelay

int PlayDelay
getset

Gets or sets jitter buffer size in ms.

The method updates PlayDelayConfig with reasonable values based on the single value provided. Use PlayDelayConfig for more precise control.

◆ PlayDelayConfig

AudioOutDelayControl.PlayDelayConfig PlayDelayConfig
getset

Gets or sets jitter buffer config.

Make sure that the new value is fully initialized or built from AudioOutDelayControl.PlayDelayConfig.Default.


Photon Voice: Member List

  • Unity
  • Speaker
Speaker Member List

This is the complete list of members for Speaker, including all inherited members.

audioOutput (defined in Speaker) | Speaker | protected
Awake() (defined in Speaker) | Speaker | protectedvirtual
CreateAudioOut() (defined in Speaker) | Speaker | protectedvirtual
IsLinked | Speaker |
IsPlaying | Speaker |
Lag | Speaker |
Logger (defined in VoiceComponent) | VoiceComponent | protected
Name (defined in VoiceComponent) | VoiceComponent |
OnDestroy() (defined in Speaker) | Speaker | protectedvirtual
OnRemoteVoiceRemoveAction | Speaker |
PlayDelay | Speaker |
playDelayConfig (defined in Speaker) | Speaker | protected
PlayDelayConfig | Speaker |
RemoteVoice (defined in Speaker) | Speaker |
RestartOnDeviceChange (defined in Speaker) | Speaker |
restartOnDeviceChange (defined in Speaker) | Speaker | protected
RestartPlayback() | Speaker |
Update() (defined in Speaker) | Speaker | protected
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: SpeakerAudioFilterRead Class Reference

  • Unity
  • SpeakerAudioFilterRead
Protected Member Functions | List of all members
SpeakerAudioFilterRead Class Reference

Inherits Speaker.

Protected Member Functions

override IAudioOut< float > | CreateAudioOut ()
- Protected Member Functions inherited from Speaker
override void | Awake ()
virtual void | OnDestroy ()
void | Update ()

Additional Inherited Members

- Public Member Functions inherited from Speaker
void | RestartPlayback ()
Restarts the audio playback of the linked incoming remote audio stream via AudioSource component. More...
- Public Attributes inherited from VoiceComponent
VoiceLogger | VoiceLogger => impl.VoiceLogger
- Protected Attributes inherited from Speaker
IAudioOut< float > | audioOutput
AudioOutDelayControl.PlayDelayConfig | playDelayConfig = AudioOutDelayControl.PlayDelayConfig.Default
bool | restartOnDeviceChange = true
- Protected Attributes inherited from VoiceComponent
Voice.ILogger | Logger => impl.Logger
- Properties inherited from Speaker
bool | IsPlaying [get]
Is the speaker playing right now. More...
int? | Lag [get]
The current difference between positions in the buffer of (jittery) stream writer and (clock-driven) audio output reader in ms. More...
Action< Speaker > | OnRemoteVoiceRemoveAction [get, set]
Register a method to be called when remote voice removed. More...
RemoteVoiceLink | RemoteVoice [get]
bool | IsLinked [get]
Whether or not this Speaker has been linked to a remote voice stream. More...
AudioOutDelayControl.PlayDelayConfig | PlayDelayConfig [get, set]
Gets or sets jitter buffer config. More...
int | PlayDelay [get, set]
Gets or sets jitter buffer size in ms. More...
bool | RestartOnDeviceChange [get, set]
- Properties inherited from VoiceComponent
string | Name [set]


Photon Voice: Member List

  • Unity
  • SpeakerAudioFilterRead
SpeakerAudioFilterRead Member List

This is the complete list of members for SpeakerAudioFilterRead, including all inherited members.

audioOutput (defined in Speaker) | Speaker | protected
Awake() (defined in Speaker) | Speaker | protectedvirtual
CreateAudioOut() (defined in SpeakerAudioFilterRead) | SpeakerAudioFilterRead | protectedvirtual
IsLinked | Speaker |
IsPlaying | Speaker |
Lag | Speaker |
Logger (defined in VoiceComponent) | VoiceComponent | protected
Name (defined in VoiceComponent) | VoiceComponent |
OnDestroy() (defined in Speaker) | Speaker | protectedvirtual
OnRemoteVoiceRemoveAction | Speaker |
PlayDelay | Speaker |
playDelayConfig (defined in Speaker) | Speaker | protected
PlayDelayConfig | Speaker |
RemoteVoice (defined in Speaker) | Speaker |
RestartOnDeviceChange (defined in Speaker) | Speaker |
restartOnDeviceChange (defined in Speaker) | Speaker | protected
RestartPlayback() | Speaker |
Update() (defined in Speaker) | Speaker | protected
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: UnityAudioOut Class Reference

  • Unity
  • UnityAudioOut
Public Member Functions | Protected Attributes | Properties | List of all members
UnityAudioOut Class Reference

Inherits AudioOutDelayControl< float >.

Public Member Functions

UnityAudioOut (AudioSource audioSource, PlayDelayConfig playDelayConfig, ILogger logger, string logPrefix, bool debugInfo)
override void | OutCreate (int frequency, int channels, int bufferSamples)
override void | OutStart ()
override void | OutWrite (float[] data, int offsetSamples)
override void | Stop ()

Protected Attributes

readonly AudioSource | source
AudioClip | clip

Properties

override long OutPos [get]


Photon Voice: Member List

  • Unity
  • UnityAudioOut
UnityAudioOut Member List

This is the complete list of members for UnityAudioOut, including all inherited members.

clip (defined in UnityAudioOut) | UnityAudioOut | protected
OutCreate(int frequency, int channels, int bufferSamples) (defined in UnityAudioOut) | UnityAudioOut |
OutPos (defined in UnityAudioOut) | UnityAudioOut |
OutStart() (defined in UnityAudioOut) | UnityAudioOut |
OutWrite(float[] data, int offsetSamples) (defined in UnityAudioOut) | UnityAudioOut |
source (defined in UnityAudioOut) | UnityAudioOut | protected
Stop() (defined in UnityAudioOut) | UnityAudioOut |
UnityAudioOut(AudioSource audioSource, PlayDelayConfig playDelayConfig, ILogger logger, string logPrefix, bool debugInfo) (defined in UnityAudioOut) | UnityAudioOut |


Photon Voice: UnityLogger Class Reference

  • Unity
  • UnityLogger
Static Public Member Functions | List of all members
UnityLogger Class Reference

Static Public Member Functions

static void Log (LogLevel level, Object obj, string tag, string objName, string fmt, params object[] args)


Photon Voice: Member List

  • Unity
  • UnityLogger
UnityLogger Member List

This is the complete list of members for UnityLogger, including all inherited members.

Log(LogLevel level, Object obj, string tag, string objName, string fmt, params object[] args) (defined in UnityLogger) UnityLogger static


Photon Voice: UnityMicrophone Class Reference

  • Unity
  • UnityMicrophone
Static Public Member Functions | Properties | List of all members
UnityMicrophone Class Reference

A wrapper around UnityEngine.Microphone to be able to safely use Microphone and compile for WebGL. More...

Static Public Member Functions

static void | End (string deviceName)
static void | GetDeviceCaps (string deviceName, out int minFreq, out int maxFreq)
static int | GetPosition (string deviceName)
static bool | IsRecording (string deviceName)
static AudioClip | Start (string deviceName, bool loop, int lengthSec, int frequency)
static string | CheckDevice (Voice.ILogger logger, string logPref, string device, int suggestedFrequency, out int frequency)

Properties

static string[] devices [get]

Detailed Description

A wrapper around UnityEngine.Microphone to be able to safely use Microphone and compile for WebGL.


Photon Voice: Member List

  • Unity
  • UnityMicrophone
UnityMicrophone Member List

This is the complete list of members for UnityMicrophone, including all inherited members.

CheckDevice(Voice.ILogger logger, string logPref, string device, int suggestedFrequency, out int frequency) (defined in UnityMicrophone) | UnityMicrophone | static
devices (defined in UnityMicrophone) | UnityMicrophone | static
End(string deviceName) (defined in UnityMicrophone) | UnityMicrophone | static
GetDeviceCaps(string deviceName, out int minFreq, out int maxFreq) (defined in UnityMicrophone) | UnityMicrophone | static
GetPosition(string deviceName) (defined in UnityMicrophone) | UnityMicrophone | static
IsRecording(string deviceName) (defined in UnityMicrophone) | UnityMicrophone | static
Start(string deviceName, bool loop, int lengthSec, int frequency) (defined in UnityMicrophone) | UnityMicrophone | static


Photon Voice: UnityVoiceClient Class Reference

  • Unity
  • UnityVoiceClient
Public Member Functions | Public Attributes | Protected Member Functions | List of all members
UnityVoiceClient Class Reference

Component that represents a Voice client and manages a simple Unity integration: a single Recorder and multiple remote speakers. More...

Inherits VoiceConnection.

Public Member Functions

override bool | ConnectUsingSettings (AppSettings overwriteSettings=null)
Connect to Photon server using Settings More...
- Public Member Functions inherited from VoiceConnection
bool | AddSpeaker (Speaker speaker, object userData)
Tries to link local Speaker with remote voice stream using UserData. Useful if Speaker created after stream is started. More...
Speaker | InstantiateSpeakerPrefab (GameObject parent, bool destroyOnRemove)
Instantiates SpeakerPrefab, optionally attaches it to the provided parent. More...
bool | AddRecorder (Recorder rec)
void | RemoveRecorder (Recorder rec)

Public Attributes

override bool | AlwaysUsePrimaryRecorder => true
bool | UseVoiceAppSettings = false
Whether or not to use the Voice AppId and all the other AppSettings from Fusion's RealtimeAppSettings ScriptableObject singleton in the Voice client/app. More...
- Public Attributes inherited from VoiceConnection
virtual bool | AlwaysUsePrimaryRecorder => false
AppSettings | Settings
Settings to be used by this Voice Client More...
Voice.ILogger | Logger => voiceComponentImpl.Logger
VoiceLogger | VoiceLogger => voiceComponentImpl.VoiceLogger
bool | UsePrimaryRecorder => this.usePrimaryRecorder
Use VoiceConnection.PrimaryRecorder directly. More...

Protected Member Functions

virtual void | Start ()
override Speaker | InstantiateSpeakerForRemoteVoice (int playerId, byte voiceId, object userData)
- Protected Member Functions inherited from VoiceConnection
override void | Awake ()
virtual void | Update ()
virtual void | FixedUpdate ()
virtual void | OnDestroy ()
virtual void | OnVoiceStateChanged (ClientState fromState, ClientState toState)
void | CalcStatistics ()
virtual void | OnOperationResponseReceived (OperationResponse operationResponse)

Additional Inherited Members

- Static Public Attributes inherited from VoiceConnection
const int | ChannelAudio = 1
Recommended Photon Transport channel for audio. Chosen not to interfere with video and default channel. More...
const int | ChannelVideo = 2
Recommended Photon Transport channel for video. Chosen not to interfere with audio and default channel. More...
- Properties inherited from VoiceConnection
new LoadBalancingTransport | Client [get]
VoiceClient | VoiceClient [get]
Returns underlying Photon Voice client. More...
ClientState | ClientState [get]
Returns Photon Voice client state. More...
float | FramesReceivedPerSecond [get]
Number of frames received per second. More...
float | FramesLostPerSecond [get]
Number of frames lost per second. More...
float | FramesLostPercent [get]
Percentage of lost frames. More...
GameObject | SpeakerPrefab [get, set]
Prefab that contains Speaker component to be instantiated when receiving a new remote audio source info More...
Recorder | PrimaryRecorder [get, set]
Primary Recorder to be used by VoiceConnection implementations directly or via integration objects. More...
string | BestRegionSummaryInPreferences [get, set]
Used to store and access the "Best Region Summary" in the Player Preferences. More...
- Events inherited from VoiceConnection
Action< Speaker > | SpeakerLinked
Fires when a speaker has been linked to a remote audio stream More...
Action< RemoteVoiceLink > | RemoteVoiceAdded
Fires when a remote voice stream is added More...

Detailed Description

Component that represents a Voice client and manages a simple Unity integration: a single Recorder and multiple remote speakers.

Member Function Documentation

◆ ConnectUsingSettings()

override bool ConnectUsingSettings ( AppSettings overwriteSettings = null )
virtual

Connect to Photon server using Settings

Parameters
overwriteSettings Overwrites Settings before connecting
Returns
If true voice connection command was sent from client

Reimplemented from VoiceConnection.

Member Data Documentation

◆ UseVoiceAppSettings

bool UseVoiceAppSettings = false

Whether or not to use the Voice AppId and all the other AppSettings from Fusion's RealtimeAppSettings ScriptableObject singleton in the Voice client/app.


Photon Voice: Member List

  • Unity
  • UnityVoiceClient
UnityVoiceClient Member List

This is the complete list of members for UnityVoiceClient, including all inherited members.

AddRecorder(Recorder rec) (defined in VoiceConnection) | VoiceConnection |
AddSpeaker(Speaker speaker, object userData) | VoiceConnection |
AlwaysUsePrimaryRecorder (defined in UnityVoiceClient) | UnityVoiceClient |
Awake() (defined in VoiceConnection) | VoiceConnection | protected
BestRegionSummaryInPreferences | VoiceConnection |
CalcStatistics() (defined in VoiceConnection) | VoiceConnection | protected
ChannelAudio | VoiceConnection | static
ChannelVideo | VoiceConnection | static
Client (defined in VoiceConnection) | VoiceConnection |
ClientState | VoiceConnection |
ConnectUsingSettings(AppSettings overwriteSettings=null) | UnityVoiceClient | virtual
FixedUpdate() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
FramesLostPercent | VoiceConnection |
FramesLostPerSecond | VoiceConnection |
FramesReceivedPerSecond | VoiceConnection |
InstantiateSpeakerForRemoteVoice(int playerId, byte voiceId, object userData) (defined in UnityVoiceClient) | UnityVoiceClient | protectedvirtual
InstantiateSpeakerPrefab(GameObject parent, bool destroyOnRemove) | VoiceConnection |
Logger (defined in VoiceConnection) | VoiceConnection |
OnDestroy() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
OnOperationResponseReceived(OperationResponse operationResponse) (defined in VoiceConnection) | VoiceConnection | protectedvirtual
OnVoiceStateChanged(ClientState fromState, ClientState toState) (defined in VoiceConnection) | VoiceConnection | protectedvirtual
PrimaryRecorder | VoiceConnection |
RemoteVoiceAdded | VoiceConnection |
RemoveRecorder(Recorder rec) (defined in VoiceConnection) | VoiceConnection |
Settings | VoiceConnection |
SpeakerLinked | VoiceConnection |
SpeakerPrefab | VoiceConnection |
Start() (defined in UnityVoiceClient) | UnityVoiceClient | protectedvirtual
Update() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
UsePrimaryRecorder | VoiceConnection |
UseVoiceAppSettings | UnityVoiceClient |
VoiceClient | VoiceConnection |
VoiceLogger (defined in VoiceConnection) | VoiceConnection |


Photon Voice: VideoInEnumerator Class Reference

  • Unity
  • VideoInEnumerator
Public Member Functions | Properties | List of all members
VideoInEnumerator Class Reference

Inherits DeviceEnumeratorBase.

Public Member Functions

VideoInEnumerator (ILogger logger)
override void | Refresh ()
override void | Dispose ()
- Public Member Functions inherited from DeviceEnumeratorBase
DeviceEnumeratorBase (ILogger logger)
IEnumerator< DeviceInfo > | GetEnumerator ()

Properties

override string | Error [get]
- Properties inherited from DeviceEnumeratorBase
virtual string | Error [get, protected set]
Action | OnReady [protected get, set]
- Properties inherited from IDeviceEnumerator
bool | IsSupported [get]
Action | OnReady [set]
string | Error [get]

Additional Inherited Members

- Public Attributes inherited from DeviceEnumeratorBase
virtual bool | IsSupported => true
- Protected Attributes inherited from DeviceEnumeratorBase
List< DeviceInfo > | devices = new List<DeviceInfo>()
ILogger | logger


Photon Voice: Member List

  • Unity
  • VideoInEnumerator
VideoInEnumerator Member List

This is the complete list of members for VideoInEnumerator, including all inherited members.

DeviceEnumeratorBase(ILogger logger) (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
devices (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Dispose() (defined in VideoInEnumerator) | VideoInEnumerator | virtual
Error (defined in VideoInEnumerator) | VideoInEnumerator |
GetEnumerator() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
IsSupported (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
logger (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
OnReady (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
Refresh() (defined in VideoInEnumerator) | VideoInEnumerator | virtual
VideoInEnumerator(ILogger logger) (defined in VideoInEnumerator) | VideoInEnumerator |


Photon Voice: VoiceComponent Class Reference

  • Unity
  • VoiceComponent
Public Attributes | Protected Member Functions | Protected Attributes | Properties | List of all members
VoiceComponent Class Reference

Inherits MonoBehaviour.

Inherited by PhotonVoiceView, AudioChangesHandler, FMODRecorderSetup, Recorder, RecorderPreset, Speaker, MicAmplifier, MicrophonePermission, SaveIncomingStreamToFile, SaveOutgoingStreamToFile, and WebRtcAudioDsp.

Public Attributes

VoiceLogger VoiceLogger => impl.VoiceLogger

Protected Member Functions

virtual void Awake ()

Protected Attributes

Voice.ILogger Logger => impl.Logger

Properties

string Name [set]


Photon Voice: Member List

  • Unity
  • VoiceComponent
VoiceComponent Member List

This is the complete list of members for VoiceComponent, including all inherited members.

Awake() (defined in VoiceComponent) | VoiceComponent | protectedvirtual
Logger (defined in VoiceComponent) | VoiceComponent | protected
Name (defined in VoiceComponent) | VoiceComponent |
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: VoiceComponentImpl Class Reference

  • Unity
  • VoiceComponentImpl
Classes | Public Member Functions | Public Attributes | Properties | List of all members
VoiceComponentImpl Class Reference

Public Member Functions

void Awake (MonoBehaviour mb)

Public Attributes

Voice.ILogger | Logger => logger
VoiceLogger | VoiceLogger => voiceLogger

Properties

string Name [set]


Photon Voice: Member List

  • Unity
  • VoiceComponentImpl
VoiceComponentImpl Member List

This is the complete list of members for VoiceComponentImpl, including all inherited members.

Awake(MonoBehaviour mb) (defined in VoiceComponentImpl) | VoiceComponentImpl
Logger (defined in VoiceComponentImpl) | VoiceComponentImpl
Name (defined in VoiceComponentImpl) | VoiceComponentImpl
VoiceLogger (defined in VoiceComponentImpl) | VoiceComponentImpl


Photon Voice: VoiceConnection Class Reference

  • Unity
  • VoiceConnection
Public Member Functions | Public Attributes | Static Public Attributes | Protected Member Functions | Properties | Events | List of all members
VoiceConnection Class Reference

Component that represents a Voice client. More...

Inherits ConnectionHandler.

Inherited by UnityVoiceClient, and VoiceFollowClient.

Public Member Functions

virtual bool | ConnectUsingSettings (AppSettings overwriteSettings=null)
Connect to Photon server using Settings More...
bool | AddSpeaker (Speaker speaker, object userData)
Tries to link local Speaker with remote voice stream using UserData. Useful if Speaker created after stream is started. More...
Speaker | InstantiateSpeakerPrefab (GameObject parent, bool destroyOnRemove)
Instantiates SpeakerPrefab, optionally attaches it to the provided parent. More...
bool | AddRecorder (Recorder rec)
void | RemoveRecorder (Recorder rec)

Public Attributes

virtual bool | AlwaysUsePrimaryRecorder => false
AppSettings | Settings
Settings to be used by this Voice Client More...
Voice.ILogger | Logger => voiceComponentImpl.Logger
VoiceLogger | VoiceLogger => voiceComponentImpl.VoiceLogger
bool | UsePrimaryRecorder => this.usePrimaryRecorder
Use VoiceConnection.PrimaryRecorder directly. More...

Static Public Attributes

const int | ChannelAudio = 1
Recommended Photon Transport channel for audio. Chosen not to interfere with video and default channel. More...
const int | ChannelVideo = 2
Recommended Photon Transport channel for video. Chosen not to interfere with audio and default channel. More...

Protected Member Functions

override void | Awake ()
virtual void | Update ()
virtual void | FixedUpdate ()
virtual void | OnDestroy ()
virtual Speaker | InstantiateSpeakerForRemoteVoice (int playerId, byte voiceId, object userData)
virtual void | OnVoiceStateChanged (ClientState fromState, ClientState toState)
void | CalcStatistics ()
virtual void | OnOperationResponseReceived (OperationResponse operationResponse)

Properties

new LoadBalancingTransport | Client [get]
VoiceClient | VoiceClient [get]
Returns underlying Photon Voice client. More...
ClientState | ClientState [get]
Returns Photon Voice client state. More...
float | FramesReceivedPerSecond [get]
Number of frames received per second. More...
float | FramesLostPerSecond [get]
Number of frames lost per second. More...
float | FramesLostPercent [get]
Percentage of lost frames. More...
GameObject | SpeakerPrefab [get, set]
Prefab that contains Speaker component to be instantiated when receiving a new remote audio source info More...
Recorder | PrimaryRecorder [get, set]
Primary Recorder to be used by VoiceConnection implementations directly or via integration objects. More...
string | BestRegionSummaryInPreferences [get, set]
Used to store and access the "Best Region Summary" in the Player Preferences. More...

Events

Action< Speaker > | SpeakerLinked
Fires when a speaker has been linked to a remote audio stream More...
Action< RemoteVoiceLink > | RemoteVoiceAdded
Fires when a remote voice stream is added More...

Detailed Description

Component that represents a Voice client.

Member Function Documentation

◆ AddSpeaker()

bool AddSpeaker | ( | Speaker | speaker,
 |  | object | userData
 | ) |  |

Tries to link local Speaker with remote voice stream using UserData. Useful if Speaker created after stream is started.

Parameters
speaker | Speaker ot try linking.
userData | UserData object used to bind local Speaker with remote voice stream.
Returns

◆ ConnectUsingSettings()

virtual bool ConnectUsingSettings ( AppSettings overwriteSettings = null )
virtual

Connect to Photon server using Settings

Parameters
overwriteSettings Overwrites Settings before connecting
Returns
If true voice connection command was sent from client

Reimplemented in UnityVoiceClient.

◆ InstantiateSpeakerPrefab()

Speaker InstantiateSpeakerPrefab | ( | GameObject | parent,
 |  | bool | destroyOnRemove
 | ) |  |

Instantiates SpeakerPrefab, optionally attaches it to the provided parent.

VoiceConnection manages the instantiated object (destroys on OnRemoteVoiceRemoveAction).

Parameters
parent | The object to attach Steaker to.
destroyOnRemove | Automatically destroy instantiated prefab when remote voice is removed (the caller does not manages the instance).
Returns
Instantiated Speaker or null.

Member Data Documentation

◆ ChannelAudio

const int ChannelAudio = 1
static

Recommended Photon Transport channel for audio. Chosen not to interfere with video and default channel.

◆ ChannelVideo

const int ChannelVideo = 2
static

Recommended Photon Transport channel for video. Chosen not to interfere with audio and default channel.

◆ Settings

AppSettings Settings

Settings to be used by this Voice Client

◆ UsePrimaryRecorder

bool UsePrimaryRecorder => this.usePrimaryRecorder

Use VoiceConnection.PrimaryRecorder directly.

Property Documentation

◆ BestRegionSummaryInPreferences

string BestRegionSummaryInPreferences
getset

Used to store and access the "Best Region Summary" in the Player Preferences.

◆ ClientState

ClientState ClientState
get

Returns Photon Voice client state.

◆ FramesLostPercent

float FramesLostPercent
get

Percentage of lost frames.

◆ FramesLostPerSecond

float FramesLostPerSecond
get

Number of frames lost per second.

◆ FramesReceivedPerSecond

float FramesReceivedPerSecond
get

Number of frames received per second.

◆ PrimaryRecorder

Recorder PrimaryRecorder
getset

Primary Recorder to be used by VoiceConnection implementations directly or via integration objects.

◆ SpeakerPrefab

GameObject SpeakerPrefab
getset

Prefab that contains Speaker component to be instantiated when receiving a new remote audio source info

◆ VoiceClient

VoiceClient VoiceClient
get

Returns underlying Photon Voice client.

Event Documentation

◆ RemoteVoiceAdded

Action<RemoteVoiceLink> RemoteVoiceAdded

Fires when a remote voice stream is added

◆ SpeakerLinked

Action<Speaker> SpeakerLinked

Fires when a speaker has been linked to a remote audio stream


Photon Voice: Member List

  • Unity
  • VoiceConnection
VoiceConnection Member List

This is the complete list of members for VoiceConnection, including all inherited members.

AddRecorder(Recorder rec) (defined in VoiceConnection) | VoiceConnection |
AddSpeaker(Speaker speaker, object userData) | VoiceConnection |
AlwaysUsePrimaryRecorder (defined in VoiceConnection) | VoiceConnection |
Awake() (defined in VoiceConnection) | VoiceConnection | protected
BestRegionSummaryInPreferences | VoiceConnection |
CalcStatistics() (defined in VoiceConnection) | VoiceConnection | protected
ChannelAudio | VoiceConnection | static
ChannelVideo | VoiceConnection | static
Client (defined in VoiceConnection) | VoiceConnection |
ClientState | VoiceConnection |
ConnectUsingSettings(AppSettings overwriteSettings=null) | VoiceConnection | virtual
FixedUpdate() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
FramesLostPercent | VoiceConnection |
FramesLostPerSecond | VoiceConnection |
FramesReceivedPerSecond | VoiceConnection |
InstantiateSpeakerForRemoteVoice(int playerId, byte voiceId, object userData) (defined in VoiceConnection) | VoiceConnection | protectedvirtual
InstantiateSpeakerPrefab(GameObject parent, bool destroyOnRemove) | VoiceConnection |
Logger (defined in VoiceConnection) | VoiceConnection |
OnDestroy() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
OnOperationResponseReceived(OperationResponse operationResponse) (defined in VoiceConnection) | VoiceConnection | protectedvirtual
OnVoiceStateChanged(ClientState fromState, ClientState toState) (defined in VoiceConnection) | VoiceConnection | protectedvirtual
PrimaryRecorder | VoiceConnection |
RemoteVoiceAdded | VoiceConnection |
RemoveRecorder(Recorder rec) (defined in VoiceConnection) | VoiceConnection |
Settings | VoiceConnection |
SpeakerLinked | VoiceConnection |
SpeakerPrefab | VoiceConnection |
Update() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
UsePrimaryRecorder | VoiceConnection |
VoiceClient | VoiceConnection |
VoiceLogger (defined in VoiceConnection) | VoiceConnection |


Photon Voice: VoiceLogger Class Reference

  • Unity
  • VoiceLogger
Static Public Member Functions | Public Attributes | List of all members
VoiceLogger Class Reference

Inherits MonoBehaviour.

Static Public Member Functions

static VoiceLogger | FindLogger (GameObject gameObject)
static VoiceLogger | CreateRootLogger ()

Public Attributes

LogLevel LogLevel = LogLevel.Warning


Photon Voice: Member List

  • Unity
  • VoiceLogger
VoiceLogger Member List

This is the complete list of members for VoiceLogger, including all inherited members.

CreateRootLogger() (defined in VoiceLogger) | VoiceLogger | static
FindLogger(GameObject gameObject) (defined in VoiceLogger) | VoiceLogger | static
LogLevel (defined in VoiceLogger) | VoiceLogger |


Photon Voice: WebRtcAudioDsp Class Reference

  • Unity
  • WebRtcAudioDsp
Public Member Functions | Public Attributes | Protected Member Functions | Properties | List of all members
WebRtcAudioDsp Class Reference

Inherits VoiceComponent.

Public Member Functions

void AdjustVoiceInfo (ref VoiceInfo voiceInfo, ref AudioSampleType st)

Public Attributes

bool | IsSupported
- Public Attributes inherited from VoiceComponent
VoiceLogger | VoiceLogger => impl.VoiceLogger

Protected Member Functions

override void Awake ()

Properties

bool | AEC [get, set]
bool | AecHighPass [get, set]
int | ReverseStreamDelayMs [get, set]
bool | NoiseSuppression [get, set]
bool | HighPass [get, set]
bool | Bypass [get, set]
bool | AGC [get, set]
int | AgcCompressionGain [get, set]
int | AgcTargetLevel [get, set]
bool | VAD [get, set]
- Properties inherited from VoiceComponent
string | Name [set]

Additional Inherited Members

- Protected Attributes inherited from VoiceComponent
Voice.ILogger Logger => impl.Logger

Member Data Documentation

◆ IsSupported

bool IsSupported
Initial value:
=>
true


Photon Voice: Member List

  • Unity
  • WebRtcAudioDsp
WebRtcAudioDsp Member List

This is the complete list of members for WebRtcAudioDsp, including all inherited members.

AdjustVoiceInfo(ref VoiceInfo voiceInfo, ref AudioSampleType st) (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
AEC (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
AecHighPass (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
AGC (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
AgcCompressionGain (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
AgcTargetLevel (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
Awake() (defined in WebRtcAudioDsp) | WebRtcAudioDsp | protectedvirtual
Bypass (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
HighPass (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
IsSupported (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
Logger (defined in VoiceComponent) | VoiceComponent | protected
Name (defined in VoiceComponent) | VoiceComponent |
NoiseSuppression (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
ReverseStreamDelayMs (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
VAD (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
VoiceLogger (defined in VoiceComponent) | VoiceComponent |


Photon Voice: Photon.Voice.UWP Namespace Reference

  • UWP
Classes | Functions
Photon.Voice.UWP Namespace Reference

Classes

class | AudioInEnumerator
class | AudioInPusher
class | CaptureDevice
class | DeviceEnumerator
class | VideoInEnumerator

Functions

delegate void MediaCaptureInitConmpleted (MediaCapture mediaCpture, bool ok)


Photon Voice: AudioInEnumerator Class Reference

  • UWP
  • AudioInEnumerator
Public Member Functions | List of all members
AudioInEnumerator Class Reference

Inherits DeviceEnumerator.

Public Member Functions

AudioInEnumerator (ILogger logger)
- Public Member Functions inherited from DeviceEnumerator
DeviceEnumerator (ILogger logger, Windows.Devices.Enumeration.DeviceClass deviceClass)
override void | Refresh ()
override void | Dispose ()
- Public Member Functions inherited from DeviceEnumeratorBase
DeviceEnumeratorBase (ILogger logger)
IEnumerator< DeviceInfo > | GetEnumerator ()

Additional Inherited Members

- Public Attributes inherited from DeviceEnumeratorBase
virtual bool | IsSupported => true
- Protected Attributes inherited from DeviceEnumeratorBase
List< DeviceInfo > | devices = new List<DeviceInfo>()
ILogger | logger
- Properties inherited from DeviceEnumeratorBase
virtual string | Error [get, protected set]
Action | OnReady [protected get, set]
- Properties inherited from IDeviceEnumerator
bool | IsSupported [get]
Action | OnReady [set]
string | Error [get]


Photon Voice: Member List

  • UWP
  • AudioInEnumerator
AudioInEnumerator Member List

This is the complete list of members for AudioInEnumerator, including all inherited members.

AudioInEnumerator(ILogger logger) (defined in AudioInEnumerator) | AudioInEnumerator |
DeviceEnumerator(ILogger logger, Windows.Devices.Enumeration.DeviceClass deviceClass) (defined in DeviceEnumerator) | DeviceEnumerator |
DeviceEnumeratorBase(ILogger logger) (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
devices (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Dispose() (defined in DeviceEnumerator) | DeviceEnumerator | virtual
Error (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
GetEnumerator() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
IsSupported (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
logger (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
OnReady (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
Refresh() (defined in DeviceEnumerator) | DeviceEnumerator | virtual


Photon Voice: AudioInPusher Class Reference

  • UWP
  • AudioInPusher
Public Member Functions | Properties | List of all members
AudioInPusher Class Reference

Inherits IAudioPusher< short >.

Public Member Functions

AudioInPusher (ILogger logger, int samplingRate, int channels, string deviceID)
void | SetCallback (Action< short[]> callback, ObjectFactory< short[], int > bufferFactory)
ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
void | EndOfStream ()
I | GetPlatformAPI< I > ()
void | Dispose ()
- Public Member Functions inherited from IAudioPusher< short >
void | SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data. More...

Properties

int | SamplingRate [get]
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
bool | ErrorAccess [get]

Property Documentation

◆ Channels

int Channels
get

Number of channels in the audio signal.


Photon Voice: Member List

  • UWP
  • AudioInPusher
AudioInPusher Member List

This is the complete list of members for AudioInPusher, including all inherited members.

AudioInPusher(ILogger logger, int samplingRate, int channels, string deviceID) (defined in AudioInPusher) | AudioInPusher
Channels | AudioInPusher
DequeueOutput(out FrameFlags flags) (defined in AudioInPusher) | AudioInPusher
Dispose() (defined in AudioInPusher) | AudioInPusher
EndOfStream() (defined in AudioInPusher) | AudioInPusher
Error (defined in AudioInPusher) | AudioInPusher
ErrorAccess (defined in AudioInPusher) | AudioInPusher
GetPlatformAPI< I >() (defined in AudioInPusher) | AudioInPusher
SamplingRate (defined in AudioInPusher) | AudioInPusher
SetCallback(Action< short[]> callback, ObjectFactory< short[], int > bufferFactory) (defined in AudioInPusher) | AudioInPusher
IAudioPusher< short >.SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | IAudioPusher< short >


Photon Voice: CaptureDevice Class Reference

  • UWP
  • CaptureDevice
Public Types | Public Member Functions | Static Public Member Functions | Properties | Events | List of all members
CaptureDevice Class Reference

Public Types

enum Media

Public Member Functions

CaptureDevice (ILogger logger, Media media, string deviceID)
void | Initialize ()
void | InitializeAsync ()
async Task | CleanUpAsync ()
Asynchronous method cleaning up resources and stopping recording if necessary. More...
async Task< IMediaEncodingProperties > | SelectPreferredCameraStreamSettingAsync (MediaStreamType mediaStreamType, Func< IMediaEncodingProperties, bool > filterSettings)
Allow selection of camera settings. More...
async Task | StartRecordingAsync (MediaEncodingProfile encodingProfile, Action< byte[], FrameFlags > encoderCallback)
Starts media recording asynchronously More...
async Task | StopRecordingAsync ()
Stops recording asynchronously More...

Static Public Member Functions

static async Task< bool > CheckForRecordingDeviceAsync ()

Properties

MediaCapture CaptureSource [get]
Creates url object from MediaCapture More...

Events

EventHandler< MediaCaptureFailedEventArgs > CaptureFailed

Member Function Documentation

◆ CleanUpAsync()

async Task CleanUpAsync ( )

Asynchronous method cleaning up resources and stopping recording if necessary.

◆ SelectPreferredCameraStreamSettingAsync()

async Task<IMediaEncodingProperties> SelectPreferredCameraStreamSettingAsync | ( | MediaStreamType | mediaStreamType,
 |  | Func< IMediaEncodingProperties, bool > | filterSettings
 | ) |  |

Allow selection of camera settings.

Parameters
mediaStreamType | Type of a the media stream.
filterSettings | A predicate function, which will be called to filter the correct settings.

◆ StartRecordingAsync()

async Task StartRecordingAsync | ( | MediaEncodingProfile | encodingProfile,
 |  | Action< byte[], FrameFlags > | encoderCallback
 | ) |  |

Starts media recording asynchronously

Parameters
encodingProfile Encoding profile used for the recording session

◆ StopRecordingAsync()

async Task StopRecordingAsync ( )

Stops recording asynchronously

Property Documentation

◆ CaptureSource

MediaCapture CaptureSource
get

Creates url object from MediaCapture


Photon Voice: Member List

  • UWP
  • CaptureDevice
CaptureDevice Member List

This is the complete list of members for CaptureDevice, including all inherited members.

CaptureDevice(ILogger logger, Media media, string deviceID) (defined in CaptureDevice) | CaptureDevice |
CaptureFailed (defined in CaptureDevice) | CaptureDevice |
CaptureSource | CaptureDevice |
CheckForRecordingDeviceAsync() (defined in CaptureDevice) | CaptureDevice | static
CleanUpAsync() | CaptureDevice |
Initialize() (defined in CaptureDevice) | CaptureDevice |
InitializeAsync() (defined in CaptureDevice) | CaptureDevice |
Media enum name (defined in CaptureDevice) | CaptureDevice |
SelectPreferredCameraStreamSettingAsync(MediaStreamType mediaStreamType, Func< IMediaEncodingProperties, bool > filterSettings) | CaptureDevice |
StartRecordingAsync(MediaEncodingProfile encodingProfile, Action< byte[], FrameFlags > encoderCallback) | CaptureDevice |
StopRecordingAsync() | CaptureDevice |


Photon Voice: DeviceEnumerator Class Reference

  • UWP
  • DeviceEnumerator
Public Member Functions | List of all members
DeviceEnumerator Class Reference

Inherits DeviceEnumeratorBase.

Inherited by AudioInEnumerator, and VideoInEnumerator.

Public Member Functions

DeviceEnumerator (ILogger logger, Windows.Devices.Enumeration.DeviceClass deviceClass)
override void | Refresh ()
override void | Dispose ()
- Public Member Functions inherited from DeviceEnumeratorBase
DeviceEnumeratorBase (ILogger logger)
IEnumerator< DeviceInfo > | GetEnumerator ()

Additional Inherited Members

- Public Attributes inherited from DeviceEnumeratorBase
virtual bool | IsSupported => true
- Protected Attributes inherited from DeviceEnumeratorBase
List< DeviceInfo > | devices = new List<DeviceInfo>()
ILogger | logger
- Properties inherited from DeviceEnumeratorBase
virtual string | Error [get, protected set]
Action | OnReady [protected get, set]
- Properties inherited from IDeviceEnumerator
bool | IsSupported [get]
Action | OnReady [set]
string | Error [get]


Photon Voice: Member List

  • UWP
  • DeviceEnumerator
DeviceEnumerator Member List

This is the complete list of members for DeviceEnumerator, including all inherited members.

DeviceEnumerator(ILogger logger, Windows.Devices.Enumeration.DeviceClass deviceClass) (defined in DeviceEnumerator) | DeviceEnumerator |
DeviceEnumeratorBase(ILogger logger) (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
devices (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Dispose() (defined in DeviceEnumerator) | DeviceEnumerator | virtual
Error (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
GetEnumerator() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
IsSupported (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
logger (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
OnReady (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
Refresh() (defined in DeviceEnumerator) | DeviceEnumerator | virtual


Photon Voice: VideoInEnumerator Class Reference

  • UWP
  • VideoInEnumerator
Public Member Functions | List of all members
VideoInEnumerator Class Reference

Inherits DeviceEnumerator.

Public Member Functions

VideoInEnumerator (ILogger logger)
- Public Member Functions inherited from DeviceEnumerator
DeviceEnumerator (ILogger logger, Windows.Devices.Enumeration.DeviceClass deviceClass)
override void | Refresh ()
override void | Dispose ()
- Public Member Functions inherited from DeviceEnumeratorBase
DeviceEnumeratorBase (ILogger logger)
IEnumerator< DeviceInfo > | GetEnumerator ()

Additional Inherited Members

- Public Attributes inherited from DeviceEnumeratorBase
virtual bool | IsSupported => true
- Protected Attributes inherited from DeviceEnumeratorBase
List< DeviceInfo > | devices = new List<DeviceInfo>()
ILogger | logger
- Properties inherited from DeviceEnumeratorBase
virtual string | Error [get, protected set]
Action | OnReady [protected get, set]
- Properties inherited from IDeviceEnumerator
bool | IsSupported [get]
Action | OnReady [set]
string | Error [get]


Photon Voice: Member List

  • UWP
  • VideoInEnumerator
VideoInEnumerator Member List

This is the complete list of members for VideoInEnumerator, including all inherited members.

DeviceEnumerator(ILogger logger, Windows.Devices.Enumeration.DeviceClass deviceClass) (defined in DeviceEnumerator) | DeviceEnumerator |
DeviceEnumeratorBase(ILogger logger) (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
devices (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Dispose() (defined in DeviceEnumerator) | DeviceEnumerator | virtual
Error (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
GetEnumerator() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
IsSupported (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
logger (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
OnReady (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
Refresh() (defined in DeviceEnumerator) | DeviceEnumerator | virtual
VideoInEnumerator(ILogger logger) (defined in VideoInEnumerator) | VideoInEnumerator |


Photon Voice: Photon.Voice.Windows Namespace Reference

  • Windows
Classes
Photon.Voice.Windows Namespace Reference

Classes

class | AudioInEnumerator
Enumerates microphones available on device. More...
class | WindowsAudioInPusher


Photon Voice: AudioInEnumerator Class Reference

  • Windows
  • AudioInEnumerator
Public Member Functions | List of all members
AudioInEnumerator Class Reference

Enumerates microphones available on device. More...

Inherits DeviceEnumeratorBase.

Public Member Functions

AudioInEnumerator (ILogger logger)
override void | Refresh ()
Refreshes the microphones list. More...
override void | Dispose ()
Disposes enumerator. Call it to free native resources. More...
- Public Member Functions inherited from DeviceEnumeratorBase
DeviceEnumeratorBase (ILogger logger)
IEnumerator< DeviceInfo > | GetEnumerator ()

Additional Inherited Members

- Public Attributes inherited from DeviceEnumeratorBase
virtual bool | IsSupported => true
- Protected Attributes inherited from DeviceEnumeratorBase
List< DeviceInfo > | devices = new List<DeviceInfo>()
ILogger | logger
- Properties inherited from DeviceEnumeratorBase
virtual string | Error [get, protected set]
Action | OnReady [protected get, set]
- Properties inherited from IDeviceEnumerator
bool | IsSupported [get]
Action | OnReady [set]
string | Error [get]

Detailed Description

Enumerates microphones available on device.

Member Function Documentation

◆ Dispose()

override void Dispose ( )
virtual

Disposes enumerator. Call it to free native resources.

Implements DeviceEnumeratorBase.

◆ Refresh()

override void Refresh ( )
virtual

Refreshes the microphones list.

Implements DeviceEnumeratorBase.


Photon Voice: Member List

  • Windows
  • AudioInEnumerator
AudioInEnumerator Member List

This is the complete list of members for AudioInEnumerator, including all inherited members.

AudioInEnumerator(ILogger logger) (defined in AudioInEnumerator) | AudioInEnumerator |
DeviceEnumeratorBase(ILogger logger) (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
devices (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Dispose() | AudioInEnumerator | virtual
Error (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
GetEnumerator() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
IsSupported (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
logger (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
OnReady (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
Refresh() | AudioInEnumerator | virtual


Photon Voice: WindowsAudioInPusher Class Reference

  • Windows
  • WindowsAudioInPusher
Public Member Functions | Properties | List of all members
WindowsAudioInPusher Class Reference

Inherits IAudioPusher< short >.

Public Member Functions

WindowsAudioInPusher (int deviceID, ILogger logger)
void | SetCallback (Action< short[]> callback, ObjectFactory< short[], int > bufferFactory)
void | Dispose ()
- Public Member Functions inherited from IAudioPusher< short >
void | SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data. More...

Properties

int | Channels [get]
int | SamplingRate [get]
string | Error [get]


Photon Voice: Member List

  • Windows
  • WindowsAudioInPusher
WindowsAudioInPusher Member List

This is the complete list of members for WindowsAudioInPusher, including all inherited members.

Channels (defined in WindowsAudioInPusher) | WindowsAudioInPusher
Dispose() (defined in WindowsAudioInPusher) | WindowsAudioInPusher
Error (defined in WindowsAudioInPusher) | WindowsAudioInPusher
SamplingRate (defined in WindowsAudioInPusher) | WindowsAudioInPusher
SetCallback(Action< short[]> callback, ObjectFactory< short[], int > bufferFactory) (defined in WindowsAudioInPusher) | WindowsAudioInPusher
IAudioPusher< short >.SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | IAudioPusher< short >
WindowsAudioInPusher(int deviceID, ILogger logger) (defined in WindowsAudioInPusher) | WindowsAudioInPusher


Photon Voice: AudioDesc Class Reference

  • AudioDesc
Public Member Functions | Properties | List of all members
AudioDesc Class Reference

Inherits IAudioDesc.

Public Member Functions

AudioDesc (int samplingRate, int channels, string error)
void Dispose ()

Properties

int | SamplingRate [get]
int | Channels [get]
string | Error [get]
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...


Photon Voice: Member List

  • AudioDesc
AudioDesc Member List

This is the complete list of members for AudioDesc, including all inherited members.

AudioDesc(int samplingRate, int channels, string error) (defined in AudioDesc) | AudioDesc
Channels (defined in AudioDesc) | AudioDesc
Dispose() (defined in AudioDesc) | AudioDesc
Error (defined in AudioDesc) | AudioDesc
SamplingRate (defined in AudioDesc) | AudioDesc


Photon Voice: AudioInChangeNotifierNotSupported Class Reference

  • AudioInChangeNotifierNotSupported
Public Member Functions | Public Attributes | Properties | List of all members
AudioInChangeNotifierNotSupported Class Reference

Inherits IAudioInChangeNotifier.

Public Member Functions

AudioInChangeNotifierNotSupported (Action callback, ILogger logger)
void Dispose ()

Public Attributes

bool IsSupported => false

Properties

string | Error [get]
- Properties inherited from IAudioInChangeNotifier
bool | IsSupported [get]
string | Error [get]


Photon Voice: Member List

  • AudioInChangeNotifierNotSupported
AudioInChangeNotifierNotSupported Member List

This is the complete list of members for AudioInChangeNotifierNotSupported, including all inherited members.

AudioInChangeNotifierNotSupported(Action callback, ILogger logger) (defined in AudioInChangeNotifierNotSupported) | AudioInChangeNotifierNotSupported
Dispose() (defined in AudioInChangeNotifierNotSupported) | AudioInChangeNotifierNotSupported
Error (defined in AudioInChangeNotifierNotSupported) | AudioInChangeNotifierNotSupported
IsSupported (defined in AudioInChangeNotifierNotSupported) | AudioInChangeNotifierNotSupported


Photon Voice: AudioOutDelayControl Class Reference

  • AudioOutDelayControl
Classes
AudioOutDelayControl Class Reference

Inherited by AudioOutDelayControl< T >.

Classes

struct PlayDelayConfig


Photon Voice: AudioOutDelayControl.PlayDelayConfig Struct Reference

  • AudioOutDelayControl
  • PlayDelayConfig
Public Attributes | Static Public Attributes | List of all members
AudioOutDelayControl.PlayDelayConfig Struct Reference

Public Attributes

int | Low
int | High
int | Max
int | SpeedUpPerc

Static Public Attributes

static PlayDelayConfig Default

Member Data Documentation

◆ Default

PlayDelayConfig Default
static
Initial value:
= new PlayDelayConfig()
{
Low = 200,
High = 200,
Max = 1000,
SpeedUpPerc = 5,
}


Photon Voice: Member List

  • AudioOutDelayControl
  • PlayDelayConfig
AudioOutDelayControl.PlayDelayConfig Member List

This is the complete list of members for AudioOutDelayControl.PlayDelayConfig, including all inherited members.

Default (defined in AudioOutDelayControl.PlayDelayConfig) | AudioOutDelayControl.PlayDelayConfig | static
High (defined in AudioOutDelayControl.PlayDelayConfig) | AudioOutDelayControl.PlayDelayConfig |
Low (defined in AudioOutDelayControl.PlayDelayConfig) | AudioOutDelayControl.PlayDelayConfig |
Max (defined in AudioOutDelayControl.PlayDelayConfig) | AudioOutDelayControl.PlayDelayConfig |
SpeedUpPerc (defined in AudioOutDelayControl.PlayDelayConfig) | AudioOutDelayControl.PlayDelayConfig |


Photon Voice: AudioOutDummy< T > Class Template Reference

  • AudioOutDummy
Public Member Functions | Public Attributes | List of all members
AudioOutDummy< T > Class Template Reference

Inherits IAudioOut< T >.

Public Member Functions

void | Flush ()
void | Push (T[] frame)
void | Service ()
void | Start (int frequency, int channels, int frameSamplesPerChannel)
void | Stop ()

Public Attributes

bool | IsPlaying => false
int | Lag => 0

Additional Inherited Members

- Properties inherited from IAudioOut< T >
bool | IsPlaying [get]
int | Lag [get]


Photon Voice: Member List

  • AudioOutDummy
AudioOutDummy< T > Member List

This is the complete list of members for AudioOutDummy< T >, including all inherited members.

Flush() (defined in AudioOutDummy< T >) | AudioOutDummy< T >
IsPlaying (defined in AudioOutDummy< T >) | AudioOutDummy< T >
Lag (defined in AudioOutDummy< T >) | AudioOutDummy< T >
Push(T[] frame) (defined in AudioOutDummy< T >) | AudioOutDummy< T >
Service() (defined in AudioOutDummy< T >) | AudioOutDummy< T >
Start(int frequency, int channels, int frameSamplesPerChannel) (defined in AudioOutDummy< T >) | AudioOutDummy< T >
Stop() (defined in AudioOutDummy< T >) | AudioOutDummy< T >


Photon Voice: AudioSyncBuffer< T > Class Template Reference

  • AudioSyncBuffer
Public Member Functions | Public Attributes | List of all members
AudioSyncBuffer< T > Class Template Reference

Inherits AudioOutDelayControl< T >.

Public Member Functions

AudioSyncBuffer (PlayDelayConfig playDelayConfig, ILogger logger, string logPrefix, bool debugInfo)
override void | OutCreate (int frequency, int channels, int bufferSamples)
override void | OutStart ()
override void | OutWrite (T[] data, int offsetSamples)
override void | Stop ()
void | Read (T[] outBuf, int outChannels, int outSampleRate)

Public Attributes

override long OutPos => readPosSamples


Photon Voice: Member List

  • AudioSyncBuffer
AudioSyncBuffer< T > Member List

This is the complete list of members for AudioSyncBuffer< T >, including all inherited members.

AudioSyncBuffer(PlayDelayConfig playDelayConfig, ILogger logger, string logPrefix, bool debugInfo) (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T >
OutCreate(int frequency, int channels, int bufferSamples) (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T >
OutPos (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T >
OutStart() (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T >
OutWrite(T[] data, int offsetSamples) (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T >
Read(T[] outBuf, int outChannels, int outSampleRate) (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T >
Stop() (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T >


Photon Voice: AudioUtil Class Reference

  • AudioUtil
Classes | Static Public Member Functions | List of all members
AudioUtil Class Reference

Collection of Audio Utility functions and classes. More...

Classes

class | GeneratorPusher
IAudioPusher that provides a constant tone signal. More...
class | GeneratorReader
interface | ILevelMeter
Audio Level Metering interface. More...
interface | IVoiceDetector
Voice Activity Detector interface. More...
class | LevelMeter
Audio Level Meter. More...
class | LevelMeterDummy
Dummy Audio Level Meter that doesn't actually do anything. More...
class | LevelMeterFloat
LevelMeter specialization for float audio. More...
class | LevelMeterShort
LevelMeter specialization for short audio. More...
class | Resampler
Sample-rate conversion Audio Processor. More...
class | TempoUp
class | ToneAudioPusher
IAudioPusher that provides a constant tone signal. More...
class | ToneAudioReader
IAudioReader that provides a constant tone signal. More...
class | VoiceDetector
Simple voice activity detector triggered by signal level. More...
class | VoiceDetectorCalibration
Calibration Utility for Voice Detector More...
class | VoiceDetectorDummy
Dummy VoiceDetector that doesn't actually do anything. More...
class | VoiceDetectorFloat
VoiceDetector specialization for float audio. More...
class | VoiceDetectorShort
VoiceDetector specialization for float audio. More...
class | VoiceLevelDetectCalibrate
Utility Audio Processor Voice Detection Calibration. More...
class | WaveformAudioPusher
IAudioPusher that provides the given waveform. More...
class | WaveformAudioReader
IAudioReader that provides the given waveform. More...

Static Public Member Functions

static int | ToneToBuf< T > (T[] buf, long timeSamples, int channels, double amp, double k, double phaseMod=0)
static int | ToneToBuf< T > (T[] buf, int offset, int length, long timeSamples, int channels, double amp, double k, double phaseMod=0)
static int | WaveformToBuf< T > (T[] buf, T[] waveform, long timePos)
static void | Resample< T > (T[] src, T[] dst, int dstCount, int channels)
Resample audio data so that the complete src buffer fits into dstCount samples in the dst buffer. More...
static void | Resample< T > (T[] src, int srcOffset, int srcCount, T[] dst, int dstOffset, int dstCount, int channels)
static void | Resample< T > (T[] src, int srcOffset, int srcCount, int srcChannels, T[] dst, int dstOffset, int dstCount, int dstChannels)
static void | ResampleAndConvert (short[] src, float[] dst, int dstCount, int channels)
Resample audio data so that the complete src buffer fits into dstCount samples in the dst buffer, and convert short to float samples along the way. More...
static void | ResampleAndConvert (float[] src, short[] dst, int dstCount, int channels)
Resample audio data so that the complete src buffer fits into dstCount samples in the dst buffer, and convert float to short samples along the way. More...
static void | Convert (float[] src, short[] dst, int dstCount)
Convert audio buffer from float to short samples. More...
static void | Convert (short[] src, float[] dst, int dstCount)
Convert audio buffer from short to float samples. More...
static void | ForceToStereo< T > (T[] src, T[] dst, int srcChannels)
Convert audio buffer with arbitrary number of channels to stereo. More...

Detailed Description

Collection of Audio Utility functions and classes.

Member Function Documentation

◆ Convert() [1/2]

static void Convert | ( | float[] | src,
 |  | short[] | dst,
 |  | int | dstCount
 | ) |  |
static

Convert audio buffer from float to short samples.

Parameters
src | Source buffer.
dst | Destination buffer.
dstCount | Size of destination buffer (in total samples), source buffer must be of same length or longer.

◆ Convert() [2/2]

static void Convert | ( | short[] | src,
 |  | float[] | dst,
 |  | int | dstCount
 | ) |  |
static

Convert audio buffer from short to float samples.

Parameters
src | Source buffer.
dst | Destination buffer.
dstCount | Size of destination buffer (in total samples), source buffer must be of same length or longer.

◆ ForceToStereo< T >()

static void ForceToStereo< T > | ( | T[] | src,
 |  | T[] | dst,
 |  | int | srcChannels
 | ) |  |
static

Convert audio buffer with arbitrary number of channels to stereo.

For mono sources (srcChannels==1), the signal will be copied to both Left and Right stereo channels. For all others, the first two available channels will be used, any other channels will be discarded.

Parameters
src | Source buffer.
dst | Destination buffer.
srcChannels | Number of (interleaved) channels in src.

◆ Resample< T >()

static void Resample< T > | ( | T[] | src,
 |  | T[] | dst,
 |  | int | dstCount,
 |  | int | channels
 | ) |  |
static

Resample audio data so that the complete src buffer fits into dstCount samples in the dst buffer.

This implements a primitive nearest-neighbor resampling algorithm for an arbitrary number of channels.

Parameters
src | Source buffer.
dst | Destination buffer.
dstCount | Target size of destination buffer (in samples per channel).
channels | Number of channels in the signal (1=mono, 2=stereo). Must be > 0.

◆ ResampleAndConvert() [1/2]

static void ResampleAndConvert | ( | float[] | src,
 |  | short[] | dst,
 |  | int | dstCount,
 |  | int | channels
 | ) |  |
static

Resample audio data so that the complete src buffer fits into dstCount samples in the dst buffer, and convert float to short samples along the way.

This implements a primitive nearest-neighbor resampling algorithm for an arbitrary number of channels.

Parameters
src | Source buffer.
dst | Destination buffer.
dstCount | Target size of destination buffer (in samples per channel).
channels | Number of channels in the signal (1=mono, 2=stereo). Must be > 0.

◆ ResampleAndConvert() [2/2]

static void ResampleAndConvert | ( | short[] | src,
 |  | float[] | dst,
 |  | int | dstCount,
 |  | int | channels
 | ) |  |
static

Resample audio data so that the complete src buffer fits into dstCount samples in the dst buffer, and convert short to float samples along the way.

This implements a primitive nearest-neighbor resampling algorithm for an arbitrary number of channels.

Parameters
src | Source buffer.
dst | Destination buffer.
dstCount | Target size of destination buffer (in samples per channel).
channels | Number of channels in the signal (1=mono, 2=stereo). Must be > 0.


Photon Voice: Member List

  • AudioUtil
AudioUtil Member List

This is the complete list of members for AudioUtil, including all inherited members.

Convert(float[] src, short[] dst, int dstCount) | AudioUtil | static
Convert(short[] src, float[] dst, int dstCount) | AudioUtil | static
ForceToStereo< T >(T[] src, T[] dst, int srcChannels) | AudioUtil | static
Resample< T >(T[] src, T[] dst, int dstCount, int channels) | AudioUtil | static
Resample< T >(T[] src, int srcOffset, int srcCount, T[] dst, int dstOffset, int dstCount, int channels) (defined in AudioUtil) | AudioUtil | static
Resample< T >(T[] src, int srcOffset, int srcCount, int srcChannels, T[] dst, int dstOffset, int dstCount, int dstChannels) (defined in AudioUtil) | AudioUtil | static
ResampleAndConvert(short[] src, float[] dst, int dstCount, int channels) | AudioUtil | static
ResampleAndConvert(float[] src, short[] dst, int dstCount, int channels) | AudioUtil | static
ToneToBuf< T >(T[] buf, long timeSamples, int channels, double amp, double k, double phaseMod=0) (defined in AudioUtil) | AudioUtil | static
ToneToBuf< T >(T[] buf, int offset, int length, long timeSamples, int channels, double amp, double k, double phaseMod=0) (defined in AudioUtil) | AudioUtil | static
WaveformToBuf< T >(T[] buf, T[] waveform, long timePos) (defined in AudioUtil) | AudioUtil | static


Photon Voice: AudioUtil.GeneratorPusher< T > Class Template Reference

  • AudioUtil
  • GeneratorPusher
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
AudioUtil.GeneratorPusher< T > Class Template Referenceabstract

IAudioPusher that provides a constant tone signal. More...

Inherits IAudioPusher< T >.

Inherited by AudioUtil.ToneAudioPusher< T >, and AudioUtil.WaveformAudioPusher< T >.

Public Member Functions

GeneratorPusher (int bufSizeMs=100, int samplingRate=48000, int channels=1)
void | SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data More...
void | Dispose ()

Protected Member Functions

abstract int Gen (T[] buf, long timeSamples)

Protected Attributes

long timeSamples

Properties

int | Channels [get]
int | SamplingRate [get]
string | Error [get]
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Detailed Description

IAudioPusher that provides a constant tone signal.

Member Function Documentation

◆ SetCallback()

void SetCallback | ( | Action< T[]> | callback,
 |  | ObjectFactory< T[], int > | bufferFactory
 | ) |  |

Set the callback function used for pushing data

Parameters
callback | Callback function to use
bufferFactory | Buffer factory used to create the buffer that is pushed to the callback

Implements IAudioPusher< T >.


Photon Voice: Member List

  • AudioUtil
  • GeneratorPusher
AudioUtil.GeneratorPusher< T > Member List

This is the complete list of members for AudioUtil.GeneratorPusher< T >, including all inherited members.

Channels (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
Dispose() (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
Error (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
Gen(T[] buf, long timeSamples) (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > | protectedpure virtual
GeneratorPusher(int bufSizeMs=100, int samplingRate=48000, int channels=1) (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
SamplingRate (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | AudioUtil.GeneratorPusher< T > |
timeSamples (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > | protected


Photon Voice: AudioUtil.GeneratorReader< T > Class Template Reference

  • AudioUtil
  • GeneratorReader
Public Member Functions | Protected Member Functions | Properties | List of all members
AudioUtil.GeneratorReader< T > Class Template Referenceabstract

Inherits IAudioReader< T >.

Inherited by AudioUtil.ToneAudioReader< T >, and AudioUtil.WaveformAudioReader< T >.

Public Member Functions

GeneratorReader (Func< double > clockSec=null, int samplingRate=48000, int channels=1)
void | Dispose ()
bool | Read (T[] buf)
Fill full given frame buffer with source uncompressed data or return false if not enough such data. More...

Protected Member Functions

abstract int Gen (T[] buf, long timeSamples)

Properties

int | Channels [get]
int | SamplingRate [get]
string | Error [get]
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Member Function Documentation

◆ Read()

bool Read ( T[] buffer )

Fill full given frame buffer with source uncompressed data or return false if not enough such data.

Parameters
buffer Buffer to fill.
Returns
True if buffer was filled successfully, false otherwise.

Implements IDataReader< T >.


Photon Voice: Member List

  • AudioUtil
  • GeneratorReader
AudioUtil.GeneratorReader< T > Member List

This is the complete list of members for AudioUtil.GeneratorReader< T >, including all inherited members.

Channels (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Dispose() (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Error (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Gen(T[] buf, long timeSamples) (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > | protectedpure virtual
GeneratorReader(Func< double > clockSec=null, int samplingRate=48000, int channels=1) (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Read(T[] buf) | AudioUtil.GeneratorReader< T > |
SamplingRate (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |


Photon Voice: AudioUtil.ILevelMeter Interface Reference

  • AudioUtil
  • ILevelMeter
Public Member Functions | Properties | List of all members
AudioUtil.ILevelMeter Interface Reference

Audio Level Metering interface. More...

Inherited by AudioUtil.LevelMeter< T >, and AudioUtil.LevelMeterDummy.

Public Member Functions

void ResetAccumAvgPeakAmp ()
Reset AccumAvgPeakAmp. More...

Properties

float | CurrentAvgAmp [get]
Average amplitude value over last half second. More...
float | CurrentPeakAmp [get]
Maximum amplitude value over last half second sec. More...
float | AccumAvgPeakAmp [get]
Average of CurrentPeakAmps since last reset. More...

Detailed Description

Audio Level Metering interface.

Member Function Documentation

◆ ResetAccumAvgPeakAmp()

void ResetAccumAvgPeakAmp ( )

Reset AccumAvgPeakAmp.

Implemented in AudioUtil.LevelMeter< T >, and AudioUtil.LevelMeterDummy.

Property Documentation

◆ AccumAvgPeakAmp

float AccumAvgPeakAmp
get

Average of CurrentPeakAmps since last reset.

◆ CurrentAvgAmp

float CurrentAvgAmp
get

Average amplitude value over last half second.

◆ CurrentPeakAmp

float CurrentPeakAmp
get

Maximum amplitude value over last half second sec.


Photon Voice: Member List

  • AudioUtil
  • ILevelMeter
AudioUtil.ILevelMeter Member List

This is the complete list of members for AudioUtil.ILevelMeter, including all inherited members.

AccumAvgPeakAmp | AudioUtil.ILevelMeter
CurrentAvgAmp | AudioUtil.ILevelMeter
CurrentPeakAmp | AudioUtil.ILevelMeter
ResetAccumAvgPeakAmp() | AudioUtil.ILevelMeter


Photon Voice: AudioUtil.IVoiceDetector Interface Reference

  • AudioUtil
  • IVoiceDetector
Properties | Events | List of all members
AudioUtil.IVoiceDetector Interface Reference

Voice Activity Detector interface. More...

Inherited by AudioUtil.VoiceDetector< T >, and AudioUtil.VoiceDetectorDummy.

Properties

bool | On [get, set]
If true, voice detection enabled. More...
float | Threshold [get, set]
Voice detected as soon as signal level exceeds threshold. More...
bool | Detected [get]
If true, voice detected. More...
DateTime | DetectedTime [get]
Last time when switched to detected state. More...
int | ActivityDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. More...

Events

Action OnDetected
Called when switched to detected state. More...

Detailed Description

Voice Activity Detector interface.

Property Documentation

◆ ActivityDelayMs

int ActivityDelayMs
getset

Keep detected state during this time after signal level dropped below threshold.

◆ Detected

bool Detected
get

If true, voice detected.

◆ DetectedTime

DateTime DetectedTime
get

Last time when switched to detected state.

◆ On

bool On
getset

If true, voice detection enabled.

◆ Threshold

float Threshold
getset

Voice detected as soon as signal level exceeds threshold.

Event Documentation

◆ OnDetected

Action OnDetected

Called when switched to detected state.


Photon Voice: Member List

  • AudioUtil
  • IVoiceDetector
AudioUtil.IVoiceDetector Member List

This is the complete list of members for AudioUtil.IVoiceDetector, including all inherited members.

ActivityDelayMs | AudioUtil.IVoiceDetector
Detected | AudioUtil.IVoiceDetector
DetectedTime | AudioUtil.IVoiceDetector
On | AudioUtil.IVoiceDetector
OnDetected | AudioUtil.IVoiceDetector
Threshold | AudioUtil.IVoiceDetector


Photon Voice: AudioUtil.LevelMeter< T > Class Template Reference

  • AudioUtil
  • LevelMeter
Public Member Functions | Protected Attributes | Properties | List of all members
AudioUtil.LevelMeter< T > Class Template Referenceabstract

Audio Level Meter. More...

Inherits IProcessor< T >, and AudioUtil.ILevelMeter.

Public Member Functions

void | ResetAccumAvgPeakAmp ()
Reset AccumAvgPeakAmp. More...
abstract T[] | Process (T[] buf)
Process a frame of data. More...
void | Dispose ()

Protected Attributes

float | ampSum
float | ampPeak
int | bufferSize
float[] | prevValues
int | prevValuesHead
float | accumAvgPeakAmpSum
int | accumAvgPeakAmpCount
float | currentPeakAmp
float | norm

Properties

float | CurrentAvgAmp [get]
float | CurrentPeakAmp [get, protected set]
float? | AccumAvgPeakAmp [get]
- Properties inherited from AudioUtil.ILevelMeter
float | CurrentAvgAmp [get]
Average amplitude value over last half second. More...
float | CurrentPeakAmp [get]
Maximum amplitude value over last half second sec. More...
float | AccumAvgPeakAmp [get]
Average of CurrentPeakAmps since last reset. More...

Detailed Description

Audio Level Meter.

Member Function Documentation

◆ Process()

abstract T [] Process ( T[] buf )
pure virtual

Process a frame of data.

Parameters
buf Buffer containing input data
Returns
Buffer containing output data or null if frame has been discarded (VAD)

Implements IProcessor< T >.

◆ ResetAccumAvgPeakAmp()

void ResetAccumAvgPeakAmp ( )

Reset AccumAvgPeakAmp.

Implements AudioUtil.ILevelMeter.


Photon Voice: Member List

  • AudioUtil
  • LevelMeter
AudioUtil.LevelMeter< T > Member List

This is the complete list of members for AudioUtil.LevelMeter< T >, including all inherited members.

AccumAvgPeakAmp (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > |
accumAvgPeakAmpCount (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
accumAvgPeakAmpSum (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
ampPeak (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
ampSum (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
bufferSize (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
CurrentAvgAmp (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > |
currentPeakAmp (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
CurrentPeakAmp (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > |
Dispose() (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > |
norm (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
prevValues (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
prevValuesHead (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
Process(T[] buf) | AudioUtil.LevelMeter< T > | pure virtual
ResetAccumAvgPeakAmp() | AudioUtil.LevelMeter< T > |


Photon Voice: AudioUtil.LevelMeterDummy Class Reference

  • AudioUtil
  • LevelMeterDummy
Public Member Functions | Properties | List of all members
AudioUtil.LevelMeterDummy Class Reference

Dummy Audio Level Meter that doesn't actually do anything. More...

Inherits AudioUtil.ILevelMeter.

Public Member Functions

void ResetAccumAvgPeakAmp ()
Reset AccumAvgPeakAmp. More...

Properties

float | CurrentAvgAmp [get]
float | CurrentPeakAmp [get]
float | AccumAvgPeakAmp [get]
- Properties inherited from AudioUtil.ILevelMeter
float | CurrentAvgAmp [get]
Average amplitude value over last half second. More...
float | CurrentPeakAmp [get]
Maximum amplitude value over last half second sec. More...
float | AccumAvgPeakAmp [get]
Average of CurrentPeakAmps since last reset. More...

Detailed Description

Dummy Audio Level Meter that doesn't actually do anything.

Member Function Documentation

◆ ResetAccumAvgPeakAmp()

void ResetAccumAvgPeakAmp ( )

Reset AccumAvgPeakAmp.

Implements AudioUtil.ILevelMeter.


Photon Voice: Member List

  • AudioUtil
  • LevelMeterDummy
AudioUtil.LevelMeterDummy Member List

This is the complete list of members for AudioUtil.LevelMeterDummy, including all inherited members.

AccumAvgPeakAmp (defined in AudioUtil.LevelMeterDummy) | AudioUtil.LevelMeterDummy
CurrentAvgAmp (defined in AudioUtil.LevelMeterDummy) | AudioUtil.LevelMeterDummy
CurrentPeakAmp (defined in AudioUtil.LevelMeterDummy) | AudioUtil.LevelMeterDummy
ResetAccumAvgPeakAmp() | AudioUtil.LevelMeterDummy


Photon Voice: AudioUtil.LevelMeterFloat Class Reference

  • AudioUtil
  • LevelMeterFloat
Public Member Functions | List of all members
AudioUtil.LevelMeterFloat Class Reference

LevelMeter specialization for float audio. More...

Inherits AudioUtil.LevelMeter< float >.

Public Member Functions

LevelMeterFloat (int samplingRate, int numChannels)
Create new LevelMeterFloat instance. More...
override float[] | Process (float[] buf)
- Public Member Functions inherited from AudioUtil.LevelMeter< float >
void | ResetAccumAvgPeakAmp ()
Reset AccumAvgPeakAmp. More...
abstract T[] | Process (T[] buf)
Process a frame of data. More...
void | Dispose ()

Additional Inherited Members

- Protected Attributes inherited from AudioUtil.LevelMeter< float >
float | ampSum
float | ampPeak
int | bufferSize
float[] | prevValues
int | prevValuesHead
float | accumAvgPeakAmpSum
int | accumAvgPeakAmpCount
float | currentPeakAmp
float | norm
- Properties inherited from AudioUtil.LevelMeter< float >
float | CurrentAvgAmp [get]
float | CurrentPeakAmp [get, protected set]
float? | AccumAvgPeakAmp [get]

Detailed Description

LevelMeter specialization for float audio.

Constructor & Destructor Documentation

◆ LevelMeterFloat()

LevelMeterFloat | ( | int | samplingRate,
 |  | int | numChannels
 | ) |  |

Create new LevelMeterFloat instance.

Parameters
samplingRate | Sampling rate of the audio signal (in Hz).
numChannels | Number of channels in the audio signal.


Photon Voice: Member List

  • AudioUtil
  • LevelMeterFloat
AudioUtil.LevelMeterFloat Member List

This is the complete list of members for AudioUtil.LevelMeterFloat, including all inherited members.

AccumAvgPeakAmp (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > |
accumAvgPeakAmpCount (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
accumAvgPeakAmpSum (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
ampPeak (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
ampSum (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
bufferSize (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
CurrentAvgAmp (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > |
currentPeakAmp (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
CurrentPeakAmp (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > |
Dispose() (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > |
LevelMeterFloat(int samplingRate, int numChannels) | AudioUtil.LevelMeterFloat |
norm (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
prevValues (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
prevValuesHead (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
Process(float[] buf) (defined in AudioUtil.LevelMeterFloat) | AudioUtil.LevelMeterFloat |
LevelMeter< float >.Process(T[] buf) | AudioUtil.LevelMeter< float > | pure virtual
ResetAccumAvgPeakAmp() | AudioUtil.LevelMeter< float > |


Photon Voice: AudioUtil.LevelMeterShort Class Reference

  • AudioUtil
  • LevelMeterShort
Public Member Functions | List of all members
AudioUtil.LevelMeterShort Class Reference

LevelMeter specialization for short audio. More...

Inherits AudioUtil.LevelMeter< short >.

Public Member Functions

LevelMeterShort (int samplingRate, int numChannels)
Create new LevelMeterShort instance. More...
override short[] | Process (short[] buf)
- Public Member Functions inherited from AudioUtil.LevelMeter< short >
void | ResetAccumAvgPeakAmp ()
Reset AccumAvgPeakAmp. More...
abstract T[] | Process (T[] buf)
Process a frame of data. More...
void | Dispose ()

Additional Inherited Members

- Protected Attributes inherited from AudioUtil.LevelMeter< short >
float | ampSum
float | ampPeak
int | bufferSize
float[] | prevValues
int | prevValuesHead
float | accumAvgPeakAmpSum
int | accumAvgPeakAmpCount
float | currentPeakAmp
float | norm
- Properties inherited from AudioUtil.LevelMeter< short >
float | CurrentAvgAmp [get]
float | CurrentPeakAmp [get, protected set]
float? | AccumAvgPeakAmp [get]

Detailed Description

LevelMeter specialization for short audio.

Constructor & Destructor Documentation

◆ LevelMeterShort()

LevelMeterShort | ( | int | samplingRate,
 |  | int | numChannels
 | ) |  |

Create new LevelMeterShort instance.

Parameters
samplingRate | Sampling rate of the audio signal (in Hz).
numChannels | Number of channels in the audio signal.


Photon Voice: Member List

  • AudioUtil
  • LevelMeterShort
AudioUtil.LevelMeterShort Member List

This is the complete list of members for AudioUtil.LevelMeterShort, including all inherited members.

AccumAvgPeakAmp (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > |
accumAvgPeakAmpCount (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
accumAvgPeakAmpSum (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
ampPeak (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
ampSum (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
bufferSize (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
CurrentAvgAmp (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > |
currentPeakAmp (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
CurrentPeakAmp (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > |
Dispose() (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > |
LevelMeterShort(int samplingRate, int numChannels) | AudioUtil.LevelMeterShort |
norm (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
prevValues (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
prevValuesHead (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
Process(short[] buf) (defined in AudioUtil.LevelMeterShort) | AudioUtil.LevelMeterShort |
LevelMeter< short >.Process(T[] buf) | AudioUtil.LevelMeter< short > | pure virtual
ResetAccumAvgPeakAmp() | AudioUtil.LevelMeter< short > |


Photon Voice: AudioUtil.Resampler< T > Class Template Reference

  • AudioUtil
  • Resampler
Public Member Functions | Protected Attributes | List of all members
AudioUtil.Resampler< T > Class Template Reference

Sample-rate conversion Audio Processor. More...

Inherits IProcessor< T >.

Public Member Functions

Resampler (int dstSize, int channels)
Create a new Resampler instance. More...
T[] | Process (T[] buf)
Process a frame of data. More...
void | Dispose ()

Protected Attributes

T[] frameResampled

Detailed Description

Sample-rate conversion Audio Processor.

This processor converts the sample-rate of the source stream. Internally, it uses AudioUtil.Resample<T>(T[], T[], int, int).

Constructor & Destructor Documentation

◆ Resampler()

Resampler | ( | int | dstSize,
 |  | int | channels
 | ) |  |

Create a new Resampler instance.

Parameters
dstSize | Frame size of a destination frame. Determins output rate.
channels | Number of audio channels expected in both in- and output.

Member Function Documentation

◆ Process()

T [] Process ( T[] buf )

Process a frame of data.

Parameters
buf Buffer containing input data
Returns
Buffer containing output data or null if frame has been discarded (VAD)

Implements IProcessor< T >.


Photon Voice: Member List

  • AudioUtil
  • Resampler
AudioUtil.Resampler< T > Member List

This is the complete list of members for AudioUtil.Resampler< T >, including all inherited members.

Dispose() (defined in AudioUtil.Resampler< T >) | AudioUtil.Resampler< T > |
frameResampled (defined in AudioUtil.Resampler< T >) | AudioUtil.Resampler< T > | protected
Process(T[] buf) | AudioUtil.Resampler< T > |
Resampler(int dstSize, int channels) | AudioUtil.Resampler< T > |


Photon Voice: AudioUtil.TempoUp< T > Class Template Reference

  • AudioUtil
  • TempoUp
Public Member Functions | List of all members
AudioUtil.TempoUp< T > Class Template Reference

Public Member Functions

void | Begin (int channels, int changePerc, int skipGroup)
int | Process (T[] s, T[] d)
int | End (T[] s)
int | endFloat (float[] s)
int | endShort (short[] s)


Photon Voice: Member List

  • AudioUtil
  • TempoUp
AudioUtil.TempoUp< T > Member List

This is the complete list of members for AudioUtil.TempoUp< T >, including all inherited members.

Begin(int channels, int changePerc, int skipGroup) (defined in AudioUtil.TempoUp< T >) | AudioUtil.TempoUp< T >
End(T[] s) (defined in AudioUtil.TempoUp< T >) | AudioUtil.TempoUp< T >
endFloat(float[] s) (defined in AudioUtil.TempoUp< T >) | AudioUtil.TempoUp< T >
endShort(short[] s) (defined in AudioUtil.TempoUp< T >) | AudioUtil.TempoUp< T >
Process(T[] s, T[] d) (defined in AudioUtil.TempoUp< T >) | AudioUtil.TempoUp< T >


Photon Voice: AudioUtil.ToneAudioPusher< T > Class Template Reference

  • AudioUtil
  • ToneAudioPusher
Public Member Functions | Protected Member Functions | List of all members
AudioUtil.ToneAudioPusher< T > Class Template Reference

IAudioPusher that provides a constant tone signal. More...

Inherits AudioUtil.GeneratorPusher< T >.

Public Member Functions

ToneAudioPusher (int frequency=440, int bufSizeMs=100, int samplingRate=48000, int channels=1)
Create a new ToneAudioReader instance More...
- Public Member Functions inherited from AudioUtil.GeneratorPusher< T >
GeneratorPusher (int bufSizeMs=100, int samplingRate=48000, int channels=1)
void | SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data More...
void | Dispose ()

Protected Member Functions

override int Gen (T[] buf, long timeSamples)

Additional Inherited Members

- Protected Attributes inherited from AudioUtil.GeneratorPusher< T >
long | timeSamples
- Properties inherited from AudioUtil.GeneratorPusher< T >
int | Channels [get]
int | SamplingRate [get]
string | Error [get]
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Detailed Description

IAudioPusher that provides a constant tone signal.

Constructor & Destructor Documentation

◆ ToneAudioPusher()

ToneAudioPusher | ( | int | frequency = 440,
 |  | int | bufSizeMs = 100,
 |  | int | samplingRate = 48000,
 |  | int | channels = 1
 | ) |  |

Create a new ToneAudioReader instance

Parameters
frequency | Frequency of the generated tone (in Hz).
bufSizeMs | Size of buffers to push (in milliseconds).
samplingRate | Sampling rate of the audio signal (in Hz).
channels | Number of channels in the audio signal.


Photon Voice: Member List

  • AudioUtil
  • ToneAudioPusher
AudioUtil.ToneAudioPusher< T > Member List

This is the complete list of members for AudioUtil.ToneAudioPusher< T >, including all inherited members.

Channels (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
Dispose() (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
Error (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
Gen(T[] buf, long timeSamples) (defined in AudioUtil.ToneAudioPusher< T >) | AudioUtil.ToneAudioPusher< T > | protectedvirtual
GeneratorPusher(int bufSizeMs=100, int samplingRate=48000, int channels=1) (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
SamplingRate (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | AudioUtil.GeneratorPusher< T > |
timeSamples (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > | protected
ToneAudioPusher(int frequency=440, int bufSizeMs=100, int samplingRate=48000, int channels=1) | AudioUtil.ToneAudioPusher< T > |


Photon Voice: AudioUtil.ToneAudioReader< T > Class Template Reference

  • AudioUtil
  • ToneAudioReader
Public Member Functions | Protected Member Functions | List of all members
AudioUtil.ToneAudioReader< T > Class Template Reference

IAudioReader that provides a constant tone signal. More...

Inherits AudioUtil.GeneratorReader< T >.

Public Member Functions

ToneAudioReader (Func< double > clockSec=null, double frequency=440, int samplingRate=48000, int channels=1)
Create a new ToneAudioReader instance More...
- Public Member Functions inherited from AudioUtil.GeneratorReader< T >
GeneratorReader (Func< double > clockSec=null, int samplingRate=48000, int channels=1)
void | Dispose ()
bool | Read (T[] buf)
Fill full given frame buffer with source uncompressed data or return false if not enough such data. More...

Protected Member Functions

override int Gen (T[] buf, long timeSamples)

Additional Inherited Members

- Properties inherited from AudioUtil.GeneratorReader< T >
int | Channels [get]
int | SamplingRate [get]
string | Error [get]
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Detailed Description

IAudioReader that provides a constant tone signal.

Because of current resampling algorithm, the tone is distorted if SamplingRate does not equal encoder sampling rate.

Constructor & Destructor Documentation

◆ ToneAudioReader()

ToneAudioReader | ( | Func< double > | clockSec = null,
 |  | double | frequency = 440,
 |  | int | samplingRate = 48000,
 |  | int | channels = 1
 | ) |  |

Create a new ToneAudioReader instance

Parameters
clockSec | Function to get current time in seconds. In Unity, pass in '() => AudioSettings.dspTime' for better results.
frequency | Frequency of the generated tone (in Hz).
samplingRate | Sampling rate of the audio signal (in Hz).
channels | Number of channels in the audio signal.


Photon Voice: Member List

  • AudioUtil
  • ToneAudioReader
AudioUtil.ToneAudioReader< T > Member List

This is the complete list of members for AudioUtil.ToneAudioReader< T >, including all inherited members.

Channels (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Dispose() (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Error (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Gen(T[] buf, long timeSamples) (defined in AudioUtil.ToneAudioReader< T >) | AudioUtil.ToneAudioReader< T > | protectedvirtual
GeneratorReader(Func< double > clockSec=null, int samplingRate=48000, int channels=1) (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Read(T[] buf) | AudioUtil.GeneratorReader< T > |
SamplingRate (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
ToneAudioReader(Func< double > clockSec=null, double frequency=440, int samplingRate=48000, int channels=1) | AudioUtil.ToneAudioReader< T > |


Photon Voice: AudioUtil.VoiceDetector< T > Class Template Reference

  • AudioUtil
  • VoiceDetector
Public Member Functions | Protected Attributes | Properties | Events | List of all members
AudioUtil.VoiceDetector< T > Class Template Referenceabstract

Simple voice activity detector triggered by signal level. More...

Inherits IProcessor< T >, and AudioUtil.IVoiceDetector.

Public Member Functions

abstract T[] | Process (T[] buf)
Process a frame of data. More...
void | Dispose ()

Protected Attributes

float | norm
float | threshold
int | activityDelay
int | autoSilenceCounter = 0
int | valuesCountPerSec
int | activityDelayValuesCount

Properties

bool | On [get, set]
If true, voice detection enabled. More...
float | Threshold [get, set]
Voice detected as soon as signal level exceeds threshold. More...
bool | Detected [get, protected set]
If true, voice detected. More...
DateTime | DetectedTime [get]
Last time when switched to detected state. More...
int | ActivityDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. More...
- Properties inherited from AudioUtil.IVoiceDetector
bool | On [get, set]
If true, voice detection enabled. More...
float | Threshold [get, set]
Voice detected as soon as signal level exceeds threshold. More...
bool | Detected [get]
If true, voice detected. More...
DateTime | DetectedTime [get]
Last time when switched to detected state. More...
int | ActivityDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. More...

Events

Action | OnDetected
Called when switched to detected state. More...
- Events inherited from AudioUtil.IVoiceDetector
Action | OnDetected
Called when switched to detected state. More...

Detailed Description

Simple voice activity detector triggered by signal level.

Member Function Documentation

◆ Process()

abstract T [] Process ( T[] buf )
pure virtual

Process a frame of data.

Parameters
buf Buffer containing input data
Returns
Buffer containing output data or null if frame has been discarded (VAD)

Implements IProcessor< T >.

Property Documentation

◆ ActivityDelayMs

int ActivityDelayMs
getset

Keep detected state during this time after signal level dropped below threshold.

◆ Detected

bool Detected
getprotected set

If true, voice detected.

◆ DetectedTime

DateTime DetectedTime
get

Last time when switched to detected state.

◆ On

bool On
getset

If true, voice detection enabled.

◆ Threshold

float Threshold
getset

Voice detected as soon as signal level exceeds threshold.

Event Documentation

◆ OnDetected

Action OnDetected

Called when switched to detected state.


Photon Voice: Member List

  • AudioUtil
  • VoiceDetector
AudioUtil.VoiceDetector< T > Member List

This is the complete list of members for AudioUtil.VoiceDetector< T >, including all inherited members.

activityDelay (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > | protected
ActivityDelayMs | AudioUtil.VoiceDetector< T > |
activityDelayValuesCount (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > | protected
autoSilenceCounter (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > | protected
Detected | AudioUtil.VoiceDetector< T > |
DetectedTime | AudioUtil.VoiceDetector< T > |
Dispose() (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > |
norm (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > | protected
On | AudioUtil.VoiceDetector< T > |
OnDetected | AudioUtil.VoiceDetector< T > |
Process(T[] buf) | AudioUtil.VoiceDetector< T > | pure virtual
Threshold | AudioUtil.VoiceDetector< T > |
threshold (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > | protected
valuesCountPerSec (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > | protected


Photon Voice: AudioUtil.VoiceDetectorCalibration< T > Class Template Reference

  • AudioUtil
  • VoiceDetectorCalibration
Public Member Functions | Protected Attributes | Properties | List of all members
AudioUtil.VoiceDetectorCalibration< T > Class Template Reference

Calibration Utility for Voice Detector More...

Inherits IProcessor< T >.

Public Member Functions

VoiceDetectorCalibration (IVoiceDetector voiceDetector, ILevelMeter levelMeter, int samplingRate, int channels)
Create new VoiceDetectorCalibration instance. More...
void | Calibrate (int durationMs, Action< float > onCalibrated=null)
Start calibration. More...
T[] | Process (T[] buf)
Process a frame of data. More...
void | Dispose ()

Protected Attributes

int calibrateCount

Properties

bool IsCalibrating [get]

Detailed Description

Calibration Utility for Voice Detector

. Using this audio processor, you can calibrate the IVoiceDetector.Threshold.

Constructor & Destructor Documentation

◆ VoiceDetectorCalibration()

VoiceDetectorCalibration | ( | IVoiceDetector | voiceDetector,
 |  | ILevelMeter | levelMeter,
 |  | int | samplingRate,
 |  | int | channels
 | ) |  |

Create new VoiceDetectorCalibration instance.

Parameters
voiceDetector | Voice Detector to calibrate.
levelMeter | Level Meter to look at for calibration.
samplingRate | Sampling rate of the audio signal (in Hz).
channels | Number of channels in the audio signal.

Member Function Documentation

◆ Calibrate()

void Calibrate | ( | int | durationMs,
 |  | Action< float > | onCalibrated = null
 | ) |  |

Start calibration.

Parameters
durationMs | Duration of the calibration procedure (in milliseconds).
onCalibrated | Optional callback that is called after calibration is complete.

This activates the Calibration process. It will reset the given LevelMeter's AccumAvgPeakAmp (accumulated average peak amplitude), and when the duration has passed, use it for the VoiceDetector's detection threshold.

◆ Process()

T [] Process ( T[] buf )

Process a frame of data.

Parameters
buf Buffer containing input data
Returns
Buffer containing output data or null if frame has been discarded (VAD)

Implements IProcessor< T >.


Photon Voice: Member List

  • AudioUtil
  • VoiceDetectorCalibration
AudioUtil.VoiceDetectorCalibration< T > Member List

This is the complete list of members for AudioUtil.VoiceDetectorCalibration< T >, including all inherited members.

Calibrate(int durationMs, Action< float > onCalibrated=null) | AudioUtil.VoiceDetectorCalibration< T > |
calibrateCount (defined in AudioUtil.VoiceDetectorCalibration< T >) | AudioUtil.VoiceDetectorCalibration< T > | protected
Dispose() (defined in AudioUtil.VoiceDetectorCalibration< T >) | AudioUtil.VoiceDetectorCalibration< T > |
IsCalibrating (defined in AudioUtil.VoiceDetectorCalibration< T >) | AudioUtil.VoiceDetectorCalibration< T > |
Process(T[] buf) | AudioUtil.VoiceDetectorCalibration< T > |
VoiceDetectorCalibration(IVoiceDetector voiceDetector, ILevelMeter levelMeter, int samplingRate, int channels) | AudioUtil.VoiceDetectorCalibration< T > |


Photon Voice: AudioUtil.VoiceDetectorDummy Class Reference

  • AudioUtil
  • VoiceDetectorDummy
Properties | List of all members
AudioUtil.VoiceDetectorDummy Class Reference

Dummy VoiceDetector that doesn't actually do anything. More...

Inherits AudioUtil.IVoiceDetector.

Properties

bool | On [get, set]
float | Threshold [get, set]
bool | Detected [get]
int | ActivityDelayMs [get, set]
DateTime | DetectedTime [get]
Action | OnDetected
- Properties inherited from AudioUtil.IVoiceDetector
bool | On [get, set]
If true, voice detection enabled. More...
float | Threshold [get, set]
Voice detected as soon as signal level exceeds threshold. More...
bool | Detected [get]
If true, voice detected. More...
DateTime | DetectedTime [get]
Last time when switched to detected state. More...
int | ActivityDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. More...

Additional Inherited Members

- Events inherited from AudioUtil.IVoiceDetector
Action OnDetected
Called when switched to detected state. More...

Detailed Description

Dummy VoiceDetector that doesn't actually do anything.


Photon Voice: Member List

  • AudioUtil
  • VoiceDetectorDummy
AudioUtil.VoiceDetectorDummy Member List

This is the complete list of members for AudioUtil.VoiceDetectorDummy, including all inherited members.

ActivityDelayMs (defined in AudioUtil.VoiceDetectorDummy) | AudioUtil.VoiceDetectorDummy
Detected (defined in AudioUtil.VoiceDetectorDummy) | AudioUtil.VoiceDetectorDummy
DetectedTime (defined in AudioUtil.VoiceDetectorDummy) | AudioUtil.VoiceDetectorDummy
On (defined in AudioUtil.VoiceDetectorDummy) | AudioUtil.VoiceDetectorDummy
OnDetected (defined in AudioUtil.VoiceDetectorDummy) | AudioUtil.VoiceDetectorDummy
Threshold (defined in AudioUtil.VoiceDetectorDummy) | AudioUtil.VoiceDetectorDummy


Photon Voice: AudioUtil.VoiceDetectorFloat Class Reference

  • AudioUtil
  • VoiceDetectorFloat
Public Member Functions | List of all members
AudioUtil.VoiceDetectorFloat Class Reference

VoiceDetector specialization for float audio. More...

Inherits AudioUtil.VoiceDetector< float >.

Public Member Functions

VoiceDetectorFloat (int samplingRate, int numChannels)
Create a new VoiceDetectorFloat instance. More...
override float[] | Process (float[] buffer)
- Public Member Functions inherited from AudioUtil.VoiceDetector< float >
abstract T[] | Process (T[] buf)
Process a frame of data. More...
void | Dispose ()

Additional Inherited Members

- Protected Attributes inherited from AudioUtil.VoiceDetector< float >
float | norm
float | threshold
int | activityDelay
int | autoSilenceCounter
int | valuesCountPerSec
int | activityDelayValuesCount
- Properties inherited from AudioUtil.VoiceDetector< float >
bool | On [get, set]
If true, voice detection enabled. More...
float | Threshold [get, set]
Voice detected as soon as signal level exceeds threshold. More...
bool | Detected [get, protected set]
If true, voice detected. More...
DateTime | DetectedTime [get]
Last time when switched to detected state. More...
int | ActivityDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. More...
- Events inherited from AudioUtil.VoiceDetector< float >
Action | OnDetected
Called when switched to detected state. More...

Detailed Description

VoiceDetector specialization for float audio.

Constructor & Destructor Documentation

◆ VoiceDetectorFloat()

VoiceDetectorFloat | ( | int | samplingRate,
 |  | int | numChannels
 | ) |  |

Create a new VoiceDetectorFloat instance.

Parameters
samplingRate | Sampling rate of the audio signal (in Hz).
numChannels | Number of channels in the audio signal.


Photon Voice: Member List

  • AudioUtil
  • VoiceDetectorFloat
AudioUtil.VoiceDetectorFloat Member List

This is the complete list of members for AudioUtil.VoiceDetectorFloat, including all inherited members.

activityDelay (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > | protected
ActivityDelayMs | AudioUtil.VoiceDetector< float > |
activityDelayValuesCount (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > | protected
autoSilenceCounter (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > | protected
Detected | AudioUtil.VoiceDetector< float > |
DetectedTime | AudioUtil.VoiceDetector< float > |
Dispose() (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > |
norm (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > | protected
On | AudioUtil.VoiceDetector< float > |
OnDetected | AudioUtil.VoiceDetector< float > |
Process(float[] buffer) (defined in AudioUtil.VoiceDetectorFloat) | AudioUtil.VoiceDetectorFloat |
VoiceDetector< float >.Process(T[] buf) | AudioUtil.VoiceDetector< float > | pure virtual
threshold (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > | protected
Threshold | AudioUtil.VoiceDetector< float > |
valuesCountPerSec (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > | protected
VoiceDetectorFloat(int samplingRate, int numChannels) | AudioUtil.VoiceDetectorFloat |


Photon Voice: AudioUtil.VoiceDetectorShort Class Reference

  • AudioUtil
  • VoiceDetectorShort
Public Member Functions | List of all members
AudioUtil.VoiceDetectorShort Class Reference

VoiceDetector specialization for float audio. More...

Inherits AudioUtil.VoiceDetector< short >.

Public Member Functions

VoiceDetectorShort (int samplingRate, int numChannels)
Create a new VoiceDetectorFloat instance More...
override short[] | Process (short[] buffer)
- Public Member Functions inherited from AudioUtil.VoiceDetector< short >
abstract T[] | Process (T[] buf)
Process a frame of data. More...
void | Dispose ()

Additional Inherited Members

- Protected Attributes inherited from AudioUtil.VoiceDetector< short >
float | norm
float | threshold
int | activityDelay
int | autoSilenceCounter
int | valuesCountPerSec
int | activityDelayValuesCount
- Properties inherited from AudioUtil.VoiceDetector< short >
bool | On [get, set]
If true, voice detection enabled. More...
float | Threshold [get, set]
Voice detected as soon as signal level exceeds threshold. More...
bool | Detected [get, protected set]
If true, voice detected. More...
DateTime | DetectedTime [get]
Last time when switched to detected state. More...
int | ActivityDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. More...
- Events inherited from AudioUtil.VoiceDetector< short >
Action | OnDetected
Called when switched to detected state. More...

Detailed Description

VoiceDetector specialization for float audio.

Constructor & Destructor Documentation

◆ VoiceDetectorShort()

VoiceDetectorShort | ( | int | samplingRate,
 |  | int | numChannels
 | ) |  |

Create a new VoiceDetectorFloat instance

Parameters
samplingRate | Sampling rate of the audio signal (in Hz).
numChannels | Number of channels in the audio signal.


Photon Voice: Member List

  • AudioUtil
  • VoiceDetectorShort
AudioUtil.VoiceDetectorShort Member List

This is the complete list of members for AudioUtil.VoiceDetectorShort, including all inherited members.

activityDelay (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > | protected
ActivityDelayMs | AudioUtil.VoiceDetector< short > |
activityDelayValuesCount (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > | protected
autoSilenceCounter (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > | protected
Detected | AudioUtil.VoiceDetector< short > |
DetectedTime | AudioUtil.VoiceDetector< short > |
Dispose() (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > |
norm (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > | protected
On | AudioUtil.VoiceDetector< short > |
OnDetected | AudioUtil.VoiceDetector< short > |
Process(short[] buffer) (defined in AudioUtil.VoiceDetectorShort) | AudioUtil.VoiceDetectorShort |
VoiceDetector< short >.Process(T[] buf) | AudioUtil.VoiceDetector< short > | pure virtual
threshold (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > | protected
Threshold | AudioUtil.VoiceDetector< short > |
valuesCountPerSec (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > | protected
VoiceDetectorShort(int samplingRate, int numChannels) | AudioUtil.VoiceDetectorShort |


Photon Voice: AudioUtil.VoiceLevelDetectCalibrate< T > Class Template Reference

  • AudioUtil
  • VoiceLevelDetectCalibrate
Public Member Functions | Properties | List of all members
AudioUtil.VoiceLevelDetectCalibrate< T > Class Template Reference

Utility Audio Processor Voice Detection Calibration. More...

Inherits IProcessor< T >.

Public Member Functions

VoiceLevelDetectCalibrate (int samplingRate, int channels)
Create new VoiceLevelDetectCalibrate instance More...
void | Calibrate (int durationMs, Action< float > onCalibrated=null)
Start calibration More...
T[] | Process (T[] buf)
Process a frame of data. More...
void | Dispose ()

Properties

ILevelMeter | LevelMeter [get]
The LevelMeter in use. More...
IVoiceDetector | VoiceDetector [get]
The VoiceDetector in use More...
bool | IsCalibrating [get]

Detailed Description

Utility Audio Processor Voice Detection Calibration.

Encapsulates level meter, voice detector and voice detector calibrator in single instance.

Constructor & Destructor Documentation

◆ VoiceLevelDetectCalibrate()

VoiceLevelDetectCalibrate | ( | int | samplingRate,
 |  | int | channels
 | ) |  |

Create new VoiceLevelDetectCalibrate instance

Parameters
samplingRate | Sampling rate of the audio signal (in Hz).
channels | Number of channels in the audio signal.

Member Function Documentation

◆ Calibrate()

void Calibrate | ( | int | durationMs,
 |  | Action< float > | onCalibrated = null
 | ) |  |

Start calibration

Parameters
durationMs | Duration of the calibration procedure (in milliseconds).
onCalibrated | Called when calibration is complete. Parameter is new threshold value.

This activates the Calibration process. It will reset the given LevelMeter's AccumAvgPeakAmp (accumulated average peak amplitude), and when the duration has passed, use it for the VoiceDetector's detection threshold.

◆ Process()

T [] Process ( T[] buf )

Process a frame of data.

Parameters
buf Buffer containing input data
Returns
Buffer containing output data or null if frame has been discarded (VAD)

Implements IProcessor< T >.

Property Documentation

◆ LevelMeter

ILevelMeter LevelMeter
get

The LevelMeter in use.

◆ VoiceDetector

IVoiceDetector VoiceDetector
get

The VoiceDetector in use


Photon Voice: Member List

  • AudioUtil
  • VoiceLevelDetectCalibrate
AudioUtil.VoiceLevelDetectCalibrate< T > Member List

This is the complete list of members for AudioUtil.VoiceLevelDetectCalibrate< T >, including all inherited members.

Calibrate(int durationMs, Action< float > onCalibrated=null) | AudioUtil.VoiceLevelDetectCalibrate< T >
Dispose() (defined in AudioUtil.VoiceLevelDetectCalibrate< T >) | AudioUtil.VoiceLevelDetectCalibrate< T >
IsCalibrating (defined in AudioUtil.VoiceLevelDetectCalibrate< T >) | AudioUtil.VoiceLevelDetectCalibrate< T >
LevelMeter | AudioUtil.VoiceLevelDetectCalibrate< T >
Process(T[] buf) | AudioUtil.VoiceLevelDetectCalibrate< T >
VoiceDetector | AudioUtil.VoiceLevelDetectCalibrate< T >
VoiceLevelDetectCalibrate(int samplingRate, int channels) | AudioUtil.VoiceLevelDetectCalibrate< T >


Photon Voice: AudioUtil.WaveformAudioPusher< T > Class Template Reference

  • AudioUtil
  • WaveformAudioPusher
Public Member Functions | Protected Member Functions | Properties | List of all members
AudioUtil.WaveformAudioPusher< T > Class Template Reference

IAudioPusher that provides the given waveform. More...

Inherits AudioUtil.GeneratorPusher< T >.

Public Member Functions

WaveformAudioPusher (int bufSizeMs=100, int samplingRate=48000, int channels=1)
- Public Member Functions inherited from AudioUtil.GeneratorPusher< T >
GeneratorPusher (int bufSizeMs=100, int samplingRate=48000, int channels=1)
void | SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data More...
void | Dispose ()

Protected Member Functions

override int Gen (T[] buf, long timeSamples)

Properties

T[] | Waveform [set]
- Properties inherited from AudioUtil.GeneratorPusher< T >
int | Channels [get]
int | SamplingRate [get]
string | Error [get]
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Additional Inherited Members

- Protected Attributes inherited from AudioUtil.GeneratorPusher< T >
long timeSamples

Detailed Description

IAudioPusher that provides the given waveform.


Photon Voice: Member List

  • AudioUtil
  • WaveformAudioPusher
AudioUtil.WaveformAudioPusher< T > Member List

This is the complete list of members for AudioUtil.WaveformAudioPusher< T >, including all inherited members.

Channels (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
Dispose() (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
Error (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
Gen(T[] buf, long timeSamples) (defined in AudioUtil.WaveformAudioPusher< T >) | AudioUtil.WaveformAudioPusher< T > | protectedvirtual
GeneratorPusher(int bufSizeMs=100, int samplingRate=48000, int channels=1) (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
SamplingRate (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > |
SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | AudioUtil.GeneratorPusher< T > |
timeSamples (defined in AudioUtil.GeneratorPusher< T >) | AudioUtil.GeneratorPusher< T > | protected
Waveform (defined in AudioUtil.WaveformAudioPusher< T >) | AudioUtil.WaveformAudioPusher< T > |
WaveformAudioPusher(int bufSizeMs=100, int samplingRate=48000, int channels=1) (defined in AudioUtil.WaveformAudioPusher< T >) | AudioUtil.WaveformAudioPusher< T > |


Photon Voice: AudioUtil.WaveformAudioReader< T > Class Template Reference

  • AudioUtil
  • WaveformAudioReader
Public Member Functions | Protected Member Functions | Properties | List of all members
AudioUtil.WaveformAudioReader< T > Class Template Reference

IAudioReader that provides the given waveform. More...

Inherits AudioUtil.GeneratorReader< T >.

Public Member Functions

WaveformAudioReader (Func< double > clockSec=null, int samplingRate=48000, int channels=1)
- Public Member Functions inherited from AudioUtil.GeneratorReader< T >
GeneratorReader (Func< double > clockSec=null, int samplingRate=48000, int channels=1)
void | Dispose ()
bool | Read (T[] buf)
Fill full given frame buffer with source uncompressed data or return false if not enough such data. More...

Protected Member Functions

override int Gen (T[] buf, long timeSamples)

Properties

T[] | Waveform [set]
- Properties inherited from AudioUtil.GeneratorReader< T >
int | Channels [get]
int | SamplingRate [get]
string | Error [get]
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Detailed Description

IAudioReader that provides the given waveform.


Photon Voice: Member List

  • AudioUtil
  • WaveformAudioReader
AudioUtil.WaveformAudioReader< T > Member List

This is the complete list of members for AudioUtil.WaveformAudioReader< T >, including all inherited members.

Channels (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Dispose() (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Error (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Gen(T[] buf, long timeSamples) (defined in AudioUtil.WaveformAudioReader< T >) | AudioUtil.WaveformAudioReader< T > | protectedvirtual
GeneratorReader(Func< double > clockSec=null, int samplingRate=48000, int channels=1) (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Read(T[] buf) | AudioUtil.GeneratorReader< T > |
SamplingRate (defined in AudioUtil.GeneratorReader< T >) | AudioUtil.GeneratorReader< T > |
Waveform (defined in AudioUtil.WaveformAudioReader< T >) | AudioUtil.WaveformAudioReader< T > |
WaveformAudioReader(Func< double > clockSec=null, int samplingRate=48000, int channels=1) (defined in AudioUtil.WaveformAudioReader< T >) | AudioUtil.WaveformAudioReader< T > |


Photon Voice: BufferReaderPushAdapterAsyncPool< T > Class Template Reference

  • BufferReaderPushAdapterAsyncPool
Public Member Functions | List of all members
BufferReaderPushAdapterAsyncPool< T > Class Template Reference

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync. More...

Inherits BufferReaderPushAdapterBase< T >.

Public Member Functions

BufferReaderPushAdapterAsyncPool (IDataReader< T > reader)
Create a new BufferReaderPushAdapter instance More...
override void | Service (LocalVoice localVoice)
Do the actual data read/push. More...
- Public Member Functions inherited from BufferReaderPushAdapterBase< T >
BufferReaderPushAdapterBase (IDataReader< T > reader)
Create a new BufferReaderPushAdapterBase instance More...
void | Dispose ()
Release resources associated with this instance. More...

Additional Inherited Members

- Protected Attributes inherited from BufferReaderPushAdapterBase< T >
IDataReader< T > reader

Detailed Description

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync.

Acquires a buffer from pool before each Read, releases buffer after last Read (brings Acquire/Release overhead). Expects localVoice to be a LocalVoiceFramed<T> of same T.

Constructor & Destructor Documentation

◆ BufferReaderPushAdapterAsyncPool()

BufferReaderPushAdapterAsyncPool ( IDataReader< T > reader )

Create a new BufferReaderPushAdapter instance

Parameters
reader DataReader to read from.

Member Function Documentation

◆ Service()

override void Service ( LocalVoice localVoice )
virtual

Do the actual data read/push.

Parameters
localVoice LocalVoice instance to push data to. Must be a LocalVoiceFramed<T> of same T.

Implements BufferReaderPushAdapterBase< T >.


Photon Voice: Member List

  • BufferReaderPushAdapterAsyncPool
BufferReaderPushAdapterAsyncPool< T > Member List

This is the complete list of members for BufferReaderPushAdapterAsyncPool< T >, including all inherited members.

BufferReaderPushAdapterAsyncPool(IDataReader< T > reader) | BufferReaderPushAdapterAsyncPool< T > |
BufferReaderPushAdapterBase(IDataReader< T > reader) | BufferReaderPushAdapterBase< T > |
Dispose() | BufferReaderPushAdapterBase< T > |
reader (defined in BufferReaderPushAdapterBase< T >) | BufferReaderPushAdapterBase< T > | protected
Service(LocalVoice localVoice) | BufferReaderPushAdapterAsyncPool< T > | virtual


Photon Voice: BufferReaderPushAdapterAsyncPoolFloatToShort Class Reference

  • BufferReaderPushAdapterAsyncPoolFloatToShort
Public Member Functions | List of all members
BufferReaderPushAdapterAsyncPoolFloatToShort Class Reference

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting float samples to short. More...

Inherits BufferReaderPushAdapterBase< float >.

Public Member Functions

BufferReaderPushAdapterAsyncPoolFloatToShort (IDataReader< float > reader)
Create a new BufferReaderPushAdapter instance More...
override void | Service (LocalVoice localVoice)
Do the actual data read/push. More...
- Public Member Functions inherited from BufferReaderPushAdapterBase< float >
BufferReaderPushAdapterBase (IDataReader< T > reader)
Create a new BufferReaderPushAdapterBase instance More...
void | Dispose ()
Release resources associated with this instance. More...

Additional Inherited Members

- Protected Attributes inherited from BufferReaderPushAdapterBase< float >
IDataReader< T > reader

Detailed Description

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting float samples to short.

This adapter works exactly like BufferReaderPushAdapterAsyncPool<T>, but it converts float samples to short. Acquires a buffer from pool before each Read, releases buffer after last Read.

Expects localVoice to be a LocalVoiceFramed<T> of same T.

Constructor & Destructor Documentation

◆ BufferReaderPushAdapterAsyncPoolFloatToShort()

BufferReaderPushAdapterAsyncPoolFloatToShort ( IDataReader< float > reader )

Create a new BufferReaderPushAdapter instance

Parameters
reader DataReader to read from.

Member Function Documentation

◆ Service()

override void Service ( LocalVoice localVoice )
virtual

Do the actual data read/push.

Parameters
localVoice LocalVoice instance to push data to. Must be a LocalVoiceFramed<T> of same T.

Implements BufferReaderPushAdapterBase< float >.


Photon Voice: Member List

  • BufferReaderPushAdapterAsyncPoolFloatToShort
BufferReaderPushAdapterAsyncPoolFloatToShort Member List

This is the complete list of members for BufferReaderPushAdapterAsyncPoolFloatToShort, including all inherited members.

BufferReaderPushAdapterAsyncPoolFloatToShort(IDataReader< float > reader) | BufferReaderPushAdapterAsyncPoolFloatToShort |
BufferReaderPushAdapterBase(IDataReader< T > reader) | BufferReaderPushAdapterBase< float > |
Dispose() | BufferReaderPushAdapterBase< float > |
reader (defined in BufferReaderPushAdapterBase< float >) | BufferReaderPushAdapterBase< float > | protected
Service(LocalVoice localVoice) | BufferReaderPushAdapterAsyncPoolFloatToShort | virtual


Photon Voice: BufferReaderPushAdapterAsyncPoolShortToFloat Class Reference

  • BufferReaderPushAdapterAsyncPoolShortToFloat
Public Member Functions | List of all members
BufferReaderPushAdapterAsyncPoolShortToFloat Class Reference

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting short samples to float. More...

Inherits BufferReaderPushAdapterBase< short >.

Public Member Functions

BufferReaderPushAdapterAsyncPoolShortToFloat (IDataReader< short > reader)
Create a new BufferReaderPushAdapter instance More...
override void | Service (LocalVoice localVoice)
Do the actual data read/push. More...
- Public Member Functions inherited from BufferReaderPushAdapterBase< short >
BufferReaderPushAdapterBase (IDataReader< T > reader)
Create a new BufferReaderPushAdapterBase instance More...
void | Dispose ()
Release resources associated with this instance. More...

Additional Inherited Members

- Protected Attributes inherited from BufferReaderPushAdapterBase< short >
IDataReader< T > reader

Detailed Description

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting short samples to float.

This adapter works exactly like BufferReaderPushAdapterAsyncPool<T>, but it converts short samples to float. Acquires a buffer from pool before each Read, releases buffer after last Read.

Expects localVoice to be a LocalVoiceFramed<T> of same T.

Constructor & Destructor Documentation

◆ BufferReaderPushAdapterAsyncPoolShortToFloat()

BufferReaderPushAdapterAsyncPoolShortToFloat ( IDataReader< short > reader )

Create a new BufferReaderPushAdapter instance

Parameters
reader DataReader to read from.

Member Function Documentation

◆ Service()

override void Service ( LocalVoice localVoice )
virtual

Do the actual data read/push.

Parameters
localVoice LocalVoice instance to push data to. Must be a LocalVoiceFramed<T> of same T.

Implements BufferReaderPushAdapterBase< short >.


Photon Voice: Member List

  • BufferReaderPushAdapterAsyncPoolShortToFloat
BufferReaderPushAdapterAsyncPoolShortToFloat Member List

This is the complete list of members for BufferReaderPushAdapterAsyncPoolShortToFloat, including all inherited members.

BufferReaderPushAdapterAsyncPoolShortToFloat(IDataReader< short > reader) | BufferReaderPushAdapterAsyncPoolShortToFloat |
BufferReaderPushAdapterBase(IDataReader< T > reader) | BufferReaderPushAdapterBase< short > |
Dispose() | BufferReaderPushAdapterBase< short > |
reader (defined in BufferReaderPushAdapterBase< short >) | BufferReaderPushAdapterBase< short > | protected
Service(LocalVoice localVoice) | BufferReaderPushAdapterAsyncPoolShortToFloat | virtual


Photon Voice: BufferReaderPushAdapterBase< T > Class Template Reference

  • BufferReaderPushAdapterBase
Public Member Functions | Protected Attributes | List of all members
BufferReaderPushAdapterBase< T > Class Template Referenceabstract

Adapter base reading data from IDataReader<T>.Read and pushing it to LocalVoice. More...

Inherits IServiceable.

Inherited by BufferReaderPushAdapterAsyncPool< T >.

Public Member Functions

abstract void | Service (LocalVoice localVoice)
Do the actual data read/push. More...
BufferReaderPushAdapterBase (IDataReader< T > reader)
Create a new BufferReaderPushAdapterBase instance More...
void | Dispose ()
Release resources associated with this instance. More...

Protected Attributes

IDataReader< T > reader

Detailed Description

Adapter base reading data from IDataReader<T>.Read and pushing it to LocalVoice.

Use this with a LocalVoice of same T type.

Constructor & Destructor Documentation

◆ BufferReaderPushAdapterBase()

BufferReaderPushAdapterBase ( IDataReader< T > reader )

Create a new BufferReaderPushAdapterBase instance

Parameters
reader DataReader to read from.

Member Function Documentation

◆ Dispose()

void Dispose ( )

Release resources associated with this instance.

◆ Service()

abstract void Service ( LocalVoice localVoice )
pure virtual

Do the actual data read/push.

Parameters
localVoice LocalVoice instance to push data to.

Implements IServiceable.

Implemented in BufferReaderPushAdapterAsyncPoolShortToFloat, BufferReaderPushAdapterAsyncPoolFloatToShort, and BufferReaderPushAdapterAsyncPool< T >.


Photon Voice: Member List

  • BufferReaderPushAdapterBase
BufferReaderPushAdapterBase< T > Member List

This is the complete list of members for BufferReaderPushAdapterBase< T >, including all inherited members.

BufferReaderPushAdapterBase(IDataReader< T > reader) | BufferReaderPushAdapterBase< T > |
Dispose() | BufferReaderPushAdapterBase< T > |
reader (defined in BufferReaderPushAdapterBase< T >) | BufferReaderPushAdapterBase< T > | protected
Service(LocalVoice localVoice) | BufferReaderPushAdapterBase< T > | pure virtual


Photon Voice: DecoderConfigFrame Class Reference

  • DecoderConfigFrame
Public Member Functions | List of all members
DecoderConfigFrame Class Reference

Stores the config frame and prevents other frames decoding until the decoder is ready. More...

Inherits IDisposable.

Public Member Functions

DecoderConfigFrame (ILogger logger, IDecoder decoder)
bool | TryConfigure (ref FrameBuffer buf, bool decoderReady)
Call it in Input(). More...
void | Dispose ()

Detailed Description

Stores the config frame and prevents other frames decoding until the decoder is ready.

Member Function Documentation

◆ TryConfigure()

bool TryConfigure | ( | ref FrameBuffer | buf,
 |  | bool | decoderReady
 | ) |  |

Call it in Input().

Parameters
buf | Data frame.
decoderReady | True if the decoder is ready.
Returns
True if decoder is allowed to decode the current frame.


Photon Voice: Member List

  • DecoderConfigFrame
DecoderConfigFrame Member List

This is the complete list of members for DecoderConfigFrame, including all inherited members.

DecoderConfigFrame(ILogger logger, IDecoder decoder) (defined in DecoderConfigFrame) | DecoderConfigFrame
Dispose() (defined in DecoderConfigFrame) | DecoderConfigFrame
TryConfigure(ref FrameBuffer buf, bool decoderReady) | DecoderConfigFrame


Photon Voice: DeviceEnumeratorBase Class Reference

  • DeviceEnumeratorBase
Public Member Functions | Public Attributes | Protected Attributes | Properties | List of all members
DeviceEnumeratorBase Class Referenceabstract

Inherits IDeviceEnumerator.

Inherited by DeviceEnumeratorNotSupported, DeviceEnumeratorSingleDevice, AudioInEnumerator, AudioInEnumerator, AudioInEnumerator, VideoInEnumerator, DeviceEnumerator, and AudioInEnumerator.

Public Member Functions

DeviceEnumeratorBase (ILogger logger)
IEnumerator< DeviceInfo > | GetEnumerator ()
abstract void | Refresh ()
abstract void | Dispose ()

Public Attributes

virtual bool IsSupported => true

Protected Attributes

List< DeviceInfo > | devices = new List<DeviceInfo>()
ILogger | logger

Properties

virtual string | Error [get, protected set]
Action | OnReady [protected get, set]
- Properties inherited from IDeviceEnumerator
bool | IsSupported [get]
Action | OnReady [set]
string | Error [get]


Photon Voice: Member List

  • DeviceEnumeratorBase
DeviceEnumeratorBase Member List

This is the complete list of members for DeviceEnumeratorBase, including all inherited members.

DeviceEnumeratorBase(ILogger logger) (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
devices (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Dispose() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | pure virtual
Error (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
GetEnumerator() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
IsSupported (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
logger (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
OnReady (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
Refresh() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | pure virtual


Photon Voice: DeviceFeatures Class Reference

  • DeviceFeatures
Public Member Functions | Properties | List of all members
DeviceFeatures Class Reference

Public Member Functions

DeviceFeatures (CameraFacing facing)

Properties

CameraFacing CameraFacing [get]


Photon Voice: Member List

  • DeviceFeatures
DeviceFeatures Member List

This is the complete list of members for DeviceFeatures, including all inherited members.

CameraFacing (defined in DeviceFeatures) | DeviceFeatures
DeviceFeatures() (defined in DeviceFeatures) | DeviceFeatures
DeviceFeatures(CameraFacing facing) (defined in DeviceFeatures) | DeviceFeatures


Photon Voice: DeviceInfo Struct Reference

  • DeviceInfo
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | Properties | List of all members
DeviceInfo Struct Reference

Public Member Functions

DeviceInfo (int id, string name, DeviceFeatures features=null)
DeviceInfo (string id, string name, DeviceFeatures features=null)
DeviceInfo (string name, DeviceFeatures features=null)
override bool | Equals (object obj)
override int | GetHashCode ()
override string | ToString ()

Static Public Member Functions

static bool | operator== (DeviceInfo d1, DeviceInfo d2)
static bool | operator!= (DeviceInfo d1, DeviceInfo d2)

Public Attributes

DeviceFeatures | Features => features == null ? DeviceFeatures.Default : features
DeviceFeatures | features

Static Public Attributes

static readonly DeviceInfo Default = new DeviceInfo(true, -128, "", "[Default]")

Properties

bool | IsDefault [get]
int | IDInt [get]
string | IDString [get]
string | Name [get]


Photon Voice: Member List

  • DeviceInfo
DeviceInfo Member List

This is the complete list of members for DeviceInfo, including all inherited members.

Default (defined in DeviceInfo) | DeviceInfo | static
DeviceInfo(int id, string name, DeviceFeatures features=null) (defined in DeviceInfo) | DeviceInfo |
DeviceInfo(string id, string name, DeviceFeatures features=null) (defined in DeviceInfo) | DeviceInfo |
DeviceInfo(string name, DeviceFeatures features=null) (defined in DeviceInfo) | DeviceInfo |
Equals(object obj) (defined in DeviceInfo) | DeviceInfo |
Features (defined in DeviceInfo) | DeviceInfo |
features (defined in DeviceInfo) | DeviceInfo |
GetHashCode() (defined in DeviceInfo) | DeviceInfo |
IDInt (defined in DeviceInfo) | DeviceInfo |
IDString (defined in DeviceInfo) | DeviceInfo |
IsDefault (defined in DeviceInfo) | DeviceInfo |
Name (defined in DeviceInfo) | DeviceInfo |
operator!=(DeviceInfo d1, DeviceInfo d2) (defined in DeviceInfo) | DeviceInfo | static
operator==(DeviceInfo d1, DeviceInfo d2) (defined in DeviceInfo) | DeviceInfo | static
ToString() (defined in DeviceInfo) | DeviceInfo |


Photon Voice: FactoryPrimitiveArrayPool< T > Class Template Reference

  • FactoryPrimitiveArrayPool
Public Member Functions | Properties | List of all members
FactoryPrimitiveArrayPool< T > Class Template Reference

PrimitiveArrayPool<T> as wrapped in object factory interface. More...

Inherits ObjectFactory< T[], int >.

Public Member Functions

FactoryPrimitiveArrayPool (int capacity, string name)
FactoryPrimitiveArrayPool (int capacity, string name, int info)
T[] | New ()
T[] | New (int size)
void | Free (T[] obj)
void | Free (T[] obj, int info)
void | Dispose ()
- Public Member Functions inherited from ObjectFactory< T[], int >
TType | New ()
TType | New (TInfo info)
void | Free (TType obj)
void | Free (TType obj, TInfo info)

Properties

int | Info [get]
- Properties inherited from ObjectFactory< T[], int >
TInfo | Info [get]

Detailed Description

PrimitiveArrayPool<T> as wrapped in object factory interface.

Template Parameters
T Array element type.


Photon Voice: Member List

  • FactoryPrimitiveArrayPool
FactoryPrimitiveArrayPool< T > Member List

This is the complete list of members for FactoryPrimitiveArrayPool< T >, including all inherited members.

Dispose() (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
FactoryPrimitiveArrayPool(int capacity, string name) (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
FactoryPrimitiveArrayPool(int capacity, string name, int info) (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
Free(T[] obj) (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
Free(T[] obj, int info) (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
Free(TType obj) (defined in ObjectFactory< T[], int >) | ObjectFactory< T[], int >
Free(TType obj, TInfo info) (defined in ObjectFactory< T[], int >) | ObjectFactory< T[], int >
Info (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
New() (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
New(int size) (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
New(TInfo info) (defined in ObjectFactory< T[], int >) | ObjectFactory< T[], int >


Photon Voice: FactoryReusableArray< T > Class Template Reference

  • FactoryReusableArray
Public Member Functions | Properties | List of all members
FactoryReusableArray< T > Class Template Reference

Array factory returnig the same array instance as long as it requested with the same array length. If length changes, new array instance created. More...

Inherits ObjectFactory< T[], int >.

Public Member Functions

FactoryReusableArray (int size)
T[] | New ()
T[] | New (int size)
void | Free (T[] obj)
void | Free (T[] obj, int info)
void | Dispose ()
- Public Member Functions inherited from ObjectFactory< T[], int >
TType | New ()
TType | New (TInfo info)
void | Free (TType obj)
void | Free (TType obj, TInfo info)

Properties

int | Info [get]
- Properties inherited from ObjectFactory< T[], int >
TInfo | Info [get]

Detailed Description

Array factory returnig the same array instance as long as it requested with the same array length. If length changes, new array instance created.

Template Parameters
T Array element type.


Photon Voice: Member List

  • FactoryReusableArray
FactoryReusableArray< T > Member List

This is the complete list of members for FactoryReusableArray< T >, including all inherited members.

Dispose() (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
FactoryReusableArray(int size) (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
Free(T[] obj) (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
Free(T[] obj, int info) (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
Free(TType obj) (defined in ObjectFactory< T[], int >) | ObjectFactory< T[], int >
Free(TType obj, TInfo info) (defined in ObjectFactory< T[], int >) | ObjectFactory< T[], int >
Info (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
New() (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
New(int size) (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
New(TInfo info) (defined in ObjectFactory< T[], int >) | ObjectFactory< T[], int >


Photon Voice: Flip Struct Reference

  • Flip
Public Member Functions | Static Public Member Functions | Static Public Attributes | Properties | List of all members
Flip Struct Reference

Public Member Functions

override bool | Equals (object obj)
override int | GetHashCode ()

Static Public Member Functions

static bool | operator== (Flip f1, Flip f2)
static bool | operator!= (Flip f1, Flip f2)
static Flip | operator* (Flip f1, Flip f2)

Static Public Attributes

static Flip | None
static Flip | Vertical = new Flip() { IsVertical = true }
static Flip | Horizontal = new Flip() { IsHorizontal = true }
static Flip | Both = Vertical * Horizontal

Properties

bool | IsVertical [get]
bool | IsHorizontal [get]


Photon Voice: Member List

  • Flip
Flip Member List

This is the complete list of members for Flip, including all inherited members.

Both (defined in Flip) | Flip | static
Equals(object obj) (defined in Flip) | Flip |
GetHashCode() (defined in Flip) | Flip |
Horizontal (defined in Flip) | Flip | static
IsHorizontal (defined in Flip) | Flip |
IsVertical (defined in Flip) | Flip |
None (defined in Flip) | Flip | static
operator!=(Flip f1, Flip f2) (defined in Flip) | Flip | static
operator*(Flip f1, Flip f2) (defined in Flip) | Flip | static
operator==(Flip f1, Flip f2) (defined in Flip) | Flip | static
Vertical (defined in Flip) | Flip | static


Photon Voice: FrameBuffer Struct Reference

  • FrameBuffer
Public Member Functions | Public Attributes | Properties | List of all members
FrameBuffer Struct Reference

Public Member Functions

FrameBuffer (byte[] array, int offset, int count, FrameFlags flags, byte frameNum, IDisposable disposer)
FrameBuffer (byte[] array, FrameFlags flags, byte frameNum)
FrameBuffer (FrameBuffer from, int offset, int count, FrameFlags flags, byte frameNum)
void | Retain ()
void | Release ()
override string | ToString ()

Public Attributes

readonly byte[] | array
readonly int | offset
readonly int | count
readonly IDisposable | disposer
bool | disposed
int | refCnt
GCHandle | gcHandle
IntPtr | ptr
bool | pinned
bool | IsFEC => (Flags & FrameFlags.FEC) != 0
bool | IsConfig => (Flags & FrameFlags.Config) != 0
bool | IsKeyframe => (Flags & FrameFlags.KeyFrame) != 0

Properties

IntPtr | Ptr [get]
byte[] | Array [get]
int | Length [get]
int | Offset [get]
FrameFlags | Flags [get]
byte | FrameNum [get]


Photon Voice: Member List

  • FrameBuffer
FrameBuffer Member List

This is the complete list of members for FrameBuffer, including all inherited members.

array (defined in FrameBuffer) | FrameBuffer
Array (defined in FrameBuffer) | FrameBuffer
count (defined in FrameBuffer) | FrameBuffer
disposed (defined in FrameBuffer) | FrameBuffer
disposer (defined in FrameBuffer) | FrameBuffer
Flags (defined in FrameBuffer) | FrameBuffer
FrameBuffer(byte[] array, int offset, int count, FrameFlags flags, byte frameNum, IDisposable disposer) (defined in FrameBuffer) | FrameBuffer
FrameBuffer(byte[] array, FrameFlags flags, byte frameNum) (defined in FrameBuffer) | FrameBuffer
FrameBuffer(FrameBuffer from, int offset, int count, FrameFlags flags, byte frameNum) (defined in FrameBuffer) | FrameBuffer
FrameNum (defined in FrameBuffer) | FrameBuffer
gcHandle (defined in FrameBuffer) | FrameBuffer
IsConfig (defined in FrameBuffer) | FrameBuffer
IsFEC (defined in FrameBuffer) | FrameBuffer
IsKeyframe (defined in FrameBuffer) | FrameBuffer
Length (defined in FrameBuffer) | FrameBuffer
offset (defined in FrameBuffer) | FrameBuffer
Offset (defined in FrameBuffer) | FrameBuffer
pinned (defined in FrameBuffer) | FrameBuffer
ptr (defined in FrameBuffer) | FrameBuffer
Ptr (defined in FrameBuffer) | FrameBuffer
refCnt (defined in FrameBuffer) | FrameBuffer
Release() (defined in FrameBuffer) | FrameBuffer
Retain() (defined in FrameBuffer) | FrameBuffer
ToString() (defined in FrameBuffer) | FrameBuffer


Photon Voice: FrameOut< T > Class Template Reference

  • FrameOut
Public Member Functions | Properties | List of all members
FrameOut< T > Class Template Reference

Public Member Functions

FrameOut (T[] buf, bool endOfStream)
FrameOut< T > Set (T[] buf, bool endOfStream)

Properties

T[] | Buf [get]
bool | EndOfStream [get]


Photon Voice: Member List

  • FrameOut
FrameOut< T > Member List

This is the complete list of members for FrameOut< T >, including all inherited members.

Buf (defined in FrameOut< T >) | FrameOut< T >
EndOfStream (defined in FrameOut< T >) | FrameOut< T >
FrameOut(T[] buf, bool endOfStream) (defined in FrameOut< T >) | FrameOut< T >
Set(T[] buf, bool endOfStream) (defined in FrameOut< T >) | FrameOut< T >


Photon Voice: Framer< T > Class Template Reference

  • Framer
Public Member Functions | Protected Attributes | List of all members
Framer< T > Class Template Reference

Utility class to re-frame packets. More...

Inherited by FramerResampler< T >.

Public Member Functions

Framer (int frameSize)
Create new Framer instance. More...
virtual IEnumerable< T[]> Frame (T[] buf)
Append arbitrary-sized buffer and return available full frames. More...

Protected Attributes

T[] | frame
int | sizeofT
int | framePos = 0

Detailed Description

Utility class to re-frame packets.

Constructor & Destructor Documentation

◆ Framer()

Framer ( int frameSize )

Create new Framer instance.

Member Function Documentation

◆ Frame()

virtual IEnumerable<T[]> Frame ( T[] buf )
virtual

Append arbitrary-sized buffer and return available full frames.

Parameters
buf Array of samples to add.
Returns
Enumerator of full frames (might be none).

Reimplemented in FramerResampler< T >.


Photon Voice: Member List

  • Framer
Framer< T > Member List

This is the complete list of members for Framer< T >, including all inherited members.

frame (defined in Framer< T >) | Framer< T > | protected
Frame(T[] buf) | Framer< T > | virtual
framePos (defined in Framer< T >) | Framer< T > | protected
Framer(int frameSize) | Framer< T > |
sizeofT (defined in Framer< T >) | Framer< T > | protected


Photon Voice: FramerResampler< T > Class Template Reference

  • FramerResampler
Public Member Functions | Protected Attributes | List of all members
FramerResampler< T > Class Template Reference

Inherits Framer< T >.

Public Member Functions

FramerResampler (int frameSize, int channels, int resampleNum, int resampleDen, bool interpolate)
override IEnumerable< T[]> Frame (T[] bufT)
Append arbitrary-sized buffer and return available full frames. More...
- Public Member Functions inherited from Framer< T >
Framer (int frameSize)
Create new Framer instance. More...

Protected Attributes

bool | TisFloat
bool | interpolate
int | channels
int | resampleNum
int | resampleDen
float | resampleRatioInv
int | delta
- Protected Attributes inherited from Framer< T >
T[] | frame
int | sizeofT
int | framePos = 0

Member Function Documentation

◆ Frame()

override IEnumerable<T[]> Frame ( T[] buf )
virtual

Append arbitrary-sized buffer and return available full frames.

Parameters
buf Array of samples to add.
Returns
Enumerator of full frames (might be none).

Reimplemented from Framer< T >.


Photon Voice: Member List

  • FramerResampler
FramerResampler< T > Member List

This is the complete list of members for FramerResampler< T >, including all inherited members.

channels (defined in FramerResampler< T >) | FramerResampler< T > | protected
delta (defined in FramerResampler< T >) | FramerResampler< T > | protected
frame (defined in Framer< T >) | Framer< T > | protected
Frame(T[] bufT) | FramerResampler< T > | virtual
framePos (defined in Framer< T >) | Framer< T > | protected
Framer(int frameSize) | Framer< T > |
FramerResampler(int frameSize, int channels, int resampleNum, int resampleDen, bool interpolate) (defined in FramerResampler< T >) | FramerResampler< T > |
interpolate (defined in FramerResampler< T >) | FramerResampler< T > | protected
resampleDen (defined in FramerResampler< T >) | FramerResampler< T > | protected
resampleNum (defined in FramerResampler< T >) | FramerResampler< T > | protected
resampleRatioInv (defined in FramerResampler< T >) | FramerResampler< T > | protected
sizeofT (defined in Framer< T >) | Framer< T > | protected
TisFloat (defined in FramerResampler< T >) | FramerResampler< T > | protected


Photon Voice: IAudioDesc Interface Reference

  • IAudioDesc
Properties | List of all members
IAudioDesc Interface Reference

Audio Source interface. More...

Inherits IDisposable.

Inherited by AudioDesc, IAudioPusher< T >, and IAudioReader< T >.

Properties

int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Detailed Description

Audio Source interface.

Property Documentation

◆ Channels

int Channels
get

Number of channels in the audio signal.

◆ Error

string Error
get

If not null, audio object is in invalid state.

◆ SamplingRate

int SamplingRate
get

Sampling rate of the audio signal (in Hz).


Photon Voice: Member List

  • IAudioDesc
IAudioDesc Member List

This is the complete list of members for IAudioDesc, including all inherited members.

Channels | IAudioDesc
Error | IAudioDesc
SamplingRate | IAudioDesc


Photon Voice: IAudioInChangeNotifier Interface Reference

  • IAudioInChangeNotifier
Properties | List of all members
IAudioInChangeNotifier Interface Reference

Inherits IDisposable.

Inherited by AudioInChangeNotifierNotSupported, AudioInChangeNotifier, and AudioInChangeNotifier.

Properties

bool | IsSupported [get]
string | Error [get]


Photon Voice: Member List

  • IAudioInChangeNotifier
IAudioInChangeNotifier Member List

This is the complete list of members for IAudioInChangeNotifier, including all inherited members.

Error (defined in IAudioInChangeNotifier) | IAudioInChangeNotifier
IsSupported (defined in IAudioInChangeNotifier) | IAudioInChangeNotifier


Photon Voice: IAudioOut< T > Interface Template Reference

  • IAudioOut
Public Member Functions | Properties | List of all members
IAudioOut< T > Interface Template Reference

Inherited by AudioOutDelayControl< T >, and AudioOutDummy< T >.

Public Member Functions

void | Start (int frequency, int channels, int frameSamplesPerChannel)
void | Flush ()
void | Stop ()
void | Push (T[] frame)
void | Service ()

Properties

bool | IsPlaying [get]
int | Lag [get]


Photon Voice: Member List

  • IAudioOut
IAudioOut< T > Member List

This is the complete list of members for IAudioOut< T >, including all inherited members.

Flush() (defined in IAudioOut< T >) | IAudioOut< T >
IsPlaying (defined in IAudioOut< T >) | IAudioOut< T >
Lag (defined in IAudioOut< T >) | IAudioOut< T >
Push(T[] frame) (defined in IAudioOut< T >) | IAudioOut< T >
Service() (defined in IAudioOut< T >) | IAudioOut< T >
Start(int frequency, int channels, int frameSamplesPerChannel) (defined in IAudioOut< T >) | IAudioOut< T >
Stop() (defined in IAudioOut< T >) | IAudioOut< T >


Photon Voice: IAudioPusher< T > Interface Template Reference

  • IAudioPusher
Public Member Functions | List of all members
IAudioPusher< T > Interface Template Reference

Audio Pusher interface. More...

Inherits IAudioDesc.

Inherited by AudioUtil.GeneratorPusher< T >.

Public Member Functions

void SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data. More...

Additional Inherited Members

- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Detailed Description

Audio Pusher interface.

Opposed to an IAudioReader (which will deliver audio data when it is "pulled"), an IAudioPusher will push its audio data whenever it is ready,

Member Function Documentation

◆ SetCallback()

void SetCallback | ( | Action< T[]> | callback,
 |  | ObjectFactory< T[], int > | bufferFactory
 | ) |  |

Set the callback function used for pushing data.

Parameters
callback | Callback function to use.
bufferFactory | Buffer factory used to create the buffer that is pushed to the callback

Implemented in AudioUtil.GeneratorPusher< T >.


Photon Voice: Member List

  • IAudioPusher
IAudioPusher< T > Member List

This is the complete list of members for IAudioPusher< T >, including all inherited members.

Channels | IAudioDesc
Error | IAudioDesc
SamplingRate | IAudioDesc
SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | IAudioPusher< T >


Photon Voice: IAudioReader< T > Interface Template Reference

  • IAudioReader
List of all members
IAudioReader< T > Interface Template Reference

Audio Reader interface. More...

Inherits IDataReader< T >, and IAudioDesc.

Inherited by AudioUtil.GeneratorReader< T >, and AudioInReader< T >.

Additional Inherited Members

- Public Member Functions inherited from IDataReader< T >
bool | Read (T[] buffer)
Fill full given frame buffer with source uncompressed data or return false if not enough such data. More...
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Detailed Description

Audio Reader interface.

Opposed to an IAudioPusher (which will push its audio data whenever it is ready), an IAudioReader will deliver audio data when it is "pulled" (it's Read function is called).


Photon Voice: Member List

  • IAudioReader
IAudioReader< T > Member List

This is the complete list of members for IAudioReader< T >, including all inherited members.

Channels | IAudioDesc
Error | IAudioDesc
Read(T[] buffer) | IDataReader< T >
SamplingRate | IAudioDesc


Photon Voice: IDataReader< T > Interface Template Reference

  • IDataReader
Public Member Functions | List of all members
IDataReader< T > Interface Template Reference

Interface for pulling data, in case this is more appropriate than pushing it. More...

Inherits IDisposable.

Inherited by IAudioReader< T >.

Public Member Functions

bool Read (T[] buffer)
Fill full given frame buffer with source uncompressed data or return false if not enough such data. More...

Detailed Description

Interface for pulling data, in case this is more appropriate than pushing it.

Member Function Documentation

◆ Read()

bool Read ( T[] buffer )

Fill full given frame buffer with source uncompressed data or return false if not enough such data.

Parameters
buffer Buffer to fill.
Returns
True if buffer was filled successfully, false otherwise.

Implemented in AudioInReader< T >, and AudioUtil.GeneratorReader< T >.


Photon Voice: Member List

  • IDataReader
IDataReader< T > Member List

This is the complete list of members for IDataReader< T >, including all inherited members.

Read(T[] buffer) IDataReader< T >


Photon Voice: IDecoder Interface Reference

  • IDecoder
Public Member Functions | Properties | List of all members
IDecoder Interface Reference

Generic decoder interface. More...

Inherits IDisposable.

Inherited by IDecoderDirect< B >, OpusCodec.Decoder< T >, and RawCodec.Decoder< T >.

Public Member Functions

void | Open (VoiceInfo info)
Open (initialize) the decoder. More...
void | Input (ref FrameBuffer buf)
Consumes the given encoded data. More...

Properties

string Error [get]
If not null, the object is in invalid state. More...

Detailed Description

Generic decoder interface.

Member Function Documentation

◆ Input()

void Input ( ref FrameBuffer buf )

Consumes the given encoded data.

The callee can call buf.Retain() to prevent the caller from disposing the buffer. In this case, the callee should call buf.Release() when buffer is no longer needed.

Implemented in RawCodec.Decoder< T >, and OpusCodec.Decoder< T >.

◆ Open()

void Open ( VoiceInfo info )

Open (initialize) the decoder.

Parameters
info Properties of the data stream to decode.

Implemented in RawCodec.Decoder< T >, and OpusCodec.Decoder< T >.

Property Documentation

◆ Error

string Error
get

If not null, the object is in invalid state.


Photon Voice: Member List

  • IDecoder
IDecoder Member List

This is the complete list of members for IDecoder, including all inherited members.

Error | IDecoder
Input(ref FrameBuffer buf) | IDecoder
Open(VoiceInfo info) | IDecoder


Photon Voice: IDecoderDirect< B > Interface Template Reference

  • IDecoderDirect
Properties | List of all members
IDecoderDirect< B > Interface Template Reference

Interface for an decoder which outputs data via explicit call. More...

Inherits IDecoder.

Properties

Action< B > | Output [get, set]
Callback to call when a new decoded data buffer is available. More...
- Properties inherited from IDecoder
string | Error [get]
If not null, the object is in invalid state. More...

Additional Inherited Members

- Public Member Functions inherited from IDecoder
void | Open (VoiceInfo info)
Open (initialize) the decoder. More...
void | Input (ref FrameBuffer buf)
Consumes the given encoded data. More...

Detailed Description

Interface for an decoder which outputs data via explicit call.

Property Documentation

◆ Output

Action<B> Output
getset

Callback to call when a new decoded data buffer is available.


Photon Voice: Member List

  • IDecoderDirect
IDecoderDirect< B > Member List

This is the complete list of members for IDecoderDirect< B >, including all inherited members.

Error | IDecoder
Input(ref FrameBuffer buf) | IDecoder
Open(VoiceInfo info) | IDecoder
Output | IDecoderDirect< B >


Photon Voice: IDeviceEnumerator Interface Reference

  • IDeviceEnumerator
Public Member Functions | Properties | List of all members
IDeviceEnumerator Interface Reference

Inherits IDisposable, and IEnumerable< DeviceInfo >.

Inherited by DeviceEnumeratorBase.

Public Member Functions

void Refresh ()

Properties

bool | IsSupported [get]
Action | OnReady [set]
string | Error [get]


Photon Voice: Member List

  • IDeviceEnumerator
IDeviceEnumerator Member List

This is the complete list of members for IDeviceEnumerator, including all inherited members.

Error (defined in IDeviceEnumerator) | IDeviceEnumerator
IsSupported (defined in IDeviceEnumerator) | IDeviceEnumerator
OnReady (defined in IDeviceEnumerator) | IDeviceEnumerator
Refresh() (defined in IDeviceEnumerator) | IDeviceEnumerator


Photon Voice: IEncoder Interface Reference

  • IEncoder
Public Member Functions | Properties | List of all members
IEncoder Interface Reference

Generic encoder interface. More...

Inherits IDisposable.

Inherited by IEncoderDirect< B >.

Public Member Functions

ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
Returns next encoded data frame (if such output supported). More...
void | EndOfStream ()
Forces an encoder to flush and produce frame with EndOfStream flag (in output queue). More...
I | GetPlatformAPI< I > ()
Returns an platform-specific interface. More...

Properties

string | Error [get]
If not null, the object is in invalid state. More...
Action< ArraySegment< byte >, FrameFlags > | Output [set]
Set callback encoder calls on each encoded data frame (if such output supported). More...

Detailed Description

Generic encoder interface.

Depending on implementation, encoder should either call Output on eaach data frame or return next data frame in DequeueOutput() call.

Member Function Documentation

◆ DequeueOutput()

ArraySegment<byte> DequeueOutput ( out FrameFlags flags )

Returns next encoded data frame (if such output supported).

◆ EndOfStream()

void EndOfStream ( )

Forces an encoder to flush and produce frame with EndOfStream flag (in output queue).

◆ GetPlatformAPI< I >()

I GetPlatformAPI< I > ( )

Returns an platform-specific interface.

Type Constraints
I : class

Property Documentation

◆ Error

string Error
get

If not null, the object is in invalid state.

◆ Output

Action<ArraySegment<byte>, FrameFlags> Output
set

Set callback encoder calls on each encoded data frame (if such output supported).


Photon Voice: Member List

  • IEncoder
IEncoder Member List

This is the complete list of members for IEncoder, including all inherited members.

DequeueOutput(out FrameFlags flags) | IEncoder
EndOfStream() | IEncoder
Error | IEncoder
GetPlatformAPI< I >() | IEncoder
Output | IEncoder


Photon Voice: IEncoderDirect< B > Interface Template Reference

  • IEncoderDirect
Public Member Functions | List of all members
IEncoderDirect< B > Interface Template Reference

Interface for an encoder which consumes input data via explicit call. More...

Inherits IEncoder.

Public Member Functions

void | Input (B buf)
Consumes the given raw data. More...
- Public Member Functions inherited from IEncoder
ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
Returns next encoded data frame (if such output supported). More...
void | EndOfStream ()
Forces an encoder to flush and produce frame with EndOfStream flag (in output queue). More...
I | GetPlatformAPI< I > ()
Returns an platform-specific interface. More...

Additional Inherited Members

- Properties inherited from IEncoder
string | Error [get]
If not null, the object is in invalid state. More...
Action< ArraySegment< byte >, FrameFlags > | Output [set]
Set callback encoder calls on each encoded data frame (if such output supported). More...

Detailed Description

Interface for an encoder which consumes input data via explicit call.

Member Function Documentation

◆ Input()

void Input ( B buf )

Consumes the given raw data.

Parameters
buf Array containing raw data (e.g. audio samples).


Photon Voice: Member List

  • IEncoderDirect
IEncoderDirect< B > Member List

This is the complete list of members for IEncoderDirect< B >, including all inherited members.

DequeueOutput(out FrameFlags flags) | IEncoder
EndOfStream() | IEncoder
Error | IEncoder
GetPlatformAPI< I >() | IEncoder
Input(B buf) | IEncoderDirect< B >
Output | IEncoder


Photon Voice: IEncoderDirectImage Interface Reference

  • IEncoderDirectImage
Properties | List of all members
IEncoderDirectImage Interface Reference

Interface for an encoder which consumes images via explicit call. More...

Inherits IEncoderDirect< ImageBufferNative >.

Properties

ImageFormat ImageFormat [get]
Recommended encoder input image format. Encoder may support other formats. More...

Additional Inherited Members

- Public Member Functions inherited from IEncoderDirect< ImageBufferNative >
void Input (B buf)
Consumes the given raw data. More...

Detailed Description

Interface for an encoder which consumes images via explicit call.

Property Documentation

◆ ImageFormat

ImageFormat ImageFormat
get

Recommended encoder input image format. Encoder may support other formats.


Photon Voice: Member List

  • IEncoderDirectImage
IEncoderDirectImage Member List

This is the complete list of members for IEncoderDirectImage, including all inherited members.

ImageFormat | IEncoderDirectImage
Input(B buf) | IEncoderDirect< ImageBufferNative >


Photon Voice: ILocalVoiceAudio Interface Reference

  • ILocalVoiceAudio
Public Member Functions | Properties | List of all members
ILocalVoiceAudio Interface Reference

Interface for an outgoing audio stream. More...

Inherited by LocalVoiceAudio< T >, and LocalVoiceAudioDummy.

Public Member Functions

void VoiceDetectorCalibrate (int durationMs, Action< float > onCalibrated=null)
Trigger voice detector calibration process. More...

Properties

AudioUtil.IVoiceDetector | VoiceDetector [get]
The VoiceDetector in use. More...
AudioUtil.ILevelMeter | LevelMeter [get]
The LevelMeter utility in use. More...
bool | VoiceDetectorCalibrating [get]
If true, voice detector calibration is in progress. More...

Detailed Description

Interface for an outgoing audio stream.

A LocalVoice always brings a LevelMeter and a VoiceDetector, which you can access using this interface.

Member Function Documentation

◆ VoiceDetectorCalibrate()

void VoiceDetectorCalibrate | ( | int | durationMs,
 |  | Action< float > | onCalibrated = null
 | ) |  |

Trigger voice detector calibration process.

While calibrating, keep silence. Voice detector sets threshold based on measured backgroud noise level.

Parameters
durationMs | Duration of calibration (in milliseconds).
onCalibrated | Called when calibration is complete. Parameter is new threshold value.

Implemented in LocalVoiceAudioDummy, and LocalVoiceAudio< T >.

Property Documentation

◆ LevelMeter

AudioUtil.ILevelMeter LevelMeter
get

The LevelMeter utility in use.

◆ VoiceDetector

AudioUtil.IVoiceDetector VoiceDetector
get

The VoiceDetector in use.

Use it to enable or disable voice detector and set its parameters.

◆ VoiceDetectorCalibrating

bool VoiceDetectorCalibrating
get

If true, voice detector calibration is in progress.


Photon Voice: Member List

  • ILocalVoiceAudio
ILocalVoiceAudio Member List

This is the complete list of members for ILocalVoiceAudio, including all inherited members.

LevelMeter | ILocalVoiceAudio
VoiceDetector | ILocalVoiceAudio
VoiceDetectorCalibrate(int durationMs, Action< float > onCalibrated=null) | ILocalVoiceAudio
VoiceDetectorCalibrating | ILocalVoiceAudio


Photon Voice: ILogger Interface Reference

  • ILogger
Public Member Functions | Properties | List of all members
ILogger Interface Reference

Inherited by Logger.

Public Member Functions

void Log (LogLevel level, string fmt, params object[] args)

Properties

LogLevel Level [get]


Photon Voice: Member List

  • ILogger
ILogger Member List

This is the complete list of members for ILogger, including all inherited members.

Level (defined in ILogger) | ILogger
Log(LogLevel level, string fmt, params object[] args) (defined in ILogger) | ILogger


Photon Voice: ImageBufferInfo Struct Reference

  • ImageBufferInfo
Classes | Public Member Functions | Properties | List of all members
ImageBufferInfo Struct Reference

Classes

struct StrideSet

Public Member Functions

ImageBufferInfo (int width, int height, StrideSet stride, ImageFormat format)

Properties

int | Width [get]
int | Height [get]
StrideSet | Stride [get]
ImageFormat | Format [get]
Rotation | Rotation [get, set]
Flip | Flip [get, set]


Photon Voice: Member List

  • ImageBufferInfo
ImageBufferInfo Member List

This is the complete list of members for ImageBufferInfo, including all inherited members.

Flip (defined in ImageBufferInfo) | ImageBufferInfo
Format (defined in ImageBufferInfo) | ImageBufferInfo
Height (defined in ImageBufferInfo) | ImageBufferInfo
ImageBufferInfo(int width, int height, StrideSet stride, ImageFormat format) (defined in ImageBufferInfo) | ImageBufferInfo
Rotation (defined in ImageBufferInfo) | ImageBufferInfo
Stride (defined in ImageBufferInfo) | ImageBufferInfo
Width (defined in ImageBufferInfo) | ImageBufferInfo


Photon Voice: ImageBufferInfo.StrideSet Struct Reference

  • ImageBufferInfo
  • StrideSet
Public Member Functions | Properties | List of all members
ImageBufferInfo.StrideSet Struct Reference

Public Member Functions

StrideSet (int length, int s0=0, int s1=0, int s2=0, int s3=0)

Properties

int | this[int key] [get, set]
int | Length [get]


Photon Voice: Member List

  • ImageBufferInfo
  • StrideSet
ImageBufferInfo.StrideSet Member List

This is the complete list of members for ImageBufferInfo.StrideSet, including all inherited members.

Length (defined in ImageBufferInfo.StrideSet) | ImageBufferInfo.StrideSet
StrideSet(int length, int s0=0, int s1=0, int s2=0, int s3=0) (defined in ImageBufferInfo.StrideSet) | ImageBufferInfo.StrideSet
this[int key] (defined in ImageBufferInfo.StrideSet) | ImageBufferInfo.StrideSet


Photon Voice: ImageBufferNative Class Reference

  • ImageBufferNative
Classes | Public Member Functions | Public Attributes | Protected Member Functions | List of all members
ImageBufferNative Class Reference

Inherited by ImageBufferNativeAlloc, ImageBufferNativeGCHandleBytes, and ImageBufferNativeGCHandleSinglePlane.

Classes

struct PlaneSet

Public Member Functions

ImageBufferNative (ImageBufferInfo info)
ImageBufferNative (IntPtr buf, int width, int height, int stride, ImageFormat imageFormat)
void | Retain ()
void | Retain (int times)
void | Release ()
virtual void | Dispose ()

Public Attributes

ImageBufferInfo | Info
PlaneSet | Planes

Protected Member Functions

virtual void | Reset ()
virtual void | Free ()


Photon Voice: Member List

  • ImageBufferNative
ImageBufferNative Member List

This is the complete list of members for ImageBufferNative, including all inherited members.

Dispose() (defined in ImageBufferNative) | ImageBufferNative | virtual
Free() (defined in ImageBufferNative) | ImageBufferNative | protectedvirtual
ImageBufferNative(ImageBufferInfo info) (defined in ImageBufferNative) | ImageBufferNative |
ImageBufferNative(IntPtr buf, int width, int height, int stride, ImageFormat imageFormat) (defined in ImageBufferNative) | ImageBufferNative |
Info (defined in ImageBufferNative) | ImageBufferNative |
Planes (defined in ImageBufferNative) | ImageBufferNative |
Release() (defined in ImageBufferNative) | ImageBufferNative |
Reset() (defined in ImageBufferNative) | ImageBufferNative | protectedvirtual
Retain() (defined in ImageBufferNative) | ImageBufferNative |
Retain(int times) (defined in ImageBufferNative) | ImageBufferNative |


Photon Voice: ImageBufferNative.PlaneSet Struct Reference

  • ImageBufferNative
  • PlaneSet
Public Member Functions | Properties | List of all members
ImageBufferNative.PlaneSet Struct Reference

Public Member Functions

PlaneSet (int length, IntPtr p0=default(IntPtr), IntPtr p1=default(IntPtr), IntPtr p2=default(IntPtr), IntPtr p3=default(IntPtr))

Properties

IntPtr | this[int key] [get, set]
int | Length [get]


Photon Voice: Member List

  • ImageBufferNative
  • PlaneSet
ImageBufferNative.PlaneSet Member List

This is the complete list of members for ImageBufferNative.PlaneSet, including all inherited members.

Length (defined in ImageBufferNative.PlaneSet) | ImageBufferNative.PlaneSet
PlaneSet(int length, IntPtr p0=default(IntPtr), IntPtr p1=default(IntPtr), IntPtr p2=default(IntPtr), IntPtr p3=default(IntPtr)) (defined in ImageBufferNative.PlaneSet) | ImageBufferNative.PlaneSet
this[int key] (defined in ImageBufferNative.PlaneSet) | ImageBufferNative.PlaneSet


Photon Voice: ImageBufferNativeAlloc Class Reference

  • ImageBufferNativeAlloc
Public Member Functions | Protected Member Functions | List of all members
ImageBufferNativeAlloc Class Reference

Inherits ImageBufferNative, and IDisposable.

Public Member Functions

ImageBufferNativeAlloc (ImageBufferNativePool< ImageBufferNativeAlloc > pool, ImageBufferInfo info)
override void | Dispose ()
- Public Member Functions inherited from ImageBufferNative
ImageBufferNative (ImageBufferInfo info)
ImageBufferNative (IntPtr buf, int width, int height, int stride, ImageFormat imageFormat)
void | Retain ()
void | Retain (int times)
void | Release ()

Protected Member Functions

override void | Free ()
- Protected Member Functions inherited from ImageBufferNative
virtual void | Reset ()

Additional Inherited Members

- Public Attributes inherited from ImageBufferNative
ImageBufferInfo | Info
PlaneSet | Planes


Photon Voice: Member List

  • ImageBufferNativeAlloc
ImageBufferNativeAlloc Member List

This is the complete list of members for ImageBufferNativeAlloc, including all inherited members.

Dispose() (defined in ImageBufferNativeAlloc) | ImageBufferNativeAlloc | virtual
Free() (defined in ImageBufferNativeAlloc) | ImageBufferNativeAlloc | protectedvirtual
ImageBufferNative(ImageBufferInfo info) (defined in ImageBufferNative) | ImageBufferNative |
ImageBufferNative(IntPtr buf, int width, int height, int stride, ImageFormat imageFormat) (defined in ImageBufferNative) | ImageBufferNative |
ImageBufferNativeAlloc(ImageBufferNativePool< ImageBufferNativeAlloc > pool, ImageBufferInfo info) (defined in ImageBufferNativeAlloc) | ImageBufferNativeAlloc |
Info (defined in ImageBufferNative) | ImageBufferNative |
Planes (defined in ImageBufferNative) | ImageBufferNative |
Release() (defined in ImageBufferNative) | ImageBufferNative |
Reset() (defined in ImageBufferNative) | ImageBufferNative | protectedvirtual
Retain() (defined in ImageBufferNative) | ImageBufferNative |
Retain(int times) (defined in ImageBufferNative) | ImageBufferNative |


Photon Voice: ImageBufferNativeGCHandleBytes Class Reference

  • ImageBufferNativeGCHandleBytes
Public Member Functions | Public Attributes | Protected Member Functions | List of all members
ImageBufferNativeGCHandleBytes Class Reference

Inherits ImageBufferNative, and IDisposable.

Public Member Functions

ImageBufferNativeGCHandleBytes (ImageBufferNativePool< ImageBufferNativeGCHandleBytes > pool, ImageBufferInfo info)
override void | Dispose ()
- Public Member Functions inherited from ImageBufferNative
ImageBufferNative (ImageBufferInfo info)
ImageBufferNative (IntPtr buf, int width, int height, int stride, ImageFormat imageFormat)
void | Retain ()
void | Retain (int times)
void | Release ()

Public Attributes

byte[][] | PlaneBytes => planeBytes
- Public Attributes inherited from ImageBufferNative
ImageBufferInfo | Info
PlaneSet | Planes

Protected Member Functions

override void | Free ()
- Protected Member Functions inherited from ImageBufferNative
virtual void | Reset ()


Photon Voice: Member List

  • ImageBufferNativeGCHandleBytes
ImageBufferNativeGCHandleBytes Member List

This is the complete list of members for ImageBufferNativeGCHandleBytes, including all inherited members.

Dispose() (defined in ImageBufferNativeGCHandleBytes) | ImageBufferNativeGCHandleBytes | virtual
Free() (defined in ImageBufferNativeGCHandleBytes) | ImageBufferNativeGCHandleBytes | protectedvirtual
ImageBufferNative(ImageBufferInfo info) (defined in ImageBufferNative) | ImageBufferNative |
ImageBufferNative(IntPtr buf, int width, int height, int stride, ImageFormat imageFormat) (defined in ImageBufferNative) | ImageBufferNative |
ImageBufferNativeGCHandleBytes(ImageBufferNativePool< ImageBufferNativeGCHandleBytes > pool, ImageBufferInfo info) (defined in ImageBufferNativeGCHandleBytes) | ImageBufferNativeGCHandleBytes |
Info (defined in ImageBufferNative) | ImageBufferNative |
PlaneBytes (defined in ImageBufferNativeGCHandleBytes) | ImageBufferNativeGCHandleBytes |
Planes (defined in ImageBufferNative) | ImageBufferNative |
Release() (defined in ImageBufferNative) | ImageBufferNative |
Reset() (defined in ImageBufferNative) | ImageBufferNative | protectedvirtual
Retain() (defined in ImageBufferNative) | ImageBufferNative |
Retain(int times) (defined in ImageBufferNative) | ImageBufferNative |


Photon Voice: ImageBufferNativeGCHandleSinglePlane Class Reference

  • ImageBufferNativeGCHandleSinglePlane
Public Member Functions | Protected Member Functions | List of all members
ImageBufferNativeGCHandleSinglePlane Class Reference

Inherits ImageBufferNative, and IDisposable.

Public Member Functions

ImageBufferNativeGCHandleSinglePlane (ImageBufferNativePool< ImageBufferNativeGCHandleSinglePlane > pool, ImageBufferInfo info)
void | PinPlane (byte[] plane)
override void | Dispose ()
- Public Member Functions inherited from ImageBufferNative
ImageBufferNative (ImageBufferInfo info)
ImageBufferNative (IntPtr buf, int width, int height, int stride, ImageFormat imageFormat)
void | Retain ()
void | Retain (int times)
void | Release ()

Protected Member Functions

override void | Free ()
- Protected Member Functions inherited from ImageBufferNative
virtual void | Reset ()

Additional Inherited Members

- Public Attributes inherited from ImageBufferNative
ImageBufferInfo | Info
PlaneSet | Planes


Photon Voice: Member List

  • ImageBufferNativeGCHandleSinglePlane
ImageBufferNativeGCHandleSinglePlane Member List

This is the complete list of members for ImageBufferNativeGCHandleSinglePlane, including all inherited members.

Dispose() (defined in ImageBufferNativeGCHandleSinglePlane) | ImageBufferNativeGCHandleSinglePlane | virtual
Free() (defined in ImageBufferNativeGCHandleSinglePlane) | ImageBufferNativeGCHandleSinglePlane | protectedvirtual
ImageBufferNative(ImageBufferInfo info) (defined in ImageBufferNative) | ImageBufferNative |
ImageBufferNative(IntPtr buf, int width, int height, int stride, ImageFormat imageFormat) (defined in ImageBufferNative) | ImageBufferNative |
ImageBufferNativeGCHandleSinglePlane(ImageBufferNativePool< ImageBufferNativeGCHandleSinglePlane > pool, ImageBufferInfo info) (defined in ImageBufferNativeGCHandleSinglePlane) | ImageBufferNativeGCHandleSinglePlane |
Info (defined in ImageBufferNative) | ImageBufferNative |
PinPlane(byte[] plane) (defined in ImageBufferNativeGCHandleSinglePlane) | ImageBufferNativeGCHandleSinglePlane |
Planes (defined in ImageBufferNative) | ImageBufferNative |
Release() (defined in ImageBufferNative) | ImageBufferNative |
Reset() (defined in ImageBufferNative) | ImageBufferNative | protectedvirtual
Retain() (defined in ImageBufferNative) | ImageBufferNative |
Retain(int times) (defined in ImageBufferNative) | ImageBufferNative |


Photon Voice: ImageBufferNativePool< T > Class Template Reference

  • ImageBufferNativePool
Public Member Functions | Protected Member Functions | List of all members
ImageBufferNativePool< T > Class Template Reference

Inherits ObjectPool< T, ImageBufferInfo >.

Public Member Functions

delegate T | Factory (ImageBufferNativePool< T > pool, ImageBufferInfo info)
ImageBufferNativePool (int capacity, Factory factory, string name)
ImageBufferNativePool (int capacity, Factory factory, string name, ImageBufferInfo info)
- Public Member Functions inherited from ObjectPool< T, ImageBufferInfo >
ObjectPool (int capacity, string name)
Create a new ObjectPool instance. Does not call Init(). More...
ObjectPool (int capacity, string name, TInfo info)
Create a new ObjectPool instance with the given info structure. Calls Init(). More...
void | Init (TInfo info)
(Re-)Initializes this ObjectPool. More...
TType | AcquireOrCreate ()
Acquire an existing object, or create a new one if none are available. More...
TType | AcquireOrCreate (TInfo info)
Acquire an existing object (if info matches), or create a new one from the passed info. More...
virtual bool | Release (TType obj, TInfo objInfo)
Returns object to pool. More...
virtual bool | Release (TType obj)
Returns object to pool, or destroys it if the pool is full. More...
void | Dispose ()
Free resources assoicated with this ObjectPool More...

Protected Member Functions

override T | createObject (ImageBufferInfo info)
override void | destroyObject (T obj)
override bool | infosMatch (ImageBufferInfo i0, ImageBufferInfo i1)
- Protected Member Functions inherited from ObjectPool< T, ImageBufferInfo >
abstract TType | createObject (TInfo info)
abstract void | destroyObject (TType obj)
abstract bool | infosMatch (TInfo i0, TInfo i1)

Additional Inherited Members

- Protected Attributes inherited from ObjectPool< T, ImageBufferInfo >
int | capacity
TInfo | info
int | pos
string | name
- Properties inherited from ObjectPool< T, ImageBufferInfo >
TInfo | Info [get]
The property (info) that objects in this Pool must match. More...


Photon Voice: Member List

  • ImageBufferNativePool
ImageBufferNativePool< T > Member List

This is the complete list of members for ImageBufferNativePool< T >, including all inherited members.

AcquireOrCreate() | ObjectPool< T, ImageBufferInfo > |
AcquireOrCreate(TInfo info) | ObjectPool< T, ImageBufferInfo > |
capacity (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protected
createObject(ImageBufferInfo info) (defined in ImageBufferNativePool< T >) | ImageBufferNativePool< T > | protected
createObject(TInfo info) (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protectedpure virtual
destroyObject(T obj) (defined in ImageBufferNativePool< T >) | ImageBufferNativePool< T > | protected
destroyObject(TType obj) (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protectedpure virtual
Dispose() | ObjectPool< T, ImageBufferInfo > |
Factory(ImageBufferNativePool< T > pool, ImageBufferInfo info) (defined in ImageBufferNativePool< T >) | ImageBufferNativePool< T > |
ImageBufferNativePool(int capacity, Factory factory, string name) (defined in ImageBufferNativePool< T >) | ImageBufferNativePool< T > |
ImageBufferNativePool(int capacity, Factory factory, string name, ImageBufferInfo info) (defined in ImageBufferNativePool< T >) | ImageBufferNativePool< T > |
info (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protected
Info | ObjectPool< T, ImageBufferInfo > |
infosMatch(ImageBufferInfo i0, ImageBufferInfo i1) (defined in ImageBufferNativePool< T >) | ImageBufferNativePool< T > | protected
infosMatch(TInfo i0, TInfo i1) (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protectedpure virtual
Init(TInfo info) | ObjectPool< T, ImageBufferInfo > |
name (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protected
ObjectPool(int capacity, string name) | ObjectPool< T, ImageBufferInfo > |
ObjectPool(int capacity, string name, TInfo info) | ObjectPool< T, ImageBufferInfo > |
pos (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protected
Release(TType obj, TInfo objInfo) | ObjectPool< T, ImageBufferInfo > | virtual
Release(TType obj) | ObjectPool< T, ImageBufferInfo > | virtual


Photon Voice: IProcessor< T > Interface Template Reference

  • IProcessor
Public Member Functions | List of all members
IProcessor< T > Interface Template Reference

Processor interface. More...

Inherits IDisposable.

Inherited by AudioUtil.LevelMeter< T >, AudioUtil.Resampler< T >, AudioUtil.VoiceDetector< T >, AudioUtil.VoiceDetectorCalibration< T >, and AudioUtil.VoiceLevelDetectCalibrate< T >.

Public Member Functions

T[] Process (T[] buf)
Process a frame of data. More...

Detailed Description

Processor interface.

Member Function Documentation

◆ Process()

T [] Process ( T[] buf )

Process a frame of data.

Parameters
buf Buffer containing input data
Returns
Buffer containing output data or null if frame has been discarded (VAD)

Implemented in AudioUtil.VoiceLevelDetectCalibrate< T >, AudioUtil.VoiceDetector< T >, AudioUtil.VoiceDetectorCalibration< T >, AudioUtil.LevelMeter< T >, and AudioUtil.Resampler< T >.


Photon Voice: Member List

  • IProcessor
IProcessor< T > Member List

This is the complete list of members for IProcessor< T >, including all inherited members.

Process(T[] buf) IProcessor< T >


Photon Voice: IResettable Interface Reference

  • IResettable
Public Member Functions | List of all members
IResettable Interface Reference

Inherited by AudioInPusher, AudioInReader, and AndroidAudioInAEC.

Public Member Functions

void Reset ()


Photon Voice: Member List

  • IResettable
IResettable Member List

This is the complete list of members for IResettable, including all inherited members.

Reset() (defined in IResettable) IResettable


Photon Voice: IServiceable Interface Reference

  • IServiceable
Public Member Functions | List of all members
IServiceable Interface Reference

Interface for classes that want their Service() function to be called regularly in the context of a LocalVoice. More...

Inherited by BufferReaderPushAdapterBase< T >.

Public Member Functions

void Service (LocalVoice localVoice)
Service function that should be called regularly. More...

Detailed Description

Interface for classes that want their Service() function to be called regularly in the context of a LocalVoice.

Member Function Documentation

◆ Service()

void Service ( LocalVoice localVoice )

Service function that should be called regularly.

Implemented in BufferReaderPushAdapterAsyncPool< T >, and BufferReaderPushAdapterBase< T >.


Photon Voice: Member List

  • IServiceable
IServiceable Member List

This is the complete list of members for IServiceable, including all inherited members.

Service(LocalVoice localVoice) IServiceable


Photon Voice: IVoiceTransport Interface Reference

  • IVoiceTransport
Public Member Functions | List of all members
IVoiceTransport Interface Reference

Inherited by LoadBalancingTransport.

Public Member Functions

bool | IsChannelJoined (int channelId)
void | SendVoiceInfo (LocalVoice voice, int channelId, bool targetMe, int[] targetPlayers)
void | SendVoiceRemove (LocalVoice voice, int channelId, bool targetMe, int[] targetPlayers)
void | SendFrame (ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte frNumber, byte voiceId, int channelId, SendFrameParams par)
string | ChannelIdStr (int channelId)
string | PlayerIdStr (int playerId)
int | GetPayloadFragmentSize (SendFrameParams par)


Photon Voice: Member List

  • IVoiceTransport
IVoiceTransport Member List

This is the complete list of members for IVoiceTransport, including all inherited members.

ChannelIdStr(int channelId) (defined in IVoiceTransport) | IVoiceTransport
GetPayloadFragmentSize(SendFrameParams par) (defined in IVoiceTransport) | IVoiceTransport
IsChannelJoined(int channelId) (defined in IVoiceTransport) | IVoiceTransport
PlayerIdStr(int playerId) (defined in IVoiceTransport) | IVoiceTransport
SendFrame(ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte frNumber, byte voiceId, int channelId, SendFrameParams par) (defined in IVoiceTransport) | IVoiceTransport
SendVoiceInfo(LocalVoice voice, int channelId, bool targetMe, int[] targetPlayers) (defined in IVoiceTransport) | IVoiceTransport
SendVoiceRemove(LocalVoice voice, int channelId, bool targetMe, int[] targetPlayers) (defined in IVoiceTransport) | IVoiceTransport


Photon Voice: LoadBalancingTransport Class Reference

  • LoadBalancingTransport
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
LoadBalancingTransport Class Reference

Extends LoadBalancingClient with media streaming functionality. More...

Inherits LoadBalancingClient, IVoiceTransport, and IDisposable.

Inherited by LoadBalancingTransport2.

Public Member Functions

virtual int | GetPayloadFragmentSize (SendFrameParams par)
bool | IsChannelJoined (int channelId)
LoadBalancingTransport (ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp, bool cppCompatibilityMode=false)
Initializes a new LoadBalancingTransport. More...
new void | Service ()
This method dispatches all available incoming commands and then sends this client's outgoing commands. Call this method regularly (2 to 20 times a second). More...
virtual bool | ChangeAudioGroups (byte[] groupsToRemove, byte[] groupsToAdd)
void | SendVoiceInfo (LocalVoice voice, int channelId, bool targetMe, int[] targetPlayers)
void | SendVoiceRemove (LocalVoice voice, int channelId, bool targetMe, int[] targetPlayers)
void | SendFrame (ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte frNumber, byte voiceId, int channelId, SendFrameParams par)
string | ChannelIdStr (int channelId)
string | PlayerIdStr (int playerId)
void | Dispose ()
Releases all resources used by the LoadBalancingTransport instance. More...

Protected Member Functions

virtual object | buildFrameMessage (byte voiceId, byte evNumber, byte frNumber, ArraySegment< byte > data, FrameFlags flags)
virtual void | onEventActionVoiceClient (EventData ev)

Protected Attributes

VoiceClient | voiceClient
readonly bool | cppCompatibilityMode
readonly ILogger | logger
virtual byte | FrameCode => VoiceEvent.Code

Properties

VoiceClient VoiceClient [get]
The VoiceClient implementation associated with this LoadBalancingTransport. More...

Detailed Description

Extends LoadBalancingClient with media streaming functionality.

Use your normal LoadBalancing workflow to join a Voice room. All standard LoadBalancing features are available. Use VoiceClient to work with media streams.

Constructor & Destructor Documentation

◆ LoadBalancingTransport()

LoadBalancingTransport | ( | ILogger | logger = null,
 |  | ConnectionProtocol | connectionProtocol = ConnectionProtocol.Udp,
 |  | bool | cppCompatibilityMode = false
 | ) |  |

Initializes a new LoadBalancingTransport.

Parameters
logger | ILogger instance. If null, this instance LoadBalancingClient.DebugReturn implementation is used.ConnectionProtocol
connectionProtocol | Connection protocol (UDP or TCP). ConnectionProtocol
cppCompatibilityMode | Use a protocol compatible with Voice C++ API.

Member Function Documentation

◆ Dispose()

void Dispose ( )

Releases all resources used by the LoadBalancingTransport instance.

◆ Service()

new void Service ( )

This method dispatches all available incoming commands and then sends this client's outgoing commands. Call this method regularly (2 to 20 times a second).

Property Documentation

◆ VoiceClient

VoiceClient VoiceClient
get

The VoiceClient implementation associated with this LoadBalancingTransport.


Photon Voice: LoadBalancingTransport2 Class Reference

  • LoadBalancingTransport2
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
LoadBalancingTransport2 Class Reference

Variant of LoadBalancingTransport. Aims to be non-alloc at the cost of breaking compatibility with older clients. More...

Inherits LoadBalancingTransport.

Public Member Functions

LoadBalancingTransport2 (ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp, bool cppCompatibilityMode=false)
override int | GetPayloadFragmentSize (SendFrameParams par)
- Public Member Functions inherited from LoadBalancingTransport
bool | IsChannelJoined (int channelId)
LoadBalancingTransport (ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp, bool cppCompatibilityMode=false)
Initializes a new LoadBalancingTransport. More...
new void | Service ()
This method dispatches all available incoming commands and then sends this client's outgoing commands. Call this method regularly (2 to 20 times a second). More...
virtual bool | ChangeAudioGroups (byte[] groupsToRemove, byte[] groupsToAdd)
void | SendVoiceInfo (LocalVoice voice, int channelId, bool targetMe, int[] targetPlayers)
void | SendVoiceRemove (LocalVoice voice, int channelId, bool targetMe, int[] targetPlayers)
void | SendFrame (ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte frNumber, byte voiceId, int channelId, SendFrameParams par)
string | ChannelIdStr (int channelId)
string | PlayerIdStr (int playerId)
void | Dispose ()
Releases all resources used by the LoadBalancingTransport instance. More...

Protected Member Functions

override object | buildFrameMessage (byte voiceId, byte evNumber, byte frNumber, ArraySegment< byte > data, FrameFlags flags)
override void | onEventActionVoiceClient (EventData ev)

Protected Attributes

override byte | FrameCode => VoiceEvent.FrameCode
- Protected Attributes inherited from LoadBalancingTransport
VoiceClient | voiceClient
readonly bool | cppCompatibilityMode
readonly ILogger | logger
virtual byte | FrameCode => VoiceEvent.Code

Additional Inherited Members

- Properties inherited from LoadBalancingTransport
VoiceClient VoiceClient [get]
The VoiceClient implementation associated with this LoadBalancingTransport. More...

Detailed Description

Variant of LoadBalancingTransport. Aims to be non-alloc at the cost of breaking compatibility with older clients.


Photon Voice: Member List

  • LoadBalancingTransport2
LoadBalancingTransport2 Member List

This is the complete list of members for LoadBalancingTransport2, including all inherited members.

buildFrameMessage(byte voiceId, byte evNumber, byte frNumber, ArraySegment< byte > data, FrameFlags flags) (defined in LoadBalancingTransport2) | LoadBalancingTransport2 | protectedvirtual
ChangeAudioGroups(byte[] groupsToRemove, byte[] groupsToAdd) (defined in LoadBalancingTransport) | LoadBalancingTransport | virtual
ChannelIdStr(int channelId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
cppCompatibilityMode (defined in LoadBalancingTransport) | LoadBalancingTransport | protected
Dispose() | LoadBalancingTransport |
FrameCode (defined in LoadBalancingTransport2) | LoadBalancingTransport2 | protected
GetPayloadFragmentSize(SendFrameParams par) (defined in LoadBalancingTransport2) | LoadBalancingTransport2 | virtual
IsChannelJoined(int channelId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LoadBalancingTransport(ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp, bool cppCompatibilityMode=false) | LoadBalancingTransport |
LoadBalancingTransport2(ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp, bool cppCompatibilityMode=false) (defined in LoadBalancingTransport2) | LoadBalancingTransport2 |
logger (defined in LoadBalancingTransport) | LoadBalancingTransport | protected
onEventActionVoiceClient(EventData ev) (defined in LoadBalancingTransport2) | LoadBalancingTransport2 | protectedvirtual
PlayerIdStr(int playerId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
SendFrame(ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte frNumber, byte voiceId, int channelId, SendFrameParams par) (defined in LoadBalancingTransport) | LoadBalancingTransport |
SendVoiceInfo(LocalVoice voice, int channelId, bool targetMe, int[] targetPlayers) (defined in LoadBalancingTransport) | LoadBalancingTransport |
SendVoiceRemove(LocalVoice voice, int channelId, bool targetMe, int[] targetPlayers) (defined in LoadBalancingTransport) | LoadBalancingTransport |
Service() | LoadBalancingTransport |
VoiceClient | LoadBalancingTransport |
voiceClient (defined in LoadBalancingTransport) | LoadBalancingTransport | protected


Photon Voice: LocalVoice Class Reference

  • LocalVoice
Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | Properties | List of all members
LocalVoice Class Reference

Represents outgoing data stream. More...

Inherits IDisposable.

Inherited by LocalVoiceAudioDummy, and LocalVoiceFramed< T >.

Public Member Functions

void | SendSpacingProfileStart ()
void | RemoveSelf ()
Remove this voice from it's VoiceClient (using VoiceClient.RemoveLocalVoice More...
virtual void | Dispose ()

Static Public Attributes

const int DATA_POOL_CAPACITY = 50

Protected Member Functions

bool | targetExits (bool targetMe, int[] targetPlayers)
void | sendVoiceInfoAndConfigFrame (bool targetMe, int[] targetPlayers)
void | sendVoiceRemove (bool targetMe, int[] targetPlayers)

Protected Attributes

int[] | targetPlayers_
VoiceInfo | info
IEncoder | encoder
VoiceClient | voiceClient
bool | threadingEnabled
ArraySegment< byte > | configFrame
volatile bool | disposed
object | disposeLock = new object()
bool | isJoined => voiceClient != null && voiceClient.transport.IsChannelJoined(this.channelId)

Properties

VoiceInfo | Info [get]
Returns Info structure assigned on local voice cration. More...
bool | TransmitEnabled [get, set]
If true, stream data broadcasted. More...
bool | IsCurrentlyTransmitting [get]
Returns true if stream broadcasts. More...
int | FramesSent [get]
Sent frames counter. More...
int | FramesSentFragmented [get]
Sent fragmented frames counter. More...
int | FramesSentFragments [get]
Sent frames fragments counter. More...
int | FramesSentBytes [get]
Sent frames bytes counter. More...
bool | Reliable [get, set]
Send data reliable. See also VoiceCreateOptions.Reliable. More...
bool | Encrypt [get, set]
Send data encrypted. See also VoiceCreateOptions.Encrypt. More...
bool | Fragment [get, set]
Split frames into fragments according to the size provided by the Transport. See also VoiceCreateOptions.Fragment. More...
int | FEC [get, set]
Forward Error Correction control. See also VoiceCreateOptions.FEC. More...
IServiceable | LocalUserServiceable [get, set]
Optional user object attached to LocalVoice. its Service() will be called at each VoiceClient.Service() call. More...
byte | Group [get, set]
byte | InterestGroup [get, set]
If InterestGroup != 0, streaming only to the players subscribed to this group (if supported by the transport). See also VoiceCreateOptions.InterestGroup. More...
bool | DebugEchoMode [get, set]
If true, outgoing stream routed back to client via server same way as for remote client's streams. See also VoiceCreateOptions.DebugEchoMode. More...
int[]?? | TargetPlayers [get, set]
If TargetPlayers is not null, sending voice info and streaming only to clients having player numbers specified in the array (if supported by transport). See also VoiceCreateOptions.TargetPlayers. More...
string | SendSpacingProfileDump [get]
int | SendSpacingProfileMax [get]
Logs input frames time spacing profiling results. Do not call frequently. More...
byte | ID [get]
byte | EvNumber [get]
string | shortName [get]
string | Name [get]
string | LogPrefix [get]

Detailed Description

Represents outgoing data stream.

Member Function Documentation

◆ RemoveSelf()

void RemoveSelf ( )

Remove this voice from it's VoiceClient (using VoiceClient.RemoveLocalVoice

Property Documentation

◆ DebugEchoMode

bool DebugEchoMode
getset

If true, outgoing stream routed back to client via server same way as for remote client's streams. See also VoiceCreateOptions.DebugEchoMode.

This functionality availability depends on transport.

◆ Encrypt

bool Encrypt
getset

Send data encrypted. See also VoiceCreateOptions.Encrypt.

◆ FEC

int FEC
getset

Forward Error Correction control. See also VoiceCreateOptions.FEC.

◆ Fragment

bool Fragment
getset

Split frames into fragments according to the size provided by the Transport. See also VoiceCreateOptions.Fragment.

◆ FramesSent

int FramesSent
get

Sent frames counter.

◆ FramesSentBytes

int FramesSentBytes
get

Sent frames bytes counter.

◆ FramesSentFragmented

int FramesSentFragmented
get

Sent fragmented frames counter.

◆ FramesSentFragments

int FramesSentFragments
get

Sent frames fragments counter.

◆ Info

VoiceInfo Info
get

Returns Info structure assigned on local voice cration.

◆ InterestGroup

byte InterestGroup
getset

If InterestGroup != 0, streaming only to the players subscribed to this group (if supported by the transport). See also VoiceCreateOptions.InterestGroup.

A remote voice is created even if the remote player is not subscribed to the InterestGroup. Use VoiceCreateOptions.TargetPlayers and TargetPlayers to completely hide the existence of LocalVoice from the remote player./>

◆ IsCurrentlyTransmitting

bool IsCurrentlyTransmitting
get

Returns true if stream broadcasts.

◆ LocalUserServiceable

IServiceable LocalUserServiceable
getset

Optional user object attached to LocalVoice. its Service() will be called at each VoiceClient.Service() call.

◆ Reliable

bool Reliable
getset

Send data reliable. See also VoiceCreateOptions.Reliable.

◆ SendSpacingProfileMax

int SendSpacingProfileMax
get

Logs input frames time spacing profiling results. Do not call frequently.

◆ TargetPlayers

int []?? TargetPlayers
getset

If TargetPlayers is not null, sending voice info and streaming only to clients having player numbers specified in the array (if supported by transport). See also VoiceCreateOptions.TargetPlayers.

TargetPlayers update triggers the sending of voice info to added players and voice remove to removed. Depending on the transport, TargetPlayers may disregard InterestGroup: the remote player whos number is in TargetPlayers, receives the stream even if not subscribed to the interest group. If the local player number is in TargetPlayers, it works like DebugEchoMode. Using both DebugEchoMode and TargetPlayers at the same time to route the stream back to the sender leads to an inconsistent state after one of the options is switched off: the voice is removed but the frames are still delivered.

◆ TransmitEnabled

bool TransmitEnabled
getset

If true, stream data broadcasted.


Photon Voice: Member List

  • LocalVoice
LocalVoice Member List

This is the complete list of members for LocalVoice, including all inherited members.

configFrame (defined in LocalVoice) | LocalVoice | protected
DATA_POOL_CAPACITY (defined in LocalVoice) | LocalVoice | static
DebugEchoMode | LocalVoice |
Dispose() (defined in LocalVoice) | LocalVoice | virtual
disposed (defined in LocalVoice) | LocalVoice | protected
disposeLock (defined in LocalVoice) | LocalVoice | protected
encoder (defined in LocalVoice) | LocalVoice | protected
Encrypt | LocalVoice |
EvNumber (defined in LocalVoice) | LocalVoice |
FEC | LocalVoice |
Fragment | LocalVoice |
FramesSent | LocalVoice |
FramesSentBytes | LocalVoice |
FramesSentFragmented | LocalVoice |
FramesSentFragments | LocalVoice |
Group (defined in LocalVoice) | LocalVoice |
ID (defined in LocalVoice) | LocalVoice |
Info | LocalVoice |
info (defined in LocalVoice) | LocalVoice | protected
InterestGroup | LocalVoice |
IsCurrentlyTransmitting | LocalVoice |
isJoined (defined in LocalVoice) | LocalVoice | protected
LocalUserServiceable | LocalVoice |
LogPrefix (defined in LocalVoice) | LocalVoice |
Name (defined in LocalVoice) | LocalVoice |
Reliable | LocalVoice |
RemoveSelf() | LocalVoice |
SendSpacingProfileDump (defined in LocalVoice) | LocalVoice |
SendSpacingProfileMax | LocalVoice |
SendSpacingProfileStart() (defined in LocalVoice) | LocalVoice |
sendVoiceInfoAndConfigFrame(bool targetMe, int[] targetPlayers) (defined in LocalVoice) | LocalVoice | protected
sendVoiceRemove(bool targetMe, int[] targetPlayers) (defined in LocalVoice) | LocalVoice | protected
shortName (defined in LocalVoice) | LocalVoice | protected
targetExits(bool targetMe, int[] targetPlayers) (defined in LocalVoice) | LocalVoice | protected
TargetPlayers | LocalVoice |
targetPlayers_ (defined in LocalVoice) | LocalVoice | protected
threadingEnabled (defined in LocalVoice) | LocalVoice | protected
TransmitEnabled | LocalVoice |
voiceClient (defined in LocalVoice) | LocalVoice | protected


Photon Voice: LocalVoiceAudio< T > Class Template Reference

  • LocalVoiceAudio
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
LocalVoiceAudio< T > Class Template Reference

Outgoing audio stream. More...

Inherits LocalVoiceFramed< T >, and ILocalVoiceAudio.

Public Member Functions

void | VoiceDetectorCalibrate (int durationMs, Action< float > onCalibrated=null)
Trigger voice detector calibration process. More...
- Public Member Functions inherited from LocalVoiceFramed< T >
void | AddPostProcessor (params IProcessor< T >[] processors)
Adds processors after any built-in processors and everything added with AddPreProcessor. More...
void | AddPreProcessor (params IProcessor< T >[] processors)
Adds processors before built-in processors and everything added with AddPostProcessor. More...
void | RemoveProcessor (params IProcessor< T >[] processors)
Adds processors before built-in processors and everything added with AddPostProcessor. More...
void | ClearProcessors ()
Clears all processors in pipeline including built-in resampling. User should add at least resampler processor after call. More...
void | PushDataAsync (T[] buf)
Asynchronously push data into this stream. More...
void | PushData (T[] buf)
Synchronously push data into this stream. More...
override void | Dispose ()
Releases resources used by the LocalVoiceFramed<T> instance. Buffers used for asynchronous push will be disposed in encoder thread's 'finally'. More...
- Public Member Functions inherited from LocalVoice
void | SendSpacingProfileStart ()
void | RemoveSelf ()
Remove this voice from it's VoiceClient (using VoiceClient.RemoveLocalVoice More...

Protected Member Functions

void | initBuiltinProcessors ()
- Protected Member Functions inherited from LocalVoiceFramed< T >
T[] | processFrame (T[] buf, int p0, int p1)
- Protected Member Functions inherited from LocalVoice
bool | targetExits (bool targetMe, int[] targetPlayers)
void | sendVoiceInfoAndConfigFrame (bool targetMe, int[] targetPlayers)
void | sendVoiceRemove (bool targetMe, int[] targetPlayers)

Protected Attributes

AudioUtil.VoiceDetector< T > | voiceDetector
AudioUtil.VoiceDetectorCalibration< T > | voiceDetectorCalibration
AudioUtil.LevelMeter< T > | levelMeter
int | channels
- Protected Attributes inherited from LocalVoice
int[] | targetPlayers_
VoiceInfo | info
IEncoder | encoder
VoiceClient | voiceClient
bool | threadingEnabled
ArraySegment< byte > | configFrame
volatile bool | disposed
object | disposeLock = new object()
bool | isJoined => voiceClient != null && voiceClient.transport.IsChannelJoined(this.channelId)

Properties

virtual AudioUtil.IVoiceDetector | VoiceDetector [get]
virtual AudioUtil.ILevelMeter | LevelMeter [get]
bool | VoiceDetectorCalibrating [get]
True if the VoiceDetector is currently calibrating. More...
- Properties inherited from LocalVoiceFramed< T >
FactoryPrimitiveArrayPool< T > | BufferFactory [get]
<see cref="PushData(T[])" and />. More...
bool | PushDataAsyncReady [get]
Wether this LocalVoiceFramed has capacity for more data buffers to be pushed asynchronously. More...
- Properties inherited from LocalVoice
VoiceInfo | Info [get]
Returns Info structure assigned on local voice cration. More...
bool | TransmitEnabled [get, set]
If true, stream data broadcasted. More...
bool | IsCurrentlyTransmitting [get]
Returns true if stream broadcasts. More...
int | FramesSent [get]
Sent frames counter. More...
int | FramesSentFragmented [get]
Sent fragmented frames counter. More...
int | FramesSentFragments [get]
Sent frames fragments counter. More...
int | FramesSentBytes [get]
Sent frames bytes counter. More...
bool | Reliable [get, set]
Send data reliable. See also VoiceCreateOptions.Reliable. More...
bool | Encrypt [get, set]
Send data encrypted. See also VoiceCreateOptions.Encrypt. More...
bool | Fragment [get, set]
Split frames into fragments according to the size provided by the Transport. See also VoiceCreateOptions.Fragment. More...
int | FEC [get, set]
Forward Error Correction control. See also VoiceCreateOptions.FEC. More...
IServiceable | LocalUserServiceable [get, set]
Optional user object attached to LocalVoice. its Service() will be called at each VoiceClient.Service() call. More...
byte | Group [get, set]
byte | InterestGroup [get, set]
If InterestGroup != 0, streaming only to the players subscribed to this group (if supported by the transport). See also VoiceCreateOptions.InterestGroup. More...
bool | DebugEchoMode [get, set]
If true, outgoing stream routed back to client via server same way as for remote client's streams. See also VoiceCreateOptions.DebugEchoMode. More...
int[]?? | TargetPlayers [get, set]
If TargetPlayers is not null, sending voice info and streaming only to clients having player numbers specified in the array (if supported by transport). See also VoiceCreateOptions.TargetPlayers. More...
string | SendSpacingProfileDump [get]
int | SendSpacingProfileMax [get]
Logs input frames time spacing profiling results. Do not call frequently. More...
byte | ID [get]
byte | EvNumber [get]
string | shortName [get]
string | Name [get]
string | LogPrefix [get]
- Properties inherited from ILocalVoiceAudio
AudioUtil.IVoiceDetector | VoiceDetector [get]
The VoiceDetector in use. More...
AudioUtil.ILevelMeter | LevelMeter [get]
The LevelMeter utility in use. More...
bool | VoiceDetectorCalibrating [get]
If true, voice detector calibration is in progress. More...

Additional Inherited Members

- Static Public Attributes inherited from LocalVoice
const int DATA_POOL_CAPACITY = 50

Detailed Description

Outgoing audio stream.

Member Function Documentation

◆ VoiceDetectorCalibrate()

void VoiceDetectorCalibrate | ( | int | durationMs,
 |  | Action< float > | onCalibrated = null
 | ) |  |

Trigger voice detector calibration process.

While calibrating, keep silence. Voice detector sets threshold basing on measured backgroud noise level.

Parameters
durationMs | Duration of calibration in milliseconds.
onCalibrated | Called when calibration is complete. Parameter is new threshold value.

Implements ILocalVoiceAudio.

Property Documentation

◆ VoiceDetectorCalibrating

bool VoiceDetectorCalibrating
get

True if the VoiceDetector is currently calibrating.


Photon Voice: Member List

  • LocalVoiceAudio
LocalVoiceAudio< T > Member List

This is the complete list of members for LocalVoiceAudio< T >, including all inherited members.

AddPostProcessor(params IProcessor< T >[] processors) | LocalVoiceFramed< T > |
AddPreProcessor(params IProcessor< T >[] processors) | LocalVoiceFramed< T > |
BufferFactory | LocalVoiceFramed< T > |
channels (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > | protected
ClearProcessors() | LocalVoiceFramed< T > |
configFrame (defined in LocalVoice) | LocalVoice | protected
DATA_POOL_CAPACITY (defined in LocalVoice) | LocalVoice | static
DebugEchoMode | LocalVoice |
Dispose() | LocalVoiceFramed< T > | virtual
disposed (defined in LocalVoice) | LocalVoice | protected
disposeLock (defined in LocalVoice) | LocalVoice | protected
encoder (defined in LocalVoice) | LocalVoice | protected
Encrypt | LocalVoice |
EvNumber (defined in LocalVoice) | LocalVoice |
FEC | LocalVoice |
Fragment | LocalVoice |
FramesSent | LocalVoice |
FramesSentBytes | LocalVoice |
FramesSentFragmented | LocalVoice |
FramesSentFragments | LocalVoice |
Group (defined in LocalVoice) | LocalVoice |
ID (defined in LocalVoice) | LocalVoice |
Info | LocalVoice |
info (defined in LocalVoice) | LocalVoice | protected
initBuiltinProcessors() (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > | protected
InterestGroup | LocalVoice |
IsCurrentlyTransmitting | LocalVoice |
isJoined (defined in LocalVoice) | LocalVoice | protected
levelMeter (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > | protected
LevelMeter (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > |
LocalUserServiceable | LocalVoice |
LogPrefix (defined in LocalVoice) | LocalVoice |
Name (defined in LocalVoice) | LocalVoice |
processFrame(T[] buf, int p0, int p1) (defined in LocalVoiceFramed< T >) | LocalVoiceFramed< T > | protected
PushData(T[] buf) | LocalVoiceFramed< T > |
PushDataAsync(T[] buf) | LocalVoiceFramed< T > |
PushDataAsyncReady | LocalVoiceFramed< T > |
Reliable | LocalVoice |
RemoveProcessor(params IProcessor< T >[] processors) | LocalVoiceFramed< T > |
RemoveSelf() | LocalVoice |
SendSpacingProfileDump (defined in LocalVoice) | LocalVoice |
SendSpacingProfileMax | LocalVoice |
SendSpacingProfileStart() (defined in LocalVoice) | LocalVoice |
sendVoiceInfoAndConfigFrame(bool targetMe, int[] targetPlayers) (defined in LocalVoice) | LocalVoice | protected
sendVoiceRemove(bool targetMe, int[] targetPlayers) (defined in LocalVoice) | LocalVoice | protected
shortName (defined in LocalVoice) | LocalVoice | protected
targetExits(bool targetMe, int[] targetPlayers) (defined in LocalVoice) | LocalVoice | protected
TargetPlayers | LocalVoice |
targetPlayers_ (defined in LocalVoice) | LocalVoice | protected
threadingEnabled (defined in LocalVoice) | LocalVoice | protected
TransmitEnabled | LocalVoice |
voiceClient (defined in LocalVoice) | LocalVoice | protected
VoiceDetector (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > |
voiceDetector (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > | protected
VoiceDetectorCalibrate(int durationMs, Action< float > onCalibrated=null) | LocalVoiceAudio< T > |
VoiceDetectorCalibrating | LocalVoiceAudio< T > |
voiceDetectorCalibration (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > | protected


Photon Voice: LocalVoiceAudioDummy Class Reference

  • LocalVoiceAudioDummy
Public Member Functions | Static Public Attributes | Properties | List of all members
LocalVoiceAudioDummy Class Reference

Dummy LocalVoiceAudio More...

Inherits LocalVoice, and ILocalVoiceAudio.

Public Member Functions

void | VoiceDetectorCalibrate (int durationMs, Action< float > onCalibrated=null)
Trigger voice detector calibration process. More...
- Public Member Functions inherited from LocalVoice
void | SendSpacingProfileStart ()
void | RemoveSelf ()
Remove this voice from it's VoiceClient (using VoiceClient.RemoveLocalVoice More...
virtual void | Dispose ()

Static Public Attributes

static LocalVoiceAudioDummy | Dummy = new LocalVoiceAudioDummy()
A Dummy LocalVoiceAudio instance. More...
- Static Public Attributes inherited from LocalVoice
const int | DATA_POOL_CAPACITY = 50

Properties

AudioUtil.IVoiceDetector | VoiceDetector [get]
AudioUtil.ILevelMeter | LevelMeter [get]
bool | VoiceDetectorCalibrating [get]
- Properties inherited from LocalVoice
VoiceInfo | Info [get]
Returns Info structure assigned on local voice cration. More...
bool | TransmitEnabled [get, set]
If true, stream data broadcasted. More...
bool | IsCurrentlyTransmitting [get]
Returns true if stream broadcasts. More...
int | FramesSent [get]
Sent frames counter. More...
int | FramesSentFragmented [get]
Sent fragmented frames counter. More...
int | FramesSentFragments [get]
Sent frames fragments counter. More...
int | FramesSentBytes [get]
Sent frames bytes counter. More...
bool | Reliable [get, set]
Send data reliable. See also VoiceCreateOptions.Reliable. More...
bool | Encrypt [get, set]
Send data encrypted. See also VoiceCreateOptions.Encrypt. More...
bool | Fragment [get, set]
Split frames into fragments according to the size provided by the Transport. See also VoiceCreateOptions.Fragment. More...
int | FEC [get, set]
Forward Error Correction control. See also VoiceCreateOptions.FEC. More...
IServiceable | LocalUserServiceable [get, set]
Optional user object attached to LocalVoice. its Service() will be called at each VoiceClient.Service() call. More...
byte | Group [get, set]
byte | InterestGroup [get, set]
If InterestGroup != 0, streaming only to the players subscribed to this group (if supported by the transport). See also VoiceCreateOptions.InterestGroup. More...
bool | DebugEchoMode [get, set]
If true, outgoing stream routed back to client via server same way as for remote client's streams. See also VoiceCreateOptions.DebugEchoMode. More...
int[]?? | TargetPlayers [get, set]
If TargetPlayers is not null, sending voice info and streaming only to clients having player numbers specified in the array (if supported by transport). See also VoiceCreateOptions.TargetPlayers. More...
string | SendSpacingProfileDump [get]
int | SendSpacingProfileMax [get]
Logs input frames time spacing profiling results. Do not call frequently. More...
byte | ID [get]
byte | EvNumber [get]
string | shortName [get]
string | Name [get]
string | LogPrefix [get]
- Properties inherited from ILocalVoiceAudio
AudioUtil.IVoiceDetector | VoiceDetector [get]
The VoiceDetector in use. More...
AudioUtil.ILevelMeter | LevelMeter [get]
The LevelMeter utility in use. More...
bool | VoiceDetectorCalibrating [get]
If true, voice detector calibration is in progress. More...

Additional Inherited Members

- Protected Member Functions inherited from LocalVoice
bool | targetExits (bool targetMe, int[] targetPlayers)
void | sendVoiceInfoAndConfigFrame (bool targetMe, int[] targetPlayers)
void | sendVoiceRemove (bool targetMe, int[] targetPlayers)
- Protected Attributes inherited from LocalVoice
int[] | targetPlayers_
VoiceInfo | info
IEncoder | encoder
VoiceClient | voiceClient
bool | threadingEnabled
ArraySegment< byte > | configFrame
volatile bool | disposed
object | disposeLock = new object()
bool | isJoined => voiceClient != null && voiceClient.transport.IsChannelJoined(this.channelId)

Detailed Description

Dummy LocalVoiceAudio

For testing, this LocalVoiceAudio implementation features a AudioUtil.VoiceDetectorDummy and a AudioUtil.LevelMeterDummy

Member Function Documentation

◆ VoiceDetectorCalibrate()

void VoiceDetectorCalibrate | ( | int | durationMs,
 |  | Action< float > | onCalibrated = null
 | ) |  |

Trigger voice detector calibration process.

While calibrating, keep silence. Voice detector sets threshold based on measured backgroud noise level.

Parameters
durationMs | Duration of calibration (in milliseconds).
onCalibrated | Called when calibration is complete. Parameter is new threshold value.

Implements ILocalVoiceAudio.

Member Data Documentation

◆ Dummy

LocalVoiceAudioDummy Dummy = new LocalVoiceAudioDummy()
static

A Dummy LocalVoiceAudio instance.


Photon Voice: Member List

  • LocalVoiceAudioDummy
LocalVoiceAudioDummy Member List

This is the complete list of members for LocalVoiceAudioDummy, including all inherited members.

configFrame (defined in LocalVoice) | LocalVoice | protected
DATA_POOL_CAPACITY (defined in LocalVoice) | LocalVoice | static
DebugEchoMode | LocalVoice |
Dispose() (defined in LocalVoice) | LocalVoice | virtual
disposed (defined in LocalVoice) | LocalVoice | protected
disposeLock (defined in LocalVoice) | LocalVoice | protected
Dummy | LocalVoiceAudioDummy | static
encoder (defined in LocalVoice) | LocalVoice | protected
Encrypt | LocalVoice |
EvNumber (defined in LocalVoice) | LocalVoice |
FEC | LocalVoice |
Fragment | LocalVoice |
FramesSent | LocalVoice |
FramesSentBytes | LocalVoice |
FramesSentFragmented | LocalVoice |
FramesSentFragments | LocalVoice |
Group (defined in LocalVoice) | LocalVoice |
ID (defined in LocalVoice) | LocalVoice |
info (defined in LocalVoice) | LocalVoice | protected
Info | LocalVoice |
InterestGroup | LocalVoice |
IsCurrentlyTransmitting | LocalVoice |
isJoined (defined in LocalVoice) | LocalVoice | protected
LevelMeter (defined in LocalVoiceAudioDummy) | LocalVoiceAudioDummy |
LocalUserServiceable | LocalVoice |
LocalVoiceAudioDummy() (defined in LocalVoiceAudioDummy) | LocalVoiceAudioDummy |
LogPrefix (defined in LocalVoice) | LocalVoice |
Name (defined in LocalVoice) | LocalVoice |
Reliable | LocalVoice |
RemoveSelf() | LocalVoice |
SendSpacingProfileDump (defined in LocalVoice) | LocalVoice |
SendSpacingProfileMax | LocalVoice |
SendSpacingProfileStart() (defined in LocalVoice) | LocalVoice |
sendVoiceInfoAndConfigFrame(bool targetMe, int[] targetPlayers) (defined in LocalVoice) | LocalVoice | protected
sendVoiceRemove(bool targetMe, int[] targetPlayers) (defined in LocalVoice) | LocalVoice | protected
shortName (defined in LocalVoice) | LocalVoice | protected
targetExits(bool targetMe, int[] targetPlayers) (defined in LocalVoice) | LocalVoice | protected
TargetPlayers | LocalVoice |
targetPlayers_ (defined in LocalVoice) | LocalVoice | protected
threadingEnabled (defined in LocalVoice) | LocalVoice | protected
TransmitEnabled | LocalVoice |
voiceClient (defined in LocalVoice) | LocalVoice | protected
VoiceDetector (defined in LocalVoiceAudioDummy) | LocalVoiceAudioDummy |
VoiceDetectorCalibrate(int durationMs, Action< float > onCalibrated=null) | LocalVoiceAudioDummy |
VoiceDetectorCalibrating (defined in LocalVoiceAudioDummy) | LocalVoiceAudioDummy |


Photon Voice: LocalVoiceAudioFloat Class Reference

  • LocalVoiceAudioFloat
List of all members
LocalVoiceAudioFloat Class Reference

Specialization of LocalVoiceAudio<T> for float audio More...

Inherits LocalVoiceAudio< float >.

Additional Inherited Members

- Public Member Functions inherited from LocalVoiceAudio< float >
void | VoiceDetectorCalibrate (int durationMs, Action< float > onCalibrated=null)
Trigger voice detector calibration process. More...
- Protected Member Functions inherited from LocalVoiceAudio< float >
void | initBuiltinProcessors ()
- Protected Attributes inherited from LocalVoiceAudio< float >
AudioUtil.VoiceDetector< T > | voiceDetector
AudioUtil.VoiceDetectorCalibration< T > | voiceDetectorCalibration
AudioUtil.LevelMeter< T > | levelMeter
int | channels
- Properties inherited from LocalVoiceAudio< float >
virtual AudioUtil.IVoiceDetector | VoiceDetector [get]
virtual AudioUtil.ILevelMeter | LevelMeter [get]
bool | VoiceDetectorCalibrating [get]
True if the VoiceDetector is currently calibrating. More...

Detailed Description

Specialization of LocalVoiceAudio<T> for float audio


Photon Voice: Member List

  • LocalVoiceAudioFloat
LocalVoiceAudioFloat Member List

This is the complete list of members for LocalVoiceAudioFloat, including all inherited members.

channels (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > | protected
initBuiltinProcessors() (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > | protected
LevelMeter (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > |
levelMeter (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > | protected
VoiceDetector (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > |
voiceDetector (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > | protected
VoiceDetectorCalibrate(int durationMs, Action< float > onCalibrated=null) | LocalVoiceAudio< float > |
VoiceDetectorCalibrating | LocalVoiceAudio< float > |
voiceDetectorCalibration (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > | protected


Photon Voice: LocalVoiceAudioShort Class Reference

  • LocalVoiceAudioShort
List of all members
LocalVoiceAudioShort Class Reference

Specialization of LocalVoiceAudio<T> for short audio More...

Inherits LocalVoiceAudio< short >.

Additional Inherited Members

- Public Member Functions inherited from LocalVoiceAudio< short >
void | VoiceDetectorCalibrate (int durationMs, Action< float > onCalibrated=null)
Trigger voice detector calibration process. More...
- Protected Member Functions inherited from LocalVoiceAudio< short >
void | initBuiltinProcessors ()
- Protected Attributes inherited from LocalVoiceAudio< short >
AudioUtil.VoiceDetector< T > | voiceDetector
AudioUtil.VoiceDetectorCalibration< T > | voiceDetectorCalibration
AudioUtil.LevelMeter< T > | levelMeter
int | channels
- Properties inherited from LocalVoiceAudio< short >
virtual AudioUtil.IVoiceDetector | VoiceDetector [get]
virtual AudioUtil.ILevelMeter | LevelMeter [get]
bool | VoiceDetectorCalibrating [get]
True if the VoiceDetector is currently calibrating. More...

Detailed Description

Specialization of LocalVoiceAudio<T> for short audio


Photon Voice: Member List

  • LocalVoiceAudioShort
LocalVoiceAudioShort Member List

This is the complete list of members for LocalVoiceAudioShort, including all inherited members.

channels (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > | protected
initBuiltinProcessors() (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > | protected
LevelMeter (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > |
levelMeter (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > | protected
VoiceDetector (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > |
voiceDetector (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > | protected
VoiceDetectorCalibrate(int durationMs, Action< float > onCalibrated=null) | LocalVoiceAudio< short > |
VoiceDetectorCalibrating | LocalVoiceAudio< short > |
voiceDetectorCalibration (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > | protected


Photon Voice: LocalVoiceFramed< T > Class Template Reference

  • LocalVoiceFramed
Public Member Functions | Protected Member Functions | Properties | List of all members
LocalVoiceFramed< T > Class Template Reference

Typed re-framing LocalVoice More...

Inherits LocalVoice.

Inherited by LocalVoiceAudio< T >.

Public Member Functions

void | AddPostProcessor (params IProcessor< T >[] processors)
Adds processors after any built-in processors and everything added with AddPreProcessor. More...
void | AddPreProcessor (params IProcessor< T >[] processors)
Adds processors before built-in processors and everything added with AddPostProcessor. More...
void | RemoveProcessor (params IProcessor< T >[] processors)
Adds processors before built-in processors and everything added with AddPostProcessor. More...
void | ClearProcessors ()
Clears all processors in pipeline including built-in resampling. User should add at least resampler processor after call. More...
void | PushDataAsync (T[] buf)
Asynchronously push data into this stream. More...
void | PushData (T[] buf)
Synchronously push data into this stream. More...
override void | Dispose ()
Releases resources used by the LocalVoiceFramed<T> instance. Buffers used for asynchronous push will be disposed in encoder thread's 'finally'. More...
- Public Member Functions inherited from LocalVoice
void | SendSpacingProfileStart ()
void | RemoveSelf ()
Remove this voice from it's VoiceClient (using VoiceClient.RemoveLocalVoice More...

Protected Member Functions

T[] | processFrame (T[] buf, int p0, int p1)
- Protected Member Functions inherited from LocalVoice
bool | targetExits (bool targetMe, int[] targetPlayers)
void | sendVoiceInfoAndConfigFrame (bool targetMe, int[] targetPlayers)
void | sendVoiceRemove (bool targetMe, int[] targetPlayers)

Properties

FactoryPrimitiveArrayPool< T > | BufferFactory [get]
<see cref="PushData(T[])" and />. More...
bool | PushDataAsyncReady [get]
Wether this LocalVoiceFramed has capacity for more data buffers to be pushed asynchronously. More...
- Properties inherited from LocalVoice
VoiceInfo | Info [get]
Returns Info structure assigned on local voice cration. More...
bool | TransmitEnabled [get, set]
If true, stream data broadcasted. More...
bool | IsCurrentlyTransmitting [get]
Returns true if stream broadcasts. More...
int | FramesSent [get]
Sent frames counter. More...
int | FramesSentFragmented [get]
Sent fragmented frames counter. More...
int | FramesSentFragments [get]
Sent frames fragments counter. More...
int | FramesSentBytes [get]
Sent frames bytes counter. More...
bool | Reliable [get, set]
Send data reliable. See also VoiceCreateOptions.Reliable. More...
bool | Encrypt [get, set]
Send data encrypted. See also VoiceCreateOptions.Encrypt. More...
bool | Fragment [get, set]
Split frames into fragments according to the size provided by the Transport. See also VoiceCreateOptions.Fragment. More...
int | FEC [get, set]
Forward Error Correction control. See also VoiceCreateOptions.FEC. More...
IServiceable | LocalUserServiceable [get, set]
Optional user object attached to LocalVoice. its Service() will be called at each VoiceClient.Service() call. More...
byte | Group [get, set]
byte | InterestGroup [get, set]
If InterestGroup != 0, streaming only to the players subscribed to this group (if supported by the transport). See also VoiceCreateOptions.InterestGroup. More...
bool | DebugEchoMode [get, set]
If true, outgoing stream routed back to client via server same way as for remote client's streams. See also VoiceCreateOptions.DebugEchoMode. More...
int[]?? | TargetPlayers [get, set]
If TargetPlayers is not null, sending voice info and streaming only to clients having player numbers specified in the array (if supported by transport). See also VoiceCreateOptions.TargetPlayers. More...
string | SendSpacingProfileDump [get]
int | SendSpacingProfileMax [get]
Logs input frames time spacing profiling results. Do not call frequently. More...
byte | ID [get]
byte | EvNumber [get]
string | shortName [get]
string | Name [get]
string | LogPrefix [get]

Additional Inherited Members

- Static Public Attributes inherited from LocalVoice
const int | DATA_POOL_CAPACITY = 50
- Protected Attributes inherited from LocalVoice
int[] | targetPlayers_
VoiceInfo | info
IEncoder | encoder
VoiceClient | voiceClient
bool | threadingEnabled
ArraySegment< byte > | configFrame
volatile bool | disposed
object | disposeLock = new object()
bool | isJoined => voiceClient != null && voiceClient.transport.IsChannelJoined(this.channelId)

Detailed Description

Typed re-framing LocalVoice

Consumes data in array buffers of arbitrary length. Repacks them in frames of VoiceInfo.FrameSize length for further processing and encoding.

Member Function Documentation

◆ AddPostProcessor()

void AddPostProcessor ( params IProcessor< T >[] processors )

Adds processors after any built-in processors and everything added with AddPreProcessor.

Parameters
processors

◆ AddPreProcessor()

void AddPreProcessor ( params IProcessor< T >[] processors )

Adds processors before built-in processors and everything added with AddPostProcessor.

Parameters
processors

◆ ClearProcessors()

void ClearProcessors ( )

Clears all processors in pipeline including built-in resampling. User should add at least resampler processor after call.

◆ Dispose()

override void Dispose ( )
virtual

Releases resources used by the LocalVoiceFramed<T> instance. Buffers used for asynchronous push will be disposed in encoder thread's 'finally'.

Reimplemented from LocalVoice.

◆ PushData()

void PushData ( T[] buf )

Synchronously push data into this stream.

◆ PushDataAsync()

void PushDataAsync ( T[] buf )

Asynchronously push data into this stream.

◆ RemoveProcessor()

void RemoveProcessor ( params IProcessor< T >[] processors )

Adds processors before built-in processors and everything added with AddPostProcessor.

Parameters
processors

Property Documentation

◆ BufferFactory

FactoryPrimitiveArrayPool<T> BufferFactory
get

<see cref="PushData(T[])" and />.

◆ PushDataAsyncReady

bool PushDataAsyncReady
get

Wether this LocalVoiceFramed has capacity for more data buffers to be pushed asynchronously.


Photon Voice: Member List

  • LocalVoiceFramed
LocalVoiceFramed< T > Member List

This is the complete list of members for LocalVoiceFramed< T >, including all inherited members.

AddPostProcessor(params IProcessor< T >[] processors) | LocalVoiceFramed< T > |
AddPreProcessor(params IProcessor< T >[] processors) | LocalVoiceFramed< T > |
BufferFactory | LocalVoiceFramed< T > |
ClearProcessors() | LocalVoiceFramed< T > |
configFrame (defined in LocalVoice) | LocalVoice | protected
DATA_POOL_CAPACITY (defined in LocalVoice) | LocalVoice | static
DebugEchoMode | LocalVoice |
Dispose() | LocalVoiceFramed< T > | virtual
disposed (defined in LocalVoice) | LocalVoice | protected
disposeLock (defined in LocalVoice) | LocalVoice | protected
encoder (defined in LocalVoice) | LocalVoice | protected
Encrypt | LocalVoice |
EvNumber (defined in LocalVoice) | LocalVoice |
FEC | LocalVoice |
Fragment | LocalVoice |
FramesSent | LocalVoice |
FramesSentBytes | LocalVoice |
FramesSentFragmented | LocalVoice |
FramesSentFragments | LocalVoice |
Group (defined in LocalVoice) | LocalVoice |
ID (defined in LocalVoice) | LocalVoice |
info (defined in LocalVoice) | LocalVoice | protected
Info | LocalVoice |
InterestGroup | LocalVoice |
IsCurrentlyTransmitting | LocalVoice |
isJoined (defined in LocalVoice) | LocalVoice | protected
LocalUserServiceable | LocalVoice |
LogPrefix (defined in LocalVoice) | LocalVoice |
Name (defined in LocalVoice) | LocalVoice |
processFrame(T[] buf, int p0, int p1) (defined in LocalVoiceFramed< T >) | LocalVoiceFramed< T > | protected
PushData(T[] buf) | LocalVoiceFramed< T > |
PushDataAsync(T[] buf) | LocalVoiceFramed< T > |
PushDataAsyncReady | LocalVoiceFramed< T > |
Reliable | LocalVoice |
RemoveProcessor(params IProcessor< T >[] processors) | LocalVoiceFramed< T > |
RemoveSelf() | LocalVoice |
SendSpacingProfileDump (defined in LocalVoice) | LocalVoice |
SendSpacingProfileMax | LocalVoice |
SendSpacingProfileStart() (defined in LocalVoice) | LocalVoice |
sendVoiceInfoAndConfigFrame(bool targetMe, int[] targetPlayers) (defined in LocalVoice) | LocalVoice | protected
sendVoiceRemove(bool targetMe, int[] targetPlayers) (defined in LocalVoice) | LocalVoice | protected
shortName (defined in LocalVoice) | LocalVoice | protected
targetExits(bool targetMe, int[] targetPlayers) (defined in LocalVoice) | LocalVoice | protected
TargetPlayers | LocalVoice |
targetPlayers_ (defined in LocalVoice) | LocalVoice | protected
threadingEnabled (defined in LocalVoice) | LocalVoice | protected
TransmitEnabled | LocalVoice |
voiceClient (defined in LocalVoice) | LocalVoice | protected


Photon Voice: MonoPInvokeCallbackAttribute Class Reference

  • MonoPInvokeCallbackAttribute
Public Member Functions | List of all members
MonoPInvokeCallbackAttribute Class Reference

Inherits Attribute.

Public Member Functions

MonoPInvokeCallbackAttribute (Type t)


Photon Voice: Member List

  • MonoPInvokeCallbackAttribute
MonoPInvokeCallbackAttribute Member List

This is the complete list of members for MonoPInvokeCallbackAttribute, including all inherited members.

MonoPInvokeCallbackAttribute(Type t) (defined in MonoPInvokeCallbackAttribute) MonoPInvokeCallbackAttribute


Photon Voice: ObjectFactory< TType, TInfo > Interface Template Reference

  • ObjectFactory
Public Member Functions | Properties | List of all members
ObjectFactory< TType, TInfo > Interface Template Reference

Uniform interface to ObjectPool<TType, TInfo> and single reusable object. More...

Inherits IDisposable.

Public Member Functions

TType | New ()
TType | New (TInfo info)
void | Free (TType obj)
void | Free (TType obj, TInfo info)

Properties

TInfo Info [get]

Detailed Description

Uniform interface to ObjectPool<TType, TInfo> and single reusable object.

Template Parameters
TType | Object type.
TInfo | Type of property used to check 2 objects identity (like integral length of array).


Photon Voice: Member List

  • ObjectFactory
ObjectFactory< TType, TInfo > Member List

This is the complete list of members for ObjectFactory< TType, TInfo >, including all inherited members.

Free(TType obj) (defined in ObjectFactory< TType, TInfo >) | ObjectFactory< TType, TInfo >
Free(TType obj, TInfo info) (defined in ObjectFactory< TType, TInfo >) | ObjectFactory< TType, TInfo >
Info (defined in ObjectFactory< TType, TInfo >) | ObjectFactory< TType, TInfo >
New() (defined in ObjectFactory< TType, TInfo >) | ObjectFactory< TType, TInfo >
New(TInfo info) (defined in ObjectFactory< TType, TInfo >) | ObjectFactory< TType, TInfo >


Photon Voice: ObjectPool< TType, TInfo > Class Template Reference

  • ObjectPool
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
ObjectPool< TType, TInfo > Class Template Referenceabstract

Generic Pool to re-use objects of a certain type (TType) that optionally match a certain property or set of properties (TInfo). More...

Inherits IDisposable.

Public Member Functions

ObjectPool (int capacity, string name)
Create a new ObjectPool instance. Does not call Init(). More...
ObjectPool (int capacity, string name, TInfo info)
Create a new ObjectPool instance with the given info structure. Calls Init(). More...
void | Init (TInfo info)
(Re-)Initializes this ObjectPool. More...
TType | AcquireOrCreate ()
Acquire an existing object, or create a new one if none are available. More...
TType | AcquireOrCreate (TInfo info)
Acquire an existing object (if info matches), or create a new one from the passed info. More...
virtual bool | Release (TType obj, TInfo objInfo)
Returns object to pool. More...
virtual bool | Release (TType obj)
Returns object to pool, or destroys it if the pool is full. More...
void | Dispose ()
Free resources assoicated with this ObjectPool More...

Protected Member Functions

abstract TType | createObject (TInfo info)
abstract void | destroyObject (TType obj)
abstract bool | infosMatch (TInfo i0, TInfo i1)

Protected Attributes

int | capacity
TInfo | info
int | pos
string | name

Properties

TInfo Info [get]
The property (info) that objects in this Pool must match. More...

Detailed Description

Generic Pool to re-use objects of a certain type (TType) that optionally match a certain property or set of properties (TInfo).

Template Parameters
TType | Object type.
TInfo | Type of parameter used to check 2 objects identity (like integral length of array).

Constructor & Destructor Documentation

◆ ObjectPool() [1/2]

ObjectPool | ( | int | capacity,
 |  | string | name
 | ) |  |

Create a new ObjectPool instance. Does not call Init().

Parameters
capacity | Capacity (size) of the object pool.
name | Name of the object pool.

◆ ObjectPool() [2/2]

ObjectPool | ( | int | capacity,
 |  | string | name,
 |  | TInfo | info
 | ) |  |

Create a new ObjectPool instance with the given info structure. Calls Init().

Parameters
capacity | Capacity (size) of the object pool.
name | Name of the object pool.
info | Info about this Pool's objects.

Member Function Documentation

◆ AcquireOrCreate() [1/2]

TType AcquireOrCreate ( )

Acquire an existing object, or create a new one if none are available.

If it fails to get one from the pool, this will create from the info given in this pool's constructor.

◆ AcquireOrCreate() [2/2]

TType AcquireOrCreate ( TInfo info )

Acquire an existing object (if info matches), or create a new one from the passed info.

Parameters
info Info structure to match, or create a new object with.

◆ Dispose()

void Dispose ( )

Free resources assoicated with this ObjectPool

◆ Init()

void Init ( TInfo info )

(Re-)Initializes this ObjectPool.

If there are objects available in this Pool, they will be destroyed. Allocates (Capacity) new Objects.

Parameters
info Info about this Pool's objects.

◆ Release() [1/2]

virtual bool Release ( TType obj )
virtual

Returns object to pool, or destroys it if the pool is full.

Parameters
obj The object to return to the pool.

◆ Release() [2/2]

virtual bool Release | ( | TType | obj,
 |  | TInfo | objInfo
 | ) |  |
virtual

Returns object to pool.

Parameters
obj | The object to return to the pool.
objInfo | The info structure about obj.

obj is returned to the pool only if objInfo matches this pool's info. Else, it is destroyed.

Property Documentation

◆ Info

TInfo Info
get

The property (info) that objects in this Pool must match.


Photon Voice: Member List

  • ObjectPool
ObjectPool< TType, TInfo > Member List

This is the complete list of members for ObjectPool< TType, TInfo >, including all inherited members.

AcquireOrCreate() | ObjectPool< TType, TInfo > |
AcquireOrCreate(TInfo info) | ObjectPool< TType, TInfo > |
capacity (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protected
createObject(TInfo info) (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protectedpure virtual
destroyObject(TType obj) (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protectedpure virtual
Dispose() | ObjectPool< TType, TInfo > |
info (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protected
Info | ObjectPool< TType, TInfo > |
infosMatch(TInfo i0, TInfo i1) (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protectedpure virtual
Init(TInfo info) | ObjectPool< TType, TInfo > |
name (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protected
ObjectPool(int capacity, string name) | ObjectPool< TType, TInfo > |
ObjectPool(int capacity, string name, TInfo info) | ObjectPool< TType, TInfo > |
pos (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protected
Release(TType obj, TInfo objInfo) | ObjectPool< TType, TInfo > | virtual
Release(TType obj) | ObjectPool< TType, TInfo > | virtual


Photon Voice: OpusCodec Class Reference

  • OpusCodec
Classes | Public Types | Properties | List of all members
OpusCodec Class Reference

Classes

class | Decoder
class | Encoder
class | EncoderFloat
class | EncoderShort
class | Factory
class | Util

Public Types

enum FrameDuration

Properties

static string Version [get]


Photon Voice: Member List

  • OpusCodec
OpusCodec Member List

This is the complete list of members for OpusCodec, including all inherited members.

FrameDuration enum name (defined in OpusCodec) | OpusCodec |
Version (defined in OpusCodec) | OpusCodec | static


Photon Voice: OpusCodec.Decoder< T > Class Template Reference

  • OpusCodec
  • Decoder
Public Member Functions | Protected Attributes | Properties | List of all members
OpusCodec.Decoder< T > Class Template Reference

Inherits IDecoder.

Public Member Functions

Decoder (Action< FrameOut< T >> output, ILogger logger)
void | Open (VoiceInfo i)
Open (initialize) the decoder. More...
void | Dispose ()
void | Input (ref FrameBuffer buf)
Consumes the given encoded data. More...

Protected Attributes

OpusDecoder< T > decoder

Properties

string | Error [get]
- Properties inherited from IDecoder
string | Error [get]
If not null, the object is in invalid state. More...

Member Function Documentation

◆ Input()

void Input ( ref FrameBuffer buf )

Consumes the given encoded data.

The callee can call buf.Retain() to prevent the caller from disposing the buffer. In this case, the callee should call buf.Release() when buffer is no longer needed.

Implements IDecoder.

◆ Open()

void Open ( VoiceInfo info )

Open (initialize) the decoder.

Parameters
info Properties of the data stream to decode.

Implements IDecoder.


Photon Voice: Member List

  • OpusCodec
  • Decoder
OpusCodec.Decoder< T > Member List

This is the complete list of members for OpusCodec.Decoder< T >, including all inherited members.

decoder (defined in OpusCodec.Decoder< T >) | OpusCodec.Decoder< T > | protected
Decoder(Action< FrameOut< T >> output, ILogger logger) (defined in OpusCodec.Decoder< T >) | OpusCodec.Decoder< T > |
Dispose() (defined in OpusCodec.Decoder< T >) | OpusCodec.Decoder< T > |
Error (defined in OpusCodec.Decoder< T >) | OpusCodec.Decoder< T > |
Input(ref FrameBuffer buf) | OpusCodec.Decoder< T > |
Open(VoiceInfo i) | OpusCodec.Decoder< T > |


Photon Voice: OpusCodec.Encoder< T > Class Template Reference

  • OpusCodec
  • Encoder
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
OpusCodec.Encoder< T > Class Template Referenceabstract

Inherits IEncoderDirect< T[]>.

Public Member Functions

void | Input (T[] buf)
void | EndOfStream ()
ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
I | GetPlatformAPI< I > ()
void | Dispose ()
- Public Member Functions inherited from IEncoderDirect< T[]>
void | Input (B buf)
Consumes the given raw data. More...

Protected Member Functions

Encoder (VoiceInfo i, ILogger logger)
abstract void encodeTyped (T[] buf)

Protected Attributes

OpusEncoder | encoder
bool | disposed

Properties

string | Error [get]
Action< ArraySegment< byte >, FrameFlags > | Output [get, set]


Photon Voice: Member List

  • OpusCodec
  • Encoder
OpusCodec.Encoder< T > Member List

This is the complete list of members for OpusCodec.Encoder< T >, including all inherited members.

DequeueOutput(out FrameFlags flags) (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |
Dispose() (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |
disposed (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > | protected
encoder (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > | protected
Encoder(VoiceInfo i, ILogger logger) (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > | protected
encodeTyped(T[] buf) (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > | protectedpure virtual
EndOfStream() (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |
Error (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |
GetPlatformAPI< I >() (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |
Input(T[] buf) (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |
IEncoderDirect< T[]>.Input(B buf) | IEncoderDirect< T[]> |
Output (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |


Photon Voice: OpusCodec.EncoderFloat Class Reference

  • OpusCodec
  • EncoderFloat
Protected Member Functions | List of all members
OpusCodec.EncoderFloat Class Reference

Inherits OpusCodec.Encoder< float >.

Protected Member Functions

override void | encodeTyped (float[] buf)
- Protected Member Functions inherited from OpusCodec.Encoder< float >
Encoder (VoiceInfo i, ILogger logger)
abstract void | encodeTyped (T[] buf)

Additional Inherited Members

- Public Member Functions inherited from OpusCodec.Encoder< float >
void | Input (T[] buf)
void | EndOfStream ()
ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
I | GetPlatformAPI< I > ()
void | Dispose ()
- Protected Attributes inherited from OpusCodec.Encoder< float >
OpusEncoder | encoder
bool | disposed
- Properties inherited from OpusCodec.Encoder< float >
string | Error [get]
Action< ArraySegment< byte >, FrameFlags > | Output [get, set]


Photon Voice: Member List

  • OpusCodec
  • EncoderFloat
OpusCodec.EncoderFloat Member List

This is the complete list of members for OpusCodec.EncoderFloat, including all inherited members.

DequeueOutput(out FrameFlags flags) (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |
Dispose() (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |
disposed (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > | protected
encoder (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > | protected
Encoder(VoiceInfo i, ILogger logger) (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > | protected
encodeTyped(float[] buf) (defined in OpusCodec.EncoderFloat) | OpusCodec.EncoderFloat | protected
encodeTyped(T[] buf) (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > | protectedpure virtual
EndOfStream() (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |
Error (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |
GetPlatformAPI< I >() (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |
Input(T[] buf) (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |
Output (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |


Photon Voice: OpusCodec.EncoderShort Class Reference

  • OpusCodec
  • EncoderShort
Protected Member Functions | List of all members
OpusCodec.EncoderShort Class Reference

Inherits OpusCodec.Encoder< short >.

Protected Member Functions

override void | encodeTyped (short[] buf)
- Protected Member Functions inherited from OpusCodec.Encoder< short >
Encoder (VoiceInfo i, ILogger logger)
abstract void | encodeTyped (T[] buf)

Additional Inherited Members

- Public Member Functions inherited from OpusCodec.Encoder< short >
void | Input (T[] buf)
void | EndOfStream ()
ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
I | GetPlatformAPI< I > ()
void | Dispose ()
- Protected Attributes inherited from OpusCodec.Encoder< short >
OpusEncoder | encoder
bool | disposed
- Properties inherited from OpusCodec.Encoder< short >
string | Error [get]
Action< ArraySegment< byte >, FrameFlags > | Output [get, set]


Photon Voice: Member List

  • OpusCodec
  • EncoderShort
OpusCodec.EncoderShort Member List

This is the complete list of members for OpusCodec.EncoderShort, including all inherited members.

DequeueOutput(out FrameFlags flags) (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |
Dispose() (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |
disposed (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > | protected
encoder (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > | protected
Encoder(VoiceInfo i, ILogger logger) (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > | protected
encodeTyped(short[] buf) (defined in OpusCodec.EncoderShort) | OpusCodec.EncoderShort | protected
encodeTyped(T[] buf) (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > | protectedpure virtual
EndOfStream() (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |
Error (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |
GetPlatformAPI< I >() (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |
Input(T[] buf) (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |
Output (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |


Photon Voice: OpusCodec.Factory Class Reference

  • OpusCodec
  • Factory
Static Public Member Functions | List of all members
OpusCodec.Factory Class Reference

Static Public Member Functions

static IEncoder CreateEncoder< B > (VoiceInfo i, ILogger logger)


Photon Voice: Member List

  • OpusCodec
  • Factory
OpusCodec.Factory Member List

This is the complete list of members for OpusCodec.Factory, including all inherited members.

CreateEncoder< B >(VoiceInfo i, ILogger logger) (defined in OpusCodec.Factory) OpusCodec.Factory static


Photon Voice: OpusCodec.Util Class Reference

  • OpusCodec
  • Util
List of all members
OpusCodec.Util Class Reference


Photon Voice: Member List

  • OpusCodec
  • Util
OpusCodec.Util Member List

This is the complete list of members for OpusCodec.Util, including all inherited members.


Photon Voice: PhotonAppSettings Class Reference

  • PhotonAppSettings
Public Member Functions | Static Public Member Functions | Public Attributes | Properties | List of all members
PhotonAppSettings Class Reference

Collection of connection-relevant settings, used internally by PhotonNetwork.ConnectUsingSettings. More...

Inherits ScriptableObject.

Public Member Functions

void | UseCloud (string cloudAppid, string code="")
Sets appid and region code in the AppSettings. Used in Editor. More...
override string | ToString ()
String summary of the AppSettings. More...

Static Public Member Functions

static void LoadOrCreateSettings ()

Public Attributes

AppSettings AppSettings

Properties

static PhotonAppSettings Instance [get]

Detailed Description

Collection of connection-relevant settings, used internally by PhotonNetwork.ConnectUsingSettings.

Includes the AppSettings class from the Realtime APIs plus some other, PUN-relevant, settings.

Member Function Documentation

◆ ToString()

override string ToString ( )

String summary of the AppSettings.

◆ UseCloud()

void UseCloud | ( | string | cloudAppid,
 |  | string | code = ""
 | ) |  |

Sets appid and region code in the AppSettings. Used in Editor.


Photon Voice: Member List

  • PhotonAppSettings
PhotonAppSettings Member List

This is the complete list of members for PhotonAppSettings, including all inherited members.

AppSettings (defined in PhotonAppSettings) | PhotonAppSettings |
Instance (defined in PhotonAppSettings) | PhotonAppSettings | static
LoadOrCreateSettings() (defined in PhotonAppSettings) | PhotonAppSettings | static
ToString() | PhotonAppSettings |
UseCloud(string cloudAppid, string code="") | PhotonAppSettings |


Photon Voice: Platform Class Reference

  • Platform
Static Public Member Functions | List of all members
Platform Class Reference

Static Public Member Functions

static IDeviceEnumerator | CreateAudioInEnumerator (ILogger logger)
static IAudioInChangeNotifier | CreateAudioInChangeNotifier (Action callback, ILogger logger)
static IEncoder | CreateDefaultAudioEncoder< T > (ILogger logger, VoiceInfo info)
static IAudioDesc | CreateDefaultAudioSource (ILogger logger, DeviceInfo dev, int samplingRate, int channels, object otherParams=null)
static IDeviceEnumerator | CreateVideoInEnumerator (ILogger logger)
static IEncoderDirectImage | CreateDefaultVideoEncoder (ILogger logger, VoiceInfo info)
static IDecoderDirect< ImageBufferNative > | CreateDefaultVideoDecoder (ILogger logger, VoiceInfo info)
static IVideoRecorder | CreateDefaultVideoRecorder (ILogger logger, VoiceInfo info, DeviceInfo camDevice, Action< IVideoRecorder > onReady)
static IVideoPlayer | CreateDefaultVideoPlayer (ILogger logger, VoiceInfo info, Action< IVideoPlayer > onReady)
static IPreviewManager | CreateDefaultPreviewManager (ILogger logger)
static IVideoRecorder | CreateVideoRecorderUnityTexture (ILogger logger, VoiceInfo info, DeviceInfo camDevice, Action< IVideoRecorder > onReady)
static IVideoPlayer | CreateVideoPlayerUnityTexture (ILogger logger, VoiceInfo info, Action< IVideoPlayer > onReady)
static IPreviewManager | CreatePreviewManagerUnityTexture (ILogger logger)


Photon Voice: Member List

  • Platform
Platform Member List

This is the complete list of members for Platform, including all inherited members.

CreateAudioInChangeNotifier(Action callback, ILogger logger) (defined in Platform) | Platform | static
CreateAudioInEnumerator(ILogger logger) (defined in Platform) | Platform | static
CreateDefaultAudioEncoder< T >(ILogger logger, VoiceInfo info) (defined in Platform) | Platform | static
CreateDefaultAudioSource(ILogger logger, DeviceInfo dev, int samplingRate, int channels, object otherParams=null) (defined in Platform) | Platform | static
CreateDefaultPreviewManager(ILogger logger) (defined in Platform) | Platform | static
CreateDefaultVideoDecoder(ILogger logger, VoiceInfo info) (defined in Platform) | Platform | static
CreateDefaultVideoEncoder(ILogger logger, VoiceInfo info) (defined in Platform) | Platform | static
CreateDefaultVideoPlayer(ILogger logger, VoiceInfo info, Action< IVideoPlayer > onReady) (defined in Platform) | Platform | static
CreateDefaultVideoRecorder(ILogger logger, VoiceInfo info, DeviceInfo camDevice, Action< IVideoRecorder > onReady) (defined in Platform) | Platform | static
CreatePreviewManagerUnityTexture(ILogger logger) (defined in Platform) | Platform | static
CreateVideoInEnumerator(ILogger logger) (defined in Platform) | Platform | static
CreateVideoPlayerUnityTexture(ILogger logger, VoiceInfo info, Action< IVideoPlayer > onReady) (defined in Platform) | Platform | static
CreateVideoRecorderUnityTexture(ILogger logger, VoiceInfo info, DeviceInfo camDevice, Action< IVideoRecorder > onReady) (defined in Platform) | Platform | static


Photon Voice: PrimitiveArrayPool< T > Class Template Reference

  • PrimitiveArrayPool
Public Member Functions | Protected Member Functions | List of all members
PrimitiveArrayPool< T > Class Template Reference

Pool of Arrays with components of type T, with ObjectPool info being the array's size. More...

Inherits ObjectPool< T[], int >.

Public Member Functions

PrimitiveArrayPool (int capacity, string name)
PrimitiveArrayPool (int capacity, string name, int info)
- Public Member Functions inherited from ObjectPool< T[], int >
ObjectPool (int capacity, string name)
Create a new ObjectPool instance. Does not call Init(). More...
ObjectPool (int capacity, string name, TInfo info)
Create a new ObjectPool instance with the given info structure. Calls Init(). More...
void | Init (TInfo info)
(Re-)Initializes this ObjectPool. More...
TType | AcquireOrCreate ()
Acquire an existing object, or create a new one if none are available. More...
TType | AcquireOrCreate (TInfo info)
Acquire an existing object (if info matches), or create a new one from the passed info. More...
virtual bool | Release (TType obj, TInfo objInfo)
Returns object to pool. More...
virtual bool | Release (TType obj)
Returns object to pool, or destroys it if the pool is full. More...
void | Dispose ()
Free resources assoicated with this ObjectPool More...

Protected Member Functions

override T[] | createObject (int info)
override void | destroyObject (T[] obj)
override bool | infosMatch (int i0, int i1)
- Protected Member Functions inherited from ObjectPool< T[], int >
abstract TType | createObject (TInfo info)
abstract void | destroyObject (TType obj)
abstract bool | infosMatch (TInfo i0, TInfo i1)

Additional Inherited Members

- Protected Attributes inherited from ObjectPool< T[], int >
int | capacity
TInfo | info
int | pos
string | name
- Properties inherited from ObjectPool< T[], int >
TInfo | Info [get]
The property (info) that objects in this Pool must match. More...

Detailed Description

Pool of Arrays with components of type T, with ObjectPool info being the array's size.

Template Parameters
T Array element type.


Photon Voice: Member List

  • PrimitiveArrayPool
PrimitiveArrayPool< T > Member List

This is the complete list of members for PrimitiveArrayPool< T >, including all inherited members.

AcquireOrCreate() | ObjectPool< T[], int > |
AcquireOrCreate(TInfo info) | ObjectPool< T[], int > |
capacity (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protected
createObject(int info) (defined in PrimitiveArrayPool< T >) | PrimitiveArrayPool< T > | protected
createObject(TInfo info) (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protectedpure virtual
destroyObject(T[] obj) (defined in PrimitiveArrayPool< T >) | PrimitiveArrayPool< T > | protected
destroyObject(TType obj) (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protectedpure virtual
Dispose() | ObjectPool< T[], int > |
info (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protected
Info | ObjectPool< T[], int > |
infosMatch(int i0, int i1) (defined in PrimitiveArrayPool< T >) | PrimitiveArrayPool< T > | protected
infosMatch(TInfo i0, TInfo i1) (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protectedpure virtual
Init(TInfo info) | ObjectPool< T[], int > |
name (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protected
ObjectPool(int capacity, string name) | ObjectPool< T[], int > |
ObjectPool(int capacity, string name, TInfo info) | ObjectPool< T[], int > |
pos (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protected
PrimitiveArrayPool(int capacity, string name) (defined in PrimitiveArrayPool< T >) | PrimitiveArrayPool< T > |
PrimitiveArrayPool(int capacity, string name, int info) (defined in PrimitiveArrayPool< T >) | PrimitiveArrayPool< T > |
Release(TType obj, TInfo objInfo) | ObjectPool< T[], int > | virtual
Release(TType obj) | ObjectPool< T[], int > | virtual


Photon Voice: RawCodec Class Reference

  • RawCodec
Classes
RawCodec Class Reference

Classes

class | Decoder
class | Encoder
class | ShortToFloat


Photon Voice: RawCodec.Decoder< T > Class Template Reference

  • RawCodec
  • Decoder
Public Member Functions | Properties | List of all members
RawCodec.Decoder< T > Class Template Reference

Inherits IDecoder.

Public Member Functions

Decoder (Action< FrameOut< T >> output)
void | Open (VoiceInfo info)
Open (initialize) the decoder. More...
void | Input (ref FrameBuffer byteBuf)
Consumes the given encoded data. More...
void | Dispose ()

Properties

string | Error [get]
- Properties inherited from IDecoder
string | Error [get]
If not null, the object is in invalid state. More...

Member Function Documentation

◆ Input()

void Input ( ref FrameBuffer buf )

Consumes the given encoded data.

The callee can call buf.Retain() to prevent the caller from disposing the buffer. In this case, the callee should call buf.Release() when buffer is no longer needed.

Implements IDecoder.

◆ Open()

void Open ( VoiceInfo info )

Open (initialize) the decoder.

Parameters
info Properties of the data stream to decode.

Implements IDecoder.


Photon Voice: Member List

  • RawCodec
  • Decoder
RawCodec.Decoder< T > Member List

This is the complete list of members for RawCodec.Decoder< T >, including all inherited members.

Decoder(Action< FrameOut< T >> output) (defined in RawCodec.Decoder< T >) | RawCodec.Decoder< T >
Dispose() (defined in RawCodec.Decoder< T >) | RawCodec.Decoder< T >
Error (defined in RawCodec.Decoder< T >) | RawCodec.Decoder< T >
Input(ref FrameBuffer byteBuf) | RawCodec.Decoder< T >
Open(VoiceInfo info) | RawCodec.Decoder< T >


Photon Voice: RawCodec.Encoder< T > Class Template Reference

  • RawCodec
  • Encoder
Public Member Functions | Properties | List of all members
RawCodec.Encoder< T > Class Template Reference

Inherits IEncoderDirect< T[]>.

Public Member Functions

ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
void | EndOfStream ()
I | GetPlatformAPI< I > ()
void | Dispose ()
void | Input (T[] buf)
- Public Member Functions inherited from IEncoderDirect< T[]>
void | Input (B buf)
Consumes the given raw data. More...

Properties

string | Error [get]
Action< ArraySegment< byte >, FrameFlags > | Output [get, set]


Photon Voice: Member List

  • RawCodec
  • Encoder
RawCodec.Encoder< T > Member List

This is the complete list of members for RawCodec.Encoder< T >, including all inherited members.

DequeueOutput(out FrameFlags flags) (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >
Dispose() (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >
EndOfStream() (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >
Error (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >
GetPlatformAPI< I >() (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >
Input(T[] buf) (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >
IEncoderDirect< T[]>.Input(B buf) | IEncoderDirect< T[]>
Output (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >


Photon Voice: RawCodec.ShortToFloat Class Reference

  • RawCodec
  • ShortToFloat
Public Member Functions | List of all members
RawCodec.ShortToFloat Class Reference

Public Member Functions

ShortToFloat (Action< FrameOut< float >> output)
void Output (FrameOut< short > shortBuf)


Photon Voice: Member List

  • RawCodec
  • ShortToFloat
RawCodec.ShortToFloat Member List

This is the complete list of members for RawCodec.ShortToFloat, including all inherited members.

Output(FrameOut< short > shortBuf) (defined in RawCodec.ShortToFloat) | RawCodec.ShortToFloat
ShortToFloat(Action< FrameOut< float >> output) (defined in RawCodec.ShortToFloat) | RawCodec.ShortToFloat


Photon Voice: RemoteVoiceInfo Class Reference

  • RemoteVoiceInfo
Properties | List of all members
RemoteVoiceInfo Class Reference

Information about a remote voice (incoming stream). More...

Properties

VoiceInfo | Info [get]
Remote voice info. More...
int | ChannelId [get]
ID of channel used for transmission. More...
int | PlayerId [get]
Player ID of voice owner. More...
byte | VoiceId [get]
Voice ID (unique in the room). More...

Detailed Description

Information about a remote voice (incoming stream).

Property Documentation

◆ ChannelId

int ChannelId
get

ID of channel used for transmission.

◆ Info

VoiceInfo Info
get

Remote voice info.

◆ PlayerId

int PlayerId
get

Player ID of voice owner.

◆ VoiceId

byte VoiceId
get

Voice ID (unique in the room).


Photon Voice: Member List

  • RemoteVoiceInfo
RemoteVoiceInfo Member List

This is the complete list of members for RemoteVoiceInfo, including all inherited members.

ChannelId | RemoteVoiceInfo
Info | RemoteVoiceInfo
PlayerId | RemoteVoiceInfo
VoiceId | RemoteVoiceInfo


Photon Voice: RemoteVoiceOptions Struct Reference

  • RemoteVoiceOptions
Public Member Functions | Properties | List of all members
RemoteVoiceOptions Struct Reference

Event Actions and other options for a remote voice (incoming stream). More...

Public Member Functions

RemoteVoiceOptions (ILogger logger, string logPrefix, VoiceInfo voiceInfo)
void | SetOutput (Action< FrameOut< float >> output)
Create default audio decoder and register a method to be called when a data frame is decoded. More...
void | SetOutput (Action< FrameOut< short >> output)
Create default audio decoder and register a method to be called when a data frame is decoded. More...

Properties

Action | OnRemoteVoiceRemoveAction [get, set]
Register a method to be called when the remote voice is removed. More...
IDecoder | Decoder [get, set]
Remote voice data decoder. Use to set decoder options or override it with user decoder. More...

Detailed Description

Event Actions and other options for a remote voice (incoming stream).

Member Function Documentation

◆ SetOutput() [1/2]

void SetOutput ( Action< FrameOut< float >> output )

Create default audio decoder and register a method to be called when a data frame is decoded.

◆ SetOutput() [2/2]

void SetOutput ( Action< FrameOut< short >> output )

Create default audio decoder and register a method to be called when a data frame is decoded.

Property Documentation

◆ Decoder

IDecoder Decoder
getset

Remote voice data decoder. Use to set decoder options or override it with user decoder.

◆ OnRemoteVoiceRemoveAction

Action OnRemoteVoiceRemoveAction
getset

Register a method to be called when the remote voice is removed.


Photon Voice: Member List

  • RemoteVoiceOptions
RemoteVoiceOptions Member List

This is the complete list of members for RemoteVoiceOptions, including all inherited members.

Decoder | RemoteVoiceOptions
OnRemoteVoiceRemoveAction | RemoteVoiceOptions
RemoteVoiceOptions(ILogger logger, string logPrefix, VoiceInfo voiceInfo) (defined in RemoteVoiceOptions) | RemoteVoiceOptions
SetOutput(Action< FrameOut< float >> output) | RemoteVoiceOptions
SetOutput(Action< FrameOut< short >> output) | RemoteVoiceOptions


Photon Voice: SendFrameParams Struct Reference

  • SendFrameParams
Public Member Functions | Properties | List of all members
SendFrameParams Struct Reference

Public Member Functions

SendFrameParams (bool targetMe, int[] targetPlayers, byte interestGroup, bool reliable, bool encrypt)

Properties

bool | TargetMe [get]
int[] | TargetPlayers [get]
byte | InterestGroup [get]
bool | Reliable [get]
bool | Encrypt [get]


Photon Voice: Member List

  • SendFrameParams
SendFrameParams Member List

This is the complete list of members for SendFrameParams, including all inherited members.

Encrypt (defined in SendFrameParams) | SendFrameParams
InterestGroup (defined in SendFrameParams) | SendFrameParams
Reliable (defined in SendFrameParams) | SendFrameParams
SendFrameParams(bool targetMe, int[] targetPlayers, byte interestGroup, bool reliable, bool encrypt) (defined in SendFrameParams) | SendFrameParams
TargetMe (defined in SendFrameParams) | SendFrameParams
TargetPlayers (defined in SendFrameParams) | SendFrameParams


Photon Voice: UnsupportedCodecException Class Reference

  • UnsupportedCodecException
Public Member Functions | List of all members
UnsupportedCodecException Class Reference

Exception thrown if an unsupported codec is encountered. More...

Inherits Exception.

Public Member Functions

UnsupportedCodecException (string info, Codec codec)
Create a new UnsupportedCodecException. More...

Detailed Description

Exception thrown if an unsupported codec is encountered.

Constructor & Destructor Documentation

◆ UnsupportedCodecException()

UnsupportedCodecException | ( | string | info,
 |  | Codec | codec
 | ) |  |

Create a new UnsupportedCodecException.

Parameters
info | The info prepending standard message.
codec | The codec actually encountered.


Photon Voice: Member List

  • UnsupportedCodecException
UnsupportedCodecException Member List

This is the complete list of members for UnsupportedCodecException, including all inherited members.

UnsupportedCodecException(string info, Codec codec) UnsupportedCodecException


Photon Voice: UnsupportedPlatformException Class Reference

  • UnsupportedPlatformException
Public Member Functions | List of all members
UnsupportedPlatformException Class Reference

Exception thrown if an unsupported platform is encountered. More...

Inherits Exception.

Public Member Functions

UnsupportedPlatformException (string subject, string platform=null)
Create a new UnsupportedPlatformException. More...

Detailed Description

Exception thrown if an unsupported platform is encountered.

Constructor & Destructor Documentation

◆ UnsupportedPlatformException()

UnsupportedPlatformException | ( | string | subject,
 |  | string | platform = null
 | ) |  |

Create a new UnsupportedPlatformException.

Parameters
subject The info prepending standard message.

///

Parameters
platform Optional platform name.


Photon Voice: Member List

  • UnsupportedPlatformException
UnsupportedPlatformException Member List

This is the complete list of members for UnsupportedPlatformException, including all inherited members.

UnsupportedPlatformException(string subject, string platform=null) UnsupportedPlatformException


Photon Voice: UnsupportedSampleTypeException Class Reference

  • UnsupportedSampleTypeException
Public Member Functions | List of all members
UnsupportedSampleTypeException Class Reference

Exception thrown if an unsupported audio sample type is encountered. More...

Inherits Exception.

Public Member Functions

UnsupportedSampleTypeException (Type t)
Create a new UnsupportedSampleTypeException. More...

Detailed Description

Exception thrown if an unsupported audio sample type is encountered.

PhotonVoice generally supports 32-bit floating point ("float") or 16-bit signed integer ("short") audio, but it usually won't be converted automatically due to the high CPU overhead (and potential loss of precision) involved.

Constructor & Destructor Documentation

◆ UnsupportedSampleTypeException()

UnsupportedSampleTypeException ( Type t )

Create a new UnsupportedSampleTypeException.

Parameters
t The sample type actually encountered.


Photon Voice: Member List

  • UnsupportedSampleTypeException
UnsupportedSampleTypeException Member List

This is the complete list of members for UnsupportedSampleTypeException, including all inherited members.

UnsupportedSampleTypeException(Type t) UnsupportedSampleTypeException


Photon Voice: VoiceClient Class Reference

  • VoiceClient
Classes | Public Member Functions | Properties | List of all members
VoiceClient Class Reference

Voice client interact with other clients on network via IVoiceTransport. More...

Inherits IDisposable.

Classes

struct CreateOptions

Public Member Functions

delegate void | RemoteVoiceInfoDelegate (int channelId, int playerId, byte voiceId, VoiceInfo voiceInfo, ref RemoteVoiceOptions options)
Remote voice info event delegate. More...
IEnumerable< LocalVoice > | LocalVoicesInChannel (int channelId)
Iterates through copy of all local voices list of given channel. More...
void | LogSpacingProfiles ()
void | LogStats ()
void | SetRemoteVoiceDelayFrames (Codec codec, int delayFrames)
VoiceClient (IVoiceTransport transport, ILogger logger, CreateOptions opt=default(CreateOptions))
Creates VoiceClient instance More...
void | Service ()
This method dispatches all available incoming commands and then sends this client's outgoing commands. Call this method regularly (2..20 times a second). More...
LocalVoice | CreateLocalVoice (VoiceInfo voiceInfo, int channelId, VoiceCreateOptions options=default(VoiceCreateOptions))
Creates basic outgoing stream w/o data processing support. Provided encoder should generate output data stream. More...
LocalVoiceAudio< T > | CreateLocalVoiceAudio< T > (VoiceInfo voiceInfo, IAudioDesc audioSourceDesc, int channelId, VoiceCreateOptions options=default(VoiceCreateOptions))
LocalVoice | CreateLocalVoiceAudioFromSource (VoiceInfo voiceInfo, IAudioDesc source, AudioSampleType sampleType, int channelId, VoiceCreateOptions options=default(VoiceCreateOptions))
Creates outgoing audio stream of type automatically assigned and adds procedures (callback or serviceable) for consuming given audio source data. Adds audio specific features (e.g. resampling, level meter) to processing pipeline and to returning stream handler. More...
LocalVoiceVideo | CreateLocalVoiceVideo (VoiceInfo voiceInfo, IVideoRecorder recorder, int channelId, VoiceCreateOptions options=default(VoiceCreateOptions))
Creates outgoing video stream consuming sequence of image buffers. More...
void | RemoveLocalVoice (LocalVoice voice)
Removes local voice (outgoing data stream).

Parameters
voice Handler of outgoing stream to be removed.
More...
void | onJoinChannel (int channelId)
void | onJoinAllChannels ()
void | onLeaveChannel (int channel)
void | onLeaveAllChannels ()
void | onPlayerJoin (int channelId, int playerId)
void | onPlayerJoin (int playerId)
void | onPlayerLeave (int channelId, int playerId)
void | onPlayerLeave (int playerId)
void | onVoiceInfo (int channelId, int playerId, byte voiceId, byte eventNumber, VoiceInfo info)
void | onVoiceRemove (int playerId, byte[] voiceIds)
void | onFrame (int playerId, byte voiceId, byte evNumber, ref FrameBuffer receivedBytes, bool isLocalPlayer)
void | Dispose ()

Properties

bool | ThreadingEnabled [get, set]
int | EventsLost [get, set]
Lost events counter (the number of empty frames sent to the deocder). More...
int | FramesLost [get, set]
Lost frames counter (the number of empty frames sent to the deocder). More...
int | FramesFragPart [get, set]
The counter of assembled frames, fragments of which are partially missing. More...
int | FramesRecovered [get, set]
Recovered frames counter. More...
int | FramesLate [get, set]
Counter of late (incorrectly ordered) frames. More...
int | FramesReceived [get]
Received frames counter. More...
int | FramesReceivedFEC [get, set]
Received FEC events counter. More...
int | FramesTryFEC [get, set]
FEC recorery attempts counter. More...
int | FramesReceivedFragments [get, set]
Received events for fragmented frames counter. More...
int | FramesReceivedFragmented [get, set]
Assembled fragmented frames counter. More...
int | FramesSent [get]
Sent frames counter. More...
int | FramesSentBytes [get]
Sent frames bytes counter. More...
int | RoundTripTime [get]
Average time required voice packet to return to sender. More...
int | RoundTripTimeVariance [get]
Average round trip time variation. More...
bool | SuppressInfoDuplicateWarning [get, set]
Do not log warning when duplicate info received. More...
RemoteVoiceInfoDelegate | OnRemoteVoiceInfoAction [get, set]
Register a method to be called when remote voice info arrived (after join or new new remote voice creation). Metod parameters: (int channelId, int playerId, byte voiceId, VoiceInfo voiceInfo, ref RemoteVoiceOptions options); More...
int | DebugLostPercent [get, set]
Lost frames simulation ratio. More...
IEnumerable< LocalVoice > | LocalVoices [get]
Iterates through copy of all local voices list. More...
IEnumerable< RemoteVoiceInfo > | RemoteVoiceInfos [get]
Iterates through all remote voices infos. More...

Detailed Description

Voice client interact with other clients on network via IVoiceTransport.

Constructor & Destructor Documentation

◆ VoiceClient()

VoiceClient | ( | IVoiceTransport | transport,
 |  | ILogger | logger,
 |  | CreateOptions | opt = default(CreateOptions)
 | ) |  |

Creates VoiceClient instance

Member Function Documentation

◆ CreateLocalVoice()

LocalVoice CreateLocalVoice | ( | VoiceInfo | voiceInfo,
 |  | int | channelId,
 |  | VoiceCreateOptions | options = default(VoiceCreateOptions)
 | ) |  |

Creates basic outgoing stream w/o data processing support. Provided encoder should generate output data stream.

Parameters
voiceInfo | Outgoing stream parameters.
channelId | Transport channel specific to transport.
options | Voice creation options.
Returns
Outgoing stream handler.

◆ CreateLocalVoiceAudioFromSource()

LocalVoice CreateLocalVoiceAudioFromSource | ( | VoiceInfo | voiceInfo,
 |  | IAudioDesc | source,
 |  | AudioSampleType | sampleType,
 |  | int | channelId,
 |  | VoiceCreateOptions | options = default(VoiceCreateOptions)
 | ) |  |

Creates outgoing audio stream of type automatically assigned and adds procedures (callback or serviceable) for consuming given audio source data. Adds audio specific features (e.g. resampling, level meter) to processing pipeline and to returning stream handler.

Parameters
voiceInfo | Outgoing stream parameters.
source | Streaming audio source.
sampleType | Voice's audio sample type. If does not match source audio sample type, conversion will occur.
channelId | Transport channel specific to transport.
options | Voice creation options.
Returns
Outgoing stream handler.

audioSourceDesc.SamplingRate and voiceInfo.SamplingRate may do not match. Automatic resampling will occur in this case.

◆ CreateLocalVoiceVideo()

LocalVoiceVideo CreateLocalVoiceVideo | ( | VoiceInfo | voiceInfo,
 |  | IVideoRecorder | recorder,
 |  | int | channelId,
 |  | VoiceCreateOptions | options = default(VoiceCreateOptions)
 | ) |  |

Creates outgoing video stream consuming sequence of image buffers.

Parameters
voiceInfo | Outgoing stream parameters.
recorder | Video recorder.
channelId | Transport channel specific to transport.
options | Voice creation options.
Returns
Outgoing stream handler.

◆ LocalVoicesInChannel()

IEnumerable<LocalVoice> LocalVoicesInChannel ( int channelId )

Iterates through copy of all local voices list of given channel.

◆ RemoteVoiceInfoDelegate()

delegate void RemoteVoiceInfoDelegate | ( | int | channelId,
 |  | int | playerId,
 |  | byte | voiceId,
 |  | VoiceInfo | voiceInfo,
 |  | ref RemoteVoiceOptions | options
 | ) |  |

Remote voice info event delegate.

◆ RemoveLocalVoice()

void RemoveLocalVoice ( LocalVoice voice )

Removes local voice (outgoing data stream).

Parameters
voice Handler of outgoing stream to be removed.

◆ Service()

void Service ( )

This method dispatches all available incoming commands and then sends this client's outgoing commands. Call this method regularly (2..20 times a second).

Property Documentation

◆ DebugLostPercent

int DebugLostPercent
getset

Lost frames simulation ratio.

◆ EventsLost

int EventsLost
getset

Lost events counter (the number of empty frames sent to the deocder).

◆ FramesFragPart

int FramesFragPart
getset

The counter of assembled frames, fragments of which are partially missing.

◆ FramesLate

int FramesLate
getset

Counter of late (incorrectly ordered) frames.

◆ FramesLost

int FramesLost
getset

Lost frames counter (the number of empty frames sent to the deocder).

◆ FramesReceived

int FramesReceived
get

Received frames counter.

◆ FramesReceivedFEC

int FramesReceivedFEC
getset

Received FEC events counter.

◆ FramesReceivedFragmented

int FramesReceivedFragmented
getset

Assembled fragmented frames counter.

◆ FramesReceivedFragments

int FramesReceivedFragments
getset

Received events for fragmented frames counter.

◆ FramesRecovered

int FramesRecovered
getset

Recovered frames counter.

◆ FramesSent

int FramesSent
get

Sent frames counter.

◆ FramesSentBytes

int FramesSentBytes
get

Sent frames bytes counter.

◆ FramesTryFEC

int FramesTryFEC
getset

FEC recorery attempts counter.

◆ LocalVoices

IEnumerable<LocalVoice> LocalVoices
get

Iterates through copy of all local voices list.

◆ OnRemoteVoiceInfoAction

RemoteVoiceInfoDelegate OnRemoteVoiceInfoAction
getset

Register a method to be called when remote voice info arrived (after join or new new remote voice creation). Metod parameters: (int channelId, int playerId, byte voiceId, VoiceInfo voiceInfo, ref RemoteVoiceOptions options);

◆ RemoteVoiceInfos

IEnumerable<RemoteVoiceInfo> RemoteVoiceInfos
get

Iterates through all remote voices infos.

◆ RoundTripTime

int RoundTripTime
get

Average time required voice packet to return to sender.

◆ RoundTripTimeVariance

int RoundTripTimeVariance
get

Average round trip time variation.

◆ SuppressInfoDuplicateWarning

bool SuppressInfoDuplicateWarning
getset

Do not log warning when duplicate info received.


Photon Voice: Member List

  • VoiceClient
VoiceClient Member List

This is the complete list of members for VoiceClient, including all inherited members.

CreateLocalVoice(VoiceInfo voiceInfo, int channelId, VoiceCreateOptions options=default(VoiceCreateOptions)) | VoiceClient
CreateLocalVoiceAudio< T >(VoiceInfo voiceInfo, IAudioDesc audioSourceDesc, int channelId, VoiceCreateOptions options=default(VoiceCreateOptions)) (defined in VoiceClient) | VoiceClient
CreateLocalVoiceAudioFromSource(VoiceInfo voiceInfo, IAudioDesc source, AudioSampleType sampleType, int channelId, VoiceCreateOptions options=default(VoiceCreateOptions)) | VoiceClient
CreateLocalVoiceVideo(VoiceInfo voiceInfo, IVideoRecorder recorder, int channelId, VoiceCreateOptions options=default(VoiceCreateOptions)) | VoiceClient
DebugLostPercent | VoiceClient
Dispose() (defined in VoiceClient) | VoiceClient
EventsLost | VoiceClient
FramesFragPart | VoiceClient
FramesLate | VoiceClient
FramesLost | VoiceClient
FramesReceived | VoiceClient
FramesReceivedFEC | VoiceClient
FramesReceivedFragmented | VoiceClient
FramesReceivedFragments | VoiceClient
FramesRecovered | VoiceClient
FramesSent | VoiceClient
FramesSentBytes | VoiceClient
FramesTryFEC | VoiceClient
LocalVoices | VoiceClient
LocalVoicesInChannel(int channelId) | VoiceClient
LogSpacingProfiles() (defined in VoiceClient) | VoiceClient
LogStats() (defined in VoiceClient) | VoiceClient
onFrame(int playerId, byte voiceId, byte evNumber, ref FrameBuffer receivedBytes, bool isLocalPlayer) (defined in VoiceClient) | VoiceClient
onJoinAllChannels() (defined in VoiceClient) | VoiceClient
onJoinChannel(int channelId) (defined in VoiceClient) | VoiceClient
onLeaveAllChannels() (defined in VoiceClient) | VoiceClient
onLeaveChannel(int channel) (defined in VoiceClient) | VoiceClient
onPlayerJoin(int channelId, int playerId) (defined in VoiceClient) | VoiceClient
onPlayerJoin(int playerId) (defined in VoiceClient) | VoiceClient
onPlayerLeave(int channelId, int playerId) (defined in VoiceClient) | VoiceClient
onPlayerLeave(int playerId) (defined in VoiceClient) | VoiceClient
OnRemoteVoiceInfoAction | VoiceClient
onVoiceInfo(int channelId, int playerId, byte voiceId, byte eventNumber, VoiceInfo info) (defined in VoiceClient) | VoiceClient
onVoiceRemove(int playerId, byte[] voiceIds) (defined in VoiceClient) | VoiceClient
RemoteVoiceInfoDelegate(int channelId, int playerId, byte voiceId, VoiceInfo voiceInfo, ref RemoteVoiceOptions options) | VoiceClient
RemoteVoiceInfos | VoiceClient
RemoveLocalVoice(LocalVoice voice) | VoiceClient
RoundTripTime | VoiceClient
RoundTripTimeVariance | VoiceClient
Service() | VoiceClient
SetRemoteVoiceDelayFrames(Codec codec, int delayFrames) (defined in VoiceClient) | VoiceClient
SuppressInfoDuplicateWarning | VoiceClient
ThreadingEnabled (defined in VoiceClient) | VoiceClient
VoiceClient(IVoiceTransport transport, ILogger logger, CreateOptions opt=default(CreateOptions)) | VoiceClient


Photon Voice: VoiceClient.CreateOptions Struct Reference

  • VoiceClient
  • CreateOptions
Public Attributes | Static Public Attributes | List of all members
VoiceClient.CreateOptions Struct Reference

Public Attributes

byte | VoiceIDMin
byte | VoiceIDMax

Static Public Attributes

static CreateOptions Default

Member Data Documentation

◆ Default

CreateOptions Default
static
Initial value:
= new CreateOptions()
{
VoiceIDMin = 1,
VoiceIDMax = 15
}


Photon Voice: Member List

  • VoiceClient
  • CreateOptions
VoiceClient.CreateOptions Member List

This is the complete list of members for VoiceClient.CreateOptions, including all inherited members.

Default (defined in VoiceClient.CreateOptions) | VoiceClient.CreateOptions | static
VoiceIDMax (defined in VoiceClient.CreateOptions) | VoiceClient.CreateOptions |
VoiceIDMin (defined in VoiceClient.CreateOptions) | VoiceClient.CreateOptions |


Photon Voice: VoiceCreateOptions Struct Reference

  • VoiceCreateOptions
Public Attributes | List of all members
VoiceCreateOptions Struct Reference

Used to initialize optional properties of the LocalVoice instance at creation time. More...

Public Attributes

IEncoder Encoder
Encoder. More...
byte | InterestGroup
See LocalVoice.InterestGroup. More...
int[] | TargetPlayers
See LocalVoice.TargetPlayersSet to [] to make sure that LocalVoice does not create Remote voices during creation More...
bool | DebugEchoMode
See LocalVoice.DebugEchoMode. More...
bool | Reliable
See LocalVoice.Reliable. More...
bool | Encrypt
See LocalVoice.Encrypt. More...
bool | Fragment
See LocalVoice.Fragment. More...
int | FEC
See LocalVoice.FEC. More...

Detailed Description

Used to initialize optional properties of the LocalVoice instance at creation time.

Member Data Documentation

◆ DebugEchoMode

bool DebugEchoMode

See LocalVoice.DebugEchoMode.

◆ Encoder

IEncoder Encoder

Encoder.

◆ Encrypt

bool Encrypt

See LocalVoice.Encrypt.

◆ FEC

int FEC

See LocalVoice.FEC.

◆ Fragment

bool Fragment

See LocalVoice.Fragment.

◆ InterestGroup

byte InterestGroup

See LocalVoice.InterestGroup.

◆ Reliable

bool Reliable

See LocalVoice.Reliable.

◆ TargetPlayers

int [] TargetPlayers

See LocalVoice.TargetPlayersSet to [] to make sure that LocalVoice does not create Remote voices during creation


Photon Voice: Member List

  • VoiceCreateOptions
VoiceCreateOptions Member List

This is the complete list of members for VoiceCreateOptions, including all inherited members.

DebugEchoMode | VoiceCreateOptions
Encoder | VoiceCreateOptions
Encrypt | VoiceCreateOptions
FEC | VoiceCreateOptions
Fragment | VoiceCreateOptions
InterestGroup | VoiceCreateOptions
Reliable | VoiceCreateOptions
TargetPlayers | VoiceCreateOptions


Photon Voice: VoiceEvent Class Reference

  • VoiceEvent
Static Public Attributes | List of all members
VoiceEvent Class Reference

Static Public Attributes

const byte | Code = 202
Single event used for voice communications. More...
const byte | FrameCode = 203

Member Data Documentation

◆ Code

const byte Code = 202
static

Single event used for voice communications.

Change if it conflicts with other event codes used in the same Photon room.


Photon Voice: Member List

  • VoiceEvent
VoiceEvent Member List

This is the complete list of members for VoiceEvent, including all inherited members.

Code | VoiceEvent | static
FrameCode (defined in VoiceEvent) | VoiceEvent | static


Photon Voice: VoiceFollowClient Class Reference

  • VoiceFollowClient
Public Member Functions | Public Attributes | Protected Member Functions | Properties | List of all members
VoiceFollowClient Class Referenceabstract

This class can be used to automatically sync client states between Leader and Voice clients. More...

Inherits VoiceConnection.

Inherited by FusionVoiceClient, and PunVoiceClient.

Public Member Functions

bool | ConnectAndJoinRoom ()
Connect voice client to Photon servers and join a Voice room More...
void | Disconnect ()
Disconnect voice client from all Photon servers More...
- Public Member Functions inherited from VoiceConnection
virtual bool | ConnectUsingSettings (AppSettings overwriteSettings=null)
Connect to Photon server using Settings More...
bool | AddSpeaker (Speaker speaker, object userData)
Tries to link local Speaker with remote voice stream using UserData. Useful if Speaker created after stream is started. More...
Speaker | InstantiateSpeakerPrefab (GameObject parent, bool destroyOnRemove)
Instantiates SpeakerPrefab, optionally attaches it to the provided parent. More...
bool | AddRecorder (Recorder rec)
void | RemoveRecorder (Recorder rec)

Public Attributes

bool | AutoConnectAndJoin = true
Auto connect voice client and join a voice room when Leader client is joined to a Leader room More...
- Public Attributes inherited from VoiceConnection
virtual bool | AlwaysUsePrimaryRecorder => false
AppSettings | Settings
Settings to be used by this Voice Client More...
Voice.ILogger | Logger => voiceComponentImpl.Logger
VoiceLogger | VoiceLogger => voiceComponentImpl.VoiceLogger
bool | UsePrimaryRecorder => this.usePrimaryRecorder
Use VoiceConnection.PrimaryRecorder directly. More...

Protected Member Functions

abstract string | GetVoiceRoomName ()
abstract bool | ConnectVoice ()
virtual void | Start ()
override void | OnDestroy ()
override void | OnOperationResponseReceived (OperationResponse operationResponse)
void | LeaderStateChanged (ClientState toState)
override void | OnVoiceStateChanged (ClientState fromState, ClientState toState)
virtual bool | JoinVoiceRoom (string voiceRoomName)
- Protected Member Functions inherited from VoiceConnection
override void | Awake ()
virtual void | Update ()
virtual void | FixedUpdate ()
virtual Speaker | InstantiateSpeakerForRemoteVoice (int playerId, byte voiceId, object userData)
void | CalcStatistics ()

Properties

abstract bool | LeaderInRoom [get]
abstract bool | LeaderOfflineMode [get]
- Properties inherited from VoiceConnection
new LoadBalancingTransport | Client [get]
VoiceClient | VoiceClient [get]
Returns underlying Photon Voice client. More...
ClientState | ClientState [get]
Returns Photon Voice client state. More...
float | FramesReceivedPerSecond [get]
Number of frames received per second. More...
float | FramesLostPerSecond [get]
Number of frames lost per second. More...
float | FramesLostPercent [get]
Percentage of lost frames. More...
GameObject | SpeakerPrefab [get, set]
Prefab that contains Speaker component to be instantiated when receiving a new remote audio source info More...
Recorder | PrimaryRecorder [get, set]
Primary Recorder to be used by VoiceConnection implementations directly or via integration objects. More...
string | BestRegionSummaryInPreferences [get, set]
Used to store and access the "Best Region Summary" in the Player Preferences. More...

Additional Inherited Members

- Static Public Attributes inherited from VoiceConnection
const int | ChannelAudio = 1
Recommended Photon Transport channel for audio. Chosen not to interfere with video and default channel. More...
const int | ChannelVideo = 2
Recommended Photon Transport channel for video. Chosen not to interfere with audio and default channel. More...
- Events inherited from VoiceConnection
Action< Speaker > | SpeakerLinked
Fires when a speaker has been linked to a remote audio stream More...
Action< RemoteVoiceLink > | RemoteVoiceAdded
Fires when a remote voice stream is added More...

Detailed Description

This class can be used to automatically sync client states between Leader and Voice clients.

Member Function Documentation

◆ ConnectAndJoinRoom()

bool ConnectAndJoinRoom ( )

Connect voice client to Photon servers and join a Voice room

Returns
If true, connection command send from client

◆ Disconnect()

void Disconnect ( )

Disconnect voice client from all Photon servers

Member Data Documentation

◆ AutoConnectAndJoin

bool AutoConnectAndJoin = true

Auto connect voice client and join a voice room when Leader client is joined to a Leader room


Photon Voice: Member List

  • VoiceFollowClient
VoiceFollowClient Member List

This is the complete list of members for VoiceFollowClient, including all inherited members.

AddRecorder(Recorder rec) (defined in VoiceConnection) | VoiceConnection |
AddSpeaker(Speaker speaker, object userData) | VoiceConnection |
AlwaysUsePrimaryRecorder (defined in VoiceConnection) | VoiceConnection |
AutoConnectAndJoin | VoiceFollowClient |
Awake() (defined in VoiceConnection) | VoiceConnection | protected
BestRegionSummaryInPreferences | VoiceConnection |
CalcStatistics() (defined in VoiceConnection) | VoiceConnection | protected
ChannelAudio | VoiceConnection | static
ChannelVideo | VoiceConnection | static
Client (defined in VoiceConnection) | VoiceConnection |
ClientState | VoiceConnection |
ConnectAndJoinRoom() | VoiceFollowClient |
ConnectUsingSettings(AppSettings overwriteSettings=null) | VoiceConnection | virtual
ConnectVoice() (defined in VoiceFollowClient) | VoiceFollowClient | protectedpure virtual
Disconnect() | VoiceFollowClient |
FixedUpdate() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
FramesLostPercent | VoiceConnection |
FramesLostPerSecond | VoiceConnection |
FramesReceivedPerSecond | VoiceConnection |
GetVoiceRoomName() (defined in VoiceFollowClient) | VoiceFollowClient | protectedpure virtual
InstantiateSpeakerForRemoteVoice(int playerId, byte voiceId, object userData) (defined in VoiceConnection) | VoiceConnection | protectedvirtual
InstantiateSpeakerPrefab(GameObject parent, bool destroyOnRemove) | VoiceConnection |
JoinVoiceRoom(string voiceRoomName) (defined in VoiceFollowClient) | VoiceFollowClient | protectedvirtual
LeaderInRoom (defined in VoiceFollowClient) | VoiceFollowClient | protected
LeaderOfflineMode (defined in VoiceFollowClient) | VoiceFollowClient | protected
LeaderStateChanged(ClientState toState) (defined in VoiceFollowClient) | VoiceFollowClient | protected
Logger (defined in VoiceConnection) | VoiceConnection |
OnDestroy() (defined in VoiceFollowClient) | VoiceFollowClient | protectedvirtual
OnOperationResponseReceived(OperationResponse operationResponse) (defined in VoiceFollowClient) | VoiceFollowClient | protectedvirtual
OnVoiceStateChanged(ClientState fromState, ClientState toState) (defined in VoiceFollowClient) | VoiceFollowClient | protectedvirtual
PrimaryRecorder | VoiceConnection |
RemoteVoiceAdded | VoiceConnection |
RemoveRecorder(Recorder rec) (defined in VoiceConnection) | VoiceConnection |
Settings | VoiceConnection |
SpeakerLinked | VoiceConnection |
SpeakerPrefab | VoiceConnection |
Start() (defined in VoiceFollowClient) | VoiceFollowClient | protectedvirtual
Update() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
UsePrimaryRecorder | VoiceConnection |
VoiceClient | VoiceConnection |
VoiceLogger (defined in VoiceConnection) | VoiceConnection |


Photon Voice: VoiceInfo Struct Reference

  • VoiceInfo
Public Member Functions | Static Public Member Functions | Properties | List of all members
VoiceInfo Struct Reference

Describes stream properties. More...

Public Member Functions

override string ToString ()

Static Public Member Functions

static VoiceInfo | CreateAudioOpus (POpusCodec.Enums.SamplingRate samplingRate, int channels, OpusCodec.FrameDuration frameDurationUs, int bitrate, object userdata=null)
Create stream info for an Opus audio stream. More...
static VoiceInfo | CreateAudio (Codec codec, int samplingRate, int channels, int frameDurationUs, object userdata=null)
Create stream info for an audio stream. More...
static VoiceInfo | CreateVideo (Codec codec, int bitrate, int width, int height, int fps, int keyFrameInt, object userdata=null)
Create stream info for a video stream. More...

Properties

Codec | Codec [get, set]
int | SamplingRate [get, set]
Audio sampling rate (frequency, in Hz). More...
int | Channels [get, set]
Number of channels. More...
int | FrameDurationUs [get, set]
Uncompressed frame (audio packet) size in microseconds. More...
int | Bitrate [get, set]
Target bitrate (in bits/second). More...
int | Width [get, set]
Video width. More...
int | Height [get, set]
Video height More...
int | FPS [get, set]
Video frames per second More...
int | KeyFrameInt [get, set]
Video keyframe interval in frames More...
object | UserData [get, set]
Optional user data. Should be serializable by Photon. More...
int | FrameDurationSamples [get]
Uncompressed frame (data packet) size in samples. More...
int | FrameSize [get]
Uncompressed frame (data packet) array size. More...

Detailed Description

Describes stream properties.

Member Function Documentation

◆ CreateAudio()

static VoiceInfo CreateAudio | ( | Codec | codec,
 |  | int | samplingRate,
 |  | int | channels,
 |  | int | frameDurationUs,
 |  | object | userdata = null
 | ) |  |
static

Create stream info for an audio stream.

Parameters
codec | Audio codec.
samplingRate | Audio sampling rate.
channels | Number of channels.
frameDurationUs | Uncompressed frame (audio packet) size in microseconds.
userdata | Optional user data. Should be serializable by Photon.
Returns
VoiceInfo instance.

◆ CreateAudioOpus()

static VoiceInfo CreateAudioOpus | ( | POpusCodec.Enums.SamplingRate | samplingRate,
 |  | int | channels,
 |  | OpusCodec.FrameDuration | frameDurationUs,
 |  | int | bitrate,
 |  | object | userdata = null
 | ) |  |
static

Create stream info for an Opus audio stream.

Parameters
samplingRate | Audio sampling rate.
channels | Number of channels.
frameDurationUs | Uncompressed frame (audio packet) size in microseconds.
bitrate | Stream bitrate (in bits/second).
userdata | Optional user data. Should be serializable by Photon.
Returns
VoiceInfo instance.

◆ CreateVideo()

static VoiceInfo CreateVideo | ( | Codec | codec,
 |  | int | bitrate,
 |  | int | width,
 |  | int | height,
 |  | int | fps,
 |  | int | keyFrameInt,
 |  | object | userdata = null
 | ) |  |
static

Create stream info for a video stream.

Parameters
codec | Video codec.
bitrate | Stream bitrate.
width | Streamed video width. If 0, width and height of video source used (no rescaling).
height | Streamed video height. If -1, aspect ratio preserved during rescaling.
fps | Streamed video frames per second.
keyFrameInt | Keyframes interval in frames.

///

Parameters
userdata Optional user data. Should be serializable by Photon.
Returns
VoiceInfo instance.

Property Documentation

◆ Bitrate

int Bitrate
getset

Target bitrate (in bits/second).

◆ Channels

int Channels
getset

Number of channels.

◆ FPS

int FPS
getset

Video frames per second

◆ FrameDurationSamples

int FrameDurationSamples
get

Uncompressed frame (data packet) size in samples.

◆ FrameDurationUs

int FrameDurationUs
getset

Uncompressed frame (audio packet) size in microseconds.

◆ FrameSize

int FrameSize
get

Uncompressed frame (data packet) array size.

◆ Height

int Height
getset

Video height

◆ KeyFrameInt

int KeyFrameInt
getset

Video keyframe interval in frames

◆ SamplingRate

int SamplingRate
getset

Audio sampling rate (frequency, in Hz).

◆ UserData

object UserData
getset

Optional user data. Should be serializable by Photon.

◆ Width

int Width
getset

Video width.


Photon Voice: Member List

  • VoiceInfo
VoiceInfo Member List

This is the complete list of members for VoiceInfo, including all inherited members.

Bitrate | VoiceInfo |
Channels | VoiceInfo |
Codec (defined in VoiceInfo) | VoiceInfo |
CreateAudio(Codec codec, int samplingRate, int channels, int frameDurationUs, object userdata=null) | VoiceInfo | static
CreateAudioOpus(POpusCodec.Enums.SamplingRate samplingRate, int channels, OpusCodec.FrameDuration frameDurationUs, int bitrate, object userdata=null) | VoiceInfo | static
CreateVideo(Codec codec, int bitrate, int width, int height, int fps, int keyFrameInt, object userdata=null) | VoiceInfo | static
FPS | VoiceInfo |
FrameDurationSamples | VoiceInfo |
FrameDurationUs | VoiceInfo |
FrameSize | VoiceInfo |
Height | VoiceInfo |
KeyFrameInt | VoiceInfo |
SamplingRate | VoiceInfo |
ToString() (defined in VoiceInfo) | VoiceInfo |
UserData | VoiceInfo |
Width | VoiceInfo |


Photon Voice: WebRTCAudioLib Class Reference

  • WebRTCAudioLib
Public Types | Public Member Functions | List of all members
WebRTCAudioLib Class Reference

Inherited by WebRTCAudioProcessor.

Public Types

enum | Error
enum | Param

Public Member Functions

static IntPtr | webrtc_audio_processor_create (int samplingRate, int channels, int frameSize, int revSamplingRate, int revChannels)
static int | webrtc_audio_processor_init (IntPtr proc)
static int | webrtc_audio_processor_set_param (IntPtr proc, int param, int v)
static int | webrtc_audio_processor_process (IntPtr proc, short[] buffer, int offset, out bool voiceDetected)
static int | webrtc_audio_processor_process_reverse (IntPtr proc, short[] buffer, int bufferSize)
static void | webrtc_audio_processor_destroy (IntPtr proc)


Photon Voice: Member List

  • WebRTCAudioLib
WebRTCAudioLib Member List

This is the complete list of members for WebRTCAudioLib, including all inherited members.

Error enum name (defined in WebRTCAudioLib) | WebRTCAudioLib
Param enum name (defined in WebRTCAudioLib) | WebRTCAudioLib
webrtc_audio_processor_create(int samplingRate, int channels, int frameSize, int revSamplingRate, int revChannels) (defined in WebRTCAudioLib) | WebRTCAudioLib
webrtc_audio_processor_destroy(IntPtr proc) (defined in WebRTCAudioLib) | WebRTCAudioLib
webrtc_audio_processor_init(IntPtr proc) (defined in WebRTCAudioLib) | WebRTCAudioLib
webrtc_audio_processor_process(IntPtr proc, short[] buffer, int offset, out bool voiceDetected) (defined in WebRTCAudioLib) | WebRTCAudioLib
webrtc_audio_processor_process_reverse(IntPtr proc, short[] buffer, int bufferSize) (defined in WebRTCAudioLib) | WebRTCAudioLib
webrtc_audio_processor_set_param(IntPtr proc, int param, int v) (defined in WebRTCAudioLib) | WebRTCAudioLib


Photon Voice: WebRTCAudioProcessor Class Reference

  • WebRTCAudioProcessor
Public Member Functions | Static Public Attributes | Properties | List of all members
WebRTCAudioProcessor Class Reference

Inherits WebRTCAudioLib, and IProcessor< short >.

Public Member Functions

WebRTCAudioProcessor (ILogger logger, int frameSize, int samplingRate, int channels, int reverseSamplingRate, int reverseChannels)
short[] | Process (short[] buf)
void | OnAudioOutFrameFloat (float[] data)
void | Dispose ()
- Public Member Functions inherited from WebRTCAudioLib
static IntPtr | webrtc_audio_processor_create (int samplingRate, int channels, int frameSize, int revSamplingRate, int revChannels)
static int | webrtc_audio_processor_init (IntPtr proc)
static int | webrtc_audio_processor_set_param (IntPtr proc, int param, int v)
static int | webrtc_audio_processor_process (IntPtr proc, short[] buffer, int offset, out bool voiceDetected)
static int | webrtc_audio_processor_process_reverse (IntPtr proc, short[] buffer, int bufferSize)
static void | webrtc_audio_processor_destroy (IntPtr proc)
- Public Member Functions inherited from IProcessor< short >
T[] | Process (T[] buf)
Process a frame of data. More...

Static Public Attributes

static readonly int[] SupportedSamplingRates = { 8000, 16000, 32000, 48000 }

Properties

int | AECStreamDelayMs [set]
bool?? | AEC [set]
bool? | AECHighPass [set]
bool?? | AECMobile [set]
bool? | HighPass [set]
bool? | NoiseSuppression [set]
bool? | AGC [set]
int | AGCCompressionGain [set]
int | AGCTargetLevel [set]
bool? | AGC2 [set]
bool? | VAD [set]
bool | Bypass [set]

Additional Inherited Members

- Public Types inherited from WebRTCAudioLib
enum | Error
enum | Param


Photon Voice: Member List

  • WebRTCAudioProcessor
WebRTCAudioProcessor Member List

This is the complete list of members for WebRTCAudioProcessor, including all inherited members.

AEC (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AECHighPass (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AECMobile (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AECStreamDelayMs (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AGC (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AGC2 (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AGCCompressionGain (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AGCTargetLevel (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
Bypass (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
Dispose() (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
Error enum name (defined in WebRTCAudioLib) | WebRTCAudioLib |
HighPass (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
NoiseSuppression (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
OnAudioOutFrameFloat(float[] data) (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
Param enum name (defined in WebRTCAudioLib) | WebRTCAudioLib |
Process(short[] buf) (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
IProcessor< short >.Process(T[] buf) | IProcessor< short > |
SupportedSamplingRates (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor | static
VAD (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
webrtc_audio_processor_create(int samplingRate, int channels, int frameSize, int revSamplingRate, int revChannels) (defined in WebRTCAudioLib) | WebRTCAudioLib |
webrtc_audio_processor_destroy(IntPtr proc) (defined in WebRTCAudioLib) | WebRTCAudioLib |
webrtc_audio_processor_init(IntPtr proc) (defined in WebRTCAudioLib) | WebRTCAudioLib |
webrtc_audio_processor_process(IntPtr proc, short[] buffer, int offset, out bool voiceDetected) (defined in WebRTCAudioLib) | WebRTCAudioLib |
webrtc_audio_processor_process_reverse(IntPtr proc, short[] buffer, int bufferSize) (defined in WebRTCAudioLib) | WebRTCAudioLib |
webrtc_audio_processor_set_param(IntPtr proc, int param, int v) (defined in WebRTCAudioLib) | WebRTCAudioLib |
WebRTCAudioProcessor(ILogger logger, int frameSize, int samplingRate, int channels, int reverseSamplingRate, int reverseChannels) (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |


Photon Voice: Class Index

Class Index
a | b | c | d | e | f | g | i | l | m | o | p | r | s | t | u | v | w
a
d
IDeviceEnumerator (Photon.Voice) MonoPInvokeCallbackAttribute (Photon.Voice) AudioUtil.ToneAudioReader (Photon.Voice)
IEncoder (Photon.Voice)
o
u
AndroidAudioInAEC (Photon.Voice.Unity) OpusCodec.Decoder (Photon.Voice) IEncoderDirect (Photon.Voice)
AndroidAudioInParameters (Photon.Voice.Unity) RawCodec.Decoder (Photon.Voice) IEncoderDirectImage (Photon.Voice) ObjectFactory (Photon.Voice) UnityAudioOut (Photon.Voice.Unity)
AudioChangesHandler (Photon.Voice.Unity) DecoderConfigFrame (Photon.Voice) AudioUtil.ILevelMeter (Photon.Voice) ObjectPool (Photon.Voice) UnityLogger (Photon.Voice.Unity)
AudioClipWrapper (Photon.Voice.Unity) DeviceEnumerator (Photon.Voice.UWP) ILocalVoiceAudio (Photon.Voice) OpusCodec (Photon.Voice) UnityMicrophone (Photon.Voice.Unity)
AudioDesc (Photon.Voice) DeviceEnumeratorBase (Photon.Voice) ILogger (Photon.Voice)
p
UnityVoiceClient (Photon.Voice.Unity)
AudioInChangeNotifier (Photon.Voice.MacOS) DeviceFeatures (Photon.Voice) ImageBufferInfo (Photon.Voice) UnsupportedCodecException (Photon.Voice)
AudioInChangeNotifier (Photon.Voice.IOS) DeviceInfo (Photon.Voice) ImageBufferNative (Photon.Voice) PhotonAppSettings (Photon.Voice) UnsupportedPlatformException (Photon.Voice)
AudioInChangeNotifierNotSupported (Photon.Voice) RecorderPreset.DSP (Photon.Voice.Unity) ImageBufferNativeAlloc (Photon.Voice) PhotonVoiceCreatedParams (Photon.Voice.Unity) UnsupportedSampleTypeException (Photon.Voice)
AudioInEnumerator (Photon.Voice.FMOD)
e
ImageBufferNativeGCHandleBytes (Photon.Voice) PhotonVoiceLagSimulationGui (Photon.Voice.Unity.UtilityScripts) OpusCodec.Util (Photon.Voice)
AudioInEnumerator (Photon.Voice.MacOS) ImageBufferNativeGCHandleSinglePlane (Photon.Voice) PhotonVoiceStatsGui (Photon.Voice.Unity.UtilityScripts)
v
AudioInEnumerator (Photon.Voice.Unity) OpusCodec.Encoder (Photon.Voice) ImageBufferNativePool (Photon.Voice) PhotonVoiceView (Photon.Voice.PUN)
AudioInEnumerator (Photon.Voice.UWP) RawCodec.Encoder (Photon.Voice) IProcessor (Photon.Voice) ImageBufferNative.PlaneSet (Photon.Voice) VideoInEnumerator (Photon.Voice.UWP)
AudioInEnumerator (Photon.Voice.Windows) OpusCodec.EncoderFloat (Photon.Voice) IResettable (Photon.Voice) Platform (Photon.Voice) VideoInEnumerator (Photon.Voice.Unity)
AudioInPusher (Photon.Voice.IOS) OpusCodec.EncoderShort (Photon.Voice) IServiceable (Photon.Voice) AudioOutDelayControl.PlayDelayConfig (Photon.Voice) VoiceClient (Photon.Voice)
AudioInPusher (Photon.Voice.MacOS)
f
AudioUtil.IVoiceDetector (Photon.Voice) PrimitiveArrayPool (Photon.Voice) VoiceComponent (Photon.Voice.Unity)
AudioInPusher (Photon.Voice.UWP) IVoiceTransport (Photon.Voice) PunVoiceClient (Photon.Voice.PUN) VoiceComponentImpl (Photon.Voice.Unity)
AudioInReader (Photon.Voice.IOS) OpusCodec.Factory (Photon.Voice)
l
r
VoiceConnection (Photon.Voice.Unity)
AudioInReader (Photon.Voice.FMOD) FactoryPrimitiveArrayPool (Photon.Voice) VoiceCreateOptions (Photon.Voice)
AudioInReader (Photon.Voice.MacOS) FactoryReusableArray (Photon.Voice) AudioUtil.LevelMeter (Photon.Voice) RawCodec (Photon.Voice) VoiceDebugScript (Photon.Voice.PUN.UtilityScripts)
AudioOut (Photon.Voice.FMOD) Flip (Photon.Voice) AudioUtil.LevelMeterDummy (Photon.Voice) Recorder (Photon.Voice.Unity) AudioUtil.VoiceDetector (Photon.Voice)
AudioOutCapture (Photon.Voice.Unity) FMODRecorderSetup (Photon.Voice.Unity.FMOD) AudioUtil.LevelMeterFloat (Photon.Voice) RecorderPreset (Photon.Voice.Unity) AudioUtil.VoiceDetectorCalibration (Photon.Voice)
AudioOutDelayControl (Photon.Voice) FrameBuffer (Photon.Voice) AudioUtil.LevelMeterShort (Photon.Voice) RemoteVoiceInfo (Photon.Voice) AudioUtil.VoiceDetectorDummy (Photon.Voice)
AudioOutDelayControl (Photon.Voice) FrameOut (Photon.Voice) LoadBalancingTransport (Photon.Voice) RemoteVoiceLink (Photon.Voice.Unity) AudioUtil.VoiceDetectorFloat (Photon.Voice)
AudioOutDummy (Photon.Voice) Framer (Photon.Voice) LoadBalancingTransport2 (Photon.Voice) RemoteVoiceOptions (Photon.Voice) AudioUtil.VoiceDetectorShort (Photon.Voice)
AudioOutEvent (Photon.Voice.FMOD) FramerResampler (Photon.Voice) LocalVoice (Photon.Voice) AudioUtil.Resampler (Photon.Voice) VoiceEvent (Photon.Voice)
AudioSessionParameters (Photon.Voice.IOS) FusionVoiceClient (Photon.Voice.Fusion) LocalVoiceAudio (Photon.Voice)
s
VoiceFollowClient (Photon.Voice)
AudioSessionParametersPresets (Photon.Voice.IOS)
g
LocalVoiceAudioDummy (Photon.Voice) VoiceInfo (Photon.Voice)
AudioSyncBuffer (Photon.Voice) LocalVoiceAudioFloat (Photon.Voice) SaveIncomingStreamToFile (Photon.Voice.Unity.UtilityScripts) AudioUtil.VoiceLevelDetectCalibrate (Photon.Voice)
AudioUtil (Photon.Voice) AudioUtil.GeneratorPusher (Photon.Voice) LocalVoiceAudioShort (Photon.Voice) SaveOutgoingStreamToFile (Photon.Voice.Unity.UtilityScripts) VoiceLogger (Photon.Voice.Unity)
b
AudioUtil.GeneratorReader (Photon.Voice) LocalVoiceFramed (Photon.Voice) SendFrameParams (Photon.Voice) VoiceNetworkObject (Photon.Voice.Fusion)
i
Logger (Photon.Voice.Unity) RawCodec.ShortToFloat (Photon.Voice)
w
BufferReaderPushAdapterAsyncPool (Photon.Voice)
m
Speaker (Photon.Voice.Unity)
BufferReaderPushAdapterAsyncPoolFloatToShort (Photon.Voice) IAudioDesc (Photon.Voice) SpeakerAudioFilterRead (Photon.Voice.Unity) AudioUtil.WaveformAudioPusher (Photon.Voice)
BufferReaderPushAdapterAsyncPoolShortToFloat (Photon.Voice) IAudioInChangeNotifier (Photon.Voice) MicAmplifier (Photon.Voice.Unity.UtilityScripts) SpeakerFMOD (Photon.Voice.Unity.FMOD) AudioUtil.WaveformAudioReader (Photon.Voice)
BufferReaderPushAdapterBase (Photon.Voice) IAudioOut (Photon.Voice) MicAmplifierFloat (Photon.Voice.Unity.UtilityScripts) ImageBufferInfo.StrideSet (Photon.Voice) WaveWriter (Photon.Voice.Unity.UtilityScripts)
c
IAudioPusher (Photon.Voice) MicAmplifierShort (Photon.Voice.Unity.UtilityScripts)
t
WebRtcAudioDsp (Photon.Voice.Unity)
IAudioReader (Photon.Voice) MicrophonePermission (Photon.Voice.Unity.UtilityScripts) WebRTCAudioLib (Photon.Voice)
CaptureDevice (Photon.Voice.UWP) IDataReader (Photon.Voice) MicWrapper (Photon.Voice.Unity) AudioUtil.TempoUp (Photon.Voice) WebRTCAudioProcessor (Photon.Voice)
ConnectAndJoin (Photon.Voice.Unity.UtilityScripts) IDecoder (Photon.Voice) MicWrapperPusher (Photon.Voice.Unity) TestTone (Photon.Voice.Unity.UtilityScripts) WindowsAudioInPusher (Photon.Voice.Windows)
VoiceClient.CreateOptions (Photon.Voice) IDecoderDirect (Photon.Voice) MicWrapperPusherOnAudioFilterRead (Photon.Voice.Unity) AudioUtil.ToneAudioPusher (Photon.Voice)
a | b | c | d | e | f | g | i | l | m | o | p | r | s | t | u | v | w


Photon Voice: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 12345]
C AndroidAudioInParameters |
►C Attribute |
C MonoPInvokeCallbackAttribute |
►C AudioOutDelayControl |
C AudioOutDelayControl< T > |
►C AudioOutDelayControl< float > |
C UnityAudioOut |
►C AudioOutDelayControl< T > |
C AudioSyncBuffer< T > |
►C AudioOut< T > |
C AudioOutEvent< T > |
C AudioSessionParameters |
C AudioSessionParametersPresets |
C AudioSyncBuffer< float > |
C AudioUtil | Collection of Audio Utility functions and classes
►C BufferReaderPushAdapterBase< float > |
C BufferReaderPushAdapterAsyncPoolFloatToShort | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting float samples to short
►C BufferReaderPushAdapterBase< short > |
C BufferReaderPushAdapterAsyncPoolShortToFloat | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting short samples to float
C CaptureDevice |
►C ConnectionHandler |
►C VoiceConnection | Component that represents a Voice client
C UnityVoiceClient | Component that represents a Voice client and manages a simple Unity integration: a single Recorder and multiple remote speakers
►C VoiceFollowClient | This class can be used to automatically sync client states between Leader and Voice clients
C FusionVoiceClient |
C PunVoiceClient | This class can be used to automatically sync client states between PUN and Voice. It also finds the Speaker component for a character's voice. For this to work attach a PhotonVoiceView next to the PhotonView of your player's prefab
C VoiceClient.CreateOptions |
C DeviceFeatures |
C DeviceInfo |
C RecorderPreset.DSP |
►C OpusCodec.Encoder< float > |
C OpusCodec.EncoderFloat |
►C OpusCodec.Encoder< short > |
C OpusCodec.EncoderShort |
►C Exception |
C UnsupportedCodecException | Exception thrown if an unsupported codec is encountered
C UnsupportedPlatformException | Exception thrown if an unsupported platform is encountered
C UnsupportedSampleTypeException | Exception thrown if an unsupported audio sample type is encountered
C OpusCodec.Factory |
C FactoryPrimitiveArrayPool< short > |
C Flip |
C FrameBuffer |
C FrameOut< T > |
►C Framer< T > | Utility class to re-frame packets
C FramerResampler< T > |
C Framer< float > |
►C IAudioOut< T > |
C AudioOutDelayControl< T > |
C AudioOutDummy< T > |
C IAudioOut< float > |
►C IAudioPusher< float > |
C AudioInPusher |
C AudioInPusher |
C MicWrapperPusher |
►C IAudioPusher< short > |
C AndroidAudioInAEC |
C AudioInPusher |
C WindowsAudioInPusher |
►C IAudioReader< float > |
C AudioInReader |
C AudioInReader |
C AudioClipWrapper |
C MicWrapper |
►C IConnectionCallbacks |
C ConnectAndJoin |
►C IDisposable |
C DecoderConfigFrame | Stores the config frame and prevents other frames decoding until the decoder is ready
►C IAudioDesc | Audio Source interface
C AudioDesc |
►C IAudioPusher< T > | Audio Pusher interface
►C AudioUtil.GeneratorPusher< T > | IAudioPusher that provides a constant tone signal
C AudioUtil.ToneAudioPusher< T > | IAudioPusher that provides a constant tone signal
C AudioUtil.WaveformAudioPusher< T > | IAudioPusher that provides the given waveform
►C IAudioReader< T > | Audio Reader interface
►C AudioUtil.GeneratorReader< T > |
C AudioUtil.ToneAudioReader< T > | IAudioReader that provides a constant tone signal
C AudioUtil.WaveformAudioReader< T > | IAudioReader that provides the given waveform
C AudioInReader< T > |
►C IAudioInChangeNotifier |
C AudioInChangeNotifierNotSupported |
C AudioInChangeNotifier |
C AudioInChangeNotifier |
►C IDataReader< T > | Interface for pulling data, in case this is more appropriate than pushing it
C IAudioReader< T > | Audio Reader interface
►C IDecoder | Generic decoder interface
C IDecoderDirect< B > | Interface for an decoder which outputs data via explicit call
C OpusCodec.Decoder< T > |
C RawCodec.Decoder< T > |
►C IDeviceEnumerator |
►C DeviceEnumeratorBase |
C AudioInEnumerator |
C AudioInEnumerator | Enumerates microphones available on device
C AudioInEnumerator |
C VideoInEnumerator |
►C DeviceEnumerator |
C AudioInEnumerator |
C VideoInEnumerator |
C AudioInEnumerator | Enumerates microphones available on device
►C IEncoder | Generic encoder interface
C IEncoderDirect< B > | Interface for an encoder which consumes input data via explicit call
C ImageBufferNativeAlloc |
C ImageBufferNativeGCHandleBytes |
C ImageBufferNativeGCHandleSinglePlane |
►C IProcessor< T > | Processor interface
C AudioUtil.LevelMeter< T > | Audio Level Meter
C AudioUtil.Resampler< T > | Sample-rate conversion Audio Processor
C AudioUtil.VoiceDetector< T > | Simple voice activity detector triggered by signal level
C AudioUtil.VoiceDetectorCalibration< T > | Calibration Utility for Voice Detector
C AudioUtil.VoiceLevelDetectCalibrate< T > | Utility Audio Processor Voice Detection Calibration
►C LoadBalancingTransport | Extends LoadBalancingClient with media streaming functionality
C LoadBalancingTransport2 | Variant of LoadBalancingTransport. Aims to be non-alloc at the cost of breaking compatibility with older clients
►C LocalVoice | Represents outgoing data stream
C LocalVoiceAudioDummy | Dummy LocalVoiceAudio
►C LocalVoiceFramed< T > | Typed re-framing LocalVoice
C LocalVoiceAudio< T > | Outgoing audio stream
C ObjectFactory< TType, TInfo > | Uniform interface to ObjectPool<TType, TInfo> and single reusable object
C ObjectPool< TType, TInfo > | Generic Pool to re-use objects of a certain type (TType) that optionally match a certain property or set of properties (TInfo)
C WaveWriter |
C VoiceClient | Voice client interact with other clients on network via IVoiceTransport
►C IEncoderDirect< ImageBufferNative > |
C IEncoderDirectImage | Interface for an encoder which consumes images via explicit call
►C IEncoderDirect< T[]> |
C OpusCodec.Encoder< T > |
C RawCodec.Encoder< T > |
►C IEnumerable |
C IDeviceEnumerator |
►C AudioUtil.ILevelMeter | Audio Level Metering interface
C AudioUtil.LevelMeter< T > | Audio Level Meter
C AudioUtil.LevelMeterDummy | Dummy Audio Level Meter that doesn't actually do anything
►C ILocalVoiceAudio | Interface for an outgoing audio stream
C LocalVoiceAudio< T > | Outgoing audio stream
C LocalVoiceAudioDummy | Dummy LocalVoiceAudio
►C ILogger |
C Logger |
C ImageBufferInfo |
►C ImageBufferNative |
C ImageBufferNativeAlloc |
C ImageBufferNativeGCHandleBytes |
C ImageBufferNativeGCHandleSinglePlane |
C ImageBufferNativePool< Photon.Voice.ImageBufferNativeAlloc > |
C ImageBufferNativePool< Photon.Voice.ImageBufferNativeGCHandleBytes > |
C ImageBufferNativePool< Photon.Voice.ImageBufferNativeGCHandleSinglePlane > |
►C IMatchmakingCallbacks |
C ConnectAndJoin |
►C INetworkRunnerCallbacks |
C FusionVoiceClient |
►C IProcessor< float > |
C MicAmplifierFloat |
►C IProcessor< short > |
C MicAmplifierShort |
C WebRTCAudioProcessor |
►C IResettable |
C AudioInPusher |
C AudioInReader |
C AndroidAudioInAEC |
►C IServiceable | Interface for classes that want their Service() function to be called regularly in the context of a LocalVoice
►C BufferReaderPushAdapterBase< T > | Adapter base reading data from IDataReader<T>.Read and pushing it to LocalVoice
C BufferReaderPushAdapterAsyncPool< T > | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync
►C AudioUtil.IVoiceDetector | Voice Activity Detector interface
C AudioUtil.VoiceDetector< T > | Simple voice activity detector triggered by signal level
C AudioUtil.VoiceDetectorDummy | Dummy VoiceDetector that doesn't actually do anything
►C IVoiceTransport |
C LoadBalancingTransport | Extends LoadBalancingClient with media streaming functionality
►C AudioUtil.LevelMeter< float > |
C AudioUtil.LevelMeterFloat | LevelMeter specialization for float audio
►C AudioUtil.LevelMeter< short > |
C AudioUtil.LevelMeterShort | LevelMeter specialization for short audio
►C LoadBalancingClient |
C LoadBalancingTransport | Extends LoadBalancingClient with media streaming functionality
►C LocalVoiceAudio< float > |
C LocalVoiceAudioFloat | Specialization of LocalVoiceAudio<T> for float audio
►C LocalVoiceAudio< short > |
C LocalVoiceAudioShort | Specialization of LocalVoiceAudio<T> for short audio
►C MonoBehaviour |
C AudioOutCapture |
C MicWrapperPusherOnAudioFilterRead |
C ConnectAndJoin |
C PhotonVoiceLagSimulationGui |
C PhotonVoiceStatsGui | Basic GUI to show traffic and health statistics of the connection to Photon, toggled by shift+tab
C TestTone |
►C VoiceComponent |
C PhotonVoiceView | Component that should be attached to a networked PUN prefab that has PhotonView. It will bind remote Recorder with local Speaker of the same networked prefab. This component makes automatic voice stream routing easy for players' characters/avatars
C AudioChangesHandler | This component is useful to handle audio device and config changes
C FMODRecorderSetup |
C Recorder | Component representing outgoing audio stream in scene
C RecorderPreset |
►C Speaker |
C SpeakerFMOD |
C SpeakerAudioFilterRead |
C MicAmplifier |
C MicrophonePermission | Helper to request Microphone permission on Android or iOS
C SaveIncomingStreamToFile |
C SaveOutgoingStreamToFile |
C WebRtcAudioDsp |
C VoiceLogger |
►C MonoBehaviourPun |
C VoiceDebugScript | Utility script to be attached next to PhotonVoiceView & PhotonView on the player prefab to be network instantiated. Call voiceDebugScript.CantHearYou() on the networked object of the remote (or local) player if you can't hear the corresponding player
►C NetworkBehaviour |
C VoiceNetworkObject |
C ObjectFactory< float[], int > |
C ObjectFactory< short[], int > |
►C ObjectFactory< T[], int > |
C FactoryPrimitiveArrayPool< T > | PrimitiveArrayPool<T> as wrapped in object factory interface
C FactoryReusableArray< T > | Array factory returnig the same array instance as long as it requested with the same array length. If length changes, new array instance created
►C ObjectPool< T, ImageBufferInfo > |
C ImageBufferNativePool< T > |
►C ObjectPool< T[], int > |
C PrimitiveArrayPool< T > | Pool of Arrays with components of type T, with ObjectPool info being the array's size
C OpusCodec |
C PhotonVoiceCreatedParams |
C ImageBufferNative.PlaneSet |
C Platform |
C AudioOutDelayControl.PlayDelayConfig |
C RawCodec |
C RemoteVoiceInfo | Information about a remote voice (incoming stream)
C RemoteVoiceLink |
C RemoteVoiceOptions | Event Actions and other options for a remote voice (incoming stream)
►C ScriptableObject |
C PhotonAppSettings | Collection of connection-relevant settings, used internally by PhotonNetwork.ConnectUsingSettings
C SendFrameParams |
C RawCodec.ShortToFloat |
C ImageBufferInfo.StrideSet |
C AudioUtil.TempoUp< T > |
C UnityLogger |
C UnityMicrophone | A wrapper around UnityEngine.Microphone to be able to safely use Microphone and compile for WebGL
C OpusCodec.Util |
C VoiceComponentImpl |
C VoiceCreateOptions | Used to initialize optional properties of the LocalVoice instance at creation time
►C AudioUtil.VoiceDetector< float > |
C AudioUtil.VoiceDetectorFloat | VoiceDetector specialization for float audio
►C AudioUtil.VoiceDetector< short > |
C AudioUtil.VoiceDetectorShort | VoiceDetector specialization for float audio
C VoiceEvent |
C VoiceInfo | Describes stream properties
►C WebRTCAudioLib |
C WebRTCAudioProcessor |


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • AccumAvgPeakAmp : AudioUtil.ILevelMeter
  • AcquireOrCreate() : ObjectPool< TType, TInfo >
  • ActivityDelayMs : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • AddPostProcessor() : LocalVoiceFramed< T >
  • AddPreProcessor() : LocalVoiceFramed< T >
  • AddSpeaker() : VoiceConnection
  • AudioClip : Recorder
  • AutoConnectAndJoin : VoiceFollowClient


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • BestRegionSummaryInPreferences : VoiceConnection
  • Bitrate : Recorder , VoiceInfo
  • BufferFactory : LocalVoiceFramed< T >
  • BufferReaderPushAdapterAsyncPool() : BufferReaderPushAdapterAsyncPool< T >
  • BufferReaderPushAdapterAsyncPoolFloatToShort() : BufferReaderPushAdapterAsyncPoolFloatToShort
  • BufferReaderPushAdapterAsyncPoolShortToFloat() : BufferReaderPushAdapterAsyncPoolShortToFloat
  • BufferReaderPushAdapterBase() : BufferReaderPushAdapterBase< T >


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • Calibrate() : AudioUtil.VoiceDetectorCalibration< T > , AudioUtil.VoiceLevelDetectCalibrate< T >
  • CaptureSource : CaptureDevice
  • ChannelAudio : VoiceConnection
  • ChannelId : RemoteVoiceInfo
  • Channels : IAudioDesc , AudioInPusher , VoiceInfo
  • ChannelVideo : VoiceConnection
  • CleanUpAsync() : CaptureDevice
  • ClearProcessors() : LocalVoiceFramed< T >
  • ClientState : VoiceConnection
  • Code : VoiceEvent
  • ConnectAndJoinRoom() : VoiceFollowClient
  • ConnectUsingSettings() : UnityVoiceClient , VoiceConnection
  • Convert() : AudioUtil
  • CreateAudio() : VoiceInfo
  • CreateAudioOpus() : VoiceInfo
  • CreateLocalVoice() : VoiceClient
  • CreateLocalVoiceAudioFromSource() : VoiceClient
  • CreateLocalVoiceVideo() : VoiceClient
  • CreateVideo() : VoiceInfo
  • CurrentAvgAmp : AudioUtil.ILevelMeter
  • CurrentPeakAmp : AudioUtil.ILevelMeter


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • DebugEchoMode : LocalVoice , Recorder , VoiceCreateOptions
  • DebugLostPercent : VoiceClient
  • Decoder : RemoteVoiceOptions
  • DequeueOutput() : IEncoder
  • Detected : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • DetectedTime : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • DisableVad : VoiceDebugScript
  • Disconnect() : VoiceFollowClient
  • Dispose() : BufferReaderPushAdapterBase< T > , AudioInChangeNotifier , LoadBalancingTransport , LocalVoiceFramed< T > , AudioInChangeNotifier , AudioInEnumerator , ObjectPool< TType, TInfo > , AudioInEnumerator
  • Dummy : LocalVoiceAudioDummy


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • Encoder : VoiceCreateOptions
  • Encrypt : LocalVoice , Recorder , VoiceCreateOptions
  • EndOfStream() : IEncoder
  • Error : IAudioDesc , IDecoder , IEncoder , AudioInChangeNotifier
  • EventsLost : VoiceClient


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • FEC : LocalVoice , VoiceCreateOptions
  • ForceRecordingAndTransmission : VoiceDebugScript
  • ForceToStereo< T >() : AudioUtil
  • FPS : VoiceInfo
  • Fragment : LocalVoice , VoiceCreateOptions
  • Frame() : Framer< T > , FramerResampler< T >
  • FrameDuration : Recorder
  • FrameDurationSamples : VoiceInfo
  • FrameDurationUs : VoiceInfo
  • Framer() : Framer< T >
  • FramesFragPart : VoiceClient
  • FrameSize : VoiceInfo
  • FramesLate : VoiceClient
  • FramesLost : VoiceClient
  • FramesLostPercent : VoiceConnection
  • FramesLostPerSecond : VoiceConnection
  • FramesReceived : VoiceClient
  • FramesReceivedFEC : VoiceClient
  • FramesReceivedFragmented : VoiceClient
  • FramesReceivedFragments : VoiceClient
  • FramesReceivedPerSecond : VoiceConnection
  • FramesRecovered : VoiceClient
  • FramesSent : LocalVoice , VoiceClient
  • FramesSentBytes : LocalVoice , VoiceClient
  • FramesSentFragmented : LocalVoice
  • FramesSentFragments : LocalVoice
  • FramesTryFEC : VoiceClient


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GetPlatformAPI< I >() : IEncoder


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HandleDeviceChange : AudioChangesHandler
  • HandleDeviceChangeAndroid : AudioChangesHandler
  • HandleDeviceChangeIOS : AudioChangesHandler
  • Height : VoiceInfo


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • ImageFormat : IEncoderDirectImage
  • IncreaseLogLevels : VoiceDebugScript
  • Info : LocalVoice , ObjectPool< TType, TInfo > , RemoteVoiceInfo
  • Init() : ObjectPool< TType, TInfo >
  • Input() : IDecoder , IEncoderDirect< B > , OpusCodec.Decoder< T > , RawCodec.Decoder< T >
  • InputFactory : Recorder
  • Instance : PunVoiceClient
  • InstantiateSpeakerPrefab() : VoiceConnection
  • InterestGroup : LocalVoice , Recorder , VoiceCreateOptions
  • IsCurrentlyTransmitting : LocalVoice , Recorder
  • IsLinked : Speaker
  • IsPlaying : Speaker
  • IsRecording : VoiceNetworkObject , PhotonVoiceView
  • IsSpeaking : VoiceNetworkObject , PhotonVoiceView


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • KeyFrameInt : VoiceInfo


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • Lag : Speaker
  • LevelMeter : AudioUtil.VoiceLevelDetectCalibrate< T > , ILocalVoiceAudio , Recorder
  • LevelMeterFloat() : AudioUtil.LevelMeterFloat
  • LevelMeterShort() : AudioUtil.LevelMeterShort
  • LoadBalancingTransport() : LoadBalancingTransport
  • LocalDebug : VoiceDebugScript
  • LocalUserServiceable : LocalVoice
  • LocalVoices : VoiceClient
  • LocalVoicesInChannel() : VoiceClient
  • LoopAudioClip : Recorder


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • MicrophoneType : Recorder


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • ObjectPool() : ObjectPool< TType, TInfo >
  • On : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • OnDetected : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • OnRemoteVoiceInfoAction : VoiceClient
  • OnRemoteVoiceRemoveAction : RemoteVoiceOptions , Speaker
  • Open() : IDecoder , OpusCodec.Decoder< T > , RawCodec.Decoder< T >
  • Output : IDecoderDirect< B > , IEncoder


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • PlayDelay : Speaker
  • PlayDelayConfig : Speaker
  • PlayerId : RemoteVoiceInfo
  • PrimaryRecorder : VoiceConnection
  • Process() : AudioUtil.LevelMeter< T > , AudioUtil.Resampler< T > , AudioUtil.VoiceDetector< T > , AudioUtil.VoiceDetectorCalibration< T > , AudioUtil.VoiceLevelDetectCalibrate< T > , IProcessor< T >
  • PushData() : LocalVoiceFramed< T >
  • PushDataAsync() : LocalVoiceFramed< T >
  • PushDataAsyncReady : LocalVoiceFramed< T >


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • Read() : AudioUtil.GeneratorReader< T > , AudioInReader< T > , IDataReader< T >
  • RecorderInUse : VoiceNetworkObject , PhotonVoiceView
  • RecordingEnabled : Recorder
  • RecordWhenJoined : Recorder
  • Refresh() : AudioInEnumerator
  • Release() : ObjectPool< TType, TInfo >
  • Reliable : LocalVoice , VoiceCreateOptions
  • ReliableMode : Recorder
  • RemoteVoiceAdded : VoiceConnection
  • RemoteVoiceInfoDelegate() : VoiceClient
  • RemoteVoiceInfos : VoiceClient
  • RemoveLocalVoice() : VoiceClient
  • RemoveProcessor() : LocalVoiceFramed< T >
  • RemoveSelf() : LocalVoice
  • Resample< T >() : AudioUtil
  • ResampleAndConvert() : AudioUtil
  • Resampler() : AudioUtil.Resampler< T >
  • ResetAccumAvgPeakAmp() : AudioUtil.ILevelMeter , AudioUtil.LevelMeter< T > , AudioUtil.LevelMeterDummy
  • ResetLocalAudio() : Recorder
  • RestartPlayback() : Speaker
  • RestartRecording() : Recorder
  • RoundTripTime : VoiceClient
  • RoundTripTimeVariance : VoiceClient


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • SamplingRate : IAudioDesc , Recorder , VoiceInfo
  • SelectPreferredCameraStreamSettingAsync() : CaptureDevice
  • SendSpacingProfileMax : LocalVoice
  • Service() : BufferReaderPushAdapterAsyncPool< T > , BufferReaderPushAdapterAsyncPoolFloatToShort , BufferReaderPushAdapterAsyncPoolShortToFloat , BufferReaderPushAdapterBase< T > , IServiceable , LoadBalancingTransport , VoiceClient
  • SetAndroidNativeMicrophoneSettings() : Recorder
  • SetCallback() : AudioUtil.GeneratorPusher< T > , IAudioPusher< T >
  • SetIosAudioSessionParameters() : Recorder
  • SetOutput() : RemoteVoiceOptions
  • Settings : VoiceConnection
  • SourceType : Recorder
  • SpeakerInUse : VoiceNetworkObject , PhotonVoiceView
  • SpeakerLinked : VoiceConnection
  • SpeakerPrefab : VoiceConnection
  • StartRecordingAsync() : CaptureDevice
  • StopRecordingAsync() : CaptureDevice
  • StopRecordingWhenPaused : Recorder
  • SuppressInfoDuplicateWarning : VoiceClient


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TargetPlayers : LocalVoice , Recorder , VoiceCreateOptions
  • TestAudioClip : VoiceDebugScript
  • TestUsingAudioClip : VoiceDebugScript
  • Threshold : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • ToneAudioPusher() : AudioUtil.ToneAudioPusher< T >
  • ToneAudioReader() : AudioUtil.ToneAudioReader< T >
  • ToString() : PhotonAppSettings
  • TransmitEnabled : LocalVoice , Recorder
  • TryConfigure() : DecoderConfigFrame


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • UnsupportedCodecException() : UnsupportedCodecException
  • UnsupportedPlatformException() : UnsupportedPlatformException
  • UnsupportedSampleTypeException() : UnsupportedSampleTypeException
  • UseCloud() : PhotonAppSettings
  • UseFusionAppSettings : FusionVoiceClient
  • UseFusionAuthValues : FusionVoiceClient
  • UseMicrophoneTypeFallback : Recorder
  • UseOnAudioFilterRead : Recorder
  • UsePrimaryRecorder : VoiceConnection
  • UsePunAppSettings : PunVoiceClient
  • UsePunAuthValues : PunVoiceClient
  • UserData : Recorder , VoiceInfo
  • UseVoiceAppSettings : UnityVoiceClient


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • VoiceClient : LoadBalancingTransport , VoiceConnection , VoiceClient
  • VoiceDetection : Recorder
  • VoiceDetectionDelayMs : Recorder
  • VoiceDetectionThreshold : Recorder
  • VoiceDetector : AudioUtil.VoiceLevelDetectCalibrate< T > , ILocalVoiceAudio , Recorder
  • VoiceDetectorCalibrate() : ILocalVoiceAudio , LocalVoiceAudio< T > , LocalVoiceAudioDummy , Recorder
  • VoiceDetectorCalibrating : ILocalVoiceAudio , LocalVoiceAudio< T > , Recorder
  • VoiceDetectorCalibration() : AudioUtil.VoiceDetectorCalibration< T >
  • VoiceDetectorFloat() : AudioUtil.VoiceDetectorFloat
  • VoiceDetectorShort() : AudioUtil.VoiceDetectorShort
  • VoiceId : RemoteVoiceInfo
  • VoiceLevelDetectCalibrate() : AudioUtil.VoiceLevelDetectCalibrate< T >
  • VoiceRoomNameSuffix : PunVoiceClient


Photon Voice: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • Width : VoiceInfo


Photon Voice: Class Members - Functions

- a -

  • AcquireOrCreate() : ObjectPool< TType, TInfo >
  • AddPostProcessor() : LocalVoiceFramed< T >
  • AddPreProcessor() : LocalVoiceFramed< T >
  • AddSpeaker() : VoiceConnection

- b -

  • BufferReaderPushAdapterAsyncPool() : BufferReaderPushAdapterAsyncPool< T >
  • BufferReaderPushAdapterAsyncPoolFloatToShort() : BufferReaderPushAdapterAsyncPoolFloatToShort
  • BufferReaderPushAdapterAsyncPoolShortToFloat() : BufferReaderPushAdapterAsyncPoolShortToFloat
  • BufferReaderPushAdapterBase() : BufferReaderPushAdapterBase< T >

- c -

  • Calibrate() : AudioUtil.VoiceDetectorCalibration< T > , AudioUtil.VoiceLevelDetectCalibrate< T >
  • CleanUpAsync() : CaptureDevice
  • ClearProcessors() : LocalVoiceFramed< T >
  • ConnectAndJoinRoom() : VoiceFollowClient
  • ConnectUsingSettings() : UnityVoiceClient , VoiceConnection
  • Convert() : AudioUtil
  • CreateAudio() : VoiceInfo
  • CreateAudioOpus() : VoiceInfo
  • CreateLocalVoice() : VoiceClient
  • CreateLocalVoiceAudioFromSource() : VoiceClient
  • CreateLocalVoiceVideo() : VoiceClient
  • CreateVideo() : VoiceInfo

- d -

  • DequeueOutput() : IEncoder
  • Disconnect() : VoiceFollowClient
  • Dispose() : BufferReaderPushAdapterBase< T > , AudioInChangeNotifier , LoadBalancingTransport , LocalVoiceFramed< T > , AudioInChangeNotifier , AudioInEnumerator , ObjectPool< TType, TInfo > , AudioInEnumerator

- e -

  • EndOfStream() : IEncoder

- f -

  • ForceToStereo< T >() : AudioUtil
  • Frame() : Framer< T > , FramerResampler< T >
  • Framer() : Framer< T >

- g -

  • GetPlatformAPI< I >() : IEncoder

- i -

  • Init() : ObjectPool< TType, TInfo >
  • Input() : IDecoder , IEncoderDirect< B > , OpusCodec.Decoder< T > , RawCodec.Decoder< T >
  • InstantiateSpeakerPrefab() : VoiceConnection

- l -

  • LevelMeterFloat() : AudioUtil.LevelMeterFloat
  • LevelMeterShort() : AudioUtil.LevelMeterShort
  • LoadBalancingTransport() : LoadBalancingTransport
  • LocalVoicesInChannel() : VoiceClient

- o -

  • ObjectPool() : ObjectPool< TType, TInfo >
  • Open() : IDecoder , OpusCodec.Decoder< T > , RawCodec.Decoder< T >

- p -

  • Process() : AudioUtil.LevelMeter< T > , AudioUtil.Resampler< T > , AudioUtil.VoiceDetector< T > , AudioUtil.VoiceDetectorCalibration< T > , AudioUtil.VoiceLevelDetectCalibrate< T > , IProcessor< T >
  • PushData() : LocalVoiceFramed< T >
  • PushDataAsync() : LocalVoiceFramed< T >

- r -

  • Read() : AudioUtil.GeneratorReader< T > , AudioInReader< T > , IDataReader< T >
  • Refresh() : AudioInEnumerator
  • Release() : ObjectPool< TType, TInfo >
  • RemoteVoiceInfoDelegate() : VoiceClient
  • RemoveLocalVoice() : VoiceClient
  • RemoveProcessor() : LocalVoiceFramed< T >
  • RemoveSelf() : LocalVoice
  • Resample< T >() : AudioUtil
  • ResampleAndConvert() : AudioUtil
  • Resampler() : AudioUtil.Resampler< T >
  • ResetAccumAvgPeakAmp() : AudioUtil.ILevelMeter , AudioUtil.LevelMeter< T > , AudioUtil.LevelMeterDummy
  • ResetLocalAudio() : Recorder
  • RestartPlayback() : Speaker
  • RestartRecording() : Recorder

- s -

  • SelectPreferredCameraStreamSettingAsync() : CaptureDevice
  • Service() : BufferReaderPushAdapterAsyncPool< T > , BufferReaderPushAdapterAsyncPoolFloatToShort , BufferReaderPushAdapterAsyncPoolShortToFloat , BufferReaderPushAdapterBase< T > , IServiceable , LoadBalancingTransport , VoiceClient
  • SetAndroidNativeMicrophoneSettings() : Recorder
  • SetCallback() : AudioUtil.GeneratorPusher< T > , IAudioPusher< T >
  • SetIosAudioSessionParameters() : Recorder
  • SetOutput() : RemoteVoiceOptions
  • StartRecordingAsync() : CaptureDevice
  • StopRecordingAsync() : CaptureDevice

- t -

  • ToneAudioPusher() : AudioUtil.ToneAudioPusher< T >
  • ToneAudioReader() : AudioUtil.ToneAudioReader< T >
  • ToString() : PhotonAppSettings
  • TryConfigure() : DecoderConfigFrame

- u -

  • UnsupportedCodecException() : UnsupportedCodecException
  • UnsupportedPlatformException() : UnsupportedPlatformException
  • UnsupportedSampleTypeException() : UnsupportedSampleTypeException
  • UseCloud() : PhotonAppSettings

- v -

  • VoiceClient() : VoiceClient
  • VoiceDetectorCalibrate() : ILocalVoiceAudio , LocalVoiceAudio< T > , LocalVoiceAudioDummy , Recorder
  • VoiceDetectorCalibration() : AudioUtil.VoiceDetectorCalibration< T >
  • VoiceDetectorFloat() : AudioUtil.VoiceDetectorFloat
  • VoiceDetectorShort() : AudioUtil.VoiceDetectorShort
  • VoiceLevelDetectCalibrate() : AudioUtil.VoiceLevelDetectCalibrate< T >


Photon Voice: Class Members - Variables

  • AutoConnectAndJoin : VoiceFollowClient
  • ChannelAudio : VoiceConnection
  • ChannelVideo : VoiceConnection
  • Code : VoiceEvent
  • DebugEchoMode : VoiceCreateOptions
  • DisableVad : VoiceDebugScript
  • Dummy : LocalVoiceAudioDummy
  • Encoder : VoiceCreateOptions
  • Encrypt : VoiceCreateOptions
  • FEC : VoiceCreateOptions
  • ForceRecordingAndTransmission : VoiceDebugScript
  • Fragment : VoiceCreateOptions
  • HandleDeviceChange : AudioChangesHandler
  • HandleDeviceChangeAndroid : AudioChangesHandler
  • HandleDeviceChangeIOS : AudioChangesHandler
  • IncreaseLogLevels : VoiceDebugScript
  • InterestGroup : VoiceCreateOptions
  • IsRecording : VoiceNetworkObject
  • IsSpeaking : VoiceNetworkObject
  • LocalDebug : VoiceDebugScript
  • Reliable : VoiceCreateOptions
  • Settings : VoiceConnection
  • TargetPlayers : VoiceCreateOptions
  • TestAudioClip : VoiceDebugScript
  • TestUsingAudioClip : VoiceDebugScript
  • UseFusionAppSettings : FusionVoiceClient
  • UseFusionAuthValues : FusionVoiceClient
  • UsePrimaryRecorder : VoiceConnection
  • UseVoiceAppSettings : UnityVoiceClient
  • VoiceRoomNameSuffix : PunVoiceClient


Photon Voice: Class Members - Properties

- a -

  • AccumAvgPeakAmp : AudioUtil.ILevelMeter
  • ActivityDelayMs : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • AudioClip : Recorder

- b -

  • BestRegionSummaryInPreferences : VoiceConnection
  • Bitrate : Recorder , VoiceInfo
  • BufferFactory : LocalVoiceFramed< T >

- c -

  • CaptureSource : CaptureDevice
  • ChannelId : RemoteVoiceInfo
  • Channels : IAudioDesc , AudioInPusher , VoiceInfo
  • ClientState : VoiceConnection
  • CurrentAvgAmp : AudioUtil.ILevelMeter
  • CurrentPeakAmp : AudioUtil.ILevelMeter

- d -

  • DebugEchoMode : LocalVoice , Recorder
  • DebugLostPercent : VoiceClient
  • Decoder : RemoteVoiceOptions
  • Detected : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • DetectedTime : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >

- e -

  • Encrypt : LocalVoice , Recorder
  • Error : IAudioDesc , IDecoder , IEncoder , AudioInChangeNotifier
  • EventsLost : VoiceClient

- f -

  • FEC : LocalVoice
  • FPS : VoiceInfo
  • Fragment : LocalVoice
  • FrameDuration : Recorder
  • FrameDurationSamples : VoiceInfo
  • FrameDurationUs : VoiceInfo
  • FramesFragPart : VoiceClient
  • FrameSize : VoiceInfo
  • FramesLate : VoiceClient
  • FramesLost : VoiceClient
  • FramesLostPercent : VoiceConnection
  • FramesLostPerSecond : VoiceConnection
  • FramesReceived : VoiceClient
  • FramesReceivedFEC : VoiceClient
  • FramesReceivedFragmented : VoiceClient
  • FramesReceivedFragments : VoiceClient
  • FramesReceivedPerSecond : VoiceConnection
  • FramesRecovered : VoiceClient
  • FramesSent : LocalVoice , VoiceClient
  • FramesSentBytes : LocalVoice , VoiceClient
  • FramesSentFragmented : LocalVoice
  • FramesSentFragments : LocalVoice
  • FramesTryFEC : VoiceClient

- h -

  • Height : VoiceInfo

- i -

  • ImageFormat : IEncoderDirectImage
  • Info : LocalVoice , ObjectPool< TType, TInfo > , RemoteVoiceInfo
  • InputFactory : Recorder
  • Instance : PunVoiceClient
  • InterestGroup : LocalVoice , Recorder
  • IsCurrentlyTransmitting : LocalVoice , Recorder
  • IsLinked : Speaker
  • IsPlaying : Speaker
  • IsRecording : PhotonVoiceView
  • IsSpeaking : PhotonVoiceView

- k -

  • KeyFrameInt : VoiceInfo

- l -

  • Lag : Speaker
  • LevelMeter : AudioUtil.VoiceLevelDetectCalibrate< T > , ILocalVoiceAudio , Recorder
  • LocalUserServiceable : LocalVoice
  • LocalVoices : VoiceClient
  • LoopAudioClip : Recorder

- m -

  • MicrophoneType : Recorder

- o -

  • On : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • OnRemoteVoiceInfoAction : VoiceClient
  • OnRemoteVoiceRemoveAction : RemoteVoiceOptions , Speaker
  • Output : IDecoderDirect< B > , IEncoder

- p -

  • PlayDelay : Speaker
  • PlayDelayConfig : Speaker
  • PlayerId : RemoteVoiceInfo
  • PrimaryRecorder : VoiceConnection
  • PushDataAsyncReady : LocalVoiceFramed< T >

- r -

  • RecorderInUse : VoiceNetworkObject , PhotonVoiceView
  • RecordingEnabled : Recorder
  • RecordWhenJoined : Recorder
  • Reliable : LocalVoice
  • ReliableMode : Recorder
  • RemoteVoiceInfos : VoiceClient
  • RoundTripTime : VoiceClient
  • RoundTripTimeVariance : VoiceClient

- s -

  • SamplingRate : IAudioDesc , Recorder , VoiceInfo
  • SendSpacingProfileMax : LocalVoice
  • SourceType : Recorder
  • SpeakerInUse : VoiceNetworkObject , PhotonVoiceView
  • SpeakerPrefab : VoiceConnection
  • StopRecordingWhenPaused : Recorder
  • SuppressInfoDuplicateWarning : VoiceClient

- t -

  • TargetPlayers : LocalVoice , Recorder
  • Threshold : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • TransmitEnabled : LocalVoice , Recorder

- u -

  • UseMicrophoneTypeFallback : Recorder
  • UseOnAudioFilterRead : Recorder
  • UsePunAppSettings : PunVoiceClient
  • UsePunAuthValues : PunVoiceClient
  • UserData : Recorder , VoiceInfo

- v -

  • VoiceClient : LoadBalancingTransport , VoiceConnection
  • VoiceDetection : Recorder
  • VoiceDetectionDelayMs : Recorder
  • VoiceDetectionThreshold : Recorder
  • VoiceDetector : AudioUtil.VoiceLevelDetectCalibrate< T > , ILocalVoiceAudio , Recorder
  • VoiceDetectorCalibrating : ILocalVoiceAudio , LocalVoiceAudio< T > , Recorder
  • VoiceId : RemoteVoiceInfo

- w -

  • Width : VoiceInfo


Photon Voice: Class Members - Events

  • OnDetected : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • RemoteVoiceAdded : VoiceConnection
  • SpeakerLinked : VoiceConnection


Photon Voice: Member List

  • LoadBalancingTransport
LoadBalancingTransport Member List

This is the complete list of members for LoadBalancingTransport, including all inherited members.

buildFrameMessage(byte voiceId, byte evNumber, byte frNumber, ArraySegment< byte > data, FrameFlags flags) (defined in LoadBalancingTransport) | LoadBalancingTransport | protectedvirtual
ChangeAudioGroups(byte[] groupsToRemove, byte[] groupsToAdd) (defined in LoadBalancingTransport) | LoadBalancingTransport | virtual
ChannelIdStr(int channelId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
cppCompatibilityMode (defined in LoadBalancingTransport) | LoadBalancingTransport | protected
Dispose() | LoadBalancingTransport |
FrameCode (defined in LoadBalancingTransport) | LoadBalancingTransport | protected
GetPayloadFragmentSize(SendFrameParams par) (defined in LoadBalancingTransport) | LoadBalancingTransport | virtual
IsChannelJoined(int channelId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LoadBalancingTransport(ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp, bool cppCompatibilityMode=false) | LoadBalancingTransport |
logger (defined in LoadBalancingTransport) | LoadBalancingTransport | protected
onEventActionVoiceClient(EventData ev) (defined in LoadBalancingTransport) | LoadBalancingTransport | protectedvirtual
PlayerIdStr(int playerId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
SendFrame(ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte frNumber, byte voiceId, int channelId, SendFrameParams par) (defined in LoadBalancingTransport) | LoadBalancingTransport |
SendVoiceInfo(LocalVoice voice, int channelId, bool targetMe, int[] targetPlayers) (defined in LoadBalancingTransport) | LoadBalancingTransport |
SendVoiceRemove(LocalVoice voice, int channelId, bool targetMe, int[] targetPlayers) (defined in LoadBalancingTransport) | LoadBalancingTransport |
Service() | LoadBalancingTransport |
voiceClient (defined in LoadBalancingTransport) | LoadBalancingTransport | protected
VoiceClient | LoadBalancingTransport |


Photon Voice: Photon Directory Reference

  • Assets
Photon Directory Reference


Photon Voice: FMOD Directory Reference

  • Assets
  • PhotonVoice
  • Code
  • FMOD
FMOD Directory Reference


Photon Voice: Unity Directory Reference

  • Assets
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • Unity
Unity Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: Core Directory Reference

  • Assets
  • PhotonVoice
  • PhotonVoiceApi
  • Core
Core Directory Reference


Photon Voice: UtilityScripts Directory Reference

  • Assets
  • PhotonVoice
  • Code
  • PUN
  • UtilityScripts
UtilityScripts Directory Reference


Photon Voice: PUN Directory Reference

  • Assets
  • PhotonVoice
  • Code
  • PUN
PUN Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: Apple Directory Reference

  • Assets
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • Apple
Apple Directory Reference


Photon Voice: Android Directory Reference

  • Assets
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • Unity
  • Android
Android Directory Reference


Photon Voice: img Directory Reference

  • img
img Directory Reference


Photon Voice: WebGL Directory Reference

  • Assets
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • Unity
  • WebGL
WebGL Directory Reference


Photon Voice: MicAmplifier Directory Reference

  • Assets
  • PhotonVoice
  • Code
  • UtilityScripts
  • MicAmplifier
MicAmplifier Directory Reference


Photon Voice: Assets Directory Reference

  • Assets
Assets Directory Reference


Photon Voice: Windows Directory Reference

  • Assets
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • Windows
Windows Directory Reference


Photon Voice: Fusion Directory Reference

  • Assets
  • PhotonVoice
  • Code
  • Fusion
Fusion Directory Reference


Photon Voice: PhotonVoiceApi Directory Reference

  • Assets
  • PhotonVoice
  • PhotonVoiceApi
PhotonVoiceApi Directory Reference

Directories

directory Platforms


Photon Voice: UWP Directory Reference

  • Assets
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • UWP
UWP Directory Reference


Photon Voice: PhotonVoice Directory Reference

  • Assets
  • PhotonVoice
PhotonVoice Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: Code Directory Reference

  • Assets
  • PhotonVoice
  • Code
Code Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: FMOD Directory Reference

  • Assets
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • FMOD
FMOD Directory Reference


Photon Voice: UtilityScripts Directory Reference

  • Assets
  • PhotonVoice
  • Code
  • UtilityScripts
UtilityScripts Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: Platforms Directory Reference

  • Assets
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
Platforms Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: Main Page

Photon Voice Documentation

Photon Voice 2 has three key classes:

  • Photon.Voice.Unity.VoiceConnection (extends Photon.Realtime.ConnectionHandler)
  • Photon.Voice.Unity.Recorder
  • Photon.Voice.Unity.Speaker

If you also use the integration with PUN 2, we added two components for ease-of-use and more convenience:

  • Photon.Voice.PUN.PhotonVoiceNetwork
  • Photon.Voice.PUN.PhotonVoiceView

Photon Voice 2 also comes with a WebRTC based DSP (Photon.Voice.Unity.WebRtcAudioDsp using Photon.Voice.WebRTCAudioProcessor).

Read more in the official documentation here.
You can download Photon Voice 2 here.